Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Register VG224 with CME

The ephones for VG224 don't get registered with SCCP on the gateway. I've already done the ATAs and the IP phones, and they seem working fine.

I'm having some unluck with the VG224. I beleive the problem is from the VG224 itself. The config of this device on the CME is as follow:

ephone-dn 13

number 214

name CCO

ephone 10

mac-address xxxx.xxxx.xxxx

type anl

button 1:13

For the mac address i followed the instruction in the manual for how to set up the mac for each phone on VG224.

When i do show ephone, it doesn't seem that the phone with that particular mac-address is seeing the ip of the VG224. Any ideas?

10 REPLIES
Community Member

Re: Register VG224 with CME

Hi!

Please send the VG224's config and the output of "show sccp" command on the VG. This will be very helpful.

Community Member

Re: Register VG224 with CME

Here is the VG224 config output:

Building configuration...

Current configuration : 1768 bytes

!

configuration mode exclusive auto

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname GTS-VG224

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$c2ql$dNq1qHU5s17pHqqYChPMM1

!

no aaa new-model

!

resource policy

!

!

!

!

stcapp ccm-group 1

!

voice-card 0

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0/0

ip address 10.1.30.30 255.255.255.0

ip nat inside

ip virtual-reassembly

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

!

ip http server

!

!

!

control-plane

!

!

voice-port 2/0

ren 3

disconnect-ack

loss-plan plan4

disc_pi_off

input gain 10

output attenuation 10

playout-delay minimum low

timing digit 53

description cflow1

music-threshold -50

bearer-cap Speech

station-id name CCO

station-id number 262

caller-id enable

!

voice-port 2/1

!

voice-port 2/2

!

voice-port 2/3

!

voice-port 2/4

!

voice-port 2/5

!

voice-port 2/6

!

voice-port 2/7

!

voice-port 2/8

!

voice-port 2/9

!

voice-port 2/10

!

voice-port 2/11

!

voice-port 2/12

!

voice-port 2/13

!

voice-port 2/14

!

voice-port 2/15

!

voice-port 2/16

!

voice-port 2/17

!

voice-port 2/18

!

voice-port 2/19

!

voice-port 2/20

!

voice-port 2/21

!

voice-port 2/22

!

voice-port 2/23

!

ccm-manager config server 10.1.30.100

ccm-manager config

ccm-manager sccp local FastEthernet0/0

ccm-manager sccp

!

!

sccp local FastEthernet0/0

sccp ccm 10.1.30.100 identifier 1

!

sccp ccm group 1

bind interface FastEthernet0/0

associate ccm 1 priority 1

!

!

dial-peer voice 1 pots

destination-pattern 262

port 2/0

forward-digits all

!

dial-peer voice 2 pots

!

!

!

line con 0

speed 115200

line aux 0

line vty 0 4

password cisco

login

!

end

!!!!!!!!!!!!!!!!!!!!!!

show SCCP:

SCCP Admin State: DOWN

Gateway IP Address: 10.1.30.30, Port Number: 2000

IP Precedence: 5

User Masked Codec list: None

Call Manager: 10.1.30.100, Port Number: 2000

Priority: N/A, Version: 3.1, Identifier: 1

Community Member

Re: Register VG224 with CME

Here is the VG224 config output:

Building configuration...

Current configuration : 1768 bytes

!

configuration mode exclusive auto

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname GTS-VG224

!

boot-start-marker

boot-end-marker

!

enable secret xxx

!

no aaa new-model

!

resource policy

!

!

!

!

stcapp ccm-group 1

!

voice-card 0

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0/0

ip address 10.1.30.30 255.255.255.0

ip nat inside

ip virtual-reassembly

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

!

ip http server

!

!

!

control-plane

!

!

voice-port 2/0

ren 3

disconnect-ack

loss-plan plan4

disc_pi_off

input gain 10

output attenuation 10

playout-delay minimum low

timing digit 53

description cflow1

music-threshold -50

bearer-cap Speech

station-id name CCO

station-id number 262

caller-id enable

!

voice-port 2/1

!

voice-port 2/2

!

voice-port 2/3

!

voice-port 2/4

!

voice-port 2/5

!

voice-port 2/6

!

voice-port 2/7

!

voice-port 2/8

!

voice-port 2/9

!

voice-port 2/10

!

voice-port 2/11

!

voice-port 2/12

!

voice-port 2/13

!

voice-port 2/14

!

voice-port 2/15

!

voice-port 2/16

!

voice-port 2/17

!

voice-port 2/18

!

voice-port 2/19

!

voice-port 2/20

!

voice-port 2/21

!

voice-port 2/22

!

voice-port 2/23

!

ccm-manager config server 10.1.30.100

ccm-manager config

ccm-manager sccp local FastEthernet0/0

ccm-manager sccp

!

!

sccp local FastEthernet0/0

sccp ccm 10.1.30.100 identifier 1

!

sccp ccm group 1

bind interface FastEthernet0/0

associate ccm 1 priority 1

!

!

dial-peer voice 1 pots

destination-pattern 262

port 2/0

forward-digits all

!

dial-peer voice 2 pots

!

!

!

line con 0

speed 115200

line aux 0

line vty 0 4

password cisco

login

!

end

!!!!!!!!!!!!!!!!!!!!!!

show SCCP:

SCCP Admin State: DOWN

Gateway IP Address: 10.1.30.30, Port Number: 2000

IP Precedence: 5

User Masked Codec list: None

Call Manager: 10.1.30.100, Port Number: 2000

Priority: N/A, Version: 3.1, Identifier: 1

Community Member

Re: Register VG224 with CME

Hi!

You have almost completed your task.

issue following commands on the VG:

! enables stcapp

stcapp

! to allow phones to use pickup, transfer etc.

stcapp feature access-code

!enables sccp

sccp

!giving our ports to sccp management

dial-peer voice 1 pots

port 2/0

service stcapp

!

dial-peer voice 2 pots

port 2/1

service stcapp

After that issue again show sccp command and you will see how your phones are trying to register with CCME

Community Member

Re: Register VG224 with CME

Hi,

I've enabled the stcapp and sccp, and it seems working. The VG is registered with CME.

In the CME i did show ephone; i'm able to see the VG registered from there with a mac-address ae22.17fa.0fff, but the type is still unkown. I tried to do update with "type anl" command and it's still not taking it.

I'm not able to add ephone-dn to the ephone. Any idea how to create ephones on this gateway?

Community Member

Re: Register VG224 with CME

Hi!

Try following:

ephone 1

video

username "6808" password 12345

mac-address ae22.17fa.0400

type anl

button 1:17

ephone 2

video

username "6808" password 12345

mac-address ae22.17fa.0401

type anl

button 1:17

etc.

The needed mac-addresses you may fing in sh sccp command on the VG.

Community Member

Re: Register VG224 with CME

Thanks for the reply..

I have done this, but it's still not working.

I didn't see any mac-address in the sh sccp command on the VG except the AE22.17F4.0FFF

Here is the last 3 ephones as was shown with "sh ephone" command on the CME:

ephone-11 Mac:AE22.17F4.0FFF TCP socket:[13] activeLine:0 REGISTERED in SCCP ver 6

mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0

IP:10.1.30.30 38696 unknown 30032 keealive 34 max_line 0

ephone-13 Mac:AE22.17F4.0400 TCP socket:[-1] activeLine:0 UNREGISTERED

mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0

IP:0.0.0.0 0 unknown 0 keealive 0 max_line 0

ephone-14 Mac:AE22.17F4.0401 TCP socket:[-1] activeLine:0 UNREGISTERED

mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0

IP:0.0.0.0 0 unknown 0 keealive 0 max_line 0

ephone-11 was registered automatically after i enabled sccp and stcapp. i entered ephone-13 and ephone 14

Community Member

Re: Register VG224 with CME

You need to issue the dial-peer command on the VG for each port, you wich to use in CCME.

Perhaps, at the moment you have just one dial-peer. In my config it looks as follows:

dial-peer voice 1 pots

port 2/0

service stcapp

!

dial-peer voice 2 pots

port 2/1

service stcapp

...

dial-peer voice 24 pots

port 2/23

service stcapp

Community Member

Re: Register VG224 with CME

i have issued the dial-peer command for all the port (port2/0-port2/23) in the VG.

Community Member

Re: Register VG224 with CME

any idea regarding the VG problem i have?

2231
Views
0
Helpful
10
Replies
CreatePlease to create content