Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Registering a 3945 VG in CUCM 8.6 using MGCP

I have also created the gateway in CallManager with the hostname.domain where it asks for the domain name. I cannot figure out why this voice gateway is not registering in CM. Any help would be greatly appreciated!

Here is my config on the VG:

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname XXXXX_3945_VG

!

boot-start-marker

boot-end-marker

!

!

card type t1 0 0

!

no aaa new-model

!

network-clock-participate wic 0

network-clock-select 1 T1 0/0/0

!

crypto pki token default removal timeout 0

!

!

no ipv6 cef

ip auth-proxy max-login-attempts 5

ip admission max-login-attempts 5

!

!

!

!

!

ip cef

!

multilink bundle-name authenticated

!

!

!        

!

isdn switch-type primary-ni

!

voice-card 0

!

!

!

!

!

!

!

!

license udi pid C3900-SPE150/K9 sn FOC15440X6L

hw-module pvdm 0/0

!

!

!

!

redundancy

!

!

!

!

!

controller T1 0/0/0

cablelength long 0db

pri-group timeslots 1-24 service mgcp

!

controller T1 0/0/1

cablelength long 0db

!

!

!

!

!

!

!

!

!

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

ip address x.x.x.x 255.255.255.0 (Voice vlan interface)

duplex auto

speed auto

!

interface GigabitEthernet0/0.20

shutdown

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface GigabitEthernet0/2

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0/0:23

no ip address

encapsulation hdlc

isdn switch-type primary-ni

isdn incoming-voice voice

isdn bind-l3 ccm-manager

isdn bchan-number-order ascending

no cdp enable

!

ip default-gateway x.x.x.x

ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

ip route 0.0.0.0 0.0.0.0 x.x.x.x

!

!

nls resp-timeout 1

cpd cr-id 1

!

!

control-plane

!

!

voice-port 0/0/0:23

!

!

!

!

ccm-manager switchback immediate

ccm-manager redundant-host x.x.x.x (CM subscriber)

ccm-manager mgcp

no ccm-manager fax protocol cisco

ccm-manager music-on-hold

ccm-manager config server x.x.x.x (CM publisher)

ccm-manager config

!

mgcp

mgcp call-agent x.x.x.x (CM publisher) 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

mgcp package-capability sst-package

mgcp package-capability pre-package

no mgcp package-capability res-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 inhibit

mgcp rtp payload-type g726r16 static

mgcp bind control source-interface GigabitEthernet0/0

mgcp bind media source-interface GigabitEthernet0/0

!

mgcp profile default

!

!

!

!

!        

gatekeeper

shutdown

!

!

!

line con 0

line aux 0

line 2

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

stopbits 1

line vty 0 4

logging synchronous

login local

transport input all

line vty 5 15

logging synchronous

login local

transport input all

!

scheduler allocate 20000 1000

!

end

-----------------------------------------------------------

4 REPLIES
New Member

Registering a 3945 VG in CUCM 8.6 using MGCP

Here is the output of show isdn status:

Global ISDN Switchtype = primary-ni

%Q.931 is backhauled to CCM MANAGER 0x0003 on DSL 0. Layer 3 output may not apply

ISDN Serial0/0/0:23 interface

        dsl 0, interface ISDN Switchtype = primary-ni

        L2 Protocol = Q.921 0x0000  L3 Protocol(s) = CCM MANAGER 0x0003

    Layer 1 Status:

        DEACTIVATED

    Layer 2 Status:

        TEI = 0, Ces = 1, SAPI = 0, State = TEI_ASSIGNED

    Layer 3 Status:

        0 Active Layer 3 Call(s)

    Active dsl 0 CCBs = 0

    The Free Channel Mask:  0x00000000

    Number of L2 Discards = 0, L2 Session ID = 0

    Total Allocated ISDN CCBs = 0

VIP Super Bronze

Registering a 3945 VG in CUCM 8.6 using MGCP

I dont see any ip domain name command on your VG. Hence you should only use the hostname of the gateway in cucm without any domain name. You should only use domain name if you have ip domain name configured.

So I suggest you remove the .domain name on cucm and leave only the hostname. Then on the voice gateway do a no mgcp and then mgcp.

Please rate all useful posts

"There is a wideness in God's mercy Like the wideness of the sea.There's a kindness in His justice Which is more than liberty"

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
New Member

Registering a 3945 VG in CUCM 8.6 using MGCP

I tried removing the .domain in CUCM, and entering mgcp / no mgcp on the gateway. Unfortunately this did not solve the problem. Thank you for your input.

VIP Super Bronze

Registering a 3945 VG in CUCM 8.6 using MGCP

Looking closer at your debug isdn q931, I can see that layer 1 is deactivated. This suggests a physical layer issue, cabling etc. Can you check that...

Please rate all useful posts

"There is a wideness in God's mercy Like the wideness of the sea.There's a kindness in His justice Which is more than liberty"

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
799
Views
0
Helpful
4
Replies