Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Registering IP Phone 7821

Hi all,

 

i have Cisco SIP IP Phone 7821. I have trouble to make it registered with my CME 10.5. i have trying fast-track configuration and many advice from the other discussion, but still no luck at all. Hereby my CME configuration :

Version 15.4(3)M

voice service voip
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 no supplementary-service h450.2
 no supplementary-service h450.3
 supplementary-service h450.12
 fax protocol pass-through g711ulaw
 h323
 sip
  bind control source-interface Loopback10
  bind media source-interface Loopback10
  registrar server
!

voice register global
 mode  cme
 source-address x.x.x.x port 5060
 max-dn 400
 max-pool 50
 load 7821 sip78xx.10-2-1-12.loads
 timezone 41
 time-format 24
 date-format D/M/Y
 tftp-path flash:
 file text
 create profile 
 network-locale GB
 ntp-server x.x.x.x mode directedbroadcast
!
voice register dn  1
 number 1010
 name 7821
 label NewSIP1
 mwi
!
voice register pool  1
 busy-trigger-per-button 2
 id mac xxxx.xxxx.xxxx
 type 7821
 number 1 dn 1
 presence call-list
 dtmf-relay rtp-nte
 codec g711ulaw
!

tftp-server flash:kern78xx.10-2-1-12.sbn
tftp-server flash:rootfs78xx.10-2-1-12.sbn
tftp-server flash:sboot78xx.10-2-1-12.sbn
tftp-server flash:sip78xx.10-2-1-12.loads

 

Need your advice,

 

thanks.

5 REPLIES
Community Member

If you are still having this

If you are still having this problem, you need to add the following on your configuration:

 

voice service voip
 sip
  registrar server expires max 600 min 60

 

Let me know if that works...it did for me. After debugging registration, the phone was  looking to register to the server.

 

Community Member

Hey; try this and please let

Hey;

 

try this and please let me know if it fixed;

Voice register pool  1
 busy-trigger-per-button 2
 id mac xxxx.xxxx.xxxx
 type 7821
 number 1 dn 1
 presence call-list
 dtmf-relay rtp-nte
 codec g711ulaw

session-transport tcp 

 

and go to "voice register global"

create profile

 

if problem still active please attach "debug tftp events" and status messages from an ip phone maybe you can take a pic of screen

Good day

Community Member

Hi adnanramadhan12 !!!My name

Hi adnanramadhan12 !!!

My name is Enrique Villasana and I have similar problem right now...

I have Ip phones 7821/7841 and CME 10.5 IOS:154-3.M2.

Here you have my current configuration:

voice service voip
 ip address trusted list
 ipv4 10.2.50.0 255.255.255.0
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 supplementary-service h450.12
 no supplementary-service sip moved-temporarily
 no supplementary-service sip refer
 fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
 h323
  call start slow
 sip
  bind control source-interface GigabitEthernet0/0.3
  bind media source-interface GigabitEthernet0/0.3
  registrar server expires max 600 min 60
!
!
interface GigabitEthernet0/0.3
 description Voice VLAN
 encapsulation dot1Q 3
 ip address 10.2.50.254 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 ip traffic-export apply TAC size 10000000
.
!
voice register global
 mode  cme
 source-address 10.2.50.254 port 5060
 max-dn 180
 max-pool 42
 load 7821 sip78xx.10-1-1SR1-4
 load 7841 sip78xx.10-1-1SR1-4
 authenticate register
 timezone 14
 tftp-path flash:
 create profile sync 0008536074803216
!
!
voice register dn  1
 number 235
 pickup-call any-group
 name Reception Reception
 label Reception Reception
!
!
voice register pool  1
 busy-trigger-per-button 1
 id mac aaaa.bbbb.cccc
 type 7841
 number 1 dn 1
 template 1
 dtmf-relay rtp-nte
 username cisco password cisco
 description Reception
 codec g711ulaw
!
tftp-server flash:rootfs78xx.10-1-1SR1-4.sbn
tftp-server flash:sboot78xx.10-1-1SR1-4.sbn
tftp-server flash:sip78xx.10-1-1SR1-4.loads
tftp-server flash:kern78xx.10-1-1SR1-4.sbn

 

Could you solved your problem?? If so , could you please tell what I am missing or misconfiguring on my current configuration??

I really appreciate your help !!

Enrirque Villasana

Community Member

Hello Adnan,I am facing same

Hello Adnan,

I am facing same issue in CME 10.0.

How did you ended up with your problem ?

Regards,

 

Community Member

Hi Ilana!!As I explained on


Hi Ilana!!

As I explained on another similar case... after one week testing (and fighting) with Cisco TAC, they accepted my RMA requirement of the SPIAD Router.

Once I received and installed the replacement router, all phones registered !!!! Including a new CP-8831 !!

If you have a SPIAD Router, with similar strange behavior i really recommend you to require a RMA.

I HTH

Enrique

 

797
Views
0
Helpful
5
Replies
CreatePlease to create content