Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

Remote Callers can't hear ringback on E1

I'm running CMExpress on Cisco 2911 with one E1 card and callers can't hear ringback when the call is actually ringing in the local site. They just hear one ringback on the establish of call and after that, nothing until the end-user off-hook the phone.

Can someone have an idea about this issue?

Tahnks in advanced for your help.

This is the configuration:

controller E1 0/0/0
 framing NO-CRC4
 ds0-group 0 timeslots 1-15,17-31 type r2-digital r2-compelled ani
 cas-custom 0
  country telmex
  release-guard-time 2
  disconnect-tone
  category 2
  answer-signal group-b 1
  caller-digits 4
  dnis-digits min 4 max 4
  answer-guard-time 500
  groupa-callerid-end
  dtmf timer inter-digit 250
!
  voice-card 0
 dspfarm
 dsp services dspfarm
!
voice-port 0/0/0:0
 cptone MX
!

dial-peer voice 7 pots
 description ### INCOMING CALLS E1-PSTN ###
 translation-profile incoming To-AA
 incoming called-number .
 direct-inward-dial

 

 

13 REPLIES
Green

Hi Tavo,Can you try adding a

Hi Tavo,

Can you try adding a line to your VOIP dial peer:-

Something like:-

!
!
dial-peer voice 2000 voip
desc *** VOIP DP TO CUCM SUB ***
destination-pattern 2...
session target ipv4:172.16.255.22
codec g711ulaw
progress_ind setup enable 3
!
!

Hope this helps
Regards
Alex

Regards, Alex. Please rate useful posts.

Hi Alex, your comment make me

Hi Alex, your comment make me update my case, i'm actually runnning CME with SCCP and SIP phones registered on it and when i called to any of this extensions, anyone made ringback tone.

Thanks for your help.

Green

Tavo, What version of CME are

Tavo,

 

What version of CME are you running and what is the router IOS version ?

You may be hitting bug CSCdw73507 if it is old ios 12.2 etc

Does the issue happen with both the sip & sccp phones ?

Alex

Regards, Alex. Please rate useful posts.

This my CME and IOS version:=

This my CME and IOS version:

=====================
Version 9.1
Max phoneload sccp version 17
Max dspfarm sccp version 18
Cisco Unified Communications Manager Express

======================

Cisco IOS Software, C2900 Software (C2900-UNIVERSALK9-M), Version 15.2(4)M4, RELEASE SOFTWARE (fc2)

=======================

The issue is similar to the bug CSCdw73507, When a call come from PSTN, the Caller just hear one ringback, but my IP Phone rings normal.

This is my Incoming Dial-Peer

dial-peer voice 7 pots
 description ### INCOMING CALLS E1-PSTN ###
 translation-profile incoming To-AA
 incoming called-number .
 direct-inward-dial

 

 

Thanks in advance for your help.

 

Regards,

 

 

Green

Tavo,Can you try adding this

Tavo,

Can you try adding this to your global config

!
voice call send-alert
voice rtp send-recv
!

Hope this helps.
Regards
Alex

Regards, Alex. Please rate useful posts.

Alex,I already added these

Alex,

I already added these commands, but this issue continues, Do you think my E1 Provider has some work to do about it?

Thanks in advanced for your help.

Regards,

Tavo.

Caller who calls a DID don't

Caller who calls a DID don't hear ringback, but when a AA is playing and Caller Dial an Extension in that moment he can hear ringback.

Call -> DID -> CME -> AA (Unity) -> Dial Extension -> Ringback (YES)

Call -> DID -> CME -> Ringback (NO)

Community Member

 Hi Gustavo, I have the same

 Hi Gustavo,

 

I have the same problem with the same Gateway (Cisco IOS Software, C2900 Software (C2900-UNIVERSALK9-M), Version 15.2(4)M4) registered with CUCM 9.1

Did you resolve this issu ?

Thanks in advance

BR,

Aaziz

 

Hi Aaziz, i still have the

Hi Aaziz, i still have the issue.

 

Let me know if you have any kind of suggestion.

 

Thanks a lot

 

Regards,

Tavo

VIP Super Bronze

Can you send us the ff:

Can you send us the ff: logs

debug isdn q931

debug ephone state

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
Community Member

Hi,The problem is resolved

Hi,

The problem is resolved using this two commands just in POTS Dial-peer :

 progress_ind setup enable 3
 progress_ind alert enable 8

Could you try those commands

BR,

Aaziz

Aaziz,IOS mark as Invalid

Aaziz,

IOS mark as Invalid input when i tried to use these commnds on POTS Dial-peer, but in VOIP (NO MY CASE) I can use them.

 

Thanks for your help.

 

Regards.

Ayodeji,IOS mark as invalid

Ayodeji,

IOS mark as invalid input *debug isdn q931*. I'm using Controller E1.

Thanks for your help.

BR

Tavo

443
Views
4
Helpful
13
Replies
CreatePlease to create content