Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
You may experience some slow load times, errors, and slight inconsistencies. We ask for your patience as we finalize the launch. Thank you.

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

Ringback delay

All,

Could Somebody say me if there is some command for ringback time?

The called number ring first and the calling number hear only after the second ring.

Configuration:

!

card type e1 0 0

card type e1 0 1

card type e1 0 2

card type e1 0 3

card type e1 1 0

card type e1 1 1

card type e1 2 0

enable secret 5 $1$Bc4v$WASyazVGnuuiYDBAP/LRb1

!

no aaa new-model

!

no network-clock-participate slot 1

no network-clock-participate slot 2

network-clock-participate wic 0

network-clock-participate wic 1

no network-clock-participate wic 2

no network-clock-participate wic 3

network-clock-select 1 E1 0/0/0

network-clock-select 2 E1 0/0/1

network-clock-select 3 E1 0/1/0

network-clock-select 4 E1 0/1/1

!

!

!

trunk group PSTN

!

!

trunk group PABX

!

voice-card 0

dspfarm

dsp services dspfarm

!

voice-card 1

!

voice-card 2

!

!

voice call send-alert

voice call carrier capacity active

voice rtp send-recv

!

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback cisco

h323

!

voice class codec 1

codec preference 1 g729r8

codec preference 2 g729br8

codec preference 3 g711ulaw

codec preference 4 g711alaw

!

voice class h323 1

  h225 timeout tcp establish 3

  h225 connect-passthru

  h225 h245-address on-connect

  no h225 h245-address setup

  no h225 h245-address on-progress

  no h225 h245-address on-alert

  h225 h245-address facility

  h225 h245-address progress

  h225 h245-address sync

  no h225 h245-address on-setup

  call preserve

  telephony-service ccm-compatible

  ccm-compatible

!

!

!

!

voice translation-rule 1

rule 1 /^\(....\)/ /613105\1/

!

!

voice translation-profile IncomingPABX

translate calling 1

!

voice translation-profile IncomingPSTN

translate called 1

!

!

!

controller E1 0/0/0

framing NO-CRC4

ds0-group 0 timeslots 1-15,17-31 type r2-digital r2-compelled ani

cas-custom 0

  country brazil

  metering

  double-answer

  answer-signal group-b 1

  trunk-group PSTN

description ### CONEXAO COM PSTN ###

!

controller E1 0/0/1

framing NO-CRC4

ds0-group 0 timeslots 1-15,17-31 type r2-digital r2-compelled ani

cas-custom 0

  country brazil

  metering

  double-answer

  answer-signal group-b 1

  trunk-group PABX

description ### CONEXAO COM PABX ###

!

controller E1 0/1/0

framing NO-CRC4

ds0-group 1 timeslots 1-15,17-31 type r2-digital r2-compelled ani

cas-custom 1

  country brazil

  metering

  double-answer

  answer-signal group-b 1

  trunk-group PSTN

description ### CONEXAO COM PSTN ###

!

controller E1 0/1/1

framing NO-CRC4

ds0-group 1 timeslots 1-15,17-31 type r2-digital r2-compelled ani

cas-custom 1

  country brazil

  metering

  double-answer

  answer-signal group-b 1

  trunk-group PABX

description ### CONEXAO COM PABX ###

!

controller E1 0/2/0

!

controller E1 0/2/1

!

controller E1 0/3/0

!

controller E1 0/3/1

!

controller E1 1/0/0

!

controller E1 1/0/1

!

controller E1 1/1/0

!

controller E1 1/1/1

!

controller E1 2/0/0

!

controller E1 2/0/1

!

!

class-map match-any VIDEO_IN

match access-group name VIDEO

class-map match-any NETWORK-CONTROL_OUT

match  dscp cs2

match  dscp cs6

class-map match-any VOICE-CLUSTER

match access-group name VOICE-CLUSTER

class-map match-any REAL-TIME_OUT

match  dscp ef

class-map match-any MISSAO-CRITICA_IN

match access-group name MISSAO-CRITICA

class-map match-any VIDEO_OUT

match  dscp af41

class-map match-any CALL_SIGNALING_IN

match access-group name CALL_SIGNALING

class-map match-any NETWORK-CONTROL_IN

match access-group name NETWORK-CONTROL

class-map match-any MISSAO-CRITICA_OUT

match  dscp cs3

match  dscp af31

class-map match-any NETWORK-ROUTING_IN

match access-group name NETWORK-ROUTING

class-map match-any REAL-TIME_IN

match access-group name REAL-TIME

!

!

policy-map QOS_IN

class REAL-TIME_IN

  set dscp ef

class MISSAO-CRITICA_IN

  set dscp af31

class CALL_SIGNALING_IN

  set dscp cs3

class VIDEO_IN

  set dscp af41

class NETWORK-ROUTING_IN

  set dscp cs6

class NETWORK-CONTROL_IN

  set dscp cs2

class class-default

  set dscp default

policy-map QOS_OUT

class VOICE-CLUSTER

  police 10000000

class REAL-TIME_OUT

  priority percent 15

class MISSAO-CRITICA_OUT

  bandwidth percent 31

  fair-queue

  random-detect dscp-based

class VIDEO_OUT

  police rate percent 18

class NETWORK-CONTROL_OUT

  bandwidth percent 1

class class-default

  bandwidth percent 14

  random-detect dscp-based

  fair-queue

!

!

!

!

!

!

!

!

interface Loopback0

ip address 192.168.64.167 255.255.255.255

no ip redirects

no ip unreachables

no ip proxy-arp

ip pim sparse-dense-mode

h323-gateway voip interface

h323-gateway voip bind srcaddr 192.168.64.167

!

interface Embedded-Service-Engine0/0

no ip address

!

!

ip access-list extended CALL_SIGNALING

permit tcp any any eq 2000

permit tcp any eq 2000 any

permit tcp any any eq 1720

permit tcp any eq 1720 any

permit tcp any any range 5060 5061

permit tcp any range 5060 5061 any

permit udp any any range 5060 5061

permit udp any range 5060 5061 any

ip access-list extended MISSAO-CRITICA

permit tcp any any eq 1494

permit udp any any eq 1494

permit udp any eq 1494 any

permit tcp any eq 1494 any

permit tcp any any eq 2598

permit tcp any eq 2598 any

permit udp any eq 2598 any

permit tcp any eq 1521 any

permit tcp any eq 1526 any

permit tcp any eq 1530 any

permit tcp any any eq 1521

permit tcp any any eq 1526

permit tcp any any eq 1530

ip access-list extended NETWORK-CONTROL

permit tcp any any eq telnet

permit tcp any eq telnet any

permit udp any any eq snmp

permit udp any eq snmp any

permit tcp any any eq tacacs

permit tcp any eq tacacs any

permit tcp any any eq 123

permit tcp any eq 123 any

ip access-list extended NETWORK-ROUTING

permit tcp any any eq bgp

permit tcp any eq bgp any

ip access-list extended REAL-TIME

permit udp any any range 16384 32767

permit udp any range 16384 32767 any

ip access-list extended VIDEO

permit ip 10.248.4.0 0.0.0.255 any

ip access-list extended VOICE-CLUSTER

permit ip 192.168.4.0 0.0.1.255 any

!

voice-port 0/0/0:0

translation-profile incoming IncomingPSTN

cptone BR

timeouts interdigit 3

timeouts call-disconnect 1

!

voice-port 0/1/0:1

translation-profile incoming IncomingPSTN

cptone BR

timeouts interdigit 3

timeouts call-disconnect 1

!

voice-port 0/0/1:0

translation-profile incoming IncomingPABX

cptone BR

timeouts interdigit 3

timeouts call-disconnect 1

!

voice-port 0/1/1:1

translation-profile incoming IncomingPABX

cptone BR

timeouts interdigit 3

timeouts call-disconnect 1

!

!

!

sccp local Loopback0

sccp ccm 192.168.4.13 identifier 1 version 7.0

sccp ccm 192.168.4.14 identifier 2 version 7.0

sccp ccm 192.168.4.15 identifier 3 version 7.0

sccp ccm 192.168.4.16 identifier 4 version 7.0

sccp ccm 192.168.8.11 identifier 5 version 7.0

sccp ccm 192.168.8.12 identifier 6 version 7.0

sccp ccm 192.168.8.13 identifier 7 version 7.0

sccp ccm 192.168.8.14 identifier 8 version 7.0

sccp ip precedence 3

sccp

!

dspfarm profile 1 transcode 

codec g729abr8

codec g729ar8

codec g711alaw

codec g711ulaw

codec g729br8

codec g729r8

maximum sessions 4

associate application SCCP

!

dspfarm profile 2 conference 

codec g729br8

codec g729r8

codec g729abr8

codec g729ar8

codec g711alaw

codec g711ulaw

maximum sessions 3

associate application SCCP

!

dial-peer voice 1 pots

tone ringback alert-no-PI

description PSTN

incoming called-number .

direct-inward-dial

forward-digits all

!

dial-peer voice 2 voip

incoming called-number .

voice-class codec 1 

voice-class h323 1

dtmf-relay h245-alphanumeric

ip qos dscp cs3 media

!

dial-peer voice 11 voip

description ### DIAL-PEER VOIP PARA CUCM 1 ###

preference 1

destination-pattern .T

session target ipv4:192.168.4.13

voice-class codec 1 

voice-class h323 1

dtmf-relay h245-alphanumeric

ip qos dscp cs3 media

!

dial-peer voice 12 voip

description ### DIAL-PEER VOIP PARA CUCM 2 ###

preference 2

destination-pattern .T

session target ipv4:192.168.4.14

voice-class codec 1 

voice-class h323 1

dtmf-relay h245-alphanumeric

ip qos dscp cs3 media

!

dial-peer voice 13 voip

description ### DIAL-PEER VOIP PARA CUCM 3 ###

preference 3

destination-pattern .T

session target ipv4:192.168.4.15

voice-class codec 1 

voice-class h323 1

dtmf-relay h245-alphanumeric

ip qos dscp cs3 media

!

dial-peer voice 14 voip

description ### DIAL-PEER VOIP PARA CUCM 4 ###

preference 4

destination-pattern .T

session target ipv4:192.168.4.16

voice-class codec 1 

voice-class h323 1

dtmf-relay h245-alphanumeric

ip qos dscp cs3 media

!

dial-peer voice 15 voip

description ### DIAL-PEER VOIP PARA CUCM 5 ###

preference 5

destination-pattern .T

session target ipv4:192.168.8.11

voice-class codec 1 

voice-class h323 1

dtmf-relay h245-alphanumeric

ip qos dscp cs3 media

!

dial-peer voice 16 voip

description ### DIAL-PEER VOIP PARA CUCM 6 ###

preference 6

destination-pattern .T

session target ipv4:192.168.8.12

voice-class codec 1 

voice-class h323 1

dtmf-relay h245-alphanumeric

ip qos dscp cs3 media

!

dial-peer voice 17 voip

description ### DIAL-PEER VOIP PARA CUCM 7 ###

preference 7

destination-pattern .T

session target ipv4:192.168.8.13

voice-class codec 1 

voice-class h323 1

dtmf-relay h245-alphanumeric

ip qos dscp cs3 media

!

dial-peer voice 18 voip

description ### DIAL-PEER VOIP PARA CUCM 8 ###

preference 8

destination-pattern .T

session target ipv4:192.168.8.14

voice-class codec 1 

voice-class h323 1

dtmf-relay h245-alphanumeric

ip qos dscp cs3 media

!

dial-peer voice 20 pots

trunkgroup PSTN

tone ringback alert-no-PI

description ### DIAL-PEER POTS REDUNDANCIA PSTN ###

preference 9

destination-pattern .T

fax rate disable

!

dial-peer voice 101 pots

trunkgroup PSTN

tone ringback alert-no-PI

description ### DIAL-PEER POTS CHAMADA LOCAL FIXO ###

destination-pattern [2-5].......

fax rate disable

!

dial-peer voice 102 pots

trunkgroup PSTN

tone ringback alert-no-PI

description ### DIAL-PEER POTS CHAMADA LOCAL CELULAR ###

destination-pattern [6-9].......

fax rate disable

!

dial-peer voice 103 pots

trunkgroup PSTN

tone ringback alert-no-PI

description ### DIAL-PEER POTS CHAMADA DDD FIXO ###

destination-pattern 0[1-9]...[2-5].......

fax rate disable

prefix 0

!

dial-peer voice 104 pots

trunkgroup PSTN

tone ringback alert-no-PI

description ### DIAL-PEER POTS CHAMADA DDD CELULAR ###

destination-pattern 0[1-9]...[6-9].......

fax rate disable

prefix 0

!

dial-peer voice 105 pots

trunkgroup PSTN

tone ringback alert-no-PI

description ### DIAL-PEER POTS CHAMADA DDI ###

destination-pattern 00T

fax rate disable

prefix 00

!

dial-peer voice 106 pots

trunkgroup PSTN

tone ringback alert-no-PI

description ### DIAL-PEER POTS CHAMADA 0500 ###

destination-pattern 0500T

fax rate disable

prefix 0500

!

dial-peer voice 107 pots

trunkgroup PSTN

tone ringback alert-no-PI

description ### DIAL-PEER POTS CHAMADA 0300 ###

destination-pattern 0300T

fax rate disable

prefix 0300

!

dial-peer voice 108 pots

trunkgroup PSTN

tone ringback alert-no-PI

description ### DIAL-PEER POTS CHAMADA 0800 ###

destination-pattern 0800T

fax rate disable

prefix 0800

!

dial-peer voice 109 pots

trunkgroup PSTN

tone ringback alert-no-PI

description ### DIAL-PEER POTS CHAMADA SERVICOS ###

destination-pattern 103T

fax rate disable

prefix 103

!

dial-peer voice 110 pots

trunkgroup PSTN

tone ringback alert-no-PI

description ### DIAL-PEER POTS CHAMADA SERVICOS ###

destination-pattern 1T

fax rate disable

prefix 1

!

dial-peer voice 111 pots

trunkgroup PSTN

tone ringback alert-no-PI

description ### DIAL-PEER POTS CHAMADA EXCLUSIVA FAX ###

destination-pattern 1111[2-5].......

fax rate disable

!

dial-peer voice 112 pots

trunkgroup PSTN

tone ringback alert-no-PI

description ### DIAL-PEER POTS CHAMADA EXCLUSIVA FAX ###

destination-pattern 1111..T

fax rate disable

prefix 031

!

dial-peer voice 1001 pots

trunkgroup PABX

tone ringback alert-no-PI

description ### DIAL-PEER POTS CHAMADA ENTRADA PABX ###

destination-pattern 613105[5-7]...

fax rate disable

forward-digits 4

!

!

call-manager-fallback

secondary-dialtone 0

max-conferences 8 gain -6

transfer-system full-consult

timeouts interdigit 3

ip source-address 192.168.64.167 port 2000

max-ephones 300

max-dn 600

system message primary SOBREVIVENCIA LOCAL

system message secondary SOBREVIVENCIA LOCAL

transfer-pattern .T

call-forward pattern .T

time-zone 17

time-format 24

date-format dd-mm-yy

!

Thanks,

Luciane de Medeiros

  • IP Telephony
Everyone's tags (2)
1 REPLY

Ringback delay

All,

The problem is solved with the following commands:

PSTN

dnis-digits min 1 max 4

dnis-complete

answer-guard-time 250

Luciane de Medeiros

656
Views
0
Helpful
1
Replies