Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Route incoming call to extension

Currently I am using Cisco CISCO2901/K9 with 4 Voice FXO interfaces.

I would like to configure as below request.

Is it possible?

What configuration is need to achieve it?


Callers are given the option to enter an extension that routes the call directly to the internal user’s phone, or to be routed to a default location, such as an operator.

Current configuration : 16879 bytes

!

version 15.2

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Cisco_CME

!

boot-start-marker

boot-end-marker

!

!

logging buffered 51200

!

no aaa new-model

clock timezone GMT 8 0

!

!

!

!

ip dhcp excluded-address 10.53.4.1 10.53.4.10

!

ip dhcp pool IPPHONE_POOL

network 10.53.4.0 255.255.255.0

dns-server 10.53.4.2

default-router 10.53.4.2

option 150 ip 10.53.4.2

!

!

!

ip cef

no ipv6 cef

multilink bundle-name authenticated

!

!

!

!

!

!

trunk group POTSTRUNK

!

!

trunk group POTSTRK

!

!

crypto pki trustpoint TP-self-signed-2913731135

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-2913731135

revocation-check none

rsakeypair TP-self-signed-2913731135

!

!

crypto pki certificate chain TP-self-signed-2913731135

certificate self-signed 01

  3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030

  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 32393133 37333131 3335301E 170D3133 30323034 30343232

  32315A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 39313337

  33313133 3530819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

  8100C8B8 A89478A0 8CE7456A 8AAA6EB7 16096839 49A19DF1 D6ABCB99 0C6E9134

  951497B5 94538B46 E1193EF4 B6A3B9E7 F3F48299 22B256DD 6D43E5F0 79E2C466

  AE742B15 E2F928DE 2166E885 17EBFB45 F36F628C F579BA86 09DBC177 18B50E28

  BF278246 722BB661 D9383AD8 49BE2CF2 AEA9FCD6 E1372878 EBEDFDE5 469E3E6B

  A1C50203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603

  551D2304 18301680 141E3A7C 08DDD58E 33243B1D 3CDC300A 959677E7 DD301D06

  03551D0E 04160414 1E3A7C08 DDD58E33 243B1D3C DC300A95 9677E7DD 300D0609

  2A864886 F70D0101 05050003 81810045 31667A3E 9ADCE589 EC6A9756 EC63BA20

  2A5F6B01 71E14526 7A634355 D1B5C7C0 8F2D7602 45B54483 F4FBFBE3 A03F407B

  05264954 C18837E9 90072CB6 9AA40BAC 4A0FECB0 DCD17EEC 15BC2CBE 4C27372A

  E9048E75 E09AE0EA ED9B871C 487D8163 D7EA0F9D A87D5EAB B750AEF7 FAD8653A

  5993BF22 2638198C 6ACBE8B6 EF4365

            quit

voice-card 0

dspfarm

dsp services dspfarm

!

!

voice call send-alert

voice rtp send-recv

!

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none

sip

  registrar server expires max 1200 min 300

!

voice class codec 1

codec preference 1 g711ulaw

codec preference 2 g729r8

!

!

voice register global

mode cme

source-address 10.53.4.2 port 5060

max-dn 200

max-pool 42

load 7942 SCCP42.9-2-1S

load 6921 SCCP69xx.9-2-1-0

authenticate register

authenticate realm abcd.local

timezone 41

time-format 24

date-format D/M/Y

tftp-path flash:

create profile sync 0324344033123261

!

voice register dn  1

number 1111

call-forward b2bua unregistered 11111111 

allow watch

name 1111

label PolycomCon-110

!

voice register pool  1

id mac 0004.F2EA.1461

number 1 dn 1

presence call-list

dtmf-relay sip-notify

username 1111 password 1111

codec g711ulaw

!

!

!

voice translation-rule 1111

!

voice translation-rule 1112

rule 1 /^9/ //

!

voice translation-rule 2001

rule 5 /^/ /9/

!

voice translation-rule 2111

!

voice translation-rule 2112

rule 5 /^6/ //

!

!

voice translation-profile CALLER_ID_TRANSLATION_PROFILE

translate calling 1111

!

voice translation-profile INBOUND_TRANSLATION_PROFILE

translate calling 2001

translate called 2000

!

voice translation-profile OUTBOUND_NORWAY_TP

translate calling 1111

translate called 2112

!

voice translation-profile OUTGOING_TRANSLATION_PROFILE

translate calling 1111

translate called 1112

!

voice translation-profile OUTGOING_TRANSLATION_PROFILE_D9

translate calling 2111

translate called 2112

!

!

!

license udi pid CISCO2901/K9 sn FGL1646215J

hw-module pvdm 0/0

!

!

!

username cisco privilege 15 password 0 cisco

!

redundancy

!

!

gw-accounting aaa

!

gw-accounting file

primary ifs flash:

acct-template callhistory-detail

!

!

!

!

interface Loopback0

ip address 10.1.10.2 255.255.255.252

ip virtual-reassembly in

!

interface Embedded-Service-Engine0/0

ip unnumbered Loopback0

ip virtual-reassembly in

service-module ip address 10.1.10.1 255.255.255.252

service-module ip default-gateway 10.1.10.2

!

interface GigabitEthernet0/0

no ip address

duplex auto

speed auto

!

interface GigabitEthernet0/0.1

encapsulation dot1Q 1 native

ip address 10.53.5.2 255.255.255.0

!

interface GigabitEthernet0/0.10

encapsulation dot1Q 3

ip address 10.53.4.2 255.255.255.0

!

interface GigabitEthernet0/1

shutdown

duplex auto

speed auto

!

ip forward-protocol nd

!

ip http server

ip http authentication local

ip http secure-server

ip http path flash:

!

ip route 0.0.0.0 0.0.0.0 10.53.5.1

ip route 10.52.100.0 255.255.255.0 10.53.4.1

ip route 10.52.138.0 255.255.255.0 10.53.4.1

ip route 10.54.2.0 255.255.255.0 10.53.4.1

!

!

!

tftp-server flash0:apps42.9-2-1TH1-13.sbn alias apps42.9-2-1TH1-13.sdn

tftp-server flash0:cnu42.9-2-1TH1-13.sbn alias cnu42.9-2-1TH1-13.sdn

tftp-server flash0:cvm42sccp.9-2-1TH1-13.sbn alias cvm42sccp.9-2-1TH1-13.sdn

tftp-server flash0:dsp42.9-2-1TH1-13.sbn alias dsp42.9-2-1TH1-13.sdn

tftp-server flash0:jar42sccp.9-2-1TH1-13.sbn alias jar42sccp.9-2-1TH1-13.sdn

tftp-server flash0:term42.default.loads alias term42.default.loads

tftp-server flash0:term62.default.loads alias term62.default.loads

!

control-plane

!

!

voice-port 0/0/0

trunk-group POTSTRK

supervisory disconnect dualtone mid-call

no battery-reversal

echo-cancel erl worst-case 0

echo-cancel mode 2

cptone MY

timeouts call-disconnect 3

timeouts ringing infinity

timeouts wait-release 3

connection plar 200

description FXS

caller-id enable

!

voice-port 0/0/1

trunk-group POTSTRK

supervisory disconnect dualtone mid-call

no battery-reversal

echo-cancel erl worst-case 0

echo-cancel mode 2

cptone MY

timeouts call-disconnect 3

timeouts ringing infinity

timeouts wait-release 3

connection plar 107

description FXS

!

voice-port 0/0/2

trunk-group POTSTRUNK

supervisory disconnect dualtone mid-call

no battery-reversal

echo-cancel erl worst-case 0

echo-cancel mode 2

cptone MY

timeouts call-disconnect 3

timeouts ringing infinity

timeouts wait-release 3

connection plar 200

description FXS

!

voice-port 0/0/3

trunk-group POTSTRUNK

supervisory disconnect dualtone mid-call

no battery-reversal

echo-cancel erl worst-case 0

echo-cancel mode 2

cptone MY

timeouts call-disconnect 3

timeouts ringing infinity

timeouts wait-release 3

connection plar 200

description FXS

!

!

!

!

!

mgcp fax t38 ecm

!

mgcp profile default

!

!

dial-peer voice 1 pots

service stcapp

port 0/0/0

!

dial-peer voice 2 pots

service stcapp

port 0/0/1

!

dial-peer voice 3 pots

service stcapp

port 0/0/2

!

dial-peer voice 4 pots

service stcapp

port 0/0/3

!

dial-peer voice 54 pots

trunkgroup POTSTRK

description ** FXO pots dial-peer **

translation-profile outgoing CALLER_ID_TRANSLATION_PROFILE

preference 5

destination-pattern 9.T

no sip-register

!

dial-peer voice 104 pots

description "Incoming Call to DN"

translation-profile incoming INBOUND_TRANSLATION_PROFILE

destination-pattern 1...

incoming called-number .%

direct-inward-dial

port 0/0/0

!

dial-peer voice 2000 voip

destination-pattern 8..

session protocol sipv2

session target ipv4:10.52.138.41

dtmf-relay sip-notify

codec g711ulaw

!

dial-peer voice 105 pots

description "Incoming Call to DN"

translation-profile incoming INBOUND_TRANSLATION_PROFILE

destination-pattern 1...

incoming called-number .%

direct-inward-dial

port 0/0/1

!

dial-peer voice 106 pots

description "Incoming Call to DN"

translation-profile incoming INBOUND_TRANSLATION_PROFILE

destination-pattern 1...

incoming called-number .%

direct-inward-dial

port 0/0/2

!

dial-peer voice 107 pots

description "Incoming Call to DN"

translation-profile incoming INBOUND_TRANSLATION_PROFILE

destination-pattern 1...

incoming called-number .%

direct-inward-dial

port 0/0/3

!

dial-peer voice 220 pots

trunkgroup POTSTRK

description ** Mobile No. (7-digits) **

translation-profile outgoing OUTGOING_TRANSLATION_PROFILE

destination-pattern 901[0,2-9].......

!

dial-peer voice 200 pots

trunkgroup POTSTRK

description ** Outstation No. **

translation-profile outgoing OUTGOING_TRANSLATION_PROFILE

destination-pattern 90[2,4-7,9]T

direct-inward-dial

!

dial-peer voice 210 pots

trunkgroup POTSTRK

description ** Sabah/Sarawak **

translation-profile outgoing OUTGOING_TRANSLATION_PROFILE

destination-pattern 908[2-9]T

direct-inward-dial

!

dial-peer voice 230 pots

trunkgroup POTSTRK

description ** Mobile No. (8-digits) **

translation-profile outgoing OUTGOING_TRANSLATION_PROFILE

destination-pattern 9011........

direct-inward-dial

!

dial-peer voice 240 pots

trunkgroup POTSTRK

description ** Toll-Free **

translation-profile outgoing OUTGOING_TRANSLATION_PROFILE

destination-pattern 91[3,6,8]00......

direct-inward-dial

!

dial-peer voice 250 pots

trunkgroup POTSTRK

description ** IDD to Singapore **

translation-profile outgoing OUTGOING_TRANSLATION_PROFILE

destination-pattern 90065[0,1-9].......

direct-inward-dial

!

dial-peer voice 260 pots

trunkgroup POTSTRK

description ** IDD to the rests **

translation-profile outgoing OUTGOING_TRANSLATION_PROFILE

preference 7

destination-pattern 900T

direct-inward-dial

!

dial-peer voice 270 pots

trunkgroup POTSTRK

description ** Local No. **

translation-profile outgoing OUTGOING_TRANSLATION_PROFILE

destination-pattern 9[2-9].......

direct-inward-dial

!

dial-peer voice 313 pots

trunkgroup POTSTRUNK

description ** Local No. **

translation-profile outgoing OUTGOING_TRANSLATION_PROFILE_D9

destination-pattern 69[2-9].......

direct-inward-dial

!

dial-peer voice 306 pots

trunkgroup POTSTRUNK

description ** Mobile No. (7-digits) **

translation-profile outgoing OUTGOING_TRANSLATION_PROFILE_D9

destination-pattern 6901[0,2-9].......

!

dial-peer voice 307 pots

trunkgroup POTSTRUNK

description ** Outstation No. **

translation-profile outgoing OUTGOING_TRANSLATION_PROFILE_D9

destination-pattern 690[2,4-7,9]T

direct-inward-dial

!

dial-peer voice 308 pots

trunkgroup POTSTRUNK

description ** Sabah/Sarawak **

translation-profile outgoing OUTGOING_TRANSLATION_PROFILE_D9

destination-pattern 6908[2-9]T

direct-inward-dial

!

dial-peer voice 310 pots

trunkgroup POTSTRUNK

description ** Toll-Free **

translation-profile outgoing OUTGOING_TRANSLATION_PROFILE_D9

destination-pattern 691[3,6,8]00......

direct-inward-dial

!

dial-peer voice 311 pots

trunkgroup POTSTRUNK

description ** IDD to Singapore **

translation-profile outgoing OUTGOING_TRANSLATION_PROFILE_D9

destination-pattern 690065[0,1-9].......

direct-inward-dial

!

dial-peer voice 312 pots

trunkgroup POTSTRUNK

description ** IDD to the rests **

translation-profile outgoing OUTGOING_TRANSLATION_PROFILE_D9

preference 7

destination-pattern 6900T

direct-inward-dial

!

dial-peer voice 2001 voip

destination-pattern 7..

session protocol sipv2

session target ipv4:10.54.2.2

dtmf-relay sip-notify

codec g711ulaw

!

!

!

!

gatekeeper

shutdown

!

!

telephony-service

max-ephones 40

max-dn 40

ip source-address 10.53.4.2 port 2000

auto assign 1 to 40

service phone ehookEnable 1

service directed-pickup gpickup

service dnis dir-lookup

timeouts interdigit 4

cnf-file location flash:

load 7942 SCCP42.9-2-1S

load 6921 SCCP69xx.9-2-1-0

time-zone 43

date-format dd-mm-yy

max-conferences 8 gain -6

moh "flash:/music-on-hold.au"

transfer-system full-consult

directory entry 1 100 name Aniza

directory entry 2 101 name Kumar

directory entry 3 102 name Desk-Phone

directory entry 4 103 name Raj

directory entry 5 104 name 5

directory entry 6 105 name Daniel

directory entry 7 106 name Anderson

directory entry 8 107 name Bala

directory entry 9 108 name Jessica

directory entry 10 115 name Staff 1

directory entry 11 116 name Staff 2

directory entry 12 117 name Staff 3

directory entry 13 118 name Staff 4

directory entry 14 119 name Staff 5

directory entry 15 120 name Staff 6

directory entry 16 321 name IT Service Desk

create cnf-files version-stamp 7960 Oct 04 2013 12:20:49

!

!

ephone-dn-template  1

!

!

ephone-template  1

softkeys idle  Redial Newcall Cfwdall Gpickup Dnd

softkeys connected  Hold Endcall Trnsfer Park Confrn ConfList

!

!

ephone-dn  1

number 100

pickup-call any-group

pickup-group 1

label Aniza

name Aniza

!

!

ephone-dn  2

number 101

pickup-call any-group

pickup-group 1

label Kumar

name Kumar

!

!

ephone-dn  3

number 102

pickup-call any-group

pickup-group 1

!

!

ephone-dn  4

number 103

pickup-call any-group

pickup-group 1

label Raj

name Raj

!

!

ephone-dn  5

number 104

pickup-call any-group

pickup-group 1

!

!

ephone-dn  6

number 105

pickup-call any-group

pickup-group 1

label Daniel

name Daniel

!

!

ephone-dn  7

number 106

pickup-call any-group

pickup-group 1

label Anderson

name Anderson

!

!

ephone-dn  8

number 107

pickup-call any-group

pickup-group 1

label Bala

name Bala

!

!

ephone-dn  9

number 116

pickup-call any-group

pickup-group 1

label Staff 4

name Staff 4

!

!

ephone-dn  10

number 109

pickup-call any-group

!

!

ephone-dn  11

number 111

pickup-call any-group

!

!

ephone-dn  12

number 321

description IT ServiceDesk

call-forward all 90048717608503

!

!

ephone-dn  15

number 115

pickup-call any-group

pickup-group 1

label Staff 1

name Staff 1

!

!

ephone-dn  16

number 108

pickup-call any-group

pickup-group 1

label Jessica

name Jessica

!

!

ephone-dn  17

number 117

pickup-call any-group

pickup-group 1

label Staff 3

name Staff 3

!

!

ephone-dn  18

number 118

pickup-call any-group

pickup-group 1

label Staff 4

name Staff 4

!

!

ephone-dn  19

number 119

pickup-call any-group

pickup-group 1

label Staff 5

name Staff 5

!

!

ephone-dn  20

number 120

pickup-call any-group

pickup-group 1

label Staff 6

name Staff 6

!

!

ephone-dn  39

number 188 no-reg primary

park-slot directed timeout 60 limit 2 transfer 100

name ParkSlot

!

!

ephone  1

mac-address 1833.9D15.43C2

ephone-template 1

type 7942

button  1:8

!

!

!

ephone  2

mac-address 1CE6.C799.7E7E

ephone-template 1

fastdial 1 0193309984 name Ken

fastdial 2 0137837783 name Gabriel

type 6921

button  1:3

!

!

!

ephone  3

mac-address 1CE6.C799.7EF9

ephone-template 1

type 6921

button  1:4

!

!

!

ephone  4

mac-address 1CE6.C799.3F86

ephone-template 1

type 6921

button  1:2

!

!

!

ephone  5

mac-address 1CE6.C799.7E43

ephone-template 1

type 6921

button  1:5

!

!

!

ephone  6

mac-address 10BD.1800.7793

ephone-template 1

type 7942

button  1:7

!

!

!

ephone  7

mac-address 1CE6.C799.83C2

ephone-template 1

type 6921

button  1:1

!

!

!

ephone  8

mac-address 10BD.1800.7807

ephone-template 1

fastdial 1 9087442905 name offshore

type 7942

button  1:9

!

!

!

ephone  9

!

!

!

ephone  15

mac-address 44AD.D9D4.0A96

ephone-template 1

speed-dial 1 690128802017 label "wan"

speed-dial 2 690129545350 label "Iris"

speed-dial 3 690128599381 label "Irrvin"

speed-dial 4 690135975705 label "Sam"

type 7965

button  1:15

!

!

!

ephone  16

mac-address 44AD.D9D4.1717

ephone-template 1

speed-dial 1 9087519905 label "lab"

speed-dial 2 690062554412867 label "Ke"

speed-dial 3 90128599381 label "Irrvin"

speed-dial 4 90183322123 label "Zen"

type 7965

button  1:16

!

!

!

ephone  17

mac-address 44AD.D9D4.1746

ephone-template 1

type 7965

button  1:17

!

!

!

ephone  18

mac-address E8ED.F3AB.0CEC

ephone-template 1

type 7965

button  1:18

!

!

!

ephone  19

mac-address E8ED.F3AB.0BD6

ephone-template 1

type 7965

button  1:19

!

!

!

ephone  20

mac-address E8ED.F3AB.0EBC

ephone-template 1

type 7965

button  1:20

!

!

ephone-hunt 1 sequential

pilot 200

list 102, 101, 100, 120

final 102

timeout 20, 20, 10, 10

statistics collect

present-call onhook-phone

!

!

ephone-hunt 2 sequential

!

!

!

!

line con 0

line aux 0

line 2

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

stopbits 1

line vty 0 4

password cisco

login local

transport input all

line vty 5 15

login

transport input all

!

scheduler allocate 20000 1000

ntp server 120.100.97.148 prefer

!

end

Cisco_CME#

4 REPLIES

Route incoming call to extension

I think you need B-ACD and AA for that ...

http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cucme/bacd/configuration/guide/cme40tcl/40bacd.html

Go though this link and change it accroding to your requirement.

Thanks

Manish

Route incoming call to extension

You can do the AA on CUE.

voice-port 0/0/0

connection plar 820952 !(AA Extension on CUE)

caller-id enable

!

dial-peer voice 820952 voip (!Dial peer to CUE)

destination-pattern 820952

session protocol sipv2

session target ipv4:172.28.85.2

!

Then configure your CUE which will be a mailbox of 820952 like in my example. You can then record prompts and have it transfer to extensions from Unity.

New Member

Route incoming call to extension

Does it mean that I have to buy additional module to support it?

New Member

Route incoming call to extension

Hi Kevin,

You can go through the link that Manish Prasad share.

You can build Auto Attendant like the request on CME using TCL script (the script is provided by Cisco and you can download form cisco.com)

You don't need any additional module to support it, just follow the config guide.

Rgds

Novri

217
Views
0
Helpful
4
Replies