Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

Route Pattern gets fast busy tone

Hi,

Well, I am facing some issues in hitting the route pattern. Let me describe you the short scenario of my Lab.

I have Cucm7 Pub and Sub servers on VMware ESXi and have added an H.323 gateway at CUCM side to hit the calls at Branch 2.

I created a route pattern 3XXX ( which happens to be Branch 2 Phones) and got it routed through the H.323 gateway and it works fine.

Also, I would like to mention here, there is no CSS or route partitions defined.

The 3XXX patterns works fine, so I copied it and created another pattern of 7XXX and saved it and then tried to hit this pattern and that is what pissing me off as I am getting the fast busy tone as soon as I hit the very first digit '7'.

I did check the Route Plan Report and there is no other patterns or DNs that might have been blocked.

So, here I am stuck, what else to be checked or how I can do the troubleshooting to get my patterns running.

Your sincere help would be appreciated.

Thanks

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Route Pattern gets fast busy tone

Take a look on this document, as screenshots to facilitate to you

http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_tech_note09186a00809643e8.shtml

The replication status need to be GOOD.

Other doc you can see

https://supportforums.cisco.com/docs/DOC-13672

I think this is better...

Let me know when you see the status.

13 REPLIES
New Member

Route Pattern gets fast busy tone

Hi,

Check Call legs with DNA.

Serviceability-Dialed number analyzer.

It will show you what the problem i hope.

Route Pattern gets fast busy tone

Check the DNA!

See where the call is going....

The call is going to a gatewy? Trunk? Did you reset the gateway or the trunk?

Regards

Hall of Fame Super Silver

Route Pattern gets fast busy tone

What is branch 2?  You are saying you have H323 GW to it, is it congfigured as CME or something else? Do you have thr GW just to simulate GW calls as if branch 2 is off of the same CM cluster there would be no need for the GW?

Do you have matching dial-peer with desintation pattern 7...?  Can you post your H323 GW config and output from "debug voice dialpeer"?

HTH,

Chris

Route Pattern gets fast busy tone

Thanks Chris for your response,

Yes BR2 is configured as CME and I have added it as H.323 GW in cucm side.

Lets not get confused with GW side for the moment. As we need to focus as why the created Pattern 7XXX is not matching at the cucm side as its not even getting towards the gateway. So stuck at the CUCM side.

I have posted the DNA Analysis for your reference.

Route Pattern gets fast busy tone

Thanks for your warm responses,

I tried the DNA and as I have PUB and SUB serverrunning so I did analysis on PUB and went to serviceability.

ON, PUB, I have noticed analysis shows it matches the pattern from my 500X phone to route 7XXX using H.323 Gateway (192.168.1.200), it says "route this pattern"  ( Snapshot Attached)

But, ON SUB, the same analysis shows "block this pattern" ( Snapshot Attached)

so I am getting the fast busy signal.

Why is that ? are they not synched up properly? Is there might be some datbase replication issues?

Your sincere help would be appreciated.

Route Pattern gets fast busy tone

Can you log on the sub and see if you can find this Route Pattern..

Your phones are registerede on SUB?

After that you can check the database replication status.

Route Pattern gets fast busy tone

Yes, My Phones are registered on Sub (being Primary) and Route Pattern is visible on both servers as well as H.323 Gateway.

What else you would suggest?

How to check replication status? and How to overcome with it ?

Re: Route Pattern gets fast busy tone

Take a look on this document, as screenshots to facilitate to you

http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_tech_note09186a00809643e8.shtml

The replication status need to be GOOD.

Other doc you can see

https://supportforums.cisco.com/docs/DOC-13672

I think this is better...

Let me know when you see the status.

Hall of Fame Super Silver

Route Pattern gets fast busy tone

definitely seems like a DB replication issue as DNA does not show matching the 7XXX route pattern.  You can follow the above provided docs on how to check the replication, and search this forum for many other examples/resolutions to similar issues.

Chris

Route Pattern gets fast busy tone

Thanks for those reference docs.

Here is the excerpt Before I did any "utils dbreplication" commands through CLI

Well, here is some snapshot from Cisco Unified Reporting then generating report through Databse status summary

After performing utils dbreplication stop and then utils dbreplication reset as per document states it didn't go to status " Good 2"

once the utils dbreplication reset all and clusterrest being done, I am still getting Replication status "4" for the SUB Node

After looking into "file view activelog cm/log/informix/ccm.log" from CLI

and then i even performed the utils dbreplication dropadmindb and followed the reference doc but I am still not getting the status to be Good.

Any Suggestions? I am quite exhausted but I am still looking for some solution.

Any clues from the posted images? What else should be done?


Re: Route Pattern gets fast busy tone

Can you reboot the subscriber?

If dont work i suggest you open a case on Cisco TAC.

Let us know about the results of the reboot....

Thanks

Route Pattern gets fast busy tone

Well, I did rebooted then but that didn't seems to solve the issue.

Later, while i was looking some traces output, there was some time synchronization issue between subscriber and publisher. Actually, there was an ntp server configured at PUB which was pointing to dead IP (for Lab testing purpose), so I deleted that server IP and it ultimately starts synching with its own internal OS time.

on SUB side, it implicitly points to PUB for time so the time got synched after few minutes.

the RTMT was kept open and I was noticing the DB status and it was;

PUB status '2' ; and SUB Status '0'

and after few minutes, something amazing happened, it changes to '2'

And when i went to Cisco Unified Reporting the report through Unified CM Databse status looks like this;

and that what i was waiting to see since more than 2 days

Now Life is Good and I noticed the output DNA has been changed to Route this pattern and I am all good.

Here, I would like to tahnks to all for their participation and providing me valuable information.

Keep up the good work. Thanks

Re: Route Pattern gets fast busy tone

Oh very good news Muhammad

Thanks for share the results

Happy New Year..

Regards

Leonardo

675
Views
8
Helpful
13
Replies