Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

SCCP Transcoders and Conference doesn't register.

Dear Friends,

I having a strange issue, I have configured my 3945 GW with SCCP for Conferencing and Transcoding. Also on the CUCM Side, i have used the Cisco IOS Enhanced media termination Point for this setup but I see the transcoders are not getting registered. I had reset the items from both the sides but No luck.

In the "Debug SCCP all" i do see error 257 in socket.

The configs:

sccp local GigabitEthernet0/2

sccp ccm 19.106.182.15 identifier 2 version 7.0

sccp ccm 19.106.214.15 identifier 1 version 7.0

sccp

!

sccp ccm group 1

bind interface GigabitEthernet0/2

associate ccm 1 priority 1

associate ccm 2 priority 2

associate profile 2 register CFB-12345678901

associate profile 1 register XCD-12345678901

!

dspfarm profile 1 transcode 

description #XCODE dsp farm - G711/G729r8 only#

codec g711ulaw

codec g711alaw

codec g729r8

maximum sessions 30

associate application SCCP

!

dspfarm profile 2 conference 

description Ad-hoc conference - G711 only

codec g711ulaw

codec g711alaw

maximum sessions 8

associate application SCCP

DEBUG sccp all:

Jan 14 15:20:13: sccp_connect_to_ccm_on_priority_basis: Trying connecting to CCM on priority basis prof_id 2, appl_type 3

Jan 14 15:20:13: sccp_connect_to_ccm_on_priority_basis: Trying CCM with ipaddr 19.106.214.15, priority 1, port 2000

Jan 14 15:20:13: sccp_appl_service_start_timer: Start timer type 1 with time_out 30000ms

Jan 14 15:20:13: sccp_tcp_socket_connect: Trying tcp soc connect for appl_type 3, prof_id 2, to ipaddr 19.106.214.15

Jan 14 15:20:13: sccp_get_ccm_intf_vrf_id: ccm sccp local interface vrfid=0appl type is 3, appl profile 2

Jan 14 15:20:13: sccp_tcp_open_and_set_option: Socket 1 opened and binded to addr 19.106.214.15 - for appl_type 3, prof_id 2

Jan 14 15:20:13:  sccp_socket_connect_to_ccm :: connecting to port 2000 sccp_socket_connect_to_ccm: soc conn to 19.106.214.15 port 2000 in progressfor appl_type 3, state 1, soc_fd 1 appl 144C622C

Jan 14 15:20:13: sym_xapp_xlate_ccapi_eve: Unsupported ccapi eve 2

Jan 14 15:20:13: sym_xapp_process_ccapi_events: Unsupported ccapi eve_id 2

Jan 14 15:20:13: sccpapp_process_socket_events: appl_type 2, soc_fd 0, soc 0, swb_soc -1

Jan 14 15:20:13: sccpapp_process_socket_events: TCP_SOCKET_READ: appl_type 2, eve 4, state 1

Jan 14 15:20:13: sccp_appl_service_stop_timer: Stop 2064E60 timer

Jan 14 15:20:13: sccp_process_socket_connect_result: appl 2064E08, soc_recv err 257, len -1, appl_type 2

Jan 14 15:20:13: sccp_process_socket_connect_result: appl_type 2, eve 1, soc_id -1, state 1

14 REPLIES
New Member

SCCP Transcoders and Conference doesn't register.

The SCCP State is Up...

fingw001-vg3945#sh sccp

SCCP Admin State: UP

Gateway Local Interface: GigabitEthernet0/2

        IPv4 Address: 19.155.95.198

        Port Number: 2000

IP Precedence: 5

User Masked Codec list: None

Call Manager: 19.106.182.15, Port Number: 2000

                Priority: N/A, Version: 7.0, Identifier: 2

                Trustpoint: N/A

Call Manager: 19.106.214.15, Port Number: 2000

                Priority: N/A, Version: 7.0, Identifier: 1

                Trustpoint: N/A

Transcoding Oper State: ACTIVE_IN_PROGRESS - Cause Code: TCP_CONN_ERROR

Active Call Manager: NONE

TCP Link Status: NOT_CONNECTED, Profile Identifier: 1

Reported Max Streams: 60, Reported Max OOS Streams: 0

Supported Codec: g711ulaw, Maximum Packetization Period: 30

Supported Codec: g711alaw, Maximum Packetization Period: 30

Supported Codec: g729r8, Maximum Packetization Period: 60

Supported Codec: rfc2833 dtmf, Maximum Packetization Period: 30

Supported Codec: rfc2833 pass-thru, Maximum Packetization Period: 30

Supported Codec: inband-dtmf to rfc2833 conversion, Maximum Packetization Period: 30

Conferencing Oper State: ACTIVE_IN_PROGRESS - Cause Code: TCP_CONN_ERROR

Active Call Manager: NONE

TCP Link Status: NOT_CONNECTED, Profile Identifier: 2

Reported Max Streams: 64, Reported Max OOS Streams: 0

Supported Codec: g711ulaw, Maximum Packetization Period: 30

Supported Codec: g711alaw, Maximum Packetization Period: 30

Supported Codec: rfc2833 dtmf, Maximum Packetization Period: 30

Supported Codec: rfc2833 pass-thru, Maximum Packetization Period: 30

Supported Codec: inband-dtmf to rfc2833 conversion, Maximum Packetization Period: 30

TLS : ENABLED

SCCP Transcoders and Conference doesn't register.

Hi Mohsin,

Apart from ensuring that TCP port 2000 is not blocked between cucm and this gateway, the only other thing that i would like to ensure is that the names of transcoder and conference bridge used on cucm configuration page is the same as configured on the gateway i.e CFB-12345678901 and XCD-12345678901.

HTH

Manish

New Member

SCCP Transcoders and Conference doesn't register.

Hi Manish,

I did a telnet to the CUCM IP from the GW sourcing the GI0/2. Its open and also to make sure I am configuring it correct on the CUCM. I did delete the Xcoder on the CUCM and configured it from copying from the GW and pasted in the CUCM. But no Luck

fingw001-vg3945#telnet 19.106.182.12 2000 /source-interface gigabitEthernet 0/2

Trying 19.106.182.12, 2000 ... Open

^C^X

[Connection to 19.106.182.12 closed by foreign host]

fingw001-vg3945#

SCCP Transcoders and Conference doesn't register.

Can you please post the running config from the gateway and a screenshot of the cucm page showing xcoder config.

Manish

New Member

SCCP Transcoders and Conference doesn't register.

fingw001-vg3945#sh running-config

Building configuration...

Current configuration : 25223 bytes

!

! Last configuration change at 13:06:36 UTC Tue Jan 14 2014 by kmohsin

! NVRAM config last updated at 12:22:27 UTC Tue Jan 14 2014 by skarth43

!

version 15.1

no service pad

service timestamps debug datetime localtime

service timestamps log datetime localtime

service password-encryption

!

hostname fingw001-vg3945

!

boot-start-marker

boot system flash:c3900-universalk9-mz.SPA.151-3.T2.bin

boot-end-marker

!

!

logging buffered 16384

no logging console

enable secret 5 $1$OFF8$8Z8jdwPVNpsGaUg4DYXR11

!

aaa new-model

!

!

aaa authentication login default group tacacs+ enable

aaa authentication enable default group tacacs+ enable

aaa authorization config-commands

aaa authorization commands 0 default group tacacs+ if-authenticated

aaa authorization commands 15 default group tacacs+ if-authenticated

aaa accounting update newinfo

aaa accounting commands 15 default

action-type start-stop

group tacacs+

!

!

!

!

!

!

aaa session-id common

errdisable recovery cause udld

errdisable recovery cause rootguard

errdisable recovery cause pagp-flap

errdisable recovery cause dtp-flap

errdisable recovery cause link-flap

errdisable recovery interval 60

!        

no ipv6 cef

no ip source-route

ip cef

!

!

!

ip multicast-routing

!

!

ip domain list nls.ford.com

ip name-server 19.155.192.72

ip name-server 19.175.128.73

multilink bundle-name authenticated

!

!

!

!

!

crypto pki token default removal timeout 0

!

!

voice-card 0

dspfarm

dsp services dspfarm

!

!

voice call send-alert

voice call convert-discpi-to-prog

voice rtp send-recv

voice dsp crash-dump file-limit 3

voice dsp crash-dump destination flash:dsp-crash

!

voice service voip

ip address trusted list

  ipv4 19.106.182.0 255.255.255.0

  ipv4 19.106.214.0 255.255.255.0

address-hiding

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

redirect ip2ip

fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none

sip

  header-passing

  error-passthru

  asserted-id pai

  early-offer forced

  midcall-signaling passthru

  privacy-policy passthru

  sip-profiles 1

!

voice class codec 1

codec preference 1 g729r8

codec preference 2 g711ulaw

!

voice class sip-profiles 1

request INVITE sip-header Supported remove

request INVITE sip-header Min-SE remove

request INVITE sip-header Session-Expires remove

request INVITE sip-header Unsupported modify "Unsupported:" "timer"

request ANY sip-header Allow-Header modify ", UPDATE" ""

response ANY sip-header Allow-Header modify ", UPDATE" ""

!

!

!

!

voice translation-rule 1

rule 1 /\(^...$\)/ /7319\1/

!

voice translation-rule 2

rule 1 /^103447\(...$\)/ /7319\1/

!

voice translation-rule 3

rule 1 /^7319\(...$\)/ /103447\1/

!

voice translation-rule 4

rule 1 /^9\(.*\)/ /\1/

!

!

voice translation-profile Internal-to-PhoneDN

translate called 1

!

voice translation-profile PSTN-to-PhoneDN

translate called 2

!

voice translation-profile PhoneDN-to-PSTN

translate calling 3

translate called 4

!

!

!

application

package callfeature

  param med-inact-det enable

  param med-inact-disc-cause 44

  param med-inact-action disconnect

!

global

  service alternate DEFAULT

!

!

license udi pid C3900-SPE150/K9 sn FOC174198Z0

license accept end user agreement

hw-module pvdm 0/0

!

!

!

vtp domain fingw001-vg3945

vtp mode transparent

!

redundancy

!

!

ip tcp path-mtu-discovery age-timer 30

!!

!

!

interface GigabitEthernet0/0

no ip address

shutdown

duplex auto

speed auto

!

interface GigabitEthernet0/1

description rhost="finfw001" rint="G1/0"

ip address 19.155.95.206 255.255.255.252

duplex auto

speed auto

service-policy input EdgeMark2

!

interface GigabitEthernet0/2

description rhost="finrs001" rint="G3/22"

ip address 19.155.95.198 255.255.255.252

no ip redirects

duplex auto

speed auto

!

ip forward-protocol nd

!

no ip pim dm-fallback

ip pim autorp listener

no ip http server

no ip http secure-server

ip flow-cache timeout active 1

ip flow-export source GigabitEthernet0/2

ip flow-export version 5

ip flow-export destination 19.97.9.164 9995

!

ip route 0.0.0.0 0.0.0.0 19.155.95.197

ip route 10.80.144.0 255.255.255.0 19.155.95.205

ip route 192.168.13.232 255.255.255.252 19.155.95.205

ip tacacs source-interface GigabitEthernet0/2

!

ip access-list extended Virus_LAN

deny   53 any any

deny   55 any any

deny   77 any any

deny   pim any any

deny   tcp any any eq 5554

deny   tcp any any eq 8594

deny   tcp any any eq 8563

permit ip any any

ip access-list extended Virus_LAN_PIM

deny   53 any any

deny   55 any any

deny   77 any any

deny   tcp any any eq 5554

deny   tcp any any eq 8594

deny   tcp any any eq 8563

permit ip any any

ip access-list extended Virus_Server

deny   53 any any

deny   55 any any

deny   77 any any

deny   pim any any

deny   tcp any any eq 5554

deny   tcp any any eq 8594

deny   tcp any any eq 8563

permit ip any any

ip access-list extended Virus_Server_PIM

deny   53 any any

deny   55 any any

deny   77 any any

deny   tcp any any eq 5554

deny   tcp any any eq 8594

deny   tcp any any eq 8563

permit ip any any

ip access-list extended Virus_WAN

deny   53 any any

deny   55 any any

deny   77 any any

deny   pim any any

deny   udp any any eq 1434

deny   tcp any any eq 5554

deny   tcp any any eq 8594

deny   tcp any any eq 8563

permit ip any any

ip access-list extended Virus_WAN_PIM

deny   53 any any

deny   55 any any

deny   77 any any

deny   udp any any eq 1434

deny   tcp any any eq 5554

deny   tcp any any eq 8594

deny   tcp any any eq 8563

permit ip any any

!

ip sla responder

logging trap debugging

logging source-interface GigabitEthernet0/2

logging 19.97.9.50

logging 19.97.9.80

access-list 4 remark - SNMP access for NMS subnet

access-list 4 permit 19.97.9.0 0.0.0.255

access-list 9 remark - SNMP access for HP DDMA subnets

access-list 9 permit 19.106.113.16 0.0.0.15

access-list 9 permit 19.106.113.32 0.0.0.15

access-list 9 permit 19.106.117.16 0.0.0.15

access-list 9 permit 19.106.117.32 0.0.0.15

access-list 9 permit 19.110.113.16 0.0.0.15

access-list 9 permit 19.110.113.32 0.0.0.15

access-list 9 permit 19.110.117.16 0.0.0.15

access-list 9 permit 19.110.117.32 0.0.0.15

access-list 141 remark * Iron class - Interactive Queue (IP Precedence 1)

access-list 141 remark - generic TCP traffic, excludes Internet web & C3P Metaphase Mux

access-list 141 remark - Public Internet proxy HTTP/HTTPS excluded (drops to default queue)

access-list 141 deny   tcp any any eq 83

access-list 141 deny   tcp any eq 83 any

access-list 141 remark - C3P bulk traffic port number

access-list 141 deny   tcp any any eq 4544

access-list 141 deny   tcp any eq 4544 any

access-list 141 deny   tcp any any eq 16016

access-list 141 deny   tcp any eq 16016 any

access-list 141 remark - MX2 Handhelds (intentionally one way)

access-list 141 deny   tcp any range 4000 4050 any

access-list 141 remark - The following permit catches any non-excluded TCP

access-list 141 permit tcp any any

access-list 141 remark - SNMP traffic from NetOps Mgt subnet with CS1 *

access-list 141 permit udp 19.97.9.0 0.0.0.255 any eq snmp

access-list 141 permit udp any eq snmp 19.97.9.0 0.0.0.255

access-list 141 permit udp any 19.97.9.0 0.0.0.255 eq snmptrap

access-list 142 remark * Bronze class - Interactive Queue (IP Precedence 2)

access-list 142 remark - DNS query/response, Pinnacle

access-list 142 permit udp any any eq domain

access-list 142 permit udp any eq domain any

access-list 142 remark - HTTP traffic (within Ford only)

access-list 142 permit tcp any any eq www

access-list 142 permit tcp any eq www any

access-list 142 remark - SSL Web traffic

access-list 142 permit tcp any any eq 443

access-list 142 permit tcp any eq 443 any

access-list 142 deny   tcp any any lt 1024

access-list 142 deny   tcp any lt 1024 any

access-list 142 permit tcp any any eq 8058

access-list 142 permit tcp any eq 8058 any

access-list 143 remark * Silver class - Video Queue (IP Precedence 3)

access-list 143 remark - Exclude low ports to reduce false triggers on

access-list 143 remark client random ephemeral ports

access-list 143 deny   udp any any lt 1024

access-list 143 deny   udp any lt 1024 any

access-list 143 deny   tcp any any lt 1024

access-list 143 deny   tcp any lt 1024 any

access-list 143 remark -  Devices allowed into the video queue are trusted

access-list 143 remark at source and mark IP Prec 3.   Adding "precedence flash"

access-list 143 remark to  permits excludes unplanned usage of queue.

access-list 143 remark - H.225 RAS

access-list 143 permit udp any any eq 1719 precedence flash

access-list 143 permit udp any eq 1719 any precedence flash

access-list 143 remark - H.323 control traffic

access-list 143 permit tcp any any eq 1720 precedence flash

access-list 143 permit tcp any eq 1720 any precedence flash

access-list 143 remark - H.245 control traffic

access-list 143 permit tcp any any range 5555 5560 precedence flash

access-list 143 permit tcp any range 5555 5560 any precedence flash

access-list 143 permit tcp any any range 11000 11999 precedence flash

access-list 143 permit tcp any range 11000 11999 any precedence flash

access-list 143 remark - SCCP (skinny) traffic

access-list 143 permit tcp any any range 2000 2002 precedence flash

access-list 143 remark - Video & Audio RTCP traffics, MGCP (UDP:2427)

access-list 143 permit tcp any any range 2326 2331 precedence flash

access-list 143 permit tcp any range 2326 2331 any precedence flash

access-list 143 permit udp any any range 2327 2499 precedence flash

access-list 143 permit udp any range 2327 2499 any precedence flash

access-list 143 remark - Secure SCCP (skinny) traffic

access-list 143 permit tcp any any eq 2443 precedence flash

access-list 143 remark - Secure and non-secure SIP traffic

access-list 143 permit tcp any any range 5060 5061 precedence flash

access-list 143 permit tcp any range 5060 5061 any precedence flash

access-list 143 permit udp any any range 5060 5061 precedence flash

access-list 143 permit udp any range 5060 5061 any precedence flash

access-list 143 remark - Avaya IP telephony control signaling

access-list 143 permit tcp any any range 5010 5012 precedence flash

access-list 143 permit tcp any range 5010 5012 any precedence flash

access-list 144 remark * Gold class - Interactive Queue (IP Precedence 4)

access-list 144 remark - SQL*Net

access-list 144 permit tcp any any eq 66

access-list 144 permit tcp any eq 66 any

access-list 144 remark - Telnet

access-list 144 permit tcp any eq telnet any

access-list 144 permit tcp any any eq telnet

access-list 144 remark - Altel TN3270

access-list 144 permit tcp any any eq 1023

access-list 144 permit tcp any eq 1023 any

access-list 144 deny   tcp any any lt 1024

access-list 144 deny   tcp any lt 1024 any

access-list 144 remark - DLSw

access-list 144 permit tcp any eq 2065 any

access-list 144 permit tcp any any eq 2065

access-list 144 remark - SQL

access-list 144 permit tcp any any eq 1521

access-list 144 permit tcp any eq 1521 any

access-list 144 remark - Ford TN3270

access-list 144 permit tcp any any eq 5031

access-list 144 permit tcp any eq 5031 any

access-list 144 remark - Deny multicast and mark lightweight wireless CAPWAP control traffic

access-list 144 deny   udp any 224.0.0.0 15.255.255.255

access-list 144 permit udp any any eq 5246

access-list 144 permit udp any eq 5246 any

access-list 145 remark * Platinum class - Voice Queue (IP Precedence 5)

access-list 145 remark - Exclude low ports to reduce false triggers on client random ephemeral ports

access-list 145 deny   udp any any lt 1024

access-list 145 deny   udp any lt 1024 any

access-list 145 remark - voice RTP packets

access-list 145 permit udp any any range 16384 32767 dscp ef

access-list 145 permit udp any range 16384 32767 any dscp ef

access-list 146 remark * Internet class - Routing Queue (Trust Marking)

access-list 146 remark - Routing protocols: OSPF, EIGRP, BGP

access-list 146 permit ospf any any

access-list 146 permit eigrp any any

access-list 146 permit tcp any any eq bgp

access-list 146 permit tcp any eq bgp any

access-list 146 remark - Lightweight wireless CAPWAP data traffic

access-list 146 permit udp any any eq 5247

access-list 146 permit udp any eq 5247 any

access-list 148 remark * Mcast class - Interactive Queue (IP Precedence 1)

access-list 148 permit udp any 239.80.0.0 0.0.0.127

access-list 149 remark * IP_Video class - Video Queue (IP Precedence 4)

access-list 149 remark - Exclude low ports to reduce false triggers on client random ephemeral ports

access-list 149 deny   udp any any lt 1024

access-list 149 deny   udp any lt 1024 any

access-list 149 permit udp any any range 2326 2498 dscp af41

access-list 149 permit udp any range 2326 2498 any dscp af41

!

nls resp-timeout 1

cpd cr-id 1

!

snmp-server community B1K7PD3L RO 9

snmp-server ifindex persist

snmp-server trap-source GigabitEthernet0/2

snmp-server location addr Bldg Abbr"FCEFFI" (7007) Bldg name "Ford Finland & FORSO Address: Plaza Business Park Building Halo  Ayritie 24 City: Vantaa Finland 01510

snmp-server contact name ="Jere Vastaki" Fordnet"7319152" Phone"358-9-35170152" CDS"jvastama"

snmp-server enable traps ospf state-change

snmp-server enable traps ospf errors

snmp-server enable traps ospf retransmit

snmp-server enable traps ospf lsa

snmp-server enable traps ospf cisco-specific state-change nssa-trans-change

snmp-server enable traps ospf cisco-specific state-change shamlink neighbor

snmp-server enable traps ospf cisco-specific errors

snmp-server enable traps ospf cisco-specific retransmit

snmp-server enable traps ospf cisco-specific lsa

snmp-server enable traps envmon

snmp-server enable traps bgp

snmp-server enable traps entity

snmp-server enable traps fru-ctrl

snmp-server enable traps hsrp

snmp-server host 19.97.9.134 fordsnmp

snmp-server host 19.97.9.135 fordsnmp

tacacs-server host 19.97.9.193

tacacs-server host 19.97.9.202

tacacs-server timeout 10

tacacs-server key 7 1335051718180D2E2223212734364315

!

!

control-plane

!

!

voice-port 0/0/0

!

voice-port 0/0/1

!

voice-port 0/0/2

!

voice-port 0/0/3

!

!

!

mgcp profile default

!

sccp local GigabitEthernet0/2

sccp ccm 19.106.182.15 identifier 2 version 7.0

sccp ccm 19.106.214.15 identifier 1 version 7.0

sccp

!

sccp ccm group 1

bind interface GigabitEthernet0/2

associate ccm 1 priority 1

associate ccm 2 priority 2

associate profile 2 register CFB-FINGW001EU2

associate profile 1 register XCD-FINGW001EU2

!

dspfarm profile 1 transcode 

description #XCODE dsp farm - G711/G729r8 only#

codec g711ulaw

codec g711alaw

codec g729r8

maximum sessions 30

associate application SCCP

!

dspfarm profile 2 conference 

description Ad-hoc conference - G711 only

codec g711ulaw

codec g711alaw

maximum sessions 8

associate application SCCP

!

dial-peer voice 3501 voip

tone ringback alert-no-PI

description Incoming from PSTN/SIP provider

translation-profile incoming PSTN-to-PhoneDN

session protocol sipv2

incoming called-number .T

voice-class codec 1 

voice-class sip early-offer forced

voice-class sip profiles 1

dtmf-relay rtp-nte digit-drop

ip qos dscp cs3 signaling

no vad

!

dial-peer voice 3601 voip

tone ringback alert-no-PI

description incoming from CUCM-SIP Trunk

session protocol sipv2

incoming called-number 9T

voice-class codec 1 

voice-class sip early-offer forced

voice-class sip profiles 1

dtmf-relay rtp-nte sip-notify

ip qos dscp cs3 signaling

no vad

!

dial-peer voice 4501 voip

description Outgoing PSTN/SIP provider

translation-profile outgoing PhoneDN-to-PSTN

destination-pattern 9T

session protocol sipv2

session target ipv4:10.80.144.10

voice-class codec 1 

voice-class sip early-offer forced

voice-class sip profiles 1

voice-class sip options-keepalive

dtmf-relay rtp-nte digit-drop

ip qos dscp cs3 signaling

no vad

!

dial-peer voice 4601 voip

description Outgoing CUCM-SIP Trunk to CUCM Subscriber 1

preference 1

destination-pattern 7319...$

session protocol sipv2

session target ipv4:19.106.214.15

voice-class codec 1 

voice-class sip early-offer forced

voice-class sip profiles 1

voice-class sip options-keepalive

dtmf-relay sip-notify rtp-nte

ip qos dscp cs3 signaling

no vad

!

dial-peer voice 4602 voip

description Outgoing CUCM-SIP Trunk to CUCM Subscriber 2

preference 2

destination-pattern 7319...$

session protocol sipv2

session target ipv4:19.106.182.15

voice-class codec 1 

voice-class sip early-offer forced

voice-class sip profiles 1

voice-class sip options-keepalive

dtmf-relay sip-notify rtp-nte

ip qos dscp cs3 signaling

no vad

!

!

dial-peer hunt 1

gateway

media-inactivity-criteria all

timer media-inactive 5

timer receive-rtp 1200

!

sip-ua

set pstn-cause 1 sip-status 503

set pstn-cause 3 sip-status 503

retry invite 2

retry bye 2

retry cancel 2

timers trying 550

g729-annexb override

!

!

!

gatekeeper

shutdown

!

!

banner motd ^C

WARNING! THIS IS A PRIVATE COMPUTER SYSTEM. USAGE MAY BE

MONITORED AND UNAUTHORIZED ACCESS OR USE MAY RESULT IN

CRIMINAL OR CIVIL PROSECUTION.

Except for some privacy rights granted by applicable law,

by signing on to the system you acknowledge:

You do not have any expectation of privacy in your use of the system.

You are familiar with, understand, accept, and will comply with the

provisions of Company Directive B-109.

^C

!

line con 0

exec-timeout 20 0

password 7 045307225A7364775E4A03

transport preferred none

line aux 0

exec-timeout 20 0

password 7 045307225A7364775E4A03

line vty 0 4

exec-timeout 20 0

password 7 060E0305191C2120524414

transport preferred none

transport input telnet

!

scheduler allocate 20000 1000

ntp server 19.211.4.1

ntp server 19.211.5.1

end

fingw001-vg3945#   

fingw001-vg3945#

VIP Super Bronze

SCCP Transcoders and Conference doesn't register.

Ensure that the cucm servers configured in your sccp configuration are also the same servers in the cucm group assigned to the CFB and Xcoder...

Then try a conf t, no sccp, sccp ( this will reset the sccp process on the gateway)

Please rate all useful posts

"The essence of christianity is not the enthronement but the obliteration of self --William Barclay"

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"

SCCP Transcoders and Conference doesn't register.

Config looks good, try the couple of steps suggested by aokanlawon and if the issue persists its surely going to be a network issue, as suggested by the TCP errors in the output of show sccp.

Manish

New Member

SCCP Transcoders and Conference doesn't register.

aokanlawon,

Thanks for the comment. But It was already checked but no issues found. As i mentioned while raising, it has been reset from both the sides (CUCM & GW ). Also the GW has been reloaded. I am looking some info on the  "TCP_CONN_ERROR" which I am getting on the "Show SCCP". it did checked this on forums but didn't get the valid information. Also If you could check the Debugs. I do receive the error.. Please advise..

Jan 14 15:20:13: sccp_process_socket_connect_result: appl 2064E08, soc_recv err 257, len -1, appl_type 2

VIP Super Bronze

SCCP Transcoders and Conference doesn't register.

Is there a firewall between the gateway and CUCM?

Please rate all useful posts

"The essence of christianity is not the enthronement but the obliteration of self --William Barclay"

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
New Member

SCCP Transcoders and Conference doesn't register.

Yes, There is a firewall but we have ensure that the ports are unblocked thru it.. Just fyi below..

fingw001-vg3945#telnet 19.106.182.12 2000 /source-interface gigabitEthernet 0/2

Trying 19.106.182.12, 2000 ... Open

^C^X

[Connection to 19.106.182.12 closed by foreign host]

fingw001-vg3945#

VIP Super Bronze

SCCP Transcoders and Conference doesn't register.

Can you turn on "debug ip tcp transaction" on the gateway. From the logs, the gateway doesnt seem to be able to open TCP connection to port 2000

Please rate all useful posts

"The essence of christianity is not the enthronement but the obliteration of self --William Barclay"

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
New Member

SCCP Transcoders and Conference doesn't register.

Yes, I do see some issue in the connectivity..

Jan 14 17:21:13: TCB122D846C setting property TCP_NO_DELAY (0) 13BCE49C

Jan 14 17:21:13: TCP: Random local port generated 27178, network 1

Jan 14 17:21:13: TCB122D846C bound to 19.155.95.198.27178

Jan 14 17:21:13: TCB122D846C setting property TCP_NONBLOCKING_WRITE (10) 13BCE52C

Jan 14 17:21:13: TCB122D846C setting property TCP_NONBLOCKING_READ (14) 13BCE52C

Jan 14 17:21:13: TCB122D846C setting property TCP keepalive timeout (17) 13BCE52C

Jan 14 17:21:13: TCB122D846C setting property TCP_TOS (11) 13BCE4D0

Jan 14 17:21:13: Reserved port 27178 in Transport Port Agent for TCP IP type 1

Jan 14 17:21:13: TCP: pmtu enabled,  mss is currently set to 1460

Jan 14 17:21:13: TCP: sending SYN, seq 624419875, ack 0

Jan 14 17:21:13: TCP0: Connection to 19.106.214.15:2000, advertising MSS 1460

Jan 14 17:21:13: TCP0: state was CLOSED -> SYNSENT [27178 -> 19.106.214.15(2000)]

Jan 14 17:21:13: TCB0204FB44 setting property TCP_TOS (11) 13912CD0

Jan 14 17:21:13: TCB0204EC2C setting property TCP_TOS (11) 13912CD0

Jan 14 17:21:15: TCB0204EC2C setting property TCP_TOS (11) 13912CD0

Jan 14 17:21:15: TCB13D17D2C setting property TCP_TOS (11) 13912CD0

Jan 14 17:21:15: 19.155.95.198:27178 <---> 19.106.214.15:2000   congestion window changes

Jan 14 17:21:15: cwnd from 1460 to 1460, ssthresh from 65535 to 2920

Jan 14 17:21:15: TCP0: timeout #1 - timeout is 4000 ms, seq 624419875

Jan 14 17:21:15: TCP: (27178) -> 19.106.214.15(2000)

Jan 14 17:21:15: TCP0: ICMP destination unreachable received

Jan 14 17:21:15: Released port 27178 in Transport Port Agent for TCP IP type 1 delay 240000

Jan 14 17:21:15: TCP0: state was SYNSENT -> CLOSED [27178 -> 19.106.214.15(2000)]

Jan 14 17:21:15: TCB 0x122D846C destroyed

Jan 14 17:21:15: TCB0204FB44 setting property TCP_TOS (11) 13912CD0

Jan 14 17:21:15: TCB0204EC2C setting property TCP_TOS (11) 13912CD0

Jan 14 17:21:15: TCB13D17D2C setting property TCP_TOS (11) 13912CD0

Any suggestions on this? I feel to take this up with the Firewall team..

SCCP Transcoders and Conference doesn't register.

interface GigabitEthernet0/2

description rhost="finrs001" rint="G3/22"

ip address 19.155.95.198 255.255.255.252

h323-gateway voip bind srcaddr 19.155.95.198

no ip redirects

duplex auto

speed auto

VIP Super Bronze

SCCP Transcoders and Conference doesn't register.

I suggest you contact the firewall team..The TCP connection is not getting established...

Please rate all useful posts

"The essence of christianity is not the enthronement but the obliteration of self --William Barclay"

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
1340
Views
0
Helpful
14
Replies
CreatePlease to create content