Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Setting up gateway - 2651XM PRI - no ISDN option Serial interface

I have a 2651XM running c2600-is-mz.122-15.T5.bin IOS.

It has the following hardware and software:

Primary Rate ISDN software, Version 1.1.

Basic Rate ISDN software, Version 1.1.

2 FastEthernet/IEEE 802.3 interface(s)

1 Serial network interface(s)

1 ISDN Basic Rate interface(s)

2 Channelized T1/PRI port(s)

2 Voice FXO interface(s)

2 Voice FXS interface(s)

I have configured the T1 card as:

controller T1 0/0

framing esf

clock source internal

linecode b8zs

cablelength short 133

channel-group 23 timeslots 24

However, when I go into the Serial 0/0:23 interface there are no "ISDN" commands. I want to set up the ISDN switchtype and setup the ISDN Bind-13 ccm-manager command.

Am I missing something?

Here is my running config:

Current configuration : 1860 bytes

!

version 12.2

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname testdialSBC

!

logging queue-limit 100

enable secret xxx

!

clock timezone cst -6

ip subnet-zero

ip tcp synwait-time 13

ip cef

!

!

!

isdn switch-type primary-ni

!

!

!

!

!

!

no voice hpi capture buffer

no voice hpi capture destination

!

!

ccm-manager redundant-host 10.10.14.56

ccm-manager mgcp

ccm-manager music-on-hold

ccm-manager config server 10.10.14.56

ccm-manager config

mta receive maximum-recipients 0

!

!

controller T1 0/0

framing esf

clock source internal

linecode b8zs

cablelength short 133

channel-group 23 timeslots 24

!

controller T1 0/1

shutdown

framing sf

linecode ami

!

!

!

interface FastEthernet0/0

ip address 10.10.14.41 255.255.255.0

speed 100

full-duplex

!

interface BRI0/0

no ip address

shutdown

isdn switch-type basic-5ess

!

interface Serial0/0:23

no ip address

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

no ip http server

ip classless

ip route 0.0.0.0 0.0.0.0 10.10.14.1

!

!

!

!

call rsvp-sync

!

voice-port 1/0/0

!

voice-port 1/0/1

!

voice-port 1/1/0

!

voice-port 1/1/1

!

mgcp

mgcp call-agent 10.10.14.58 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp package-capability rtp-package

no mgcp package-capability res-package

mgcp package-capability sst-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 inhibit

mgcp rtp payload-type g726r16 static

!

mgcp profile default

!

sccp local FastEthernet0/0

sccp

sccp ccm 10.10.14.58 priority 1

sccp ccm 10.10.14.56 priority 2

!

!

dial-peer cor custom

!

!

!

!

line con 0

password xxx

login

line aux 0

line vty 0 4

password xxx

login

!

!

end

Thanks in advance for any repsonses.

JP

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Gold

Re: Setting up gateway - 2651XM PRI - no ISDN option Serial inte

Hi, which exact hardware do you have ? Do "show diag" to know. Not all HW supports PRI voice.

6 REPLIES
Cisco Employee

Re: Setting up gateway - 2651XM PRI - no ISDN option Serial inte

channel-group 23 timeslots 24 is for DATA

you need pri-group timeslost 1-24 service mgcp

if you search in CCO you will find several guides on how to configure this

Gateway Protocols

Configuration Examples and TechNotes

http://www.cisco.com/en/US/tech/tk1077/tech_configuration_examples_list.html

HTH

javalenc

if this helps, please rate

HTH

java

if this helps, please rate

www.cisco.com/go/pdi
New Member

Re: Setting up gateway - 2651XM PRI - no ISDN option Serial inte

Thanks for the quick response . .

However, when I go to the controller t1 1/0 interface I do not have that command option.

Do I need to upgrade my IOS?

Thanks,

JP

Cisco Employee

Re: Setting up gateway - 2651XM PRI - no ISDN option Serial inte

12.2 is pretty old, also make sure you have voice services on the IOS

HTH

javalenc

if this helps, please rate

HTH

java

if this helps, please rate

www.cisco.com/go/pdi
Hall of Fame Super Gold

Re: Setting up gateway - 2651XM PRI - no ISDN option Serial inte

Hi, which exact hardware do you have ? Do "show diag" to know. Not all HW supports PRI voice.

New Member

Re: Setting up gateway - 2651XM PRI - no ISDN option Serial inte

Here is the show diag:

Slot 0:

C2651XM 2FE Mainboard Port adapter, 4 ports

Port adapter is analyzed

Port adapter insertion time unknown

EEPROM contents at hardware discovery:

Hardware Revision : 1.0

PCB Serial Number : JAD06510CU8 (1423307700)

Part Number : 73-7756-02

RMA History : 00

RMA Number : 0-0-0-0

Board Revision : A0

Deviation Number : 0-0

Product (FRU) Number : C2651XM-2FE

EEPROM format version 4

EEPROM contents (hex):

0x00: 04 FF 40 03 6F 41 01 00 C1 18 4A 41 44 30 36 35

0x10: 31 30 43 55 38 20 28 31 34 32 33 33 30 37 37 30

0x20: 30 29 82 49 1E 4C 02 04 00 81 00 00 00 00 42 41

0x30: 30 80 00 00 00 00 FF FF FF FF FF FF FF FF FF FF

0x40: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

0x50: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

0x60: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

0x70: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

WIC Slot 0:

T1 (2 port) WAN daughter card

Hardware revision 1.0 Board revision F0

Serial number 33331845 Part number 800-04477-03

FRU Part Number WIC/VIC-T1,DUAL=

Test history 0x0 RMA number 00-00-00

Connector type PCI

EEPROM format version 1

EEPROM contents (hex):

0x20: 01 22 01 00 01 FC 9A 85 50 11 7D 03 00 00 00 00

0x30: 78 00 00 00 05 03 03 00 FF FF FF FF FF FF FF FF

WIC Slot 1:

BRI U - 2091 WAN daughter card

Hardware revision 4.0 Board revision B0

Serial number 14690921 Part number 800-01834-02

FRU Part Number WIC-1B-U=

Test history 0x0 RMA number 00-00-00

Connector type Wan Module

EEPROM format version 1

EEPROM contents (hex):

0x20: 01 09 04 00 00 E0 2A 69 50 07 2A 02 00 00 00 00

0x30: 58 00 00 00 99 06 23 01 FF FF FF FF FF FF FF FF

Slot 1:

4 PORT Voice PM for C2600 Port adapter

Port adapter is disabled

Port adapter insertion time unknown

EEPROM contents at hardware discovery:

Hardware revision 1.1 Board revision D0

Serial number 13922808 Part number 800-02491-02

FRU Part Number: NM-2V=

Test history 0x0 RMA number 00-00-00

EEPROM format version 1

EEPROM contents (hex):

0x00: 01 65 01 01 00 D4 71 F8 50 09 BB 02 00 00 00 00

I have downloaded multiple IOS' with no luck. Still no PRI-group timeslots 1-24 service MGCP on the controller or ISDN commands on the serial interfaces.

Thanks,

Jeff

Hall of Fame Super Gold

Re: Setting up gateway - 2651XM PRI - no ISDN option Serial inte

Hi,

you would need either AIM-VOICE30 or an NM-HDV-xx to enable the VWIC for voice. The latter is recommended as it it newer technology with the PVDM2 modules.

Currently you have no DSP resources in the the router to do that.

Please remember to rate useful posts.

627
Views
9
Helpful
6
Replies
CreatePlease to create content