Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Setting up remote CME IP Phone on 877w Router

Hi,

I currently have a site to site VPN set up between our head office (ASA5510) and a remote site (877w)

We are running CME 4.3 at the head office on a 2821 Router

The head office has data network and voice network

The remote site just has one network

I have managed to set up a phone (7945) at the remote site and successfully register it to the CME system

I receive a dial-tone but whenever I make or receive a call the phone resets and re-registers.

Sometimes I can make a call before it resets

Can anyone explain why it would do this or steps I can take to resolve this issue.

Can the 877w be set up with a voice vlan?

Regards,

Chris

13 REPLIES
New Member

Re: Setting up remote CME IP Phone on 877w Router

Just looked at the debug for the phone on the web interface, it is full of these entries

15:01:00 10: Name=SEPxxxxxxxxxxx Load= SCCP45.8-4-1SR1S Last=TCP-timeout

Not sure if that is related

Re: Setting up remote CME IP Phone on 877w Router

Hi Chris,

What sounds like is happening is that when the call is placed, it takes up all of the bandwidth available. Then, TCP keepalives are not able to make it over the connection, and the phone unregisters.

I would set up voice QoS so that both your signaling and your audio have priority queueing.

hth,

nick

New Member

Re: Setting up remote CME IP Phone on 877w Router

Thanks,

Do you know how I go about setting up voice QOS on a 877 Router? Is any documentation available

Chris

Re: Setting up remote CME IP Phone on 877w Router

This should help, if you have more questions, do a cisco.com search for "LLQ" qos.

Sample config:

class-map match-any voice-control

match ip dscp af31

match ip dscp cs3

match access-group 101

class-map match-any voice-RTP

match ip dscp ef

match ip rtp 16384 16383

!

!

policy-map Voice-QoS

class voice-RTP

priority [bandwidth-value]

set dscp ef

class voice-control

bandwidth [bandwidth-value]

set dscp af31

class class-default

fair-queue

!For MGCP

access-list 101 permit udp any any range 2427 2428

!For H.323

access-list 101 permit tcp any any range 1718 1720

access-list 101 permit tcp any any eq 1731

!For Skinny (phones registered to CCM)

access-list 101 permit tcp any any eq 2000

!For Sip

access-list 101 permit tcp any any eq 5060

interface x/x

service-policy output Voice-QoS

Note that for some versions of IOS, the command 'match ip dscp' needs to be replaced with 'match dscp'.

What this will do is take any traffic marked as a DSCP of 'ef', or any unmarked RTP traffic, and marks it as RTP traffic and sets the DSCP values accordingly. This traffic is sent to a priority queue. Then, it takes any traffic marked as DSCP of 'af31' or running on port thatis used for control traffic, marks it as control traffic (and sets the DSCP if needed), then puts it in a queue. All other traffic is sent to the fair-queue.

Estimate about 8K of call-control traffic per call. You can find out how much bandwidth you will need for RTP traffic with the voice-call bandwidth calculator found here:

http://tools.cisco.com/Support/VBC/do/CodecCalc1.do

Just be careful when you apply this QoS policy that those 100 and 101 access-lists aren't overwriting any ACLs that you already have configured.

hth,

nick

New Member

Re: Setting up remote CME IP Phone on 877w Router

Thanks Nick for your help.

Do I apply this to my BVI1 interface?

"service-policy output Voice-QoS"

As soon as I apply it the router locks up and I have to reboot.

I've attached a truncated config

Thanks,

Chris

Re: Setting up remote CME IP Phone on 877w Router

You will only need this on your WAN interface. In this case, it will be your FastE going to your cablemodem/DSL or whatever you're connecting to the internet with.

No idea on the router locking up - run the latest code you can fit on the flash and it will probably stop happening.

hth,

nick

New Member

Re: Setting up remote CME IP Phone on 877w Router

Thanks,

I put it on the inside interface (BVI1), that was probably why, I have the latest IOS.

It is an ADSL Router so I have an ATM0 and ATM0.1 subinterface, I think I can place the "service-policy output Voice-QoS" command below pvc 0/101 in my config, is this correct?

New Member

Re: Setting up remote CME IP Phone on 877w Router

As an update to this, I tried applying it to pvc 0/101. It seemed to accept the request but when I checked the config after it did not appear.

I applied it to ATM0 and did appear in the config after and applied the policy but the problem with my phone re-registering still occurs and no traffic seems to be using the policy (please see below)

From the original post you mentioned the phone is probably taking all the bandwidth, is there a policy I need to apply that restricts the bandwidth it can use?

---------------------------

show policy-map interface atm 0

ATM0

Service-policy output: Voice-QoS

queue stats for all priority classes:

queue limit 64 packets

(queue depth/total drops/no-buffer drops) 0/0/0

(pkts output/bytes output) 0/0

Class-map: voice-RTP (match-any)

0 packets, 0 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: ip rtp 16384 16383

0 packets, 0 bytes

5 minute rate 0 bps

Match: ip dscp ef (46)

0 packets, 0 bytes

5 minute rate 0 bps

Priority: 128 kbps, burst bytes 4470, b/w exceed drops: 0

QoS Set

dscp ef

Packets marked 0

Class-map: voice-control (match-any)

3 packets, 508 bytes

5 minute offered rate 0 bps, drop rate 0 bps

Match: ip dscp af31 (26)

0 packets, 0 bytes

5 minute rate 0 bps

Match: ip dscp cs3 (24)

3 packets, 508 bytes

5 minute rate 0 bps

Match: access-group 105

0 packets, 0 bytes

5 minute rate 0 bps

Queueing

queue limit 64 packets

(queue depth/total drops/no-buffer drops) 0/0/0

(pkts output/bytes output) 0/0

bandwidth 128 kbps

QoS Set

dscp af31

Packets marked 3

Class-map: class-default (match-any)

58331 packets, 4346742 bytes

5 minute offered rate 75000 bps, drop rate 0 bps

Match: any

Queueing

queue limit 64 packets

(queue depth/total drops/no-buffer drops/flowdrops) 0/0/0/0

(pkts output/bytes output) 0/0

Fair-queue: per-flow queue limit 16

Thanks,

Chris

Re: Setting up remote CME IP Phone on 877w Router

Hi Chris,

Applying QoS on an ATM circuit is different, and unfortunately I'm not very familiar with doing that.

I would start with a cisco.com search for LLQ on ATM.

hth,

nick

New Member

Re: Setting up remote CME IP Phone on 877w Router

Thanks,

I have added 'qos pre-classify' and I can now see voice traffic on the VPN when using 'sh policy interface atm 0'

Unfortunately the phone is still re-registering after I make or receive a call from it, does anyone know where I can go from here?

New Member

Re: Setting up remote CME IP Phone on 877w Router

After all this, I managed to get this working by disabling Skinny inspection on the ASA

New Member

Re: Setting up remote CME IP Phone on 877w Router

Hello Chris.

I am trying to do tha same that you have, but the phone 7940, doesn't try to register to de remote CME. When the phone stars he get's the ip address but then the "protocol application invalid" appears in the display and it stays like this.

Did you have this problem, can you show me how you have your DHCP poll configured, because it seems that the question is there.

thanks in advance

JG

New Member

Re: Setting up remote CME IP Phone on 877w Router

Hi,

I didn't have that problem, my DHCP setup should be in the config I attached earlier.

The main issue I had was setting up the NAT exemptions and Interesting traffic for the Site-Site VPN connection between the remote site and ASA firewall. This had to be reconfigured to see my 192.168.100.0/24 voice network.

I also had to add a route on the ASA to see the Voice Network.

If you could post your configs I can compare them to mine

Thanks,

Chris

504
Views
0
Helpful
13
Replies
CreatePlease to create content