Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Simulating Call on PRI

I implemented a 2821 voice gateway so we could test our PRI connectivity to our provider. We do not have our call manager server or phones yet, but wondered if I could simulate a call directly from the router itself. Please let me know if this is possible.

Thank you in advance.

1 ACCEPTED SOLUTION

Accepted Solutions
Super Bronze

Re: Simulating Call on PRI

Hi

Yes, it's possible.

You'll need to configure the PRI controller as you would for a CME type install.

Boot it up, and if you have the correct hardware you should see a T1 or E1 controller.

If you don't see a controller, and you have a T1/E1 type, you may need to enter something like:

card type e1 0 0                  <--- or t1, whatever's appropriate

then:

isdn switch-type xxx (whatever you use locally)

controller e1

pri-group timeslots 1-30

(no 'service mgcp' means it will terminate locally)

You may need to set crc off, or whatever else you would do for a local PRI.

Do a show isdn status, to verify you have MULTIPLE_FRAME_ESTABLISHED

If you do, then create a dial-peer to use the PRI:

dial-peer voice 101 pots

destination-pattern 9T

port 0/0/0:15

Then you can this command to start a test call:

csim start

Regards

Aaron

Please rate helpful posts...

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!
4 REPLIES
Hall of Fame Super Gold

Re: Simulating Call on PRI

csim start

or

isdn test call interface xx

Super Bronze

Re: Simulating Call on PRI

Hi

Yes, it's possible.

You'll need to configure the PRI controller as you would for a CME type install.

Boot it up, and if you have the correct hardware you should see a T1 or E1 controller.

If you don't see a controller, and you have a T1/E1 type, you may need to enter something like:

card type e1 0 0                  <--- or t1, whatever's appropriate

then:

isdn switch-type xxx (whatever you use locally)

controller e1

pri-group timeslots 1-30

(no 'service mgcp' means it will terminate locally)

You may need to set crc off, or whatever else you would do for a local PRI.

Do a show isdn status, to verify you have MULTIPLE_FRAME_ESTABLISHED

If you do, then create a dial-peer to use the PRI:

dial-peer voice 101 pots

destination-pattern 9T

port 0/0/0:15

Then you can this command to start a test call:

csim start

Regards

Aaron

Please rate helpful posts...

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!
New Member

Re: Simulating Call on PRI

Not sure what I'm missing, but calls are not coming through to my cell.  Below  is the running config, followed by the debug:

User Access Verification

Username:
Password:
lldcptimain>en
Password:
lldcptimain#sh run
Building configuration...


Current configuration : 3903 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname lldcptimain
!
boot-start-marker
boot system flash c2800nm-ipvoicek9-mz.124-22.T4.bin
boot-end-marker
!
card type t1 0 0
logging message-counter syslog
logging buffered 51200 warnings
enable secret 5 $1$FGEF$OH2F1J2DVkONMPY1/ZcEM/
enable password CshYOh9z
!
no aaa new-model
network-clock-participate wic 0
network-clock-select 1 T1 0/0/0
!
dot11 syslog
ip source-route
!
!
ip cef
!
!
ip domain name yourdomain.com
no ipv6 cef
multilink bundle-name authenticated
!
!
!
!
isdn switch-type primary-ni
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
voice-card 0
!
!
crypto pki trustpoint TP-self-signed-1270686785
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-1270686785
revocation-check none
rsakeypair TP-self-signed-1270686785
!
!
crypto pki certificate chain TP-self-signed-1270686785
certificate self-signed 01
  30820252 308201BB A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 31323730 36383637 3835301E 170D3039 30343130 32313434
  30355A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 32373036
  38363738 3530819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100C0A2 0F7E8F3A 806A6FCE 493F6AAE 42A11B77 00FA1A92 232A7AD4 A20FE6F0
  BCCF0AEB D5B35D60 D2C5BCEF D3DA5EAB BAE1B191 18864262 0077927F 6EDF0EB3
  31208C0E 97412BDE F0A197AC 9E3266F1 DBD30AE3 5142EE2F 17FA4A5B 7F5BF454
  BCFE2FA0 6D8FF908 F8636E30 329C5CB6 FB35B27F 5FF299F4 5F642660 6BD2F58B
  5A8D0203 010001A3 7A307830 0F060355 1D130101 FF040530 030101FF 30250603
  551D1104 1E301C82 1A6C6C64 63707469 6D61696E 2E796F75 72646F6D 61696E2E
  636F6D30 1F060355 1D230418 30168014 77DC25FA 0CCB3FD5 2C76E570 2C7FDD73
  E7028FF5 301D0603 551D0E04 16041477 DC25FA0C CB3FD52C 76E5702C 7FDD73E7
  028FF530 0D06092A 864886F7 0D010104 05000381 81005A50 EF04FBCA 8183C0D7
  8868A368 435CD697 AF0C2C97 C7F41169 3467B771 6A33703C 355BC548 1D0D4065
  D45FBA83 935E85C5 B44A1B06 91E0ACB8 64A935AE A7CF8BB7 94E83400 0C5466C0
  EC501C6A E7A86987 8FE5A509 139B0382 43C13668 CE0A9F0D 25553DB5 17FD21DD
  C70A4F37 F6D5E43F 1A6A1491 0A5175C6 415DD1F6 883C
        quit
!
!
archive
log config
  hidekeys
!
!
controller T1 0/0/0
cablelength long 0db
pri-group timeslots 1-24
!
controller T1 0/0/1
cablelength long 0db
!
!
!
!
!
interface GigabitEthernet0/0
description

ip address x.x.x.x

duplex auto
speed auto
!
interface GigabitEthernet0/1
description

ip address 192.168.250.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0/0:23
no ip address
encapsulation hdlc
isdn switch-type primary-ni
isdn incoming-voice voice
no cdp enable
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 xxxxxxx

!
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
access-list 23 permit any
!
!
!
!
control-plane
!
!
!
voice-port 0/0/0:23
!
ccm-manager fax protocol cisco
!
!
!
!
dial-peer voice 101 pots
destination-pattern 9T
port 0/0/0:23
forward-digits 10
!
!
!
line con 0
line aux 0
line vty 0 4
access-class 23 in
privilege level 15
login local
transport input telnet ssh
line vty 5 15
access-class 23 in
privilege level 15
login local
transport input telnet ssh
!
scheduler allocate 20000 1000
end

------DEBUG-----

lldcptimain#isdn test call interface serial0/0/0:23 95555555555

lldcptimain#
*Mar 11 18:47:33.186: ISDN Se0/0/0:23 Q931d: Default type/plan 0x0 0x0 sw-type 1
3 Called number 95555555555 isdn_map 0 mask 0x0
*Mar 11 18:47:33.186: ISDN Se0/0/0:23 Q931d: No call_decode, isdn default set
*Mar 11 18:47:33.186: ISDN Se0/0/0:23 Q931: Applying typeplan for sw-type 0xD is
0x0 0x0, Called num 95555555555

*Mar 11 18:47:33.186: ISDN Se0/0/0:23 Q931d: CCIE_BuildChanId_IE: int_ident_len
0
*Mar 11 18:47:33.186: ISDN Se0/0/0:23 Q931d: L3_Go: source 0x0400, ces 1, event
0x0080, call id 0x8009, int id 0x0
*Mar 11 18:47:33.186: ISDN Se0/0/0:23 Q931d: L3_Go: event 0x80  cr_len 2 cr 0
*Mar 11 18:47:33.186: ISDN Se0/0/0:23 Q931d: L3_Go: call_id 0x8009 cr 0x0 state
0 event 0x80 ces 1
*Mar 11 18:47:33.186: ISDN Se0/0/0:23 Q931d: L3_ProcessEvent: callref = 0x0000 C
C_SETUP_REQ:U0_SetupReq(nlcb)
*Mar 11 18:47:33.186: ISDN Se0/0/0:23 Q931d: srl_send_l3_pak:
        source_id = Q.931 0x0300, dest_id = Q.921 0x0000, prim = DL_DATA_REQ 0x0
240
        priv_len = 4 int_id = 0x47C10D90 datasize = 44
*Mar 11 18:47:33.186: ISDN Se0/0/0:23 Q931d: data =
*Mar 11 18:47:33.186:   47C10D9000000300024004D400018C00
*Mar 11 18:47:33.186:   0802008805040288901803A98397700C
*Mar 11 18:47:33.186:   803933313736353032383134
*Mar 11 18:47:33.186: ISDN Se0/0/0:23 Q931: Sending SETUP  callref = 0x0088 call
ID = 0x8009 switch = primary-ni interface = User
*Mar 11 18:47:33.186: ISDN Se0/0/0:23 Q931d: L3_state_change: callref 0x0088 old
NULL_STATE, new CALL_INIT
*Mar 11 18:47:33.190: ISDN Se0/0/0:23 Q931: TX -> SETUP pd = 8  callref = 0x0088

        Bearer Capability i = 0x8890
                Standard = CCITT
                Transfer Capability = Unrestricted Digital
                Transfer Mode = Circuit
                Transfer Rate = 64 kbit/s
        Channel ID i = 0xA98397
                Exclusive, Channel 23
        Called Party Number i = 0x80, '95555555555'
                Plan:Unknown, Type:Unknown
*Mar 11 18:47:33.246: ISDN Se0/0/0:23 Q931: RX <- CALL_PROC pd = 8  callref = 0x
8088
        Channel ID i = 0xA98397
                Exclusive, Channel 23
*Mar 11 18:47:33.250: ISDN Se0/0/0:23 Q931d: L3IF_rx_L2_pak: received data
*Mar 11 18:47:33.250:   08028088021803A98397
*Mar 11 18:47:33.250: ISDN Se0/0/0:23 Q931d: L3_Go: source 0x020A, ces 1, event
0x0002, call id 0x0000, int id 0x0
*Mar 11 18:47:33.250: ISDN Se0/0/0:23 Q931d: L3_Go: event 0x2  cr_len 2 cr 136
*Mar 11 18:47:33.250: ISDN Se0/0/0:23 Q931d: L3_Go: call_id 0x8009 cr 0x88 state
1 event 0x2 ces 1
*Mar 11 18:47:33.250: ISDN Se0/0/0:23 Q931d: L3_ProcessEvent: callref = 0x0088 C
ALL_PROC:U1_CallProc(nlcb)
*Mar 11 18:47:33.250: ISDN Se0/0/0:23 Q931d: L3_state_change: callref 0x0088 old
CALL_INIT, new OUT_CALL_PROC
*Mar 11 18:47:33.250: ISDN Se0/0/0:23 Q931d: extract_called_number: Extracted ca
lled number
*Mar 11 18:47:33.250: ISDN Se0/0/0:23 **ERROR**: call_setup_ack_proceeding: NO H
DLC available b channel 22 call id 0x8009
*Mar 11 18:47:33.250: ISDN Se0/0/0:23 Q931d: L3_Go: source 0x0400, ces 1, event
0x0084, call id 0x8009, int id 0x0
*Mar 11 18:47:33.250: ISDN Se0/0/0:23 Q931d: L3_Go: event 0x84  cr_len 2 cr 136
*Mar 11 18:47:33.250: ISDN Se0/0/0:23 Q931d: L3_Go: call_id 0x8009 cr 0x88 state
3 event 0x84 ces 1
*Mar 11 18:47:33.250: ISDN Se0/0/0:23 Q931d: L3_ProcessEvent: callref = 0x0088 C
C_DISCONNECT_REQ:Ux_DiscReq(nlcb)
*Mar 11 18:47:33.250: ISDN Se0/0/0:23 Q931d: srl_send_l3_pak:
        source_id = Q.931 0x0300, dest_id = Q.921 0x0000, prim = DL_DATA_REQ 0x0
240
        priv_len = 4 int_id = 0x47C10D90 datasize = 25
*Mar 11 18:47:33.250: ISDN Se0/0/0:23 Q931d: data =
*Mar 11 18:47:33.250:   47C10D9000000300024004D400018C00
*Mar 11 18:47:33.250:   0802008845080280A2
*Mar 11 18:47:33.250: ISDN Se0/0/0:23 Q931d: L3_state_change: callref 0x0088 old
OUT_CALL_PROC, new DISCONNECT_REQUEST
*Mar 11 18:47:33.250: ISDN Se0/0/0:23 Q931: TX -> DISCONNECT pd = 8  callref = 0
x0088
        Cause i = 0x80A2 - No circuit/channel available
*Mar 11 18:47:33.254: ISDN Se0/0/0:23 Q931: RX <- DISCONNECT pd = 8  callref = 0
x8088
        Cause i = 0x8290 - Normal call clearing
*Mar 11 18:47:33.254: ISDN Se0/0/0:23 Q931d: L3IF_rx_L2_pak: received data
*Mar 11 18:47:33.254:   080280884508028290
*Mar 11 18:47:33.254: ISDN Se0/0/0:23 Q931d: L3_Go: source 0x020A, ces 1, event
0x0045, call id 0x0000, int id 0x0
*Mar 11 18:47:33.254: ISDN Se0/0/0:23 Q931d: L3_Go: event 0x45  cr_len 2 cr 136
*Mar 11 18:47:33.254: ISDN Se0/0/0:23 Q931d: L3_Go: call_id 0x8009 cr 0x88 state
11 event 0x45 ces 1
*Mar 11 18:47:33.254: ISDN Se0/0/0:23 Q931d: L3_ProcessEvent: callref = 0x0088 D
ISCONNECT:U11_Disconnect(nlcb)
*Mar 11 18:47:33.254: ISDN Se0/0/0:23 Q931d: srl_send_l3_pak:
        source_id = Q.931 0x0300, dest_id = Q.921 0x0000, prim = DL_DATA_REQ 0x0
240
        priv_len = 4 int_id = 0x47C10D90 datasize = 21
*Mar 11 18:47:33.254: ISDN Se0/0/0:23 Q931d: data =
*Mar 11 18:47:33.254:   47C10D9000000300024004D400018C00
*Mar 11 18:47:33.254:   080200884D
*Mar 11 18:47:33.254: ISDN Se0/0/0:23 Q931d: L3_state_change: callref 0x0088 old
DISCONNECT_REQUEST, new RELEASE_REQUEST
*Mar 11 18:47:33.254: ISDN Se0/0/0:23 Q931: TX -> RELEASE pd = 8  callref = 0x00
88
*Mar 11 18:47:33.282: ISDN Se0/0/0:23 Q931: RX <- RELEASE pd = 8  callref = 0x80
88
*Mar 11 18:47:33.282: ISDN Se0/0/0:23 Q931d: L3IF_rx_L2_pak: received data
*Mar 11 18:47:33.282:   080280884D
*Mar 11 18:47:33.282: ISDN Se0/0/0:23 Q931d: L3_Go: source 0x020A, ces 1, event
0x004D, call id 0x0000, int id 0x0
*Mar 11 18:47:33.282: ISDN Se0/0/0:23 Q931d: L3_Go: event 0x4D  cr_len 2 cr 136
*Mar 11 18:47:33.282: ISDN Se0/0/0:23 Q931d: L3_Go: call_id 0x8009 cr 0x88 state
19 event 0x4D ces 1
*Mar 11 18:47:33.282: ISDN Se0/0/0:23 Q931d: L3_ProcessEvent: callref = 0x0088 R
ELEASE:U19_Release(nlcb)
*Mar 11 18:47:33.282: ISDN Se0/0/0:23 Q931d: L3_state_change: callref 0x0088 old
RELEASE_REQUEST, new NULL_STATE
*Mar 11 18:47:33.282: ISDN Se0/0/0:23 Q931d: L3_Go: source 0x0400, ces 1, event
0x00AB, call id 0x8009, int id 0x0
*Mar 11 18:47:33.282: ISDN Se0/0/0:23 Q931d: L3_Go: event 0xAB  cr_len 2 cr 136
*Mar 11 18:47:33.286: ISDN Se0/0/0:23 Q931d: L3_Go: call_id 0x8009 cr 0x0 state
0 event 0xAB ces 1
*Mar 11 18:47:33.286: ISDN Se0/0/0:23 Q931d: L3_ProcessEvent: callref = 0x0000 C
C_REL_COMP_REQ:Ux_RelCompReq(nlcb)

Super Bronze

Re: Simulating Call on PRI

Hi

You are getting :   Cause i = 0x80A2 - No circuit/channel available

In the UK, this typically means:

1) We're running a fractional PRI, and have tried to use a channel we ain't paying for... so need to reconfig the pri-group. Not so common elsewhere.. If you suspect that's the case, there's a command to change the b-channel selection order to use channel 1 first. - isdn bchan-number-order asc

2) SP hasn't enabled the circuit. If we get a new circuit, we usually have to phone up the SP who will then enable it.


Regards

Aaron

Please rate helpful posts...

Aaron Please remember to rate helpful posts to identify useful responses, and mark 'Answered' if appropriate!
1071
Views
8
Helpful
4
Replies
CreatePlease login to create content