Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Sip 503 service unavailable and sip 500 internal server error

Hi guys,could any one help me in the following.

ITSP-->Voice gateway configured as CUBE-->CUCM-->UCCX

I am moving a system from cme and aa enviroment to cucm and uccx

The VGW is configured as CUBE and also is added as h323 gateway on cucm.

When i tested the debug ccsip messages shows

Sip 503 service unavailable or

sip 500 internal server error.

I can't now provide any debugs cause i am not on site,only on Saturday.

As i read in previous discussion that could be the bind source address problem but i had this configured.

Also i tried to configure the gateway instead of h232 to use sip trunk from cucm,but after this the incoming calls didn't even reach the router,the debug ccsip messages showed nothing.

For now can any one advice me to what these 2 errors related to.

What could be missing?

Thanks in advance.

  • IP Telephony
4 REPLIES
VIP Super Bronze

Sip 503 service unavailable and sip 500 internal server error

Ahmed,

Its difficult to say unless we see both configs and the logs...Usually when you get a 5XX error, you should see the reason code for that error...Can you share that here. When you can send the ff:

1. sh run

2. debug voip ccapi inout

3.debug ccsip messages

Please rate all useful posts

"opportunity is a haughty goddess who waste no time with those who are unprepared"

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
New Member

Sip 503 service unavailable and sip 500 internal server error

Hi Aokanlawon,

Actually i can't now ,so kindly asking you to check this post on Saturday and i ll update you with all the configs and debugs.

Thanks man.

New Member

Re: Sip 503 service unavailable and sip 500 internal server erro

Hi there : can some one explain the reason that i am getting this sip error with itsp:

here is the debug of ccsip messages:

Received:

INVITE sip:5555317884@178.208.X.X;user=phone SIP/2.0

Via: SIP/2.0/UDP 188.254.68.66:9298;branch=z9hG4bK-6110d60075a24c0f-a3c000c-1

Call-ID: isbc6994325518768294927-1385194135-11717

From: <>9268854639@sipgw120.com;user=phone>;tag=sbc09106994325518768294927

To: <5555317884>

CSeq: 1 INVITE

Min-SE: 90

Session-Expires: 3600;refresher=uac

Contact: <9268854936>

Allow: INVITE,CANCEL,BYE,ACK,REFER,UPDATE,INFO,PRACK

Supported: timer,100rel

Diversion: <>8002001706@sipgw120.com>;privacy=off;screen=no;reason=unknown,<>8002001706@sipgw120.com>;privacy=off;screen=no;reason=unknown

Max-Forwards: 70

User-Agent: VCS 5.8.2.56-03

Content-Length: 394

Content-Type: application/sdp

v=0

o=- 87852 198805 IN IP4 188.254.68.67

s=SBC call

c=IN IP4 188.254.68.67

t=0 0

m=audio 23682 RTP/AVP 8 0 18 98 96 97 101

a=rtpmap:98 G.729a/8000

a=rtpmap:96 G.729ab/8000

a=rtpmap:97 G.729b/8000

a=rtpmap:101 telephone-event/8000

a=fmtp:101 0-15

a=fmtp:18 annexb=no

a=ptime:10

a=X-vrzcap:vbd Ver=1 Mode=FaxPr ModemRtpRed=0

a=X-vrzcap:identification bin=DSR2866 Prot=mgcp App=MG

00:43:23: //11/FDB448CE8020/SIP/Msg/ccsipDisplayMsg:

Sent:

SIP/2.0 100 Trying

Via: SIP/2.0/UDP 188.254.68.66:9298;branch=z9hG4bK-6110d60075a24c0f-a3c000c-1

From: <>9268854639@sipgw120.com;user=phone>;tag=sbc09106994325518768294927

To: <5555317884>

Date: Sat, 23 Nov 2013 08:06:29 GMT

Call-ID: isbc6994325518768294927-1385194135-11717

CSeq: 1 INVITE

Allow-Events: telephone-event

Server: Cisco-SIPGateway/IOS-12.x

Content-Length: 0

00:43:23: //11/FDB448CE8020/SIP/Msg/ccsipDisplayMsg:

Sent:

SIP/2.0 503 Service Unavailable

Via: SIP/2.0/UDP 188.254.68.66:9298;branch=z9hG4bK-6110d60075a24c0f-a3c000c-1

From: <>9268854936@sipgw120.com;user=phone>;tag=sbc09106994325518768294927

To: <5555317884>

c2801#er=phone>;tag=27BA64-1DAE

Date: Sat, 23 Nov 2013 08:06:29 GMT

Call-ID: isbc6994325518768294927-1385194135-11717

CSeq: 1 INVITE

Allow-Events: telephone-event

Server: Cisco-SIPGateway/IOS-12.x

Reason: Q.850;cause=38

Content-Length: 0

00:43:23: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Received:

ACK sip:5555317884@178.208.129.221;user=phone SIP/2.0

Via: SIP/2.0/UDP 188.254.68.66:9298;branch=z9hG4bK-6110d60075a24c0f-a3c000c-1

Call-ID: isbc6994325518768294927-1385194135-11717

From: <>9268854639@sipgw120.com;user=phone>;tag=sbc09106994325518768294927

To: <5555317884>;tag=27BA64-1DAE

CSeq: 1 ACK

Max-Forwards: 70

Content-Length: 0

show run:

voice service voip

ip address trusted list

  ipv4 87.226.136.164 255.255.255.255

  ipv4 172.16.24.0 255.255.255.0

  ipv4 188.254.68.66 255.255.255.255

  ipv4 188.254.68.67 255.255.255.255

  ipv4 188.254.69.66 255.255.255.255

  ipv4 188.254.69.67 255.255.255.255

  ipv4 46.38.52.68 255.255.255.255

address-hiding

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

supplementary-service h450.12

no supplementary-service sip moved-temporarily

no supplementary-service sip refer

redirect ip2ip

fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback cisco

sip

voice class codec 1

codec preference 1 g729br8

codec preference 2 g729r8

codec preference 3 g711alaw

codec preference 4 g711ulaw

voice class codec 2

codec preference 1 g711ulaw

codec preference 2 g711alaw

codec preference 3 g729r8

codec preference 4 g729br8

voice translation-rule 1

rule 1 /XXX5397962/ /1999/

!        

voice translation-rule 2

rule 1 /XXX55317577/ /1999/

!        

voice translation-rule 3

rule 1 /5555317884/ /1999/

!        

!        

voice translation-profile ROS

translate called 1

!        

voice translation-profile ROS2

translate called 2

!        

voice translation-profile ROS3

translate called 3

interface FastEthernet0/0

ip address 178.208.129.221 255.255.255.248

ip access-group INBOUND in

no ip unreachables

ip verify unicast reverse-path

ip nat outside

ip inspect IPFW in

ip inspect IPFW out

ip virtual-reassembly in

duplex auto

speed auto

no cdp enable

!

interface FastEthernet0/1

no ip address

ip nat inside

ip virtual-reassembly in

duplex auto

speed auto

!

interface FastEthernet0/1.1

encapsulation dot1Q 1 native

ip address 10.110.0.200 255.255.255.0

ip nat inside

ip virtual-reassembly in

!

interface FastEthernet0/1.2

encapsulation dot1Q 2

ip address 172.16.24.254 255.255.255.0

ip nat inside

ip virtual-reassembly in

h323-gateway voip interface

h323-gateway voip bind srcaddr 172.16.24.254

!

ip dns server

ip nat inside source list NAT interface FastEthernet0/0 overload

ip route 0.0.0.0 0.0.0.0 178.208.X.X

ip route 192.168.0.0 255.255.0.0 Null0 254

sccp local FastEthernet0/1.2

sccp ccm 172.16.24.101 identifier 1 version 7.0

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

associate profile 1 register XCODE123456

keepalive retries 1

keepalive timeout 10

switchover method immediate

switchback method immediate

!

dspfarm profile 1 transcode 

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

codec g729r8

codec g729br8

maximum sessions 6

associate application SCCP

!

dial-peer voice 10000 voip

tone ringback alert-no-PI

description ROSTELECOM Incoming

translation-profile incoming ROS

destination-pattern 74955397962

session protocol sipv2

session target ipv4:87.226.136.164

session transport udp

incoming called-number XXXX5397962

dtmf-relay rtp-nte

codec g711ulaw

!

dial-peer voice 10010 voip

tone ringback alert-no-PI

description ROSTELECOM Incoming

translation-profile incoming ROS2

destination-pattern XXX55317577

session protocol sipv2

session target ipv4:87.226.136.164

session transport udp

incoming called-number 75555317577

dtmf-relay rtp-nte

codec g711ulaw

!

dial-peer voice 10020 voip

tone ringback alert-no-PI

description ROSTELECOM Incoming

translation-profile incoming ROS3

preference 1

destination-pattern 5555317884

session protocol sipv2

session target ipv4:188.254.68.66

session transport udp

incoming called-number 5555317884

dtmf-relay rtp-nte

codec g711ulaw

!

dial-peer voice 10021 voip

tone ringback alert-no-PI

description ROSTELECOM Incoming

translation-profile incoming ROS

preference 2

destination-pattern 5555317884

session protocol sipv2

session target ipv4:188.254.69.66

session transport udp

incoming called-number 5555317884

dtmf-relay rtp-nte

codec g711ulaw

!

dial-peer voice 2 voip

tone ringback alert-no-PI

description to CUCM_PUB

destination-pattern 1...

session target ipv4:172.16.24.101

voice-class codec 2 

dtmf-relay rtp-nte

******************************************

I see in the debug that the itsp over g729 family codecs but not g711 at all

This system was working with this dialpeers before with same provider ,just i have added the dial-peer 2 .

I have changed the codec to match what is offered by itsp but no difference,still getting the same message.

PLZ help ASAP.

Cisco Employee

Re: Sip 503 service unavailable and sip 500 internal server erro

Hi Ahmed,

As we see that the gateway is sending 503 Service Unavailable and it is communicating over H323 with the CUCM, please provide the following debugs as well with the 'deb ccsip messages' to isolate if the disconnect is being received from the other leg or by the gateway itself.

1. debug voip ccapi inout

2. debug h225 asn1

3. debug h245 asn1

Also, we see that the SDP in the invite from the provider supports G.729a, G.729ab and G.729b only. The dial peers for the SIP leg is hardcoded with G711ulaw only.

Please try to configure a new voice class codec for support of G.729a, G.729ab and G.729b and G711ulaw. Then, add it to the inbound dial peers (SIP leg).

HTH,

Jagpreet Singh Barmi

1884
Views
0
Helpful
4
Replies
This widget could not be displayed.