Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Users might experience few discrepancies in Search results. We are working on this on our side. We apologize for the inconvenience it may have caused.
New Member

SIP authorization problem with multiple logins

I have a problem with multiple sip-ua authorization on Cisco 2811 with IOS  version 15.1(1)T.

sip-ua configuration:

sip-ua
 credentials username ngn59953 password pass realm Realm
 credentials username ngn59952 password pass 8 realm Realm
 credentials username ngn59594 password pass realm Realm
 authentication username ngn59953 password pass realm Realm
 authentication username ngn59952 password pass realm Realm1
 authentication username ngn59594 password pass realm Realm2
 nat symmetric check-media-src
 no remote-party-id
 retry invite 3
 retry response 3
 retry bye 3
 retry cancel 3
 retry options 2
 registrar dns:isimngn.usi.ru expires 3600
 sip-server dns:isimngn.usi.ru
 no suspend-resume
 connection-reuse

All of them are registered successfully:

#sh sip-ua register stat
Line                             peer       expires(sec) registered P-Associ-URI
================================ ========== ============ ========== ============
ngn59594                         -1         2407         yes
ngn59952                         -1         2253         yes
ngn59953                         -1         2453         yes

But I can call only from the first one in configuration. (no matter, which is the first, it works). I know the reason but I don't have any clue why it happens. SIP invite are sent from correct number, but when SIP-proxy requires authorization the router sends authorization for first username (Full debug is in attachment.):

Sent:

INVITE sip:83452560121@isimngn.usi.ru:5060 SIP/2.0

Via: SIP/2.0/UDP 178.46.155.50:5060;branch=z9hG4bK26411241

From: "Uralmicro Test" <sip:59952@isimngn.usi.ru>;tag=6C4886AC-0

To: <sip:83452560121@isimngn.usi.ru>

Date: Mon, 20 Oct 2014 11:15:13 GMT

<output is omitted>

Proxy-Authorization: Digest username="ngn59953",realm="Realm",uri="sip:83452560121@isimngn.usi.ru:5060",response="8b6c528425a16fb43f8182b57a246765",nonce="MTQxMzgwMzY2MjY5NmI4MTI5NDUxNzkxYzdhZjM2M2JlZjlhMzFhMzVjNmJj",cnonce="64C796E3",qop=auth-int,algorithm=MD5,nc=00000001

Max-Forwards: 69

Session-Expires:  1800

Content-Length: 0

Also I've tried this sip-accounts on another similar Cisco 2811 router with same IOS version, where scheme with multiple sip-accounts are working, and I've gotten same problem. And I've tried sip-accounts from that second router on my 2811:

credentials username 3467360087 password pass realm Realm
credentials username 3467360089 password pass realm Realm 

authentication username 3467360087 password pass realm Realm
authentication username 3467360089 password pass realm Realm1

And they are working correctly!! It's really strange!!

Why such problem could be? Full debug is in attachment.

Everyone's tags (1)
4 REPLIES

Hi.Can you please send a full

Hi.

Can you please send a full config of your VG?

Thanks

 

 

Regards

 

Carlo

Please rate all helpful posts "The more you help the more you learn"
New Member

Here, config in attachment.

Here, config in attachment.

New Member

Could someone could explain

Could someone could explain me how router chooses which sip-ua authorization line to use? Maybe in my case, when sip-account usernames are not equal to telephone numbers some specific configuration should be done.

New Member

SIP-provider has changed sip

SIP-provider has changed sip-logins for us to match phone number, and now all works perfectly! But I still wonder why it hasn't worked in the first place.

199
Views
0
Helpful
4
Replies
CreatePlease to create content