Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

SIP Call Failing CME conifg is Below

SIPGATEWAY#sh run
Building configuration...

Current configuration : 2334 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname SIPGATEWAY
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no network-clock-participate slot 1
no network-clock-participate wic 0
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.5.1 192.168.5.10
!
ip dhcp pool ITS
   network 192.168.5.0 255.255.255.0
   option 150 ip 192.168.5.1
   default-router 192.168.5.1
!
!
!
!
!
!
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to sip
!
!
!
voice class codec 1
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address dhcp
duplex auto
speed auto
!
interface Serial0/0
no ip address
no fair-queue
!
interface FastEthernet0/1
ip address 192.168.5.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/1
no ip address
!
ip route 10.3.3.0 255.255.255.0 192.168.2.50
!
!
ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
!
!
!
!
dial-peer voice 2 voip
destination-pattern 9...........
voice-class codec 1
session protocol sipv2
session target ipv4:204.11.192.36
dtmf-relay rtp-nte
no vad
!
sip-ua
authentication username 17772823581 password 15160A0800337A
no remote-party-id
retry invite 2
retry register 10
sip-server ipv4:204.11.192.39
!
!
!
!
telephony-service
max-ephones 10
max-dn 10
ip source-address 192.168.5.1 port 2000
auto assign 1 to 10
--More--
*Mar  8 05:33:50.732: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed sta create cnf-files version-stamp Jan 01 2002 00:00:00
dialplan-pattern 1 7705774... extension-length 4 extension-pattern 500.
max-conferences 4 gain -6
transfer-system full-consult
!
!
ephone-dn  1  dual-line
number 5001
!
!
ephone-dn  2  dual-line
number 5002
!
!
ephone-dn  3  dual-line
number 5003
!
!
ephone-dn  4  dual-line
number 5004
!
!
ephone-dn  5  dual-line
number 5005
!
!
ephone-dn  6  dual-line
number 5006
!
!
ephone-dn  7  dual-line
number 5007
!
!
ephone-dn  8  dual-line
number 5008
!
!
ephone-dn  9  dual-line
number 5009
!
!
ephone-dn  10  dual-line
number 5010
!
!
ephone  1
mac-address 000F.34EC.C959
type 7940
button  1:1
!
!
!
ephone  2
!
!
!
ephone  3
!
!
!
ephone  4
!
!
!
ephone  5
!
!
!
ephone  6
!
!
!
ephone  7
!
!
!
ephone  8
!
!
!
ephone  9
!
!
!
ephone  10
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end


*Mar  8 06:37:10.576: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
INVITE sip:917771234567@204.11.192.36:5060 SIP/2.0
Via: SIP/2.0/UDP  192.168.5.1:5060;branch=z9hG4bKA42497
From: <sip:7705774..1@192.168.5.1>;tag=25782450-1026
To: <sip:917771234567@204.11.192.36>
Date: Fri, 08 Mar 2002 06:37:10 GMT
Call-ID: C09FFAFF-319511D6-80B8A7A1-2DFA084@192.168.5.1
Supported: 100rel,timer,replaces
Min-SE:  1800
Cisco-Guid: 3204589746-831853014-2159388577-48210052
User-Agent: Cisco-SIPGateway/IOS-12.x
Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, COMET, REFER, SUBSCRIBE, NOTIFY, INFO, UPDATE, REGISTER
CSeq: 101 INVITE
Max-Forwards: 70
Timestamp: 1015569430
Contact: <sip:7705774..1@192.168.5.1:5060>
Expires: 180
Allow-Events: telephone-event
Content-Type: application/sdp
Content-Length: 266

v=0
o=CiscoSystemsSIP-GW-UserAgent 2974 638 IN IP4 192.168.5.1
s=SIP Call
c=IN IP4 192.168.5.1
t=0 0
m=audio 16526 RTP/AVP 18 101
c=IN IP4 192.168.5.1
a=rtpmap:18 G729/8000
a=fmtp:18 annexb=no
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-16
a=ptime:20

*Mar  8 06:37:11.072: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
INVITE sip:917771234567@204.11.192.36:5060 SIP/2.0
Via: SIP/2.0/UDP  192.168.5.1:5060;branch=z9hG4bKA42497
From: <sip:7705774..1@192.168.5.1>;tag=25782450-1026
To: <sip:917771234567@204.11.192.36>
Date: Fri, 08 Mar 2002 06:37:11 GMT
Call-ID: C09FFAFF-319511D6-80B8A7A1-2DFA084@192.168.5.1
Supported: 100rel,timer,replaces
Min-SE:  1800
Cisco-Guid: 3204589746-831853014-2159388577-48210052
User-Agent: Cisco-SIPGateway/IOS-12.x
Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, COMET, REFER, SUBSCRIBE, NOTIFY, INFO, UPDATE, REGISTER
CSeq: 101 INVITE
Max-Forwards: 70
Timestamp: 1015569431
Contact: <sip:7705774..1@192.168.5.1:5060>
Expires: 180
Allow-Events: telephone-event
Content-Type: application/sdp
Content-Length: 266

v=0
o=CiscoSystemsSIP-GW-UserAgent 2974 638 IN IP4 192.168.5.1
s=SIP Call
c=IN IP4 192.168.5.1
t=0 0
m=audio 16526 RTP/AVP 18 101
c=IN IP4 192.168.5.1
a=rtpmap:18 G729/8000
a=fmtp:18 annexb=no
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-16
a=ptime:20

*Mar  8 06:37:12.072: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
INVITE sip:917771234567@204.11.192.36:5060 SIP/2.0
Via: SIP/2.0/UDP  192.168.5.1:5060;branch=z9hG4bKA42497
From: <sip:7705774..1@192.168.5.1>;tag=25782450-1026
To: <sip:917771234567@204.11.192.36>
Date: Fri, 08 Mar 2002 06:37:12 GMT
Call-ID: C09FFAFF-319511D6-80B8A7A1-2DFA084@192.168.5.1
Supported: 100rel,timer,replaces
Min-SE:  1800
Cisco-Guid: 3204589746-831853014-2159388577-48210052
User-Agent: Cisco-SIPGateway/IOS-12.x
Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, COMET, REFER, SUBSCRIBE, NOTIFY, INFO, UPDATE, REGISTER
CSeq: 101 INVITE
Max-Forwards: 70
Timestamp: 1015569432
Contact: <sip:7705774..1@192.168.5.1:5060>
Expires: 180
Allow-Events: telephone-event
Content-Type: application/sdp
Content-Length: 266

v=0
o=CiscoSystemsSIP-GW-UserAgent 2974 638 IN IP4 192.168.5.1
s=SIP Call
c=IN IP4 192.168.5.1
t=0 0
m=audio 16526 RTP/AVP 18 101
c=IN IP4 192.168.5.1
a=rtpmap:18 G729/8000
a=fmtp:18 annexb=no
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-16
a=ptime:20

520: //35/240C4CEF8052/SIP/Info/sipSPIUfreeOneCCB: Freeing ccb 84198CB4

2 ACCEPTED SOLUTIONS

Accepted Solutions
Hall of Fame Super Gold

Re: SIP Call Failing CME config are Below

Check your NAT device, as router never receives a reply.

Cisco Employee

Re: SIP Call Failing CME config are Below

as per your sip invite sent:

Sent:
INVITE sip:917771234567@204.11.192.36:5060 SIP/2.0


looks that this is sent to a routeable IP 204.11.192.36 on the internet so you will need to include a source routable address. The one you are sending is private and more than likely your SIP provider will not reply properly:

From: <7705774..1>;tag=25782450-1026

I see no public addresses within the router so you need an interface with a public address or NAT...

let me know if it helps

Efrain

5 REPLIES
Hall of Fame Super Gold

Re: SIP Call Failing Debug and CME conifg are Below

Take "debug ccsip message" ONLY and post relevant configuration ONLY.

Excessive verbosity doesn't help diagnising.

New Member

Re: SIP Call Failing CME config are Below

dialplan-pattern 1 7705774... extension-length 4 extension-pattern 500.
Should the 7705774... be the number the SIP Provider gave me? I actually created the 770number myself. I also deleted the debug CCSIP All info.

Hall of Fame Super Gold

Re: SIP Call Failing CME config are Below

Check your NAT device, as router never receives a reply.

Cisco Employee

Re: SIP Call Failing CME config are Below

as per your sip invite sent:

Sent:
INVITE sip:917771234567@204.11.192.36:5060 SIP/2.0


looks that this is sent to a routeable IP 204.11.192.36 on the internet so you will need to include a source routable address. The one you are sending is private and more than likely your SIP provider will not reply properly:

From: <7705774..1>;tag=25782450-1026

I see no public addresses within the router so you need an interface with a public address or NAT...

let me know if it helps

Efrain

New Member

Re: SIP Call Failing CME config are Below

Thanks for your help but, my CME router is behind a another firewall. In performing some tests. I found out that the firewall was not passing the traffic properly. Everything is working fine now.

292
Views
0
Helpful
5
Replies
CreatePlease login to create content