Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

SIP calls through CUCM 8.6.2 ring and when answered fast busy

We are testing SIP through one of our offices and are having trouble with the calls going through. When we place the calls they ring like a normal call, but when answered you get a fast busy. We have SIP service provided through Level 3 communications. I spoke with them for debug purposes and they're seeing the call ring acknowledged, an ok when answered and then an immediate bye. I'm not sure if it's a config issue in Call Manager or on the gateway.

 

here is the  level 3 debug, they provided me:

BYE sip:4788450763@207.227.240.79:5060 SIP/2.0
Via: SIP/2.0/UDP 10.101.1.6:5060;branch=z9hG4bK3191331
From: "test" <sip:7246204141@10.101.1.6>;tag=A6877434-491
To: <sip:4788450763@207.227.240.79>;tag=gK00c871fb
Date: Thu, 06 Nov 2014 15:25:09 GMT
Call-ID: EDB70A16-64FF11E4-9589F6A1-7A7E53DF@10.101.1.6
User-Agent: Cisco-SIPGateway/IOS-12.x
Max-Forwards: 70
Timestamp: 1415287515
CSeq: 103 BYE
Reason: Q.850;cause=96
P-RTP-Stat: PS=0,OS=0,PR=229,OR=36640,PL=0,JI=0,LA=0,DU=0
Content-Length: 0
 

 

Here's a call debug, that I just produced:

SGW_Main#

Nov  6 17:26:52.962: //-1/1780DB800000/SIP/Call/sipSPICallInfo:

The Call Setup Information is:

Call Control Block (CCB) : 0x2B987538

State of The Call        : STATE_DEAD

TCP Sockets Used         : NO

Calling Number           : xxx6204141

Called Number            : 7xxx4542969

Source IP Address (Sig  ): x.101.1.6

Destn SIP Req Addr:Port  : x.10.1.6:0

Destn SIP Resp Addr:Port : x.10.1.6:5060

Destination Name         : x.10.1.6

 

Nov  6 17:26:52.962: //-1/1780DB800000/SIP/Call/sipSPICallInfo:

Disconnect Cause (CC)    : 100

Disconnect Cause (SIP)   : 422

 

SGW_Main#

Nov  6 17:27:02.182: //529700/1780DB800000/SIP/Call/sipSPICallInfo:

The Call Setup Information is:

Call Control Block (CCB) : 0x2B976768

State of The Call        : STATE_ACTIVE

TCP Sockets Used         : NO

Calling Number           : xxx6204141

Called Number            : xxx4542969

Source IP Address (Sig  ): x.101.1.6

Destn SIP Req Addr:Port  : x.227.240.79:5060

Destn SIP Resp Addr:Port : x.227.240.79:5060

Destination Name         : x.227.240.79

 

Nov  6 17:27:02.182: //529700/1780DB800000/SIP/Call/sipSPIMediaCallInfo:

Number of Media Streams: 1

Media Stream             : 1

Negotiated Codec         : g711ulaw

Negotiated Codec Bytes   : 160

Nego. Codec payload      : 0 (tx), 0 (rx)

Negotiated Dtmf-relay    : 6

Dtmf-relay Payload       : 101 (tx), 101 (rx)

Source IP Address (Media): x.101.1.6

Source IP Port    (Media): 30516

Destn  IP Address (Media): x.227.240.78

Destn  IP Port    (Media): 11536

Orig Destn IP Address:Port (Media): [ - ]:0

 

Nov  6 17:27:02.202: //529699/1780DB800000/SIP/Call/sipSPICallInfo:

The Call Setup Information is:

Call Control Block (CCB) : 0x2B987538

State of The Call        : STATE_DEAD

TCP Sockets Used         : NO

Calling Number           : xxx6204141

Called Number            : 7xxx4542969

Source IP Address (Sig  ): x.101.1.6

Destn SIP Req Addr:Port  : x.10.1.6:5060

Destn SIP Resp Addr:Port : x.10.1.6:5060

Destination Name         : x.10.1.6

 

Nov  6 17:27:02.202: //529699/1780DB800000/SIP/Call/sipSPIMediaCallInfo:

Number of Media Streams: 1

Media Stream             : 1

Negotiated Codec         : No Codec

Negotiated Codec Bytes   : 0

Nego. Codec payload      : 255 (tx), 255 (rx)

Negotiated Dtmf-relay    : 0

Dtmf-relay Payload       : 0 (tx), 0 (rx)

Source IP Address (Media): x.101.1.6

Source IP Port    (Media): 21416

Destn  IP Address (Media):  -

Destn  IP Port    (Media): 0

Orig Destn IP Address:Port (Media): [ - ]:0

 

Nov  6 17:27:02.202: //529699/1780DB800000/SIP/Call/sipSPICallInfo:

Disconnect Cause (CC)    : 86

Disconnect Cause (SIP)   : 500

 

Nov  6 17:27:02.238: //529700/1780DB800000/SIP/Call/sipSPICallInfo:

The Call Setup Information is:

Call Control Block (CCB) : 0x2B976768

State of The Call        : STATE_DEAD

TCP Sockets Used         : NO

Calling Number           : xxx6204141

Called Number            : xxx4542969

Source IP Address (Sig  ): x.101.1.6

Destn SIP Req Addr:Port  : x.227.240.79:5060

Destn SIP Resp Addr:Port : x.227.240.79:5060

Destination Name         : x.227.240.79

 

SGW_Main#

Nov  6 17:27:02.238: //529700/1780DB800000/SIP/Call/sipSPIMediaCallInfo:

Number of Media Streams: 1

Media Stream             : 1

Negotiated Codec         : g711ulaw

Negotiated Codec Bytes   : 160

Nego. Codec payload      : 0 (tx), 0 (rx)

Negotiated Dtmf-relay    : 6

Dtmf-relay Payload       : 101 (tx), 101 (rx)

Source IP Address (Media): x.101.1.6

Source IP Port    (Media): 30516

Destn  IP Address (Media): x.227.240.78

Destn  IP Port    (Media): 11536

Orig Destn IP Address:Port (Media): [ - ]:0

 

Nov  6 17:27:02.238: //529700/1780DB800000/SIP/Call/sipSPICallInfo:

Disconnect Cause (CC)    : 96

Disconnect Cause (SIP)   : 200

 

 

 

error messages:

Call having the requested call identity has been cleared

Typical scenarios include:

Network timeout

Call cleared by remote user.

86

Indicates that the network has received a call identity information element indicating a suspended call that has in the meantime been cleared wile suspended.

Mandatory IE missing error

Typical scenarios include:

Mandatory Contact field missing in SIP message.

Session Description Protocol (SDP) body is missing.

96

CC_CAUSE_MANDATORY_IE_ MISSING

Indicates that the equipment sending this cause code has received a message that is missing an information element (IE). This IE must be present in the message before the message can be processed.

Invalid IE contents error

Typical scenarios include:

SIP Contact field is present, but format is bad

100

CC_CAUSE_INVALID_IE_ CONTENTS

Indicates that the equipment sending this cause code has received an IE that it has implemented. However, the equipment sending this cause code has not implemented one or more of the specific fields.

 

 

11 REPLIES
Cisco Employee

Hi somersettrust,Can you

Hi somersettrust,

Can you paste your CUBE configuration here?

New Member

Level 3 Communications

Level 3 Communications provides our SIP service and manages the CUBE on their side, so I don't have the config. I worked with one of their engineers, trying to troubleshoot the problem and seem to think it's coming from my voice gateway or CUCM. I can provide you with info from my voice gateway or my call mgr. When I place the call, it rings to the called party, but once it's answered the call goes fast busy. I set a route pattern up, for my cell phone, for testing purposes. I originally discovered the problem trying to test 911.
Cisco Employee

Yes, running-config from your

Yes, running-config from your VGW would be helpful.

New Member

here's the vg config: We have

here's the vg config: We have approximately 25 offices running through 2 PRI's. we just implemented SIP for a new office.

 

 

SGW_Main#sh run
Building configuration...


Current configuration : 9078 bytes
!
! Last configuration change at 16:29:33 EST Wed Nov 5 2014 by mostoller
! NVRAM config last updated at 17:10:37 EST Wed Nov 5 2014 by mostoller
! NVRAM config last updated at 17:10:37 EST Wed Nov 5 2014 by mostoller
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname SGW_Main
!
boot-start-marker
boot-end-marker
!
!
card type t1 0 0
logging buffered 100000000
!
no aaa new-model
clock timezone EST -5 0
clock summer-time EDT recurring
network-clock-participate wic 0
network-clock-select 1 T1 0/0/0
!
no ipv6 cef
ip source-route
ip cef
!
!
!
!
!
multilink bundle-name authenticated
!
!
!
!
isdn switch-type primary-4ess
!
crypto pki token default removal timeout 0
!
crypto pki trustpoint TP-self-signed-4018802375
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-4018802375
 revocation-check none
 rsakeypair TP-self-signed-4018802375
!
!
crypto pki certificate chain TP-self-signed-4018802375
 certificate self-signed 01
 
   quit
voice-card 0
 dsp services dspfarm
!
!
!
voice service voip
 ip address trusted list
  ipv4 X.227.240.0 255.255.255.0
 allow-connections sip to sip
 fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
 sip
  min-se 14400 session-expires 14400
!
voice class codec 1
 codec preference 1 g711ulaw
 codec preference 2 g729r8
!
!
!
!
voice translation-rule 1
 rule 1 /^\+1......\(....\)$/ /\1/
!
voice translation-rule 7
 rule 1 /^7/ //
!
!
voice translation-profile INCOMING-L3
 translate called 1
!
voice translation-profile OUTGOING-L3
 translate called 7
!
!
!
application
 service CMM http://10.10.1.6:8080/ccmivr/pages/IVRMainpage.vxml
 !
 global
  service alternate Default
 !
!
license udi pid CISCO2911/K9 sn FTX1701A104
hw-module pvdm 0/0
!
hw-module pvdm 0/1
!
!
!
archive
 log config
  logging enable
  logging size 1000
  notify syslog contenttype plaintext
  hidekeys
!
redundancy
!
!
controller T1 0/0/0
 cablelength long 0db
 pri-group timeslots 1-24 service mgcp
!
ip ssh version 2
!
!
!
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 ip address x.101.1.6 255.255.252.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0/0:23
 no ip address
 encapsulation hdlc
 isdn switch-type primary-ni
 isdn incoming-voice voice
 isdn bind-l3 ccm-manager
 no cdp enable
!
ip forward-protocol nd
!
no ip http server
ip http access-class 10
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip route 0.0.0.0 0.0.0.0 x.101.1.1
!
access-list 10 permit x.x.1.29
access-list 10 permit x.x.1.55
access-list 10 permit x.x.1.32
access-list 10 permit x.x.1.70
access-list 10 permit x.x.1.99
access-list 10 permit x.x.1.101
access-list 10 permit x.x.1.164
!
!
snmp-server community hansolo RO 10
snmp-server community jarjarbinks RW 10
snmp-server ifindex persist
!
control-plane
!
!
voice-port 0/0/0:23
!
ccm-manager fallback-mgcp
ccm-manager redundant-host x.10.2.7
ccm-manager mgcp
no ccm-manager fax protocol cisco
ccm-manager music-on-hold
ccm-manager config server x.10.1.6 
ccm-manager config
!
mgcp
mgcp call-agent x.10.1.6 2427 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode out-of-band
mgcp rtp unreachable timeout 1000 action notify
mgcp modem passthrough voip mode nse
mgcp quarantine persistent-event disable
mgcp package-capability rtp-package
mgcp package-capability sst-package
mgcp package-capability pre-package
no mgcp package-capability res-package
no mgcp package-capability fxr-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp fax t38 inhibit
mgcp rtp payload-type g726r16 static
!
mgcp profile default
!
sccp local GigabitEthernet0/0
sccp ccm x.10.2.7 identifier 2 version 7.0
sccp ccm x.10.1.6 identifier 1 version 7.0
sccp ip precedence 3
sccp
!
sccp ccm group 1
 associate ccm 1 priority 1
 associate ccm 2 priority 2
 associate profile 1 register MTP-SIP-Som
!
sccp ccm group 999
 associate ccm 1 priority 1
 associate ccm 2 priority 2
 associate profile 999 register GW1-XCODE
!
sccp ccm group 992
 associate ccm 1 priority 1
 associate ccm 2 priority 2
 associate profile 992 register GW1-CB
!
dspfarm profile 999 transcode 
 codec g711ulaw
 codec g711alaw
 codec g729ar8
 codec g729abr8
 maximum sessions 3
 associate application SCCP
!
dspfarm profile 992 conference 
 codec g729br8
 codec g729r8
 codec g729abr8
 codec g729ar8
 codec g711alaw
 codec g711ulaw
 maximum sessions 3
 associate application SCCP
!
dspfarm profile 1 mtp 
 codec pass-through
 codec g711ulaw
 maximum sessions software 10000
 associate application SCCP
!
dial-peer voice 1 pots
 destination-pattern 9911
 forward-digits 3
!
dial-peer voice 2 pots
 description dial-peer for local 7 digit dialing
 destination-pattern 9[2-9]......
 port 0/0/0:23
 forward-digits 7
!
dial-peer voice 3 pots
 description dial-peer for LD dialing
 destination-pattern 91..........
 port 0/0/0:23
 forward-digits 11
!
dial-peer voice 100 pots
 description dial-peer for inbound DID
 incoming called-number .
 direct-inward-dial
 port 0/0/0:23
!
dial-peer voice 8100 voip
 destination-pattern 81..
 session target ipv4:x.10.1.6
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!
dial-peer voice 88100 voip
 destination-pattern 88...
 session target ipv4:x.10.1.6
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!
dial-peer voice 207 voip
 translation-profile incoming INCOMING-L3
 translation-profile outgoing OUTGOING-L3
 destination-pattern 7.T
 session protocol sipv2
 session target ipv4:x.227.240.79
 session transport udp
 incoming called-number .
 voice-class codec 1 
 voice-class sip early-offer forced
 dtmf-relay rtp-nte
 no vad
!
dial-peer voice 208 voip
 destination-pattern [0-6,8-9]...
 session protocol sipv2
 session target ipv4:x.10.1.6
 session transport udp
 voice-class codec 1 
 dtmf-relay rtp-nte
 no vad
!
!
!
!
gatekeeper
 shutdown
!
!
call-manager-fallback
 max-conferences 8 gain -6
 transfer-system full-consult
 ip source-address x.101.1.6 port 2000
 max-ephones 58
 max-dn 300 dual-line
 system message primary call manager down
 system message secondary call manager down
 keepalive 10
!
!
banner motd ^C
******************************************************
******        Property                          ******
*****             Access Restricted              *****
****   Do not attempt to logon unless authorized  ****
******************************************************
^C
!
line con 0
 logging synchronous
 login local
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line vty 0 4
 session-timeout 60
 access-class 10 in
 privilege level 15
 logging synchronous
 login local
 transport input ssh
 transport output ssh
line vty 5 15
 session-timeout 60
 access-class 10 in
 privilege level 15
 logging synchronous
 login local
 transport input ssh
 transport output ssh
!
scheduler allocate 20000 1000
ntp update-calendar
ntp server x.x.254.1
end

SGW_Main#exit

You should have a region for

You should have a region for your Branch office, and a region for your SIP trunk between CUCM and your GW.  <- Very important. 

 

Your current call flow: 

IP phone --- sccp to ---> CUCM ---SIP trunk to -->CUBE gateway ---SIP Trunk to ITSP--> .

 

To test make sure you have your Iphone in X_REGION and your CUCM sip trunk in Y_Region. Then make sure your region relationship between X and Y = 64 kbps. Then test. 

 

Also....

The Cube config has a voice class with g711ulaw and g729r8 allowed to the ITSP. But your transcoder profile does not have g729r8 in it. I suspect if your region  is negotiating g.729 between iphone and CUCM-CUBE sip trunk, it won't be able to transcode to g711ullaw to leave to the ITSP.

 

Let me know.

New Member

I'm making the changes now,

I'm making the changes now, but won't be able to test it until tomorrow morning. As soon as I test it, I will let you know.

Thanks for the advice.

Glad it worked! The CUBE has

Glad it worked! The CUBE has to have a 911 voip dial peer with the voice class specified. 

 

On another note, your calls were not going through because transcoding is not setup properly on your CUBE. What was happening was your IPphone was negotiating G.729 all the way to the CUBE, but the the CUBE negotiated G.711 to the ITSP. So when the call connected, your CUCM noticed the mismatch and disconnected by sending the "bye" sip message. This can be fixed if your CUBE is properly setup for transcoding, because using G.711 all the time will consume more bandwidth, and you always want to have both codecs working anyways.

 

Please make sure your SIP Trunk's MGRL in call manager is in the same region as your SIP trunk, and then fix the config on the CUBE. You need to include G.729r8 under the profile for transcoding.

 

Good luck and rate useful! 

New Member

I have 911 working. When I

I have 911 working. When I would call it, it would say "call can not be completed as dialed". I created a new dial-peer specifically for 911 and that fixed it.

 

dial-peer voice 209 voip
 translation-profile incoming INCOMING-L3
 translation-profile outgoing OUTGOING-L3
 destination-pattern 911
 session protocol sipv2
 session target ipv4:x.227.240.79
 session transport udp
 incoming called-number .
 voice-class codec 1 
 voice-class sip early-offer forced
 dtmf-relay rtp-nte
 no vad

 

 

I will verify the SIP Trunk's MGRL relation to the Region. I will also check the config for the transcoding.

 

Thanks again

New Member

I added the Region and

I added the Region and tweaked a few other settings and the calls went through. Thanks!

I'm still having an issue calling 911, but I haven't looked at the dial peers in the VG. I suspect that may be the problem.

I had this issue once, it

I had this issue once, it turned out to be a codec mismatch. One side supported G.711 only while the other side was negotiating  G.729 and the transcoders were not setup properly. I initially created a separate voice class in the CUBE to force G.711 and that's how I figured out what was wrong.

Make sure your call manager regions' relationships are setup properly.

 

Thanks,

 

 

New Member

I tried modifying the region,

I tried modifying the region, of the office that we are testing SIP in and that didn't work. Do I need to modify the codec for the new office in relation to all the other offices (we have 20 plus offices) or just the main office (containing the VG and CUCM)?

 

2027
Views
15
Helpful
11
Replies