Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

SIP DTMF from Telco is failing with CUBE

I have a CUBE running 15.0(1r)M1.   ISP is SIP coming and SIP out to CUCM 8.x.  


When I run debug DTMF at the router, I see the digits being pressed.  So Im assuming they are coming, but are they coming in the correct format such as 2833, Im not sure.  If they are not standard, they will probably no relay correctly to CUCM.

SCCP--CUCM--3rd party SIP end point works fine with DTMF.. so I know its not CUCM. (I think).

My Dial-peers seem to have everything they need from the CUBE to CUCM:

dial-peer voice 200 voip
destination-pattern XXXXX
rtp payload-type nte 120
session protocol sipv2
session target ipv4:x.x.x.x
dtmf-relay rtp-nte
codec g711ulaw
no vad

I configured a transcoder at the router, registered it with CUCM, added it the MRG to the SIP trunk in case for some odd reason the DTMFs needed to be transcoded, no luck.  Tried MTP on/off on the trunk, no luck.

Am I missing something really easy here or ???

My bug toolkit login is not working tonight.   grrrrrrrrrrrrrrrrrrrrrrr

4 REPLIES
Cisco Employee

Re: SIP DTMF from Telco is failing with CUBE

Calls are probably not matching the correct inbound dial-peer. Try adding the following to the configuration and test.

dial-peer voice 200 voip

incoming called-number .

If DTMF still fails, collect the folllowing debugs.

debug voip ccapi inout

debug ccsip message

debug voip rtp session named

Please note the calling and called party numbers along with DTMF entered.

-Felipe

Re: SIP DTMF from Telco is failing with CUBE

When I see the debug, I see the DTMF in the router.

But you are saying DTMF could take a different dial peer if there is another peer matching??

Re: SIP DTMF from Telco is failing with CUBE

Actually, had to add dtmf-relay rtp-nte sip-notify to the line then it worked.

Cisco Employee

Re: SIP DTMF from Telco is failing with CUBE

DTMF related issues in CUBE environments are almost always caused by dial-peer matching issues. Both the inbound and outbound dial-peer need to be configured with the correct dtmf-relay. If they are not, then it fails.

-Felipe

423
Views
0
Helpful
4
Replies
CreatePlease to create content