Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

SIP Registrar timer problems

Hello,

I've got a CME router IOS 12.4(9T) running as a SIP-UA into a service providers SIP network.

I was running 12.4(8a) and the registrar timers was fine. Every 25 seconds or so it would renew my registration.

I changed to 12.4(9T) because I needed the ability to rename the local sip domain to be able to make calls out, not just call in. Ever since that, my registrar timer renews every 60 seconds instead of 25 seconds. This is a problem because the service provider requires a renew every 30 seconds or I get a 403 forbidden when I try to call out more then 30 seconds after renewal.

The only timers i've seen for SIP registration was the retry timer which is 100-1000ms. Obviously not applicable

The other time is the expiry time on the

registrar dns:x.y.z username test password test expiry seconds

Which doesn't seem to affect anything at all

If anyone could be of assistance, i'd be very grateful

Richard

3 REPLIES
Hall of Fame Super Gold

Re: SIP Registrar timer problems

Hi Richard,

beside noting that the ISP is very much too strict (never heard anything like that),

the "expiry seconds" is the right place to apply the config.

Can you try 12.4(11)XJ3, and if still doesn't work, raise a case with the TAC in the event a bug need to be opened ?

New Member

Re: SIP Registrar timer problems

Hello P. Bevilacqua,

It seems like you're always helping me out these days! I've fired up 12.4(11)XJ3 with the same result that 12.4(9)T and 12.4(15)T gave me. The lowest I can set the expire time to is 60 seconds.

I'm just finding it really strange how 12.4(8a) drops the timer down to 25 seconds to match the SP 30 seconds expire. Shame I can't stick with that IOS - I need the voice-class sip localhost command in the technology release for successful calling out.

Below is an extract from debug ccsip messages

Jul 4 12:05:55.755: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:

Received:

SIP/2.0 200 OK

Via: SIP/2.0/UDP 192.168.0.200:5060;received=x.x.x.x;branch=z9hG4bKB1468;rport=xyz

From: <>myphonenumber@service.provider.domain>;tag=A3D78-B79

To: <>myphonenumber@service.provider.domain>;tag=SDqpb7c99-

Call-ID: F8212588-2BDE11D6-8002E3CB-211CDA76

Timestamp: 1183550755

CSeq: 13 REGISTER

Contact: ;expires=30;q=0.5

Content-Length: 0

Note the "expires=30"

This is driving me insane. How is it that I can get everything working on an old 7912 running SIP firmware, but I can't get it working on a brand new IOS?

Hall of Fame Super Gold

Re: SIP Registrar timer problems

Hi Richard,

My sympathies, I understand your frustration. In total frankness, the SIP-UA part of Cisco IOS, is substandard respect to general level of the code.

Your only hope is to submit a case, and ask for a bug to be opened as "feature request" or something like that. On your side, you have that is was working before, so actually the new code broke something.

Then with patience, one can try to get it thought to feature developers and managers and see if something can be done about it. But, don't hold your breath.

319
Views
5
Helpful
3
Replies