Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

SIP Registration Request not reaching provider

I have a home lab setup and recently decided to add PSTN access via a SIP trunk and termination. I got the applicable information from the provider, set up the IOS configuration, but I'm not registering. I checked the CCSIP messages logs, no response. I talked to the provider, they are not getting my messages at all. Other traffic to and from the internet passes just fine (including SSL VPN). 

I've talked to my ISP many times, and they continually insist they do not block any traffic except port 25. 

Here is the applicable configuration:

 sip
  bind control source-interface Vlan1
  bind media source-interface Vlan1
  session transport tcp
  header-passing
  no call service stop

sip-ua
 credentials username XXXXXXXXX password 7 XXXXXXXXXXX realm XXXX
 authentication username XXXXXXXXXXX password 7 XXXXXXXXXXXX
 registrar ipv4:XX.XX.XX.XXX expires 3600
 sip-server ipv4:XX.XX.XX.XXX

(the source button puts the whole post in source tags... annoying)

 

And here's the debug output from ccsip all:

Apr 10 21:17:33.091: //-1/xxxxxxxxxxxx/SIP/Info/sipSPISetDateHeader: Converting TimeZone CDT to SIP default timezone = GMT
Apr 10 21:17:33.091: //594/000000000000/SIP/Info/sipSPISendRegister: Associated container=0x4F7E3670 to Register
Apr 10 21:17:33.091: //594/000000000000/SIP/Transport/sipSPISendRegister: Sending REGISTER to the transport layer
Apr 10 21:17:33.091: //594/000000000000/SIP/Transport/sipSPIGetSwitchTransportFlag: Return the Global configuration, Switch Transport is FALSE
Apr 10 21:17:33.091: //594/000000000000/SIP/Transport/sipSPITransportSendMessage: msg=0x4F3BB008, addr=XX.XX.XX.XX, port=5060, sentBy_port=0, local_addr=10.XX.XX.XX, is_req=1, transport=1, switch=0, callBack=0x0
Apr 10 21:17:33.091: //594/000000000000/SIP/Transport/sipSPITransportSendMessage: Proceedable for sending msg immediately
Apr 10 21:17:33.091: //594/000000000000/SIP/Transport/sipTransportLogicSendMsg: switch transport is 0
Apr 10 21:17:33.091: //-1/xxxxxxxxxxxx/SIP/Transport/sipConnectionManagerGetConnection: connection required for raddr:Xx.XX.XX.XX, rport:5060 with laddr:Xx.XX.XX.Xx

Apr 10 21:17:33.091: //594/000000000000/SIP/Transport/sipTransportLogicSendMsg: Set to send the msg=0x4F3BB008
Apr 10 21:17:33.091: //-1/xxxxxxxxxxxx/SIP/Transport/sipTransportPostSendMessage: Posting send for msg=0x4F3BB008, addr=XX.XX.XX.XX, port=5060, local_addr=10.Xx.XX.XX, connId=3 for UDP

I took out the message because I don't think it's relevant, and has too many IPs to XX out :)

Apr 10 21:17:37.091: //594/000000000000/SIP/Error/act_sent_register_wait_100: act_sent_register_wait_100: Out of retries
Apr 10 21:17:37.091: //-1/xxxxxxxxxxxx/SIP/Info/sipSPIDecrementOverloadCount: Count:Local 0 Global 1
Apr 10 21:17:37.091: //594/000000000000/SIP/Error/ccsip_api_register_result_ind: Message Code Class 4xx Method Code 100 received for REGISTER
Apr 10 21:17:37.091: //-1/xxxxxxxxxxxx/SIP/Info/ccsip_register_reset_dns_cache: CCSIP_REGISTER:: registrar 0 DNS resolved addr reset
Apr 10 21:17:37.091: //594/000000000000/SIP/Error/ccsip_api_register_result_ind: SIP Registration Retries Exhausted
Apr 10 21:17:37.091: //594/000000000000/SIP/Info/sipSPIRegPthruProcessResponse: Processing response w/ resp code == 408
Apr 10 21:17:37.091: //-1/xxxxxxxxxxxx/SIP/Info/sipSPIGetRPCBFromRCB: Retreiving RCB [0x4FA37D28] from RPCB [0x0]
Apr 10 21:17:37.091: //594/000000000000/SIP/Error/sipSPIRegPthruProcessResponse: Error NO RPCB

Apr 10 21:17:37.091: //-1/xxxxxxxxxxxx/SIP/Info/ccsipRegisterStartRCBTimer: Starting timer for pattern XXXXXXXX for 180 seconds
Apr 10 21:17:37.091: //-1/xxxxxxxxxxxx/SIP/Info/sipSPIDeleteContextFromTable: Context for key=[576] removed.
Apr 10 21:17:37.091: //594/000000000000/SIP/Info/sipSPIUdeleteCcbFromUACTable: ****Deleting from UAC table.
Apr 10 21:17:37.091: //594/000000000000/SIP/Info/sipSPIUdeleteCcbFromTable: Deleting from table. ccb=0x4B6CC660 key=AD7E2293-C01A11E3-80AEE452-E7A949D0
Apr 10 21:17:37.091: //594/000000000000/SIP/Info/sipSPIFlushEventBufferQueue: There are 0 events on the internal queue that are going to be free'd
Apr 10 21:17:37.091: //594/000000000000/SIP/Info/sipSPI_ipip_free_codec_profile: Codec Profiles Freed
Apr 10 21:17:37.091: //594/000000000000/SIP/Info/ccsip_offer_ans_delete:
Apr 10 21:17:37.091: //594/000000000000/SIP/Info/ccsip_iwf_delete:
Apr 10 21:17:37.091: //594/000000000000/SIP/Info/sipSPIUfreeOneCCB: Freeing ccb 4B6CC660

1 REPLY
New Member

Nevermind; I downloaded a SIP

Nevermind; I downloaded a SIP phone app for my smart phone, got it to connect in the same network. After that, I put the gateway in a DMZ and it started working. Not entirely sure why it was required, but hey, it works!

Cheers

301
Views
0
Helpful
1
Replies