Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

SIP SRST isues- cucm9.1/7841

I am setting up a BE6K  with H323 gateway and SIp Phones 7965 ans 7841.

CUCM version :9.1.2.11900-12, Firmware on phones:sip78xx.10-1-1SR1-4 and SIP45.9-3-1SR4-1S, gateway(2911) version is 15.3.3.M2.

The Issues are ,when CUCM is offline , 7965 registered with SIP  SRST gateway and only one 7841 registers and that too after 3 minutes . other phones never gets registered. Phones cannot call each other with extension, when dialing , phones accepts the digit and timeout after 2 minutes.

CUCM - SRST reference is configured as the gateway address and applied to the device pool.

phones show SRST reference in normal mode.No friewall in between

Any idea?

gateway config is as follows

 

Current configuration : 6857 bytes
!
! Last configuration change at 13:42:21 MST Sat Apr 5 2014 by admin
! NVRAM config last updated at 16:34:26 MST Fri Apr 4 2014 by admin
! NVRAM config last updated at 16:34:26 MST Fri Apr 4 2014 by admin
version 15.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname XXXX
!
boot-start-marker
boot-end-marker
!
aqm-register-fnf
!
card type t1 0 0
logging buffered 51200 warnings
!
no aaa new-model
clock timezone MST -7 0
clock summer-time MST recurring
network-clock-participate wic 0
network-clock-select 1 T1 0/0/0
!
!
!
!

ip dhcp excluded-address 192.168.254.1 192.168.254.99
ip dhcp excluded-address 192.168.254.200 192.168.254.254
!
ip dhcp pool voice
 network 192.168.254.0 255.255.255.0
 default-router 192.168.254.1
 option 150 ip 192.168.254.4
 
ip cef
no ipv6 cef
multilink bundle-name authenticated
!
!
!
!
isdn switch-type primary-ni
!         
!
crypto pki trustpoint TP-self-signed-2754105208
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-2754105208
 revocation-check none
 rsakeypair TP-self-signed-2754105208
!
!
crypto pki certificate chain TP-self-signed-2754105208
 certificate self-signed 01
  3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 32373534 31303532 3038301E 170D3134 30333131 31353233
  34395A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 37353431
  30353230 3830819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  81009CB5 2128FEDA 799E8E19 0FA05CD3 1307F3F1 13350E2D 5307FF57 7D927F26
  B5E7055B CABF167D 56EB3590 B827133E C7F1E481 4FCBFF90 2D73FFD3 9E5FD5E7
  1D1BCF10 B54C796E 84D36575 8BA1291B 2DDF1599 565694F5 ED399BAB 0AAF6B0B
  A45EB8ED 61F82963 91046B05 62A3594C 20B86F1D FD443A6C AA577204 6AFE7BB0
  B9670203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603
  551D2304 18301680 1475576D 6299BC31 6ED13FCB 9CCDC0FA 94579C7D 56301D06
  03551D0E 04160414 75576D62 99BC316E D13FCB9C CDC0FA94 579C7D56 300D0609
  2A864886 F70D0101 05050003 8181000E 9E790FAF EE056E8A E9CDD037 2686E8B1
  F6ACB6B4 2A28F4A1 28BC773E BFAD6D86 0C47FE5E 44720868 F4FBC660 A03286E8
  7E1E7331 E8934511 4A455D82 EA457122 1034034A 05E1A34E F2D130C4 1B66CCC0
  6B3B3861 F9C21B57 F2726D6F C7D6C9AE 70E4878E 037F93B0 E6BC214A 5D78B658
  E0235E59 1D1FC9B2 97F58665 A3F8C0
        quit
voice-card 0
!
!
!
voice service voip
 ip address trusted list
  ipv4 192.168.254.0
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 no supplementary-service sip refer
 fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
 h323
  no h225 timeout keepalive
  call preserve
 sip
  bind control source-interface GigabitEthernet0/0
  bind media source-interface GigabitEthernet0/0
  registrar server
!
voice class codec 1
 codec preference 1 g711ulaw
 codec preference 2 g722-64
!
voice class h323 1
  h225 timeout tcp establish 3
!
!
voice register global
 mode srst
 system message "SIP SRST SERVICE"
 max-dn 200
 max-pool 50
 timezone 6
!
voice register pool  1
 translation-profile incoming SRST-INCOMING
 id network 192.168.254.0 mask 255.255.255.0
 preference 2
 incoming called-number .
 proxy 192.168.254.8 preference 1 monitor probe icmp-ping
 dtmf-relay rtp-nte
 codec g711ulaw
!
!
!
voice translation-rule 1
 rule 1 /^\(7803576\)\(...\)/ /3\2/
!
!
voice translation-profile SRST-INCOMING
 translate called 1
!
!
!
license udi pid CISCO2911/K9 sn FGL181110T7
license accept end user agreement
hw-module pvdm 0/0
!
!
!

!
redundancy
!
!
controller T1 0/0/0
 cablelength long 0db
 pri-group timeslots 1-10,24
!
!
!         
!
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 description ***L ink to Switch ****
 ip address 192.168.254.8 255.255.255.0
 duplex auto
 speed auto
 h323-gateway voip interface
 h323-gateway voip bind srcaddr 192.168.254.8
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0/0:23
 no ip address
 encapsulation hdlc
 isdn switch-type primary-ni
 isdn incoming-voice voice
 isdn supp-service name calling
 no cdp enable
!
ip forward-protocol nd
!
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip route 0.0.0.0 0.0.0.0 192.168.254.1
!
!
!
!
control-plane
!
!
voice-port 0/0/0:23
!
voice-port 0/1/0
!
voice-port 0/1/1
!
voice-port 0/1/2
!
voice-port 0/1/3
 !
 !
 !
 !
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
dial-peer voice 1 pots
 description **INCOMING PSTN CALLS
 incoming called-number .
 direct-inward-dial
 port 0/0/0:23
!
dial-peer voice 50001 voip
 description **To CUCM1 **
 preference 1
 destination-pattern ..........
 session target ipv4:192.168.254.4
 voice-class codec 1  
 voice-class h323 1
 dtmf-relay h245-alphanumeric
 no vad
!
dial-peer voice 500 pots
 description ** Operator 0 to PSTN **
 destination-pattern 90
 port 0/0/0:23
 forward-digits 1
!
dial-peer voice 110 pots
 description ** International Calls***
 destination-pattern 9011T
 port 0/0/0:23
 prefix 011
!
dial-peer voice 90011 pots
 description ** Long Distance Calls  NA **
 destination-pattern 9[01][2-9]..[2-9]......
 port 0/0/0:23
 forward-digits 11
!
dial-peer voice 90010 pots
 description ** Local 10 digits calls **
 destination-pattern 9[2-9]..[2-9]......
 port 0/0/0:23
 forward-digits 10
!
dial-peer voice 9003 pots
 description **LOCAL SERVICES
 destination-pattern 9[2-8]11
 port 0/0/0:23
 forward-digits 3
!
dial-peer voice 9911 pots
 description **EMERGENCY SERVICES
 destination-pattern 9911
 port 0/0/0:23
 forward-digits 3
!
dial-peer voice 911 pots
 description **EMERGENCY SERVICES
 destination-pattern 911
 port 0/0/0:23
 forward-digits all
!
!
sip-ua
 registrar ipv4:192.168.254.4 expires 3600

 

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

I am having a similar issue,

I am having a similar issue, where not all 7841 phones will register in SRST mode. Seems random as which one will and will not, sometimes it is 19 phones another time it is 50+. Did you ever get a resolution?

 

Regards.

4 REPLIES
New Member

I am having a similar issue,

I am having a similar issue, where not all 7841 phones will register in SRST mode. Seems random as which one will and will not, sometimes it is 19 phones another time it is 50+. Did you ever get a resolution?

 

Regards.

New Member

Hello,I am having similar

Hello,

I am having similar issues as well. We have a CUCM 9.1.2 with several branch offices with 2901 and 2921 router using IOS (c2900-universalk9-mz.SPA.152-4.M5.bin). We have configured SRST which works with most of the phones (79XX with SCCP and SIP, 6945 phones SCCP and 99XX phones using SIP). With these phones everything works as expected.

Now we introduced 7841 phones as new phone modell and now SRST is not working with these phones.

Phone firmware is sip78xx.10-1-1SR2-1.

In case of cutting off the connection to CUCM all phones register to the local SRST gateway also the 7841 phone but the phone registers only for a few seconds. After a successfull register (can be seen in the debugs on the router) it just unregisters again and stays in a registering loop until the CUCMs are available again.

Did anybody find a solution yet to solve this issue ?

 

kind regards

Michael

New Member

Hi all I using global

Hi all

 

I using global configuration below

ephone-type 7841

phone load

phoneload

 

New Member

Is anyone solving the issue?

Is anyone solving the issue? Any update on this case?

1871
Views
10
Helpful
4
Replies
CreatePlease to create content