Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

SIP Trunk from Telco company

Dear

I have a Fiber coming from Telco or MOC , this fiber going to My Switch then going My Voice Router (with 2 Analog and one E1) as "SIP Trunk" with CUCM 8.6 .

My Questions are :

1) what I will configure in the intrface in  Switch that is going to Voice gateway ???

2)what I will configure in the intrface in  Voice router that is going to Switch  ???

Switch port interface -----> Voice port interface


3) ALL i need in CUCM , create SIP trunk and assign ip address of the Voice router or there are extra configuration ?? and i have to add this command " sip-ua " in voice gateway or i dont need it ???


4) do have good steps for my senario that is showing me how i will configure Fiber in my voice router as "sip trunk " or Sip trunk configuration ????

please this is urgent issue

thanks and regards

Everyone's tags (3)
7 REPLIES
Cisco Employee

Re: SIP Trunk from Telco company

Hello Loay,

Please check the following link:

https://supportforums.cisco.com/docs/DOC-16447

The settings for the switch sholld be the same as for data provider.

HTH,

Alex

*Please rate helpful posts

New Member

SIP Trunk from Telco company

Hi Alex

First of all thanks for ur reply , inactally i have confused regarding the role of the voice router and

but my senario is

Teleco or MOC Fiber------> Switch------->2900 Voice Router

                                                       Switch <--------CUCM 8.6

My Question is : What i Will configure in voice router and UBE ??

and My site is one only and there is no ather sites or branches , i think that the switch is here for routing as L3 is not for UBE ? i am right ?

what I will configure in the intrface in  Switch that is going to Voice gateway ???

what I will configure in the intrface in  Voice router that is going to Switch  ???

and I got some setting from the Telco SIP ID and Username , for what this and where i will use it in the configuration ???

thanks and regards

New Member

SIP Trunk from Telco company

Any Reply please

thanks

Hall of Fame Super Gold

SIP Trunk from Telco company

Are you looking for someone that configures you system? That would be the best option if you do not have Cisco Voice certification, or equivalent experience.

New Member

SIP Trunk from Telco company

Hi Paolo

I think that your understood to my question was wrong however , i mean how to configure it to switch i mean UBE as i read and as i understand , however , i did every things but i have  faced some trouble in outgoing calls though SIP trunk

My Question again is

I have CUCM8.6 and Voice gateway that are connected through SIP Trunk to Teleco or MOC

it is giving me bust tone when i am tring call outside through sip trunk

Note  :-  E1 module and FXO module  are not used or not available , the call is  going from my voice router to Teleco Router to go outside

- DID ext : 22270800 to 899

why i cant call outside ???? how to solve it ???

i didnt create SIP trunk in CUCM , is it right becasue it is not nessary as i think ??? becasue i p2p gateway from side to telco side gateway ???

below the configuration and debug

the configuration is

card type e1 0 3

enable secret 4 gMj8cDXfU6CzFI9r1WoD5G6GTI5KwVY2O2lU2DSTP4c

!

no aaa new-model

network-clock-participate wic 3

!

no ipv6 cef

ip source-route

ip cef

!

!

!

!

!

multilink bundle-name authenticated

!

!

!

!

isdn switch-type primary-net5

!

crypto pki token default removal timeout 0

!

!

voice-card 0

!

!

!

voice service voip

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none

sip

  bind control source-interface GigabitEthernet0/0

  bind media source-interface GigabitEthernet0/0

!

!

!

!

!

license udi pid CISCO2901/K9 sn FCZ1624711H

hw-module pvdm 0/0

!

!

!

!

redundancy

!

!

controller E1 0/3/0

pri-group timeslots 1-31

!

!

!

!        

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

description ## Connected to Fasttlco P2P ##

ip address 10.101.6.18 255.255.255.252

duplex auto

speed auto

!

interface GigabitEthernet0/1

description ## Internal Network ##

ip address 10.10.1.5 255.255.255.0

duplex auto

speed auto

!

interface Serial0/3/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice voice

no cdp enable

!        

router rip

version 2

network 10.0.0.0

no auto-summary

!

ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

!

!

!

!

control-plane

!

!

voice-port 0/0/0

!

voice-port 0/0/1

!

voice-port 0/3/0:15

!

voice-port 0/1/0

!

voice-port 0/1/1

!

voice-port 0/1/2

!

voice-port 0/1/3

!

voice-port 0/2/0

!

voice-port 0/2/1

!

voice-port 0/2/2

!

voice-port 0/2/3

!

!

!

mgcp profile default

!

!

dial-peer voice 10 voip

destination-pattern 8..

session protocol sipv2

session target ipv4:10.200.200.50

incoming called-number .

dtmf-relay rtp-nte

codec g711ulaw

!

dial-peer voice 11 pots

destination-pattern 9.T

progress_ind setup enable 3

progress_ind alert enable 8

progress_ind progress enable 8

progress_ind connect enable 8

direct-inward-dial

port 0/3/0:15

!

!

!

!

gatekeeper

shutdown

!

Debug is

Sep  1 20:20:04.630: //41/8017470F1100/CCAPI/cc_api_get_transfer_info:

   Transfer Number Is Null

Sep  1 20:20:04.630: //41/8017470F1100/CCAPI/cc_api_call_disconnect_done:

   Disposition=0, Interface=0x3101F7A4, Tag=0x0, Call Id=41,

   Call Entry(Disconnect Cause=21, Voice Class Cause Code=0, Retry Count=0)

Sep  1 20:20:04.630: //41/8017470F1100/CCAPI/cc_api_call_disconnect_done:

   Call Disconnect Event Sent

Sep  1 20:20:04.630: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:

Sep  1 20:20:04.630: :cc_free_feature_vsa freeing 2B3F72C8

Sep  1 20:20:04.630: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:

Sep  1 20:20:04.630:  vsacount in free is 0

Sep  1 20:20:21.794: //-1/001669191200/CCAPI/cc_api_display_ie_subfields:

   cc_api_call_setup_ind_common:

   cisco-username=22270840

   ----- ccCallInfo IE subfields -----

   cisco-ani=22270840

   cisco-anitype=0

   cisco-aniplan=0

   cisco-anipi=0

   cisco-anisi=1

   dest=924950500

   cisco-desttype=0

   cisco-destplan=0

   cisco-rdie=FFFFFFFF

   cisco-rdn=

   cisco-rdntype=-1

   cisco-rdnplan=-1

   cisco-rdnpi=-1

   cisco-rdnsi=-1

   cisco-redirectreason=-1   fwd_final_type =0

   final_redirectNumber =

   hunt_group_timeout =0

Sep  1 20:20:21.794: //-1/001669191200/CCAPI/cc_api_call_setup_ind_common:

   Interface=0x3101F7A4, Call Info(

   Calling Number=22270840,(Calling Name=)(TON=Unknown, NPI=Unknown, Screening=User, Passed, Presentation=Allowed),

   Called Number=924950500(TON=Unknown, NPI=Unknown),

   Calling Translated=FALSE, Subscriber Type Str=Unknown, FinalDestinationFlag=TRUE,

   Incoming Dial-peer=10, Progress Indication=NULL(0), Calling IE Present=TRUE,

   Source Trkgrp Route Label=, Target Trkgrp Route Label=, CLID Transparent=FALSE), Call Id=42

Sep  1 20:20:21.794: //-1/001669191200/CCAPI/ccCheckClipClir:

   In: Calling Number=22270840(TON=Unknown, NPI=Unknown, Screening=User, Passed, Presentation=Allowed)

Sep  1 20:20:21.794: //-1/001669191200/CCAPI/ccCheckClipClir:

   Out: Calling Number=22270840(TON=Unknown, NPI=Unknown, Screening=User, Passed, Presentation=Allowed)

Sep  1 20:20:21.794: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

Sep  1 20:20:21.794: :cc_get_feature_vsa malloc success

Sep  1 20:20:21.794: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

Sep  1 20:20:21.794:  cc_get_feature_vsa count is 1

Sep  1 20:20:21.794: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

Sep  1 20:20:21.794: :FEATURE_VSA attributes are: feature_name:0,feature_time:725578448,feature_id:42

Sep  1 20:20:21.794: //42/001669191200/CCAPI/cc_api_call_setup_ind_common:

   Set Up Event Sent;

   Call Info(Calling Number=22270840(TON=Unknown, NPI=Unknown, Screening=User, Passed, Presentation=Allowed),

   Called Number=924950500(TON=Unknown, NPI=Unknown))

Sep  1 20:20:21.794: //42/001669191200/CCAPI/cc_process_call_setup_ind:

   Event=0x2B7C9F18

Sep  1 20:20:21.794: //-1/xxxxxxxxxxxx/CCAPI/cc_setupind_match_search:

   Try with the demoted called number 924950500

Sep  1 20:20:21.794: //42/001669191200/CCAPI/ccCallSetContext:

   Context=0x2ADBAE4C

Sep  1 20:20:21.794: //42/001669191200/CCAPI/cc_process_call_setup_ind:

   >>>>CCAPI handed cid 42 with tag 10 to app "_ManagedAppProcess_TOLLFRAUD_APP"

Sep  1 20:20:21.794: //42/001669191200/CCAPI/ccCallDisconnect:

   Cause Value=21, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=0)

Sep  1 20:20:21.794: //42/001669191200/CCAPI/ccCallDisconnect:

   Cause Value=21, Call Entry(Responsed=TRUE, Cause Value=21)

Sep  1 20:20:21.794: //42/001669191200/CCAPI/cc_api_get_transfer_info:

   Transfer Number Is Null

Sep  1 20:20:21.794: //42/001669191200/CCAPI/cc_api_call_disconnect_done:

   Disposition=0, Interface=0x3101F7A4, Tag=0x0, Call Id=42,

   Call Entry(Disconnect Cause=21, Voice Class Cause Code=0, Retry Count=0)

Sep  1 20:20:21.794: //42/001669191200/CCAPI/cc_api_call_disconnect_done:

   Call Disconnect Event Sent

Sep  1 20:20:21.794: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:

Sep  1 20:20:21.794: :cc_free_feature_vsa freeing 2B3F72C8

Sep  1 20:20:21.794: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:

thanks and regards

Cisco Employee

Re: SIP Trunk from Telco company

Hello Loay,

This disconnect is because of the tall fraud prevention.

Sep  1 20:20:21.794: //42/001669191200/CCAPI/cc_process_call_setup_ind:

   >>>>CCAPI handed cid 42 with tag 10 to app "_ManagedAppProcess_TOLLFRAUD_APP"

Sep  1 20:20:21.794: //42/001669191200/CCAPI/ccCallDisconnect:

   Cause Value=21, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=0)

Sep  1 20:20:21.794: //42/001669191200/CCAPI/ccCallDisconnect:

   Cause Value=21, Call Entry(Responsed=TRUE, Cause Value=21)

Sep  1 20:20:21.794: //42/001669191200/CCAPI/cc_api_get_transfer_info:

   Transfer Number Is Null

You may try adding the following:

voice service voip
 ip address trusted list
  ipv4 0.0.0.0 0.0.0.0

But it is good to fill with specific servers.

Please take a look at the following link about tall fraud prevention:

http://www.cisco.com/en/US/tech/tk652/tk90/technologies_tech_note09186a0080b3e123.shtml

HTH,

Alex

*Please rate helpful posts

Cisco Employee

Re: SIP Trunk from Telco company

Hello Loay,

Did the previous step help you?

Best regards,

Alex

918
Views
4
Helpful
7
Replies