Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Users might experience few discrepancies in Search results. We are working on this on our side. We apologize for the inconvenience it may have caused.
New Member

SIP Trunk - inbound calls

Dear Experts,

i have a problem in my lab (AS4500XM with CCM5 -10.100.252.10- and SIP trunk). the problem is:

when i make call from the PSTN to our internal number i can not receive any call but i can make call to the outbound ,and below you can see the gateway cofiguration :

------------------------------------------

ip cef

!

!

isdn switch-type primary-net5

!

!

voice service voip

fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback none

sip

bind control source-interface GigabitEthernet0/0

bind media source-interface GigabitEthernet0/0

!

!controller E1 7/0

pri-group timeslots 1-31

!

controller E1 7/1

pri-group timeslots 1-31

!

controller E1 7/2

pri-group timeslots 1-31

!

controller E1 7/3

!

controller E1 7/4

!

controller E1 7/5

!

interface GigabitEthernet0/0

ip address 10.100.252.120 255.255.255.0

duplex auto

speed auto

negotiation auto

!

!

interface Serial7/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

no cdp enable

!

interface Serial7/1:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice modem

no cdp enable

!

interface Serial7/2:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice modem

no cdp enable

!

ip default-gateway 10.100.252.1

!

no ip http server

!

!

!

!

!

control-plane

!

!

!

voice-port 7/0:D

!

voice-port 7/1:D

!

voice-port 7/2:D

!

!

!

dial-peer voice 1 pots

destination-pattern 9T

port 7/1:D

!

dial-peer voice 2 voip

destination-pattern 2T

session protocol sipv2

session target ipv4:10.100.252.10

dtmf-relay rtp-nte h245-signal h245-alphanumeric

codec g711ulaw

!

!

!

-------------------------------------

Thanks all

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Gold

Re: SIP Trunk - inbound calls

Ok, add "incoming called-number ." and "direct-inward-dial" under DP 1. What you're hearing is router dialtone.

Likely you will also need "isdn overlap-receiving" under serial interface.

Then make sure that telco is sending the same number as extensions, else you will need translations.

As an appreciation to those providing naswers, please rate useful posts with the scrollbox below!

9 REPLIES
Hall of Fame Super Gold

Re: SIP Trunk - inbound calls

Hi, try configuring "incoming called-number ." under DP 2.

Then if still trouble collect "debug ccsip message" with "term mon".

Hope this helps, please rate post if it does!

New Member

Re: SIP Trunk - inbound calls

Thanks

i tried "incoming called-number " with no benefit's

and no messages from "debug ccsip message " also with terminal mon.

what can i do to solve it ?

Hall of Fame Super Gold

Re: SIP Trunk - inbound calls

Hi, if you don't seen any sip message on the router, it means the CM does not send the call, and you should configure it to do so. Unfortunately I cannot help you with the CM configuration.

New Member

Re: SIP Trunk - inbound calls

okay, but in the fact i can send call from any phone (Cisco IP-Phone) from the company.

but the problem is when i try to make call from any PSTN number or mobile to our internal phones. and i can see the calls on the gateway when i use ISDN layer 3 debug .

Hall of Fame Super Gold

Re: SIP Trunk - inbound calls

Ok, and which called number do you seen in ISDN? Currently you have configured only numbers beginning with 2 to be sent to CM.

New Member

Re: SIP Trunk - inbound calls

yes ,,, all internal numbers beginning with 2.

but no call go to internals

and i can hear some voice like modem

Hall of Fame Super Gold

Re: SIP Trunk - inbound calls

Ok, add "incoming called-number ." and "direct-inward-dial" under DP 1. What you're hearing is router dialtone.

Likely you will also need "isdn overlap-receiving" under serial interface.

Then make sure that telco is sending the same number as extensions, else you will need translations.

As an appreciation to those providing naswers, please rate useful posts with the scrollbox below!

New Member

Re: SIP Trunk - inbound calls

Thanks you very much

Hall of Fame Super Gold

Re: SIP Trunk - inbound calls

You are welcome, thanks for the appreciation and good luck!

175
Views
0
Helpful
9
Replies
CreatePlease to create content