Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

SIP trunk not registering on voice gateway

Hi guys, a bit stuck on this one. I have a voice gateway which is SIP to CUCM and has both an E1 and SIP trunk.

CUCM ----- SIP Trunk ---  Gig0/0  --> Voice Gateway ---- Serial 0/0/0:15 ----> E1 PRI

                                                                                                                  |___   Gig0/2  __> SIP

 

I have configured the calling on the PRI and all works correctly, but can't seem to get the SIP to work. The provider is from South Africa and provided a username and password for me to use, as well as specifying a network range. I have one end of the range set on the router and can ping across the interface, but I am getting the following from debug sip-ua register status:

 

#sho sip-ua register status    
Line                             peer       expires(sec) reg survival P-Associ-URI
================================ ========== ============ === ======== ============
27XXXXXXXXXX                     -1         153          no  normal 

 

My config is as follows:

 

!
isdn switch-type primary-net5
!
voice-card 0
 dspfarm
 dsp services dspfarm
!
!
no voice hunt unassigned-number
no voice hunt invalid-number
voice rtp send-recv
!
voice service voip
 ip address trusted list
  ipv4 10.60.13.30
  ipv4 10.82.13.31
  ipv4 172.18.0.1
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
 h323
 modem passthrough nse codec g711ulaw
 sip
  bind control source-interface GigabitEthernet0/0 <---- I'm not sure if this is correct. Should this be GI0/2?
  bind media source-interface GigabitEthernet0/0
  registrar server expires max 600 min 60
  early-offer forced
  midcall-signaling passthru
!
voice class codec 1
 codec preference 1 g711alaw
 codec preference 2 g711ulaw
 codec preference 3 g729r8
!
!
voice register global
 mode srst
 system message CM Fallback Service Operating
 max-dn 300
 max-pool 58
!
voice register pool  58
 id network 10.0.0.0 mask 255.0.0.0
 preference 2
 incoming called-number
 no digit collect kpml
 dtmf-relay rtp-nte cisco-rtp sip-notify
 voice-class codec 1
 no vad
!
!
!
voice translation-rule 1
 rule 1 /^\(.*\)/ /9\1/ type subscriber subscriber
 rule 2 /^\(.*\)/ /90\1/ type national national
 rule 3 /^\(.*\)/ /900\1/ type international international
!
voice translation-rule 2
 rule 1 /^6...$/ /0XX\0/
 rule 2 /^7...$/ /0XX\0/
!
voice translation-rule 3
 rule 1 /^6...$/ /+27XX\0/
 rule 2 /^7...$/ /+27XX\0/
 rule 3 /^9\(.*\)/ /\1/
!
!
voice translation-profile INBOUND
 translate calling 1
 translate called 2
!
voice translation-profile OUTBOUND
 translate called 3
!
!
redundancy
!
!
controller E1 0/0/0
 pri-group timeslots 1-31
!
interface GigabitEthernet0/0
 description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$
 ip address 10.38.20.251 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 description SIP PSTN
 ip address 172.18.0.5 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0/0:15
 no ip address
 encapsulation hdlc
 isdn switch-type primary-net5
 isdn overlap-receiving
 isdn incoming-voice voice
 isdn send-alerting
 isdn bchan-number-order ascending
 isdn sending-complete
 no cdp enable
!
!
ip route 0.0.0.0 0.0.0.0 10.38.20.201
ip route 172.18.0.0 255.255.0.0 172.18.0.1
!
!

!
voice-port 0/0/0:15
 translation-profile incoming INBOUND
 cptone ZA
!
voice-port 0/1/0
!
voice-port 0/1/1
 !
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
sccp local GigabitEthernet0/0
sccp ccm 10.82.13.31 identifier 2 version 7.0
sccp ccm 10.60.13.30 identifier 1 version 7.0
sccp
!
sccp ccm group 1
 associate ccm 1 priority 1
 associate ccm 2 priority 2
 associate profile 1 register CFB
 associate profile 2 register XCODE
 switchback method graceful
!
dspfarm profile 2 transcode  
 codec g729r8
 codec g711ulaw
 codec g711alaw
 codec g729ar8
 codec g729abr8
 maximum sessions 2
 associate application SCCP
!
dspfarm profile 1 conference  
 codec g711ulaw
 codec g711alaw
 codec g729ar8
 codec g729abr8
 codec g729r8
 codec g729br8
 maximum sessions 2
 associate application SCCP
!
!
dial-peer voice 1001 voip
 incoming called-number 27XXXXXXXXX
!
dial-peer voice 1000 voip
 description TO SA SIP PSTN
 translation-profile outgoing SIP_DDI_TRANSLATE_OUTBOUND
 preference 1
 destination-pattern 0T
 session protocol sipv2
 session target sip-server
 voice-class codec 1  
 dtmf-relay rtp-nte
 fax-relay ecm disable
 fax protocol t38 version 0 ls-redundancy 5 hs-redundancy 2 fallback pass-through g711ulaw
 no vad
!
dial-peer voice 3001 voip
 destination-pattern 0XXXX....
 session protocol sipv2
 session target ipv4:10.60.13.30
 voice-class codec 1  
 dtmf-relay rtp-nte
 fax-relay ecm disable
 fax protocol t38 version 0 ls-redundancy 5 hs-redundancy 2 fallback pass-through g711ulaw
 no vad
!
dial-peer voice 3002 voip
 preference 1
 destination-pattern 0XXXX....
 session protocol sipv2
 session target ipv4:10.82.13.31
 voice-class codec 1  
 dtmf-relay rtp-nte
 fax-relay ecm disable
 fax protocol t38 version 0 ls-redundancy 5 hs-redundancy 2 fallback pass-through g711ulaw
 no vad
!
dial-peer voice 100 pots
 incoming called-number .
 direct-inward-dial
 no sip-register
!
dial-peer voice 101 pots
 description Emergency 10111
 destination-pattern 10111
 port 0/0/0:15
 forward-digits 5
 no sip-register
!
dial-peer voice 102 pots
 description Emergency 910111
 destination-pattern 910111
 port 0/0/0:15
 forward-digits 5
 no sip-register
!
dial-peer voice 103 pots
 description Emergency 9112
 destination-pattern 9112
 port 0/0/0:15
 forward-digits 3
 no sip-register
!
dial-peer voice 104 pots
 description Emergency 112
 destination-pattern 112
 port 0/0/0:15
 forward-digits 3
 no sip-register
!
dial-peer voice 105 pots
 description Outgoing SRST 9T
 translation-profile outgoing OUTBOUND
 destination-pattern 9T
 port 0/0/0:15
 no sip-register
!
dial-peer voice 106 pots
 description Outgoing
 destination-pattern 0T
 port 0/0/0:15
 forward-digits all
 no sip-register
!
dial-peer voice 107 pots
 description Fax 011 996 6610
 destination-pattern 0119966610
 port 0/1/0
 no sip-register
!
sip-ua
 credentials username 27XXXXXXXXX password 7 14270A5A0F0078 realm sip-x01.trc.sadv.co.za
 authentication username 27XXXXXXXXX password 7 02361C0A08025D realm sip-x01.trc.sadv.co.za
 retry invite 2
 retry bye 2
 retry cancel 2
 registrar dns:sip-x01.trc.sadv.co.za expires 3600
 sip-server dns:sip-x01.trc.sadv.co.za
!
!
!
gatekeeper
 shutdown
!
!
call-manager-fallback
 secondary-dialtone 0
 max-conferences 20 gain -6
 transfer-system full-consult
 timeouts interdigit 4
 timeouts ringing 20
 ip source-address 10.38.20.251 port 2000
 max-ephones 110
 max-dn 400
 system message primary CM Fallback Service Operating
 transfer-pattern .T
 keepalive 20
 no huntstop
 mwi relay
 moh "music-on-hold.au"
 multicast moh 239.1.1.1 port 16384
 time-zone 29
 time-format 24
 date-format dd-mm-yy
!

 

When I make incoming calls to the SIP, I get a busy tone and don't see anything coming into the gateway on the ccsip messages debug.

 

Thanks

Sean

4 REPLIES
VIP Super Bronze

Its not all providers that

Its not all providers that require registrations, so I wont worry about the registration status just yet. If you cant see the call hitting your gateway at all, then that's a different problem. You need to involve your ITSP on why they are sending calls to you

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
Bronze

One other thing you are

One other thing you are pointing to a SIP server via DNS:
dns:sip-x01.trc.sadv.co.za

But I don't see a DNS server in your configuration, add:
ip name-server 8.8.8.8
(Google DNS)

Also as other have suggested are you sure you have connectivity to your ITSP?

Run a 'debug ccsip message' and try and call from the PSTN, if you don't see a load of SIP message then you need to check your connectivity.

Hope that helps!

Cisco Employee

Hi Sean,Your sip registrar

Hi Sean,

Your sip registrar configuration seems ok. Like Ayodeji said in his post, if you can't see sip messages coming to your gateway, then you need to involve the provider.

A packet capture on the gateway's gig0/2 interface should reveal more whether any messages are coming to the gateway on that interface.

You have bound sip to the gig0/0 interface. Sometimes providers, want the source address of messages to them to contain the IP address that they recognize, which means you would need to bind gig0/2 for sip and not gig0/0. This can lead to call issues.

 

Also do you see the router sending any register messages to the ITSP on the debug ccsip messages?

 

Thanks

Sreekanth

It looks like you only have

It looks like you only have private IP addresses on this box.  That may be a problem with getting the registration to work.  What's the full topology heading from this box to the internet?  You may need to enable/disable SIP inspection at the edge.

2181
Views
0
Helpful
4
Replies
CreatePlease to create content