Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Users might experience few discrepancies in Search results. We are working on this on our side. We apologize for the inconvenience it may have caused.
New Member

SIP Trunk on CUCM 8.6.2

Hi,

I'm trying to stablish a trunk connection from CUCM 8.6.2 Cluster to a Third party device for cloud based contact centre.

the client proivded their info and has asked me to configure media IP address on SIP trunk as well. But I can not find any option for that.

Can someone please advise?

Regards,                   

1 ACCEPTED SOLUTION

Accepted Solutions

Re: SIP Trunk on CUCM 8.6.2

Hi Kami

Are you able to ping your ISP and vice versa? Check in you firewall if there any RTP traffic going in both directions.

Also confirm if your MTP/XCODE are registered

Cheers
Bruno Rangel

Please remember to rate helpful  responses using the stars bellow and identify helpful or correct answers .

Cheers Bruno Rangel Please remember to rate helpful responses using the stars bellow and identify helpful or correct answers .
13 REPLIES

SIP Trunk on CUCM 8.6.2

Hi kamin,

Are you using CUBE?

With help of CUBE you can bind your media IP address by two ways:

1). Globally

voice serice voip

sip

bind media source interface interface-id

exit

2). At dial-peer level

dial-peer voice XXXX voip

session target ipv4:XXX.XXX.XXX.XXX

session protocol sipv2

voice-class sip

bind media source interface interface-id

exit

Regards,

Nishant Savalia

Regards, Nishant Savalia
Bronze

SIP Trunk on CUCM 8.6.2

Adding to what Nishant said, if you're not using CUBE for a 3rd party SIP trunk to CUCM, you should.  CUBE as your SIP edge in the environment offers you a multitude of options for directing traffic that CUCM doesn't handle natively, on top of the major benefits around security.

New Member

Re: SIP Trunk on CUCM 8.6.2

I've configured a 2921 as a cube for SIP trunk edge.

now I can recieve call but we dont have 2way audio and cant here eachother. They still asking me to configure media IP's in my side.

Media IP's are different from sip trnk termination IP.

Called number from third party is +19992430401 which will be translated to 960 and will be sent to CUCM (10.125.98.243)

Caonfiguration attached.     

Bronze

Re: SIP Trunk on CUCM 8.6.2

Can you provide the messaging for a test call with the failed media?

debug ccsip messages

Reproduce the failed call, and output the log as an attachment.  I'm betting the CUBE is sending

Since your CUBE is behind a NAT, that NAT needs to be aware of SIP and needs to modify the SDP in order for media to work properly.  Media addresses in the SDP would use the CUBE's IP by default, and since you're not modifying any of the SDP/headers in the config, they are being instructed to send media to 10.125.32.107.  Unless you have a dedicated private link to that carrier, that won't work.  I doubted it was a dedicated link since your router is private IP but the carrier is public IP.

New Member

Re: SIP Trunk on CUCM 8.6.2

10.125.32.107 is cube private IP which is translated to a public IP oin Firewall. The third party has defined this public IP as SIP termination point in their side.

Trying to place a trst call and send you the log as well.

Thanks.

New Member

Re: SIP Trunk on CUCM 8.6.2

SIP log attached

Bronze

Re: SIP Trunk on CUCM 8.6.2

So you said there's a firewall between the carrier and your CUBE.  Is that firewall set up to transform SIP messaging traffic?  If not, that's your issue.  SIP media is not handled at layer 3, it's handled at a higher layer.  Many firewall vendors support "SIP transformation" as part of their NAT enablement.  This transformation would be want turns your CUBE's internal IP into 118.127.70.123 as part of the negotiation/INVITE process.  The carrier is asking you for media IP's because they are probably seeing your INVITE packets coming to them with 10.125.32.107 (unreachable to them) instead of 118.127.70.123 (I'm assuming this is the IP that is NAT'd to your CUBE).

I also see in your log that the call flow isn't indicative of traffic flowing properly (again, that NAT).

Here's what I see

  1. Inbound INVITE from them
  2. You sent TRYING
  3. You send RINGING
  4. They send another INVITE (you'd probably see this if they didn't get the reply TRYING or a 200 OK from you)
  5. Seems to keep looping 2-4 from there, with your device retrying the RINGING, and their device retrying the INVITE

When you use the bind statement to tie your signaling and media traffic to teh port channel's IP address, that firewall needs to be intelligent enough to translate that IP in the SDP message your router responds to their INVITE with, from internal IP to extenal IP.  You're getting the initial INVITE because that firewall is probably configured as a dumb layer 3 NAT, and it's taking the inbound traffic and handing it to the CUBE.  SIP's intelligence isn't at layer 3, so that firewall needs to do a bit more than simple NAT.

We had the same issues when initially setting up this exact environment, albeit with a different provider than you.  That firewall supported the SIP transformations, so once they were enabled, we were good to go.

New Member

Re: SIP Trunk on CUCM 8.6.2

I've enbaled sip transformation on firewall but still have the same issue.

Caller give me a call . ican hear the ring and see the caller ID. but caller says the call rejects and he can see the phone is ringing. but in my side the phone rings out.

Re: SIP Trunk on CUCM 8.6.2

Hi Kamin,

Please ask your service provider that whether they are receiving 100 trying / 180 ringing messgae in reponse to the INVITE message they sent.

Is this happening with outgoing call as well? If yes, then please share logs for outgoing call as well.

Also do share your connectivity topology i.e. how you and ISP are connected to and from CUBE?

  • ISP connects to which IP address?
  • CUBE is connected to which IP address for connectivity with ISP?

Regards,
Nishant Savalia

Regards, Nishant Savalia
New Member

Re: SIP Trunk on CUCM 8.6.2

Hi Kamin,

You set the command no IP address trusted list in router?

Regards,

Bruno

New Member

Re: SIP Trunk on CUCM 8.6.2

no,

I trusted sip trunk termination ip.

please refer to configuration attached to this discussion.

New Member

Re: SIP Trunk on CUCM 8.6.2

Sorry, the commando that I used was no IP address trusted authentication.

Below is the full configuration:

sh    term le 0

Voice_Gateway#sh run

Building configuration...

Current configuration : 9753 bytes

!

! Last configuration change at 11:13:11 BR Wed Feb 12 2014

! NVRAM config last updated at 13:10:33 BR Wed Feb 12 2014

! NVRAM config last updated at 13:10:33 BR Wed Feb 12 2014

version 15.2

service tcp-keepalives-in

service tcp-keepalives-out

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname Voice_Gateway

!

boot-start-marker

boot config flash0:startup_config_1

boot-end-marker

!

!

! card type command needed for slot/vwic-slot 0/0

logging buffered 10000000

no logging console

enable secret 4 tnhtc92DXBhelxjYk8LWJrPV36S2i4ntXrpb4RFmfqY

enable password 7 13061E010803

!

no aaa new-model

clock timezone BR -2 0

!

ip cef

!

ip traffic-export profile TAC mode capture

  bidirectional

!

!

!

ip dhcp relay information option

ip dhcp excluded-address 192.168.12.1

ip dhcp excluded-address 192.168.13.1

ip dhcp excluded-address 192.168.15.1 192.168.15.10

ip dhcp excluded-address 192.168.15.250 192.168.15.254

ip dhcp excluded-address 192.168.15.1

!

ip dhcp pool VOICE_SCOPE

network 192.168.12.0 255.255.255.0

default-router 192.168.12.1

option 150 ip 192.168.12.1

lease infinite

!

ip dhcp pool Dados

network 192.168.13.0 255.255.255.0

default-router 192.168.13.1

!

ip dhcp pool VOICE

network 192.168.15.0 255.255.255.0

default-router 192.168.15.1

option 150 ip 192.168.15.1

!

ip dhcp pool voz

!

!

!

ip domain name cisco.com

no ipv6 cef

multilink bundle-name authenticated

!

!

!

!

!

!

!

voice-card 0

dspfarm

dsp services dspfarm

!

!

voice call carrier capacity active

!

voice service voip

no ip address trusted authenticate

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

no supplementary-service h450.2

no supplementary-service h450.3

no supplementary-service sip moved-temporarily

redirect ip2ip

fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none

h323

sip

  bind control source-interface GigabitEthernet0/0.15

  bind media source-interface GigabitEthernet0/0.15

  registrar server expires max 600 min 60

  no call service stop

!

voice class codec 1

codec preference 1 g711ulaw

codec preference 2 g711alaw

codec preference 3 g729r8

codec preference 4 g729br8

!

voice class codec 2

codec preference 1 g711ulaw

codec preference 2 g729r8

!

voice class h323 1

  call start slow

!

!

voice register global

mode cme

source-address 192.168.15.1 port 5060

max-dn 30

max-pool 30

load 9971 sip9971.9-4-1-9.loads

load 8941 sip8961.9-2-2SR1-9.loads

authenticate register

authenticate realm cisco.com

timezone 17

dialplan-pattern 1 3... extension-length 4

dialplan-pattern 2 1... extension-length 4

dialplan-pattern 3 2... extension-length 4

tftp-path flash:

create profile sync 0351135690512337

camera

video

!

voice register dn  1

number 5501

allow watch

name teste

label teste

!

voice register dn  2

number 2020

allow watch

name Show Room

label Show Room

!

voice register dn  3

number 2070

allow watch

name Show Room

label Show Room

!

voice register dn  5

number 3001

allow watch

name SIP

label SIP

!

voice register dialplan 1

type 7940-7960-others

pattern 1 3...

pattern 2 1...

pattern 3 2...

!

voice register pool  1

id mac 189C.5DB6.659D

type 9971

number 1 dn 1

dialplan 1

dtmf-relay rtp-nte

username 123456 password 123456

codec g711ulaw

no vad

!

voice register pool  2

id mac DCA5.F487.5ACC

type 8961

number 1 dn 2

username 2020 password 12345

codec g711ulaw

!

voice register pool  3

id mac 0004.F2BE.9054

number 1 dn 3

username 2070 password 2070

!

voice register pool  5

id mac 0000.0000.0000

number 1 dn 5

dtmf-relay rtp-nte

username 3001 password 12345

codec g711ulaw

no vad

!

!

!

!

!

license udi pid CISCO2901/K9 sn FTX173285AK

hw-module pvdm 0/0

!

hw-module pvdm 0/1

!

!

!

username admin privilege 15 secret 4 eaOP83n/Avy2EAs2tg7JbhLCX5T8h39E3GwBeTDW5sY

username cisco password 7 094F471A1A0A

username 2020 password 7 04095B545F

!

redundancy

!

!

!

!

!

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

no ip address

duplex auto

speed auto

!

interface GigabitEthernet0/0.1

encapsulation dot1Q 1 native

ip address 192.168.1.2 255.255.255.0

!

interface GigabitEthernet0/0.12

encapsulation dot1Q 12

ip address 192.168.12.1 255.255.255.0

!

interface GigabitEthernet0/0.15

encapsulation dot1Q 15

ip address 192.168.15.1 255.255.255.0

h323-gateway voip interface

h323-gateway voip bind srcaddr 192.168.15.1

!

interface GigabitEthernet0/1

ip address 192.168.2.1 255.255.255.0

duplex auto

speed auto

!

interface GigabitEthernet0/1.18

encapsulation dot1Q 1 native

ip address 192.168.18.2 255.255.255.0

!

interface GigabitEthernet0/1.30

encapsulation dot1Q 30

ip address 192.168.13.1 255.255.255.0

ip helper-address 192.168.13.1

!

ip default-gateway 192.168.15.254

ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

ip route 0.0.0.0 0.0.0.0 192.168.1.254

!

ip access-list extended IP_CALLS

permit ip host 192.168.12.1 host 192.168.1.5

!

!

!

tftp-server flash:cmterm-894x-sccp.9-2-2-0.cop.sgn

tftp-server flash:BOOT894x.0-0-0-9.bin.sgn

tftp-server flash:SCCP894x.9-2-2-0.bin1.sgn

tftp-server flash:SCCP894x.9-2-2-0.bin2.sgn

tftp-server flash:SCCP894x.9-2-2-0.bin3.sgn

tftp-server flash:SCCP894x.9-2-2-0.bin4.sgn

tftp-server flash:SCCP894x.9-2-2-0.bin5.sgn

tftp-server flash:SCCP894x.9-2-2-0.bin6.sgn

tftp-server flash:SCCP894x.9-2-2-0.bin7.sgn

tftp-server flash:SCCP894x.9-2-2-0.bin8.sgn

tftp-server flash:SCCP894x.9-2-2-0.loads

tftp-server flash:cmterm-8961.9-2-2SR1-9.cop.sgn

tftp-server flash:dkern8961.100609R2-9-2-2SR1-9.sebn

tftp-server flash:kern8961.9-2-2SR1-9.sebn

tftp-server flash:rootfs8961.9-2-2SR1-9.sebn

tftp-server flash:sboot8961.031610R1-9-2-2SR1-9.sebn

tftp-server flash:sip8961.9-2-2SR1-9.loads

tftp-server flash:skern8961.022809R2-9-2-2SR1-9.sebn

tftp-server flash:dkern9971.100609R2-9-4-1-9.sebn alias dkern9971.100609R2-9-4-1-9.sebn

tftp-server flash:kern9971.9-4-1-9.sebn alias kern9971.9-4-1-9.sebn

tftp-server flash:rootfs9971.9-4-1-9.sebn alias rootfs9971.9-4-1-9.sebn

tftp-server flash:sboot9971.031610R1-9-4-1-9.sebn alias sboot9971.031610R1-9-4-1-9.sebn

tftp-server flash:sip9971.9-4-1-9.loads alias sip9971.9-4-1-9.loads

tftp-server flash:skern9971.022809R2-9-4-1-9.sebn alias skern9971.022809R2-9-4-1-9.sebn

!

control-plane

!

!

!

!

!

!

!

mgcp profile default

!

sccp local GigabitEthernet0/0.15

sccp ccm 192.168.15.20 identifier 1 version 7.0

!

sccp ccm group 1

bind interface GigabitEthernet0/0.15

associate ccm 1 priority 1

associate profile 1 register Trans_CUCM

!

dspfarm profile 1 transcode universal 

codec ilbc

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

maximum sessions 10

associate application SCCP

!

dial-peer voice 10 voip

description ************ Calls to Avaya - SIP

shutdown

destination-pattern 10..

session protocol sipv2

session target ipv4:192.168.1.5

session transport tcp

voice-class codec 1 

dtmf-relay rtp-nte

no vad

!

dial-peer voice 11 voip

description ************ Calls to Avaya - H323

destination-pattern 1054

session target ipv4:192.168.1.5

dtmf-relay h245-alphanumeric

codec g711ulaw

no vad

!

dial-peer voice 50 voip

description ************ Calls to SIP

destination-pattern 2...

session protocol sipv2

session target ipv4:192.168.15.1

session transport tcp

voice-class codec 1 

dtmf-relay rtp-nte

no vad

!

dial-peer voice 1 voip

description ************ Calls to Escritorio BH

destination-pattern 200.

session target ipv4:192.168.33.33

voice-class codec 1 

dtmf-relay h245-alphanumeric

!

dial-peer voice 100 voip

description ************ TESTE SIP

destination-pattern 2020

session protocol sipv2

session target ipv4:192.168.15.1

voice-class codec 1 

dtmf-relay rtp-nte

!

dial-peer voice 102 voip

description ************ TESTE SIP

destination-pattern 3001

session protocol sipv2

session target ipv4:192.168.15.1

voice-class codec 1 

dtmf-relay rtp-nte

!

dial-peer voice 101 voip

description ************ TESTE SIP

destination-pattern 1...

session protocol sipv2

session target ipv4:192.168.15.10

voice-class codec 1 

dtmf-relay rtp-nte sip-notify

!

dial-peer voice 1001 voip

incoming called-number .

voice-class codec 1 

!

!

sip-ua

retry invite 5

retry response 10

registrar ipv4:192.168.15.10 expires 3600

sip-server ipv4:192.168.15.10

!

!

!

gatekeeper

shutdown

!

!

telephony-service

em keep-history

max-ephones 30

max-dn 30

ip source-address 192.168.15.1 port 2000

service local-directory authenticate

service dss

system message Laboratorio CME

load 8941 SCCP894x.9-2-2-0

time-zone 17

time-format 24

date-format dd-mm-yy

max-conferences 12 gain -6

web admin system name bruno password bruno

dn-webedit

time-webedit

transfer-system full-consult

transfer-pattern .T

create cnf-files version-stamp 7960 Feb 11 2014 14:08:17

!

!

ephone-dn  1

number 3000

label Bruno Falco

name Bruno Falco

!

!

ephone-dn  2

number 8880

label karina

name karina

!

!

ephone-dn  3

number 3001

label Noronha

name Noronha

!

!

ephone  1

mac-address AAAA.AAAA.AAAA

type CIPC

button  1:1 2:2

!

!

!

ephone  2

mac-address BBBB.BBBB.BBBB

type CIPC

button  1:2

!

!

!

ephone  3

mac-address E411.5B53.FFB1

type CIPC

button  1:3

!

!

!

ephone  5

!

!

!

!

line con 0

password 7 01100F175804

line aux 0

line 2

no activation-character

no exec

transport preferred none

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

stopbits 1

line vty 0 4

password 7 104D000A0618

login

transport input all

line vty 5 15

login local

transport input all

!

scheduler allocate 20000 1000

ntp master 1

ntp server 192.168.1.40

ntp server 192.168.15.1

ntp server 192.168.1.2

!

end


Re: SIP Trunk on CUCM 8.6.2

Hi Kami

Are you able to ping your ISP and vice versa? Check in you firewall if there any RTP traffic going in both directions.

Also confirm if your MTP/XCODE are registered

Cheers
Bruno Rangel

Please remember to rate helpful  responses using the stars bellow and identify helpful or correct answers .

Cheers Bruno Rangel Please remember to rate helpful responses using the stars bellow and identify helpful or correct answers .
1227
Views
19
Helpful
13
Replies
CreatePlease to create content