Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Sip trunk problem – add “0”

Hi,

 

How to add extra „0“ on sip trunk for outgoing call (called number).

I try this but that didn’t work?

I created new called party transformation pattern (pattern ! – to match all calls and add prefix digits 0)-> add it to partition-> add it to CSS. Then i go to sip trunk and on outbound calls add called party transformation css, and uncheck use device pool called party transformation CSS.

Save, restart trunk several times but it is not working.

 

 

I know I can do this also this way: add on Route List Member Information ->Called Party Transformations -> add 0 Prefix Digits

Or

On Route patterns -> add 0 on Prefix Digits

 

But that does not solve my problem, because outgoing call is send to group ( 2 SIP trunks from different providers) I just want extra 0 on single trunk.

Any advice?

Regards,

Ivan

1 ACCEPTED SOLUTION

Accepted Solutions

Try putting the trunks in

Try putting the trunks in different Route Groups and add these to the same Route List.

Within the Route List config you can set prefix digits for individual Route Groups

HTH

12 REPLIES

Try putting the trunks in

Try putting the trunks in different Route Groups and add these to the same Route List.

Within the Route List config you can set prefix digits for individual Route Groups

HTH

New Member

I did try what you suggest me

I did try what you suggest me but I have strange issue. When I add "0" on Route List Member Information -> Called Party Transformations -> Prefix Digits (Outgoing Calls) I am unable to make calls.

I have try several times to change restart trunk but it still did not work.

 

When I add 0 on route pattern -> Called Party Transformations -> Prefix Digits (Outgoing Calls) I am able to make calls. (But that does not solve my problem) 

VIP Super Bronze

What type of numbering plan

What type of numbering plan are you using? Did you select anything under the discard digit instruction? Often times when you select the wrong setting here, you experience call failures.

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
New Member

check attachment :-)

check attachment :-)

VIP Super Bronze

OK..That looks okay. All we

OK..That looks okay. All we can do now is to look at cucm traces and see whats going on. Can you collect detailed cucm traces please? Include the calling and called number

NB: set the prefix on the RL, not the RP so we can get a better picture. Attach the logs here..Ensure that your cucm trace is set to detailed and before you send the file, check to ensure that the calling and called numbers are present

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
New Member

Ok, i did as you sugested. I

Ok, i did as you sugested. I make 3 calls first two with "0" on Route List Member Information -> Called Party Transformations -> Prefix Digits (Outgoing Calls),

 

and last 0 is on route pattern -> and call is ok.

Used numbers:

265900 on site -> 0915636231 (called number )

0 is for outside line

 

THX!

VIP Super Bronze

Hi,I have looked at your

Hi,

I have looked at your traces and it seem to me that you are dialling the wrong digits..

 

+++Here is the number that is dialled on your phone ( you used a redial here)

You dialled 00915636231++++


07/10/2014 17:38:32.707 CCM|StationInit: (0005427) EnblocCall calledParty=00915636231.|<CLID::StandAloneCluster><NID::10.1.8.12><CT::2,100,39,1.122733407><IP::10.11.4.4><DEV::SEPE840F2F84F87><LVL::State Transition><MASK::0020>

 

+++Then here cucm does the digit transformation and prefixes the 0 on the RL+++


07/10/2014 17:38:32.710 CCM|RouteListCdrc::createPartyTransformedCcSetupReqMsg - before DAapplyCdpnXform() preXformCdpn=00915636231 preTag=ACCESS-CODE:SUBSCRIBER prePos=0:0915636231 crCdpnMask= crPrefixDigit=0 crDDI=0|<CLID::StandAloneCluster><NID::10.1.8.12><CT::2,100,39,1.122733407><IP::10.11.4.4><DEV::SEPE840F2F84F87><LVL::Detailed><MASK::0800>
07/10/2014 17:38:32.710 CCM|RouteListCdrc::createPartyTransformedCcSetupReqMsg - after  DAapplyCdpnXform() xformCdpn=000915636231 xformTag=ACCESS-CODE:SUBSCRIBER xformPos=0:0915636231 |<CLID::StandAloneCluster><NID::10.1.8.12><CT::2,100,39,1.122733407><IP::10.11.4.4><DEV::SEPE840F2F84F87><LVL::Detailed><MASK::0800>
07/10/2014 17:38:32.710 CCM|RouteListCdrc::createPartyTransformedCcSetupReqMsg CalledPattern=orgPattern, set orgCdpn =000915636231|<CLID::StandAloneCluster><NID::10.1.8.12><CT::2,100,39,1.122733407><IP::10.11.4.4><DEV::SEPE840F2F84F87><LVL::Detailed><MASK::0800>

+++++Now we see the INVITE that is sent out which includes three (0s) instead of two++++

07/10/2014 17:38:32.716 CCM|//SIP/SIPUdp/wait_SdlSPISignal: Outgoing SIP UDP message to 10.1.82.2:[5060]:
INVITE sip:000915636231@10.1.82.2:5060 SIP/2.0

 

+++This is the INVITE sent for the working call, NB it has only two (0s)+++

It looks like the transformation is not happening here even though you think it is++
07/10/2014 17:39:56.562 CCM|//SIP/SIPUdp/wait_SdlSPISignal: Outgoing SIP UDP message to 10.1.82.2:[5060]:
INVITE sip:00915636231@10.1.82.2:5060 SIP/2.0

 

So all you need to do is dial 0915636231 (just a single 0)

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
New Member

Hi, thank you very much for

Hi, thank you very much for your replay and time for debugging my calls.

I must dial 0 for outside call on CCM.

I finally solve it on RL-> discard digits I set CTNP:PreDot and then it start working!

 

THX!!

VIP Super Bronze

And you have selected the

And you have selected the correct call party xform css under the sip trunk?

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
New Member

i double check. the CCM is

i double check. the CCM is 

System version: 7.1.5.33900-10 mybe some bug?
VIP Gold

Hi Ivan,If you want to use '0

Hi Ivan,

If you want to use '0' as a access code only, then route pattern should be like 0.! and on the same page you need to select pre-dot under discard digit.

 

Suresh

New Member

it’s not that.  when I make

it’s not that.

 

when I make call, call is going on first trunk-> if the number don’t match -> than it goes on second trunk. (and on that trunk I need to send one extra 0 on Called Party Transformations -> Prefix Digits (Outgoing Calls)

102
Views
15
Helpful
12
Replies
CreatePlease login to create content