Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

SIP Trunk ring all phones

Hello,

Have posted a lot lately hopefully have not worn out my welcome!  Everyone here is very helpful and it's most appreciated. 

Last step in getting my CME configured is getting all the phones to ring on the second incoming call on my SIP trunk (and third, and fourth, and so on).  I have ephone-dn 82 configured and receiving calls, and all phones have this DN included on an overlay to button 6.  Callcentric allows me up to 2 incoming calls on the trunk, and I can purchase more if needed.

Here is the problem.  Call comes in on the trunk, all phones ring, one phone picks up, call is in session.  A second call placed to the same number appears on the screen of the phone that is on the first call, and it can be answered by hitting the Answer button, but none of the other phones ring at all.  I've tried configuring multiple instances of the ephone-dn 82 (83, 84, etc) and adding those to the overlay, but that doesn't work either.  What am I dong wrong?

sh config

Using 10065 out of 245752 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname GMIT-VOICEROUTER01

!

boot-start-marker

boot system flash c2800nm-adventerprisek9_ivs_li-mz.124-24.T6.bin

boot-end-marker

!

logging message-counter syslog

!

no aaa new-model

clock timezone boston -4

clock summer-time boston recurring

!

dot11 syslog

no ip source-route

!

!

--More--         ip cef

!

ip dhcp pool Voice

   network 172.16.2.0 255.255.255.0

   default-router 172.16.2.1

   dns-server 8.8.8.8 8.8.4.4

   option 150 ip 172.16.2.1

!

!

ip domain name domain

ip name-server 8.8.8.8

ip name-server 209.28.47.62

no ipv6 cef

!

multilink bundle-name authenticated

!

!

!

!

!

!

!

voice service voip

--More--          allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

no supplementary-service sip moved-temporarily

no supplementary-service sip refer

fax protocol cisco

sip

!

!

!

voice class codec 1

codec preference 1 g729r8

codec preference 2 g711ulaw

!

!

!

!

!

voice class sip-profiles 1

request INVITE sip-header From modify "<sip:(.*)@(.*)>" "<sip:17772882353@\2>"

!

!

--More--         !

!

!

!

!

!

!

!

voice translation-rule 3

rule 1 /^7../ /2072267262/

!

voice translation-rule 4

rule 1 /^1[2-9]..[2-9]....../ /\0/

rule 2 /^011\(.*\)/ /\1/

rule 3 /^[2-9]....../ /1207\0/

!

!

voice translation-profile SIP_1

translate calling 3

translate called 4

!

!

voice-card 0

--More--         !

!

!

!

!

username cisco privilege 15 password 7 1511021F0725

archive

log config

  hidekeys

!

!

!

!

!

!

!

!

!

interface Loopback0

description MANAGEMENT

ip address 172.16.254.4 255.255.255.255

--More--         !

interface FastEthernet0/0

ip address x.x.x.x x.x.x.x

ip nat outside

ip virtual-reassembly

duplex full

speed 100

no cdp enable

!

interface Service-Engine0/0

ip address 172.16.4.250 255.255.255.0

service-module ip address 172.16.4.251 255.255.255.0

service-module ip default-gateway 172.16.4.251

!

interface FastEthernet0/1

no ip address

duplex full

speed 100

!

interface FastEthernet0/1.10

encapsulation dot1Q 10 native

ip address 192.168.5.2 255.255.255.0

ip nat inside

--More--          ip virtual-reassembly

!

interface FastEthernet0/1.20

encapsulation dot1Q 20

ip address 172.16.3.1 255.255.255.0 secondary

ip address 172.16.2.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

router eigrp 100

redistribute static

passive-interface default

no passive-interface Service-Engine0/0

no passive-interface FastEthernet0/1

no passive-interface Loopback0

network 172.16.0.0

no auto-summary

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 24.39.49.185

ip http server

ip http authentication local

no ip http secure-server

--More--         ip http path flash:gui

!

!

ip nat inside source list 101 interface FastEthernet0/0 overload

!

access-list 101 permit ip 192.168.5.0 0.0.0.255 any

access-list 101 permit ip 172.16.0.0 0.0.255.255 any

nls resp-timeout 1

cpd cr-id 1

!

!

!

!

!

snmp-server community marvelous RO

tftp-server flash:OS79XX.TXT

tftp-server flash:P00307010200.bin

tftp-server flash:P00307010200.loads

tftp-server flash:P00307010200.sb2

tftp-server flash:P00307010200.sbn

tftp-server flash:TERM41.DEFAULT.loads

tftp-server flash:Jar41.2-9-1-45.sbn

tftp-server flash:cnu41.2-7-5-50.sbn

--More--         tftp-server flash:CVM41.2-0-1-45.sbn

!

control-plane

!

!

!

voice-port 0/0/0

!

voice-port 0/0/1

!

voice-port 0/1/0

ring number 2

connection plar opx 7001

description Connected to 207-764-1834

caller-id enable type 1

!

voice-port 0/1/1

shutdown

!

!

!

!

!

--More--         dial-peer voice 3 voip

description *** Voicemail Extension 7000 - Do not delete! ***

destination-pattern 7000

session protocol sipv2

session target ipv4:172.16.4.251

dtmf-relay sip-notify

codec g711ulaw

no vad

!

dial-peer voice 2000 voip

shutdown

destination-pattern 200.

session protocol sipv2

session target ipv4:172.16.4.251

dtmf-relay sip-notify

codec g711ulaw

!

dial-peer voice 700 voip

description SIP Trunk - Incoming

voice-class sip dtmf-relay force rtp-nte

session protocol sipv2

session target dns:callcentric.com

incoming called-number .%

--More--         !

dial-peer voice 701 voip

description SIP Trunk - Outgoing 3-Digit Calls

translation-profile outgoing SIP_1

preference 1

destination-pattern [2-8]11

voice-class codec 1

voice-class sip dtmf-relay force rtp-nte

session protocol sipv2

session target sip-server

dtmf-relay rtp-nte

!

dial-peer voice 702 voip

description SIP Trunk - Outgoing 11-Digit Calls

translation-profile outgoing SIP_1

preference 1

destination-pattern 1[2-9].........

voice-class sip dtmf-relay force rtp-nte

voice-class sip profiles 1

session protocol sipv2

session target sip-server

dtmf-relay rtp-nte

!

--More--         dial-peer voice 703 voip

description SIP Trunk - Outgoing 10-Digit Calls

translation-profile outgoing SIP_1

preference 1

destination-pattern [2-9]..[2-9]......

voice-class codec 1

voice-class sip dtmf-relay force rtp-nte

voice-class sip profiles 1

session protocol sipv2

session target sip-server

no vad

!

dial-peer voice 704 voip

description SIP Trunk - Outgoing 7-Digit Local Calls

translation-profile outgoing SIP_1

preference 1

destination-pattern [2-9]......

voice-class codec 1

voice-class sip dtmf-relay force rtp-nte

voice-class sip profiles 1

session protocol sipv2

session target sip-server

no vad

--More--         !

!

sip-ua

credentials username 17772882353 password 7 0728331F1D0714040519 realm callcentric.com

authentication username 17772882353 password 7 0728331F1D0714040519

no remote-party-id

retry invite 2

retry register 10

timers connect 100

mwi-server ipv4:172.16.4.251 expires 3600 port 5060 transport udp

registrar dns:callcentric.com expires 60

sip-server dns:callcentric.com

host-registrar

!

!

!

gatekeeper

shutdown

!

!

telephony-service

max-ephones 42

--More--          max-dn 100

ip source-address 172.16.3.1 port 2000

auto assign 1 to 10

system message Greenmark IT

url services http://phone-xml.berbee.com/menu.xml

load 7960-7940 P00307010200

voicemail 7000

mwi relay

max-conferences 8 gain -6

moh music-on-hold.au

web admin system name admin secret 5 $1$UfDD$ffCmnvpfJnT5NpJBgnDfk1

dn-webedit

transfer-system full-blind

transfer-pattern 1001

night-service weekday 17:00 07:30

night-service weekend 23:59 23:59

create cnf-files version-stamp 7960 Oct 13 2012 19:30:35

!

!

ephone-dn  1  dual-line

number 7010 no-reg both

description Eric Warren

name Eric

--More--          call-forward busy 7000

call-forward noan 7000 timeout 10

huntstop channel

no huntstop

mwi-type both

mwi sip

!

!

ephone-dn  2  dual-line

number 7011 no-reg both

description Jenn Edgecomb

name Jenn

call-forward busy 7000

call-forward noan 7000 timeout 10

huntstop channel

no huntstop

mwi-type both

mwi sip

!

!

ephone-dn  3  dual-line

number 7012 no-reg both

description Charly Chandler

--More--          name Charly

call-forward busy 7000

call-forward noan 7000 timeout 10

huntstop channel

no huntstop

mwi-type both

mwi sip

!

!

ephone-dn  4  dual-line

number 7013 no-reg both

description Tim Levesque

name Tim

call-forward busy 7000

call-forward noan 7000 timeout 10

huntstop channel

no huntstop

mwi-type both

mwi sip

!

!

ephone-dn  5  dual-line

number 7014 no-reg both

--More--          description Becky Blodgett

name Becky

call-forward busy 7000

call-forward noan 7000 timeout 10

huntstop channel

no huntstop

mwi-type both

mwi sip

!

!

ephone-dn  6  dual-line

number 7015 no-reg both

description Jessica Grigsby

name Jessica

call-forward busy 7000

call-forward noan 7000 timeout 10

huntstop channel

no huntstop

mwi-type both

mwi sip

!

!

ephone-dn  7  dual-line

--More--          number 7016 no-reg both

description Jon Kimball

name Jonathan

call-forward busy 7000

call-forward noan 7000 timeout 10

huntstop channel

no huntstop

mwi-type both

mwi sip

!

!

ephone-dn  8  dual-line

number 7017 no-reg both

description Tech Bench

name Tech Bench

huntstop channel

no huntstop

mwi-type both

!

!

ephone-dn  9  dual-line

number 7018 no-reg both

description Server Room

--More--          name Server Room

huntstop channel

no huntstop

mwi-type both

!

!

ephone-dn  10

call-forward busy 7000

call-forward noan 7000 timeout 10

!

!

ephone-dn  11

number 8000

mwi on

!

!

ephone-dn  12

number 8001

mwi off

!

!

ephone-dn  13  dual-line

number 7001

--More--          label 764-1834

name 764-1834

huntstop channel

!

!

ephone-dn  15

call-forward night-service 2000

night-service bell

!

!

ephone-dn  81  dual-line

number 12072267262 no-reg primary

label 226-7262

description Callcentric SIP Trunk DID 1

!

!

ephone-dn  82  dual-line

number 17772882353 no-reg primary

label 17772882353

description Callcentric SIP Trunk Public

!

!

ephone  1

--More--          device-security-mode none

mac-address 0019.E778.4559

type 7960

button  1:1 6o13,81,82

!

!

!

ephone  2

device-security-mode none

mac-address 000E.D76D.F67C

type 7960

button  1:2 6o13,81,82

!

!

!

ephone  3

device-security-mode none

mac-address 000E.D72E.46E0

type 7960

button  1:3 6o13,81,82

!

!

!

--More--         ephone  4

device-security-mode none

mac-address 000E.D76E.0192

type 7960

button  1:4 6o13,81,82

!

!

!

ephone  5

device-security-mode none

mac-address 000E.8461.296E

type 7960

button  1:5 6o13,81,82

!

!

!

ephone  6

device-security-mode none

mac-address 000E.D76E.019F

type 7960

button  1:6 6o13,81,82

!

!

--More--         !

ephone  7

device-security-mode none

mac-address 000D.BD40.7F37

type 7960

button  1:7 6o13,81,82

!

!

!

ephone  8

device-security-mode none

mac-address 0013.C472.847D

type 7960

button  1:8 6o13,81,82

!

!

!

ephone  9

device-security-mode none

mac-address 0007.5012.1B41

type 7960

button  1:9 6o13,81,82

!

--More--         !

!

line con 0

exec-timeout 0 0

logging synchronous

line aux 0

line 194

password 7 00071A150754

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

line vty 0 4

password 7 1511021F0725

logging synchronous

login local

transport input telnet ssh

line vty 5 15

password 7 00071A150754

logging synchronous

login local

transport input telnet ssh

--More--         !

scheduler allocate 20000 1000

end

GMIT-VOICEROUTER01#

  • IP Telephony
3 REPLIES

SIP Trunk ring all phones

Please add  "no huntstop & huntstop channel" to ephone-dn 82 and check.

//Suresh Please rate all the useful posts.
New Member

SIP Trunk ring all phones

Thanks for the reply sureshsub2.  That changed the behavior a little bit, now the second call to that line immediately gets a "party unavailable" message, as if the CME was reporting 486 busy.  The goal would be to have up to three incoming calls on that line at a time.

Silver

SIP Trunk ring all phones

So with sureshsub2's commands, you also need to configure another DN with the same number like this:

ephone-dn  83  dual-line

number 17772882353 no-reg primary

label 17772882353

description Callcentric SIP Trunk Public

preference 1

Then add DN 83 as an overlay on the same button as 82.

With dual-lines, the phone that answers the first call has exclusive access to the 2nd channel for transferring/conferencing/etc.  We use the "no huntstop command" to allow the system to hunt to another DN is that one has all the channels used up.  By using "huntstop channel" on DN 82, we tell it to mark that DN down for incoming calls once the first channel is being used.  This still allows the first phone that answered to use the 2nd channel for outgoing calls/transfers/conferencing but it will hunt to the next matching DN for incoming calls to that number.

524
Views
0
Helpful
3
Replies