Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

SIP Trunk - transcoder issue

Hi

I am using Cisco 2811 router to converge 2 RTP streams of different codes. I have scenario as below:

SIP PBX-------g729------>CISCO2811-------g711------>CUBE

I am using the universal transcoder, it does kick-in but no rtp gets established. Could some one please advise?

here is the config:

voice rtp send-recv

!

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

no supplementary-service h450.2

no supplementary-service h450.3

supplementary-service h450.12

fax protocol pass-through g711alaw

h323

  h225 h245-address on-connect

sip

  bind control source-interface FastEthernet0/1

  bind media source-interface FastEthernet0/1

!

!

!

voice class codec 10

!

voice class codec 100

codec preference 1 g729r8

codec preference 2 g729br8

codec preference 3 g711ulaw

codec preference 4 g711alaw

!

!

!

voice-card 0

dsp services dspfarm

!

!

interface FastEthernet0/0

ip address 62.215.x.x 255.255.255.248

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 10.50.1.42 255.255.255.252

ip nat inside

ip virtual-reassembly

duplex auto

speed auto

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 62.215.231.49

ip route 80.184.x.x 255.255.255.0 10.50.1.41

!

no ip http server

no ip http secure-server

!

ip nat sip-sbc

ip nat inside source list 2 interface FastEthernet0/0 overload

ip nat inside source static 10.50.1.42 62.215.x.x

!

access-list 2 permit any

access-list 100 permit ip any any log

!

!

sccp local FastEthernet0/1

sccp ccm 10.50.1.42 identifier 1 version 3.1

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

associate profile 110 register MTPNEW

!

dspfarm profile 110 transcode universal 

codec g729abr8

codec g711alaw

codec g729ar8

codec g729r8

codec g729br8

maximum sessions 12

associate application SCCP

!

!

dial-peer voice 10 voip

description ***Outgoing Calls to SIP Trunk***

destination-pattern .T

modem passthrough nse codec g711alaw

voice-class sip dtmf-relay force rtp-nte

session protocol sipv2

session target ipv4:80.184.2x.y

session transport udp

dtmf-relay rtp-nte

codec g711alaw

fax rate disable

fax protocol pass-through g711alaw

no vad

!

dial-peer voice 2 voip

translation-profile incoming inbound

voice-class codec 100

voice-class sip dtmf-relay force rtp-nte

session protocol sipv2

incoming called-number .

dtmf-relay rtp-nte

no vad

!

!

!

telephony-service

sdspfarm units 1

sdspfarm transcode sessions 128

sdspfarm tag 1 MTPNEW

max-ephones 1

max-dn 1

ip source-address 10.50.1.42 port 2000

max-conferences 8 gain -6

call-forward pattern .T

transfer-system full-consult

transfer-pattern .T

create cnf-files version-stamp Jan 01 2002 00:00:00

!

9 REPLIES
Cisco Employee

SIP Trunk - transcoder issue

So you mean the call drops or the link remains up but no voice flows ?

GP.

New Member

SIP Trunk - transcoder issue

Call gets established, I can see the transcoder session, rtp connections. But the audio is one way.

Cisco Employee

SIP Trunk - transcoder issue

aah, thanks. One way audio is mainly due to absense of required access route in both directions. Could you please verify that you have the routing in place for both directions, in 2811 ?

GP.

New Member

SIP Trunk - transcoder issue

Hi,

I got it working. Now I see that despite having enough DSP resources, no more then 16 calls are getting through. Is there any limitation or configurable parameter that would govern the number of calls on the SIP trunk?

-saif

Cisco Employee

SIP Trunk - transcoder issue

Saif,

But it seems the issue was different earlier ( as mentioned in original description ) ? Earlier, the calls were established but the audio was one-way. Was that fixed & above was a new issue ( i.e. more than 16 calls not getting established ) ?

GP.

New Member

SIP Trunk - transcoder issue

Yes, the earlier issue of one-way voice was resolved. We had some configuration issue on the IP-IP gateway. I think, I should post next issue on another discussion.

saif

Cisco Employee

SIP Trunk - transcoder issue

Thanks Saif. It would really help readers here if you could elaborate on the config issue you had on CUBE & the fix. Was that routing issue for sure ?

GP.

New Member

SIP Trunk - transcoder issue

Actually the problem was definition of the SIP 'bind source'. In case of IP-IP gateway, this parameter should be left to the routing table to decide.

saif

Cisco Employee

SIP Trunk - transcoder issue

Thanks Saif. +5 to you.

799
Views
5
Helpful
9
Replies
CreatePlease to create content