Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

SIP TURNK OUTGOING CALLS TO PSTN , EXTENSION UNREACHABLE

Hi,

My name is shaik abdullah, i have a problem over SIP TRUNK to PSTN, Incomming and Outgoing calls working fine. but when i call from

cisco IP phone to PSTN any number it is connected and RTP established, but if the distanation is having IVR with extensions, When user dial that

extension the digit is not passing to PSTN.

We trace with Telco they did recieve any digit after call connected. Please advise if any mistake in configuration below.

Current call manager version is 5.X and voice gateway using 2811.

Building configuration...

Current configuration : 6268 bytes
!
version 12.4
service tcp-keepalives-in
service timestamps debug datetime
service timestamps log datetime msec localtime show-timezone
service password-encryption
!
!
card type e1 0 2
logging buffered 8192
enable secret 5 $1$25Je$poq76rD0sM5KfP63L0liY.
enable password 7 074E2062572617004640
!
aaa new-model
!
!
!
!
aaa session-id common
network-clock-participate wic 2
dot11 syslog
!
!
ip cef
!
!
no ip domain lookup
multilink bundle-name authenticated
!
isdn switch-type primary-qsig
!
voice-card 0
dspfarm
dsp services dspfarm
!
!
!
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
no supplementary-service sip moved-temporarily
no supplementary-service sip refer
redirect ip2ip
fax protocol pass-through g711alaw
h323
  h225 timeout setup 5
sip
  bind control source-interface FastEthernet0/1
  bind media source-interface FastEthernet0/1
  header-passing error-passthru
  registrar server expires max 3600 min 3600
  transport switch udp tcp
  redirect contact order best-match
  no call service stop
!
!
voice class codec 1
codec preference 1 g711alaw
codec preference 2 g711ulaw
codec preference 3 g729r8
codec preference 4 g729br8
codec preference 5 g723ar53
!
!
!
voice class h323 1
h225 timeout tcp establish 5
!
!
!
voice class dualtone-detect-params 1
cadence-variation 30
!
!
voice class custom-cptone STC
dualtone disconnect
  frequency 425
  cadence 250 250
!
!
!
!
!
!
!
!
voice translation-rule 1
rule 1 /.*\(443....\)/ /\1/
!
voice translation-rule 3
rule 1 /\(^90..\)/ /443\1/
rule 2 /\(^91..\)/ /443\1/
rule 3 /\(^92..\)/ /443\1/
rule 4 /\(^93..\)/ /443\1/
rule 5 /\(^94..\)/ /443\1/
!
!
voice translation-profile OutCalls
translate calling 3
!
voice translation-profile inboundcalls
translate called 1
!
!
!
!
!
! !
controller E1 0/2/0
framing NO-CRC4
pri-group timeslots 1-31 service mgcp
!
ip tcp synwait-time 5
!
!
policy-map bit
!
!
translation-rule 1
!
!
translation-rule 2
!
!
!
!
!
interface FastEthernet0/0
ip address x.x.x.x255.255.255.0
duplex auto
speed auto
h323-gateway voip interface
h323-gateway voip bind srcaddr x.x.x.x

!
interface FastEthernet0/1
no ip address
no ip route-cache cef
no ip route-cache
load-interval 30
duplex auto
speed auto
!
interface FastEthernet0/1.5
  encapsulation dot1Q 3140
ip address y.y.y.y 255.255.255.252
no ip route-cache
!
interface Serial0/2/0:15
no ip address
encapsulation hdlc
isdn switch-type primary-qsig
isdn incoming-voice voice
isdn bind-l3 ccm-manager
no cdp enable
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 x.x.x.254
ip route y.y.y.y 255.255.255.255 y.y.y.y!
!
!
voice-port 0/2/0:15
!
ccm-manager redundant-host x.x.x.x

ccm-manager mgcp
ccm-manager music-on-hold
!
mgcp
mgcp call-agent x.x.x.x service-type mgcp version 0.1
mgcp rtp unreachable timeout 1000 action notify
mgcp modem passthrough voip mode nse
mgcp package-capability rtp-package
mgcp package-capability sst-package
mgcp package-capability pre-package
no mgcp package-capability res-package
no mgcp package-capability fxr-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp rtp payload-type g726r16 static
mgcp bind control source-interface FastEthernet0/0
mgcp bind media source-interface FastEthernet0/0
!
mgcp profile default
!
sccp local FastEthernet0/0
sccp ccm y.y.y.2 identifier 2 priority 2 version 5.0.1
sccp ccm y.y.y.1 identifier 1 priority 1 version 5.0.1
sccp
!
sccp ccm group 1
bind interface FastEthernet0/0
associate ccm 1 priority 1
associate ccm 2 priority 2
associate profile 2 register XXXMTP
associate profile 1 register XCODEHQ
!
dspfarm profile 1 transcode
codec g711ulaw
codec g711alaw
codec g729ar8
codec g729abr8
codec g729r8
codec g729br8
maximum sessions 8
associate application SCCP
!
dspfarm profile 2 mtp
codec g711ulaw
codec pass-through
maximum sessions software 200
associate application SCCP
!
!
dial-peer voice 999 pots
service mgcpapp
port 0/2/0:15
!
dial-peer voice 52 voip
translation-profile outgoing inboundcalls
destination-pattern 443....$
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
session protocol sipv2
session target ipv4:Y.Y.Y.1
incoming called-number .
dtmf-relay rtp-nte
no vad
!
dial-peer voice 51 voip
translation-profile outgoing OutCalls
destination-pattern .T
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
session protocol sipv2
session target ipv4:Y.Y.Y.49:5060
dtmf-relay sip-notify rtp-nte
no vad
!
!
sip-ua
retry invite 3
retry response 3
retry bye 3
retry cancel 3
retry notify 5
retry register 5
timers connect 100
timers connection aging 30
timers notify 100
registrar ipv4:Y.Y.Y.49 expires 3600
sip-server ipv4:Y.Y.Y.49
!

3 REPLIES
Cisco Employee

Re: SIP TURNK OUTGOING CALLS TO PSTN , EXTENSION UNREACHABLE

shkabdlh wrote:

but when i call from cisco IP phone to PSTN any number it is connected and RTP established, but if the distanation is having IVR with extensions, When user dial that extension the digit is not passing to PSTN.

We trace with Telco they did recieve any digit after call connected. Please advise if any mistake in configuration below.

You mentioned about a destination with IVR & Extensions, does that fall under your control ? If yes, then look for why the DTMF digits are not being detected by that destination system. As you mentioned, even your Telco sees the DTMF digits passing through after the calls are established.

If the destination system doesnt fall under your control, may be then you should talk to them & ask them why your DTMF digits are not recognized by them. Is it happening only to your calls to them or happens with all the calls or random calls, they should troubleshoot on that part.

Pls rate the post if the info provided above helps.

GP.

New Member

SIP TURNK OUTGOING CALLS TO PSTN , EXTENSION UNREACHABLE

Hi!

Did you enable Require MTP option on CallManager?

Look here, if you didn't allready, maybe can help:

http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_tech_note09186a00808b6ca6.shtml#Tp2

Cisco Employee

SIP TURNK OUTGOING CALLS TO PSTN , EXTENSION UNREACHABLE

I dont think MTP is an issue here, as he clearly mentioned that his Telco sees the DTMF digits coming in after the call is established. The issues is they are not recognized by the destination system, perhaps MTP is an issue there or DTMF recognition is disabled by mistake.

GP.

770
Views
0
Helpful
3
Replies
CreatePlease login to create content