Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Small VOIP config with 2 x 7940

Hello,

I am really a newbie in the CISCO world , and even more in telephony.

I just purchased one CISCO 7940 (Ver:8.0(5.0)) on eBay and wait for a other one to arive.

It was not dificult to configure the VLAN 10 and OPTION 150 and the RINGTONES.

My phone receive the files without errors.

But I was wondering how I can asign a phone number to my phones ?

At the moment I have no dial tone , do I need to add some extra HW , I have only :

CISCO 2691 :  System image file is "flash:c2691-adventerprisek9-mz.124-25c.bin"

and a switch CATALYST 3550

What kind of card do I need to add to be able to access a external analogue line (PABX)

Are their some SIP servers for free for test ?

Thank You in avance for your help and of-course you will be rated

PS:

1.If you have some link to a more or less same config you are welcome , it is not urgent , I just prepare myself for my CCNA training in October.

What else can you do when it is raining cats and dogs during your holiday's

2. Where can I download a virtual cisco IP phone ? on some youtube I see a virtual phone.

3. In the system:/its/ folder I can see a lot of of countries , I was wondering if this is only a language issue or maybe also a system issue ?

Best Regards,

Didier

Router#sh run

Building configuration...

Current configuration : 3026 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot system flash c2691-adventerprisek9-mz.124-25c.bin

boot-end-marker

!

enable secret 5 $1$9E60$NHlYQ8E8OAzS3O7H5k1i3.

enable password cisco

!

no aaa new-model

no ip routing

no ip cef

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address 172.16.1.1 172.16.1.9

ip dhcp excluded-address 172.16.2.1 172.16.2.9

!

ip dhcp pool DATA_SCOPE

   network 172.16.2.0 255.255.255.0

   default-router 172.16.2.1

!

ip dhcp pool VOICE_SCOPE

   network 172.16.1.0 255.255.255.0

   default-router 172.16.1.1

   option 150 ip 172.16.1.1

   dns-server 8.8.8.8

no ip domain lookup

ip domain name DRI.BE

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

username cisco privilege 15 secret 5 $1$mZkJ$4yOxPOD1Qzr2rNegO9Nv30

interface FastEthernet0/0

no ip address

no ip route-cache

duplex auto

speed auto

no mop enabled

!

interface FastEthernet0/0.10

encapsulation dot1Q 10

ip address 172.16.1.1 255.255.255.0

no ip route-cache

!

interface FastEthernet0/0.50

encapsulation dot1Q 50

ip address 172.16.2.1 255.255.255.0

no ip route-cache

!

interface Serial0/0

no ip address

no ip route-cache

shutdown

no fair-queue

!

interface FastEthernet0/1

ip address 192.168.1.1 255.255.255.0

no ip route-cache

shutdown

duplex auto

speed auto

!

interface Serial1/0

no ip address

no ip route-cache

shutdown

serial restart-delay 0

!

interface Serial1/1

no ip address

no ip route-cache

shutdown

serial restart-delay 0

!

interface Serial1/2

no ip address

no ip route-cache

shutdown

serial restart-delay 0

!

interface Serial1/3

no ip address

no ip route-cache

shutdown

serial restart-delay 0

!

ip forward-protocol nd

!

!

ip http server

ip http authentication local

no ip http secure-server

ip http path flash:

!

snmp-server community public RO

!

!

tftp-server flash:/ringtones/RingList.xml alias RingList.xml

tftp-server flash:/ringtones/DistinctiveRingList.xml alias DistinctiveRingList.xml

tftp-server flash:/ringtones/AreYouThere.raw alias AreYouThere.raw

tftp-server flash:/ringtones/Analog1.raw alias Analog1.raw

!

control-plane

telephony-service

load 7960-7940 P00308000500

max-ephones 5

max-dn 5

ip source-address 172.16.1.1 port 2000

time-format 24

create cnf-files version-stamp Jan 01 2002 00:00:00

max-conferences 4 gain -6

directory entry 1 555123 name Didier

directory entry 2 1234567890 name Veronique

!

!

line con 0

speed 115200

line aux 0

line vty 0 4

password cisco

login

end

Everyone's tags (6)
2 ACCEPTED SOLUTIONS

Accepted Solutions
Green

Small VOIP config with 2 x 7940

Didier,

Try this something like this to make basic calls between the
phones


!
ephone-dn 1 dual-line
number 2001
!
!
ephone-dn 2 dual-line
number 2002
!
ephone 1
mac-address 1111.1111.1111
type 7940
button 1:1
!
!
ephone 2
mac-address 2222.2222.2222
type 7940
button 1:2
!

For analogue access you need an FXO type card and some DSP chip resource

Here is the link to Call Manager express Admin guide
http://www.cisco.com/en/US/docs/voice_ip_comm/cucme/admin/configuration/guide/cmeover.html

Regards,
Alex.
Please rate useful posts.

Regards, Alex. Please rate useful posts.
Cisco Employee

Small VOIP config with 2 x 7940

If you want to try a softphone and you have a valid contract and access to CCO SW you can try IP Communicator, otherwise, just google ip blue softphone and you can try that one out.

HTH

java

if this helps, please rate

www.cisco.com/go/pdihelpdesk

HTH

java

if this helps, please rate

www.cisco.com/go/pdi
3 REPLIES
Green

Small VOIP config with 2 x 7940

Didier,

Try this something like this to make basic calls between the
phones


!
ephone-dn 1 dual-line
number 2001
!
!
ephone-dn 2 dual-line
number 2002
!
ephone 1
mac-address 1111.1111.1111
type 7940
button 1:1
!
!
ephone 2
mac-address 2222.2222.2222
type 7940
button 1:2
!

For analogue access you need an FXO type card and some DSP chip resource

Here is the link to Call Manager express Admin guide
http://www.cisco.com/en/US/docs/voice_ip_comm/cucme/admin/configuration/guide/cmeover.html

Regards,
Alex.
Please rate useful posts.

Regards, Alex. Please rate useful posts.
Cisco Employee

Small VOIP config with 2 x 7940

If you want to try a softphone and you have a valid contract and access to CCO SW you can try IP Communicator, otherwise, just google ip blue softphone and you can try that one out.

HTH

java

if this helps, please rate

www.cisco.com/go/pdihelpdesk

HTH

java

if this helps, please rate

www.cisco.com/go/pdi
New Member

Small VOIP config with 2 x 7940

Hello,

Thank you for your great help.

Best regards,

Didier

475
Views
0
Helpful
3
Replies
CreatePlease to create content