Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Softphone issue with CUCIMOC

Has anyone had an issue with getting CUCIMOC softphone to register. I never had this issue when we were testing in Cisco training labs.

In our lab, we have everything up on vmware in order to do a proof of concept. Everything works "except" CUCIMOC softphone will not register. Sniffer shows request to read CUCIMOC config.xml file. But softphone never registers. No SIP invite in traces.

We have no login issues and control of cisco deskphone works fine. We have checked all paramaters mutiple times, and everything is configered according to instructions.

Ironically, we're also deploying Cisco Presence in proof of concept (business wants to see this as well). Same issue with CUPC, no login issues, deskphone control works great, but softphone doesn't register (times out). Capabilities for CUPC is checked in callmanager.

We are just using default DLU's that come with UCM. Is it possible since I don't have the CUCIMOC license file uploaded (nor the CUPC license) that this is the issue? I had thought that those both just add DLU's to box, so as long as you have DLU's you don't need to worry about CUCIMOC or CUPC license?

Any comments or suggestions would be great. UCM is 7.1, Presence is 7.0

thanks in advance,

10 REPLIES
New Member

Re: Softphone issue with CUCIMOC

Anyone have input?

thanks

Red

Re: Softphone issue with CUCIMOC

I'd recommend you do a packet capture on the client side.

See if there's any SIP registration request from the client. If not, either the software (CUCIMOC/CUPC) is malfunctioning. Or they cannot resolve the destination name into an IP address.

Michael

http://htluo.blogspot.com

Re: Softphone issue with CUCIMOC

Any DLUs in your system will work. YOu may not have the correct format for the Device named correctly

Should be CSF and then login name for LDAP.

so john doe is jdoe. his Device would CSFjdoe

New Member

Re: Softphone issue with CUCIMOC

No SIP registration shows up in sniffer.

Device names do conform.

We're going to try this on current production servers over the weekend.

thanks for the input.

Re: Softphone issue with CUCIMOC

If you just loaded the Device pack for CUICMOC, you have to reboot the server also. Was this done?

New Member

Re: Softphone issue with CUCIMOC

HI Tcatlinins.

This was done. we've restarted tftp services several times, restarted server several times. We have done this in the Cisco beta testing and was quit easy. Now we have it on new vmware environment and running into this issue.

We have double/triple checked all settings.

The only difference from when we did in as part of beta testing, is now it's in UCM running in vmware, before it was on actual UCM appliance.

Regards,

New Member

Re: Softphone issue with CUCIMOC

Did you get anywhere with this issue?

I have a similar issue with the softphone not registering, or even trying to (no SIP traffic). My softphone status screen is showing no Server Address and a status of 'disconnecting' so no doubt that is my root issue, but I don't know how to fix that problem.

Does the softphone config come from a TFTP download or is it driven by registry settings? I can't see in either case why it should be wrong.

Deskphone mode seems to work ok, although I can't drag and drop user numbers on to the phone icon. I'm not sure if that's a dial rule related issues, I've yet to troubleshoot that one.

Thanks for any pointers,

Jed

Re: Softphone issue with CUCIMOC

The group policy for the CUCIMOC will have the TFTP information for the softphone.  If you have not configured the GP in AD for this, then this is why it's not working.

Once you configure the GP with the correct settings, it will then update the client PC (15 minutes or so).  Restart the client PC or restart the client.

New Member

Re: Softphone issue with CUCIMOC

I'm not using GP, this is a single client wich I applied the .BAT file to. I saw a download occur when I first logged in the user, this downloaded the CSF framework .. but I think this is an HTTOP download.

I have the TFTP server set in the registry settings, and I have .cnf.xml file in the Client Services Framework/config directory which I'm assuming was pulled via TFTP. However, there's no server IP address filled in the cnf.xml file and I would have thought that file would have defined the softphone server.

I haven't setup any CAPF details ... is that a requirement?

Jed

New Member

Re: Softphone issue with CUCIMOC

I've fixed this particular issue now. I had two clients built and each had different issues which were solved by the following steps:

- CLIENT 1 - Added in CUCM host to hosts file to allow lookup to owrk correctly. One of the clients wasn't a member of the domain so didn't have any DNS setup on it (the .cnf.xml file download worked, but then the connection process referenced the CUCM hostname which couldn't be resolved. I could see this error in the client CSF log files)

- CLIENT 1 - Reassociated user and devices in CUCM from scratch, not sure if this had any impact or not

- CLIENT 2 - Reassociated user and devices in CUCM from scratch, not sure if this had any impact or not

- CLIENT 2 - Opened up local firewall. I realised the TFTP download wasn't working on this client and this was simply a firewall issue.

My next issue is getting the drag and drop feature working for contact dialing, at the moment I simply get the no entry sign when I try to drag and drop. Can anybody tell me what I should see .. I assume a 'plus' sign or something when it's working?

I've not set any dial rules up so I'm guessing this is where I need to focus my efforts. I also have an Outlook Integration error on my MOC status saying it cannot synch with the Outlook Address Book, so I guess this could be the source of this error too.

Anybody care to comment as to which  is the most likely to resolve this issue, Outlook Integration error or dial rules?

Jed

1803
Views
6
Helpful
10
Replies