Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

[SOLVED] MGCP: I have to hang up twice to a call be finished

Hello,


I have a problem with a router 1760 using it as a Media Gateway.


It has the following IOS version: IOS (tm) C1700 Software (C1700-SV8Y7-M), Version 12.3(2)XA, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)


Problem is as follow: I do a call and it goes well, but when I hang up the phone the first time, the call is not being finalized. Using a mgcp debug I get:


*May  7 07:47:25.356: mgcpapp_process_mgcp_msg : socket drained.
*May  7 07:47:25.356: aaln/S0/SU2/0 <VOICE>mgcpapp_process_ccapi_ev CCAPI event=11-CC_EV_CALL_DISCONNECTED  state=CALL_ACTIVE  major=11-EV_ON_HOOK  minor=32-   pkg=64
*May  7 07:47:25.356: aaln/S0/SU2/0 <VOICE>mgcp_process_on_hook: callp=0x81A4C908 call_id=17
*May  7 07:47:25.356: mgcp_cr_and_init_evt_node:$$$ the node pointer 82AC57A8


*May  7 07:47:25.356: aaln/S0/SU2/0 mgcp_insert_node_to_preprocess_q:$$$enq to preprocess, qhead=82AC57A8, qtail=82AC57A8, count 1, evtptr=82AC57A8- on hook = 0
*May  7 07:47:25.356: mgcp_process_mgcp_internal_media_events: Not an internal event


.....


If I off-hook after that, the call is active. Once I hang up the telephone again, call is finished properly and during debug I got the following:


*May  7 07:59:50.526: mgcpapp_process_mgcp_msg : socket drained.
*May  7 07:59:50.526: aaln/S0/SU2/0 <VOICE>mgcpapp_process_ccapi_ev CCAPI event=11-CC_EV_CALL_DISCONNECTED  state=CALL_ACTIVE  major=11-EV_ON_HOOK  minor=32-   pkg=64
*May  7 07:59:50.526: aaln/S0/SU2/0 <VOICE>mgcp_process_on_hook: callp=0x81A4C908 call_id=6
*May  7 07:59:50.526: mgcp_cr_and_init_evt_node:$$$ the node pointer 829CF3B8


*May  7 07:59:50.526: aaln/S0/SU2/0 mgcp_insert_node_to_preprocess_q:$$$enq to preprocess, qhead=829CF3B8, qtail=829CF3B8, count 1, evtptr=829CF3B8
*May  7 07:59:50.526: mgcp_endpt_is_packet_cable_supported endpt aaln/S0/SU2/0
*May  7 07:59:50.526: aaln/S0/SU2/0 send_mgcp_notify_msg: voice_if 81A644A0, obs_evt_q_ptr 829DA1E8,complete_endpt aaln/S0/SU2/0@Ignacio
*May  7 07:59:50.526: aaln/S0/SU2/0 mgcp_get_ca_addr_port: Used addr 10.6.4.6 from endpt CA
*May  7 07:59:50.526: aaln/S0/SU2/0 mgcp_enq_retx_msg: trans_id 19,ntfy_ent
*May  7 07:59:50.530: mgcp_add_trans_id_rec: Add trans id (19, 821C4038) record
*May  7 07:59:50.530: mgcp_stw_timer_start timer type 0, duration 500


.......


This second time the gateway notifies to media gateway controller that the call has finished. I don't understand why in the first case it doesn't send it also.


Do you have any idea? I can add more information about configuration or debug traces if needed.


Thank you very much.


Regards

3 REPLIES
Bronze

Re: MGCP: I have to hang up twice to a call be finished

Hi,

I am assuming you are using this with Callmanager.I have never seen this issue before but first of all i would make sure you have a proper voice IOS version on the Router before you start any further diagnostics. I noticed you have 12.3(2) XA change this to a main line IPVOICE code first.

Cheers

Mark

New Member

Re: MGCP: I have to hang up twice to a call be finished

It sounds like a bug, I haven't run into this but also haven't used a 1760 for a gateway.  Try a different IOS or get TAC involved.  You might also make sure the local CO doesn't have an issue with call disconnects.

New Member

Re: MGCP: I have to hang up twice to a call be finished

I already found a workaround for that.

It seems that for some strange reason, the Controller didn't ask the Gateway to notify on-hook events.

I have just configured mgcp persistent onhook and it works properly right now.

Thank you very much.

520
Views
0
Helpful
3
Replies