Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

SPAN Voice Recording Issue

Hi guys, I don't know much about SPAN so please advise me if i've posted in the wrong section.

Basically we have a voice recorder that records our VOIP traffic but we think the SPAN has been set up wrong. I'll try explain how it works.

VOIP Handsets - VLAN 30

VOIP Call Servers - VLAN 31

We have a voice recording server with 2 SPAN ports for redundancy, one is plugged into a 6500 Catalyst switch which works fine and monitors traffic on vlan 30 and forwards it to the voice recorder but then we have the other plugged into a 3560 switch and this is only recording 1 side of the conversation.

We have 2 Avaya Call Server LSP's, 1 in 1 building and 1 in our main building. When calls come through to the LSP in our building it records both sides of the conversation and we think this is because the routing is taking place through the 6500 catalyst switch. When they come into the LSP in the other building and ultimately through span port 2 which is connected to the 3560 it only records 1 side. The config we have for SPAN port 2 is the following:

interface GigabitEthernet0/1
description 2nd SPAN Port for eutee-vrec1p
switchport access vlan 31
switchport mode access

srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape 10 0 0 0
queue-set 2 priority-queue out

mls qos trust cos
auto qos voip trust
spanning-tree portfast
service-policy input VOIP

The monitor session config for this switch is as following:

monitor session 1 source vlan 30

monitor session 1 destination interface Gi0/1

When I do a show monitor session 1 we get the following:

Session 1

---------

Type                   : Local Session

Source VLANs           :

    Both               : 30

Destination Ports      : Gi0/17

    Encapsulation      : Native

          Ingress      : Disabled

We tried turning the ingress on but still the same. The minute we turn the span on aswell and run wireshark all traffic stops on the port. If i havent made any sense please do let me know.

Many Thanks

1 ACCEPTED SOLUTION

Accepted Solutions

Re: SPAN Voice Recording Issue

Refer to this link on how to setup RSPAN.

https://supportforums.cisco.com/docs/DOC-32763

Sent from Cisco Technical Support iPhone App

Please rate replies and mark question as "answered" if applicable.
8 REPLIES
New Member

SPAN Voice Recording Issue

Could you lay out you topology a bit better?   Maybe I'm getting confused here, but it sounds like you trying to record phones tha are not directly attached to the same switch as that the server is connected to.   In that case wouldn't you want to use an RSPAN?

Also wouldn't you want to your voice VLAN on the interface that your server is connected to?   (Again I'm confused here) It looks like Gi 0/1 is your server's switch port, but the show monitor session 1 is saying that the destination port is Gi0/17.

Here's a snippit from my environment:

interface FastEthernet0/44

description Call Monitor

switchport access vlan 5

switchport voice vlan 67

speed 100

duplex half

spanning-tree portfast

monitor session 1 source vlan 67

monitor session 1 destination interface Fa0/44 ingress untagged vlan 67

switch1#show mon session 1

Session 1

---------

Type                   : Local Session

Source VLANs           :

    Both               : 67

Destination Ports      : Fa0/44

    Encapsulation      : Native

          Ingress      : Enabled, default VLAN = 67

    Ingress encap : Untagged

Hope that helps.

TONY

New Member

SPAN Voice Recording Issue

Hi there,

Yep we are wanting to span to a different switch. Sorry I don't think I was clear enough originally so i'll try again :-)

VOIP Handsets are in VLAN 30

VOIP Servers are in VLAN 31

We have a VOIP server plugged into 1 switch in our Fire Station and that is in VLAN 31 and have the following monitor set up:

monitor session 1 source interface Gi0/42

monitor session 1 destination remote vlan 30

Do we need to SPAN the handsets VLAN or the Servers VLAN?

We also have a VOIP server plugged into 1 switch in our HQ Building and also in VLAN 31 but also have a cable from our voice recording server to this same switch.

Port Gi0/1 is our voice recording server

monitor session 1 source vlan 30

monitor session 1 destination interface Gi0/1

Session 1

---------

Type                   : Local Session

Source VLANs           :

    Both               : 30

Destination Ports      : Gi0/1

    Encapsulation      : Native

          Ingress      : Disabled

So basically we would like to retrieve the voice traffic and record it from the Fire Station building using the RSPAN to the VLAN and then pick it up using the source command in the HQ building.

Thanks

Re: SPAN Voice Recording Issue

Refer to this link on how to setup RSPAN.

https://supportforums.cisco.com/docs/DOC-32763

Sent from Cisco Technical Support iPhone App

Please rate replies and mark question as "answered" if applicable.
New Member

SPAN Voice Recording Issue

Will have a look at this now thanks

New Member

Re: SPAN Voice Recording Issue

The above link looks like it has good details to get this done.

To answer your question, "Do we need to SPAN the handsets VLAN or the Servers VLAN?"   Your voice traffic will will be end to end communication - phone to phone or PSTN connection to phone.   The server is there mostly for call setup.   Therefore you will need to span your handset VLANs. 

New Member

SPAN Voice Recording Issue

Hi there, yep followed that guide however we cannot set the monitor session 1 source remote vlan 90 (our RSPAN VLAN) as the fibre goes directly into a Catalyst 6506 so we tried setting up this:

Set vlan 90 rspan

Set rspan source 30 90 both

Set rspan destination 4/10 90

We have no switches with VTP Mode Server our VTP Server is on the Catalyst 6506 Core Switch if that helps.

However still one sided recordings, so frustrating :-(

New Member

SPAN Voice Recording Issue

I'm not sure who your call recording solution is through, but here's one company's take on setup and configuration: http://www.vpi-corp.com/resources/manuals/VPI_ActivIP_Setup_%28Rev1%29.pdf

Page 5 outlines some basics and page 12 details the configuration.   A few things to note.   Your VTP configuration should propigate the RSPAN VLAN info.   Is your switch in a seperate VTP domain?   Maybe verify that the VLAN is being propigated by doing a show vlan.

New Member

SPAN Voice Recording Issue

Our VTP Domain is all setup correctly and the VLAN's were being propagated  across our switches. We looked through the guide again and seem to of sorted it.

Thanks anyway for your help.

1915
Views
0
Helpful
8
Replies
CreatePlease login to create content