Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

SRST does not work

Hi All,

Have a CUCM 8.6 BE (only Pub) and a Router (c2900-universalk9-mz.SPA.150-1.M6.bin). Both are configured to have SRST, and when accesing "Telephone Information" at IPPhone 6921  active server and inactive server are displayed in right order. But when WAN Link goes down, IP Phone does not come up with the inactive server,

Call-manager-fallback´s  commands where accepted at router, and when "show ephone unregistered" is typed the IP Phone´s mac address appears.

Do I have missed something at Router, talking about License ?

Thanks in advanced

1 ACCEPTED SOLUTION

Accepted Solutions

Re: SRST does not work

Well now hopefully now you are doubt free.

Aman gave you a couple +5 for your information on the SRST eval license.

31 REPLIES
Cisco Employee

SRST does not work

Hello Gerardo,

Can you please post the config from the router?


Br,
Nadeem 

Please rate all useful post.

Br, Nadeem Please rate all useful post.

Re: SRST does not work

Thank for reporting Nadeem,

Here it is the config.

VIP Purple

Re: SRST does not work

Hi Gerardo,

Does Active server Inactive Server appear on 6921 even when phone is regsitered to Call Manager?

If yes, are the phones able to communicate with each other?

what is the firmware version of 691 phones?

also, have u referenced SRST in Device pool

regds,

aman

Re: SRST does not work

Hi Aman,

That´s right, Active Server and Inactive Server appear on 6921 even phone is registered to CUCM. Phones are able to communicate each other.

Firmware is SCCP 9.2.1.0, and SRST is referenced in Device Pool, thats why Inactive Server appears on 6921.

regds,

G. Fajardo

Re: SRST does not work

Hi Gerardo,

Do you see any phone logs on the console of SRST router when WAN goes down ? like..

%IPPHONE-6-REGISTER_NEW: ephone-1:SEP2A0C293F8228 IP:10.0.10.9 Socket:2 DeviceType:Phone has registered.

Thanks

Manish

Re: SRST does not work

Hi Manish,

No logs appears on Router when WAN goes down, only if I type "sho ephone unregistered" appears that phone., but it displays no registered.

regards

VIP Purple

SRST does not work

Hi Gerardo,

what is the CUCM version and 6921 phones are working on which protocol ?

can u share the output of show license detail cme-srst?

regds,

aman

Re: SRST does not work

Hi Aman,

CUCM is 8.6 and 6921 is running skinny.

show license detail cme-srst says : "%Error: No License for cme-srst found - License feature not found"

Here is the problem  even call-manager-fallback was accepted ???

Thanks

VIP Purple

Re: SRST does not work

Hi Gerardo,

Can u try the command license accept end user agreement and check?

regds,

aman

Re: SRST does not work

Hi Aman,

License agreement was done and it looks the same, do I have to reload the router ?

VIP Purple

Re: SRST does not work

Hi Gerardo,

please do that.

regds,

aman

Re: SRST does not work

Ok Aman,

Let me take some time to do that because that router is in production, so later will tell you.

Thanks a lot for your support.

Regards,

Re: SRST does not work

Hi Aman,

Reset has been done and looks the same :" No license for cme-srst found - License feature not found "

What do you think ??

Regards,

Re: SRST does not work

Gerardo,

Do you see

"license accept end user agreement"

now under

license udi pid CISCO2901/K9 sn FTX152680XE
in your running router config?

Re: SRST does not work

Also I don't think you posted your full configuration.  Is this an MGCP gateway or h.323.

 

Check out this guide make sure everything matches up.

https://supportforums.cisco.com/docs/DOC-24097

Re: SRST does not work

Hi Gregory,

It is an H323 Gateway and does not appear that info you under agreement.

Re: SRST does not work

Gerardo,

Your running configuration should look something like this

license udi pid CISCO2901/K9 sn FTXREDACTED
license accept end user agreement
hw-module pvdm 0/0

well at least it should  in the newer version of code it should.

If you don't see it make sure do a

conf t

license accept end user agreement

Make sure type yes or y

write the configuration (wr or copy run start)

If this does not work you may want to try updating your version of IOS code

VIP Purple

Re: SRST does not work

Hi Gerardo,

can u post the show version/show running/show license feature /sh license detail output?

regds,

aman

Re: SRST does not work

Also do you have any phone at all registered you are setting your max-ephones low if you have other phones that are registered this would tell alot.  Along with Aman request above.

Here is a sample from my last srst config if it helps

call-manager-fallback

max-conferences 8 gain -6

transfer-system full-consult

timeouts interdigit 5

timeouts busy 16

ip source-address port 2000

max-ephones 42

max-dn 200 dual-line

VIP Purple

Re: SRST does not work

Hi Gerardo,

Have a look at this discussion with similar problem.

https://supportforums.cisco.com/thread/2123996

In your case , IOS version is 15.0(1)M6

regds,

aman

Re: SRST does not work

Hi Aman and Greg,

It was solved, it was an IOS problem. But what about the following: "License Type: Eval Right to use" and the "Period Left " ???

VIP Purple

SRST does not work

Hi Perez,

thanks for update.

The ISR G2 comes with a 60-day evaluation license. After 60 days, the license changes to “right to use”.Is this what you are referring too.

what is the IOS version u are using now? can u share show version and show license detail cme-srst.

regds,

aman

SRST does not work

Hi Aman,

So what will "rigth to use" mean, it means that will be active forever ???

Tomorrow i will share you the IOS version because right now Im  out of the Clients´s site.

Thanks in advanced 

VIP Purple

SRST does not work

Hi Perez,

SRST would be active forever now.

http://blog.vuurmuur.com/?p=32

Licensing functionality is working as per design here. Cme-srst licenses are honor based and hence you have to just accept the EULA. After the 60 days of EvalRightToUse the license will change to "right to use" for 12 years

regds,

aman

Re: SRST does not work

Hi Aman,

Attached send you the info you asked me. As you will see, even though with command "sho license detail cme-srts" appears the same   "%Error: no license for cme-srst found  - License feature not found" , with the command "sho license" appears as "Active" in the Index 11...

What do you think ??

Thanks so much for your support.

Re: SRST does not work

I think you are good now

Your error now looks like a typo

show license detail cme-srst not cme-srts

MTY_GONZALITOS_Branch_4082#sho license detail cme-srts

% Error: No license for cme-srts found - License feature not found

MTY_GONZALITOS_Branch_4082#sho license detail cme-srts

% Error: No license for cme-srts found - License feature not found

MTY_GONZALITOS_Branch_4082#conf t

Enter configuration commands, one per line. End with CNTL/Z.

MTY_GONZALITOS_Branc(config)#license accept end user agreement

MTY_GONZALITOS_Branc(config)#exit

MTY_GONZALITOS_Branch_4082#sho license detail cme-srts

% Error: No license for cme-srts found - License feature not

Are you still having problems with SRST?

Re: SRST does not work

                   HI Greg,

Now it is working, so I just have the doubt.

Thanks man.

Re: SRST does not work

Well now hopefully now you are doubt free.

Aman gave you a couple +5 for your information on the SRST eval license.

VIP Purple

Re: SRST does not work

Hi Perez,

thanks for the ratings.

You can try running the command show license detail cme-srst after 8 week and 3 days just to check the status again and share output.

Index 11 Feature: cme-srst                      

Period left: 8  weeks 3  days

Period Used: 20 hours 24 minutes

License Type: EvalRightToUse

License State: Active, In Use

License Count: 10/0  (In-use/Violation)

License Priority: Low

regds,

aman

564
Views
10
Helpful
31
Replies
CreatePlease to create content