Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

SRST MGCP don't see PRI

when phones registers with SRST on gateway , appear dial-peers like 1001$,1002$,1003$ . Phones can call internal numbers, but they don't see PRI

Here is the dial-peer:

dial-peer voice 4 pots

tone ringback alert-no-PI

destination-pattern [234].....

no digit-strip

direct-inward-dial

port 0/0/0:15

26 REPLIES
Bronze

Re: SRST MGCP don't see PRI

Hi,

I am assuming that when you say they don't see PRI you mean that they cannot make outgoing calls.

This sounds like a problem in you SRST config.

Please see the following guide on how to configure SRST for MGCP.

http://www.cisco.com/en/US/tech/tk1077/technologies_tech_note09186a0080144630.shtml

Hope this helps.

If it does please rate.

Regards

Dave

New Member

Re: SRST MGCP don't see PRI

Hi,

try

call application alternate [application-name]

or

service [alternate-name | default] service-name location

in the dialpeer config.

See

http://www.cisco.com/en/US/partner/products/sw/voicesw/ps2169/products_configuration_guide_chapter09186a00806674c3.html#wp1351962

Bye

Jo

New Member

Re: SRST MGCP don't see PRI

I cann't access for this link..

New Member

Re: SRST MGCP don't see PRI

Hi,

please try this link, it should work if your not logged in.

http://www.cisco.com/en/US/products/sw/voicesw/ps2169/products_configuration_guide_chapter09186a00806674c3.html#wp1351962

Or search for

"Cisco Unified SRST 4.0: Setting Up the Network"

on www.cisco.com

Bye

Jo

New Member

Re: SRST MGCP don't see PRI

didn't help

As I use IOS later 12.3 I used

applicatiob

service default

but this didn't help. What can be the problem??

Cisco Employee

Re: SRST MGCP don't see PRI

Post your full config here and we can confirm exactly how it is set up and make config suggestions.

New Member

Re: SRST MGCP don't see PRI

!

controller E1 0/0/0

framing NO-CRC4

pri-group timeslots 1-31 service mgcp

!

interface Serial0/0/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice voice

isdn bind-l3 ccm-manager

no cdp enable

!

voice-port 0/0/0:15

cptone RU

!

voice-port 0/1/0

!

voice-port 0/1/1

!

ccm-manager fallback-mgcp

ccm-manager redundant-host 10.10.0.2

ccm-manager mgcp

ccm-manager music-on-hold

ccm-manager config server 10.10.0.1

ccm-manager config

!

mgcp

mgcp call-agent 10.10.0.1 2427 service-type mgcp version 0.1

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

mgcp package-capability sst-package

mgcp package-capability pre-package

no mgcp package-capability res-package

no mgcp package-capability fxr-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp rtp payload-type g726r16 static

!

mgcp profile default

!

!

!

dial-peer voice 4 pots

tone ringback alert-no-PI

destination-pattern [2346].....

no digit-strip

direct-inward-dial

port 0/0/0:15

!

dial-peer voice 80 pots

incoming called-number .

direct-inward-dial

port 0/0/0:15

!

!

!

!

call-manager-fallback

max-conferences 8 gain -6

ip source-address 10.11.10.1 port 2000

max-ephones 128

max-dn 256

transfer-pattern 0.

transfer-pattern 0..

transfer-pattern 2.....

transfer-pattern 3.....

transfer-pattern 4.....

transfer-pattern 6.....

transfer-pattern 82.......

transfer-pattern 80..........

!

!

end

New Member

Re: SRST MGCP don't see PRI

TAG TYPE MIN OPER PREFIX DEST-PATTERN FER THRU SESS-TARGET STAT PORT

4 pots up up [2346]..... 0 up 0/0/0:15

20001 pots up up 1027$ 0 50/0/1

20002 pots up up 1001$ 0 50/0/2

20003 pots up up 1026$ 0 50/0/3

20004 pots up up 1030$ 0 50/0/4

20005 pots up up 1002$ 0 50/0/5

20006 pots up up 1707$ 0 50/0/6

20007 pots up up 1025$ 0 50/0/7

20008 pots up up 1031$ 0 50/0/8

20009 pots up down 0 50/0/9

20010 pots up down 0 50/0/10

20011 pots up down 0 50/0/11

20012 pots up down 0 50/0/12

20013 pots up down 0 50/0/13

20014 pots up down 0 50/0/14

20015 pots up down 0 50/0/15

20016 pots up down 0 50/0/16

20017 pots up down 0 50/0/17

20018 pots up down 0 50/0/18

20019 pots up down 0 50/0/19

20020 pots up down 0 50/0/20

20021 pots up down 0 50/0/21

20022 pots up down 0 50/0/22

Cisco IOS Version 12.3(11r)T2

Cisco Employee

Re: SRST MGCP don't see PRI

Please add the command 'call application alternate default' to the main config. This will allow the ISDN D channel operation to drop back to local router processing. Without this command, the router will be trying to make a connection to the call manager all the time, so the D channel will not come up .

Your ephones register in the range 1XXX (4 digits) so once the D channel is working correctly in SRST, you might also need to translate the called number that comes from the telco to this 4 digit range.

Once you add the above command, wait a moment and enabled 'debug isdn q931', then make an inwards call. Capture this log and paste it here so we can confirm the number range being sent to you.

New Member

Re: SRST MGCP don't see PRI

Feb 4 13:16:27.701: ISDN Se0/0/0:15 Q931: RX <- SETUP pd = 8 callref = 0x005D

Sending Complete

Bearer Capability i = 0x8090A3

Standard = CCITT

Transfer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA18381

Preferred, Channel 1

Progress Ind i = 0x8281 - Call not end-to-end ISDN, may have in-band info

Called Party Number i = 0x81, '422864'

Plan:ISDN, Type:Unknown

Feb 4 13:16:27.757: ISDN Se0/0/0:15 Q931: TX -> RELEASE_COMP pd = 8 callref = 0x805D

Cause i = 0x809B - Destination out of order

Feb 4 13:16:31.773: ISDN Se0/0/0:15 Q931: RX <- SETUP pd = 8 callref = 0x005E

Sending Complete

Bearer Capability i = 0x8090A3

Standard = CCITT

Transfer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA18381

Preferred, Channel 1

Progress Ind i = 0x8281 - Call not end-to-end ISDN, may have in-band info

Called Party Number i = 0x81, '422864'

Plan:ISDN, Type:Unknown

Feb 4 13:16:31.797: ISDN Se0/0/0:15 Q931: TX -> RELEASE_COMP pd = 8 callref = 0x805E

Cause i = 0x809B - Destination out of order

Feb 4 13:16:41.438: ISDN Se0/0/0:15 Q931: RX <- SETUP pd = 8 callref = 0x005F

Sending Complete

Bearer Capability i = 0x8090A3

Standard = CCITT

Transfer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA18381

Preferred, Channel 1

Progress Ind i = 0x8281 - Call not end-to-end ISDN, may have in-band info

Called Party Number i = 0x81, '422864'

Plan:ISDN, Type:Unknown

Feb 4 13:16:41.446: ISDN Se0/0/0:15 Q931: TX -> RELEASE_COMP pd = 8 callref = 0x805F

Cause i = 0x809B - Destination out of order

Outgoing calls - say that line is busy

call application alternate default - is added

Cisco Employee

Re: SRST MGCP don't see PRI

Very good - D channel is now up :-)

For inwards calls, the number range provided by your telco is 6 digits :

Called Party Number i = 0x81, '422864'

But this called number does not correspond to any registered ephone numbers :

20001 pots up up 1027$ 0 50/0/1

20002 pots up up 1001$ 0 50/0/2

20003 pots up up 1026$ 0 50/0/3

20004 pots up up 1030$ 0 50/0/4

20005 pots up up 1002$ 0 50/0/5

20006 pots up up 1707$ 0 50/0/6

20007 pots up up 1025$ 0 50/0/7

20008 pots up up 1031$ 0 50/0/8

So you need to translate the called number/s from the telco to your internal range.

Let us suppose the numbers from the telco are in the range 422XXX, and you want to map these over to your extension range of 1XXX for SRST.

The easiest way is to use a translation profile to change the 422 to 1, and leave the trailing digits unchanged.

!

voice translation-rule 111

rule 1 /^422/ /1/

!

voice translation-profile test

translate called 111

!

voice-port 0/0/0:15

translation-profile incoming test

!

Almost there! Change the translation rule to suit your number and give it another go.

Cisco Employee

Re: SRST MGCP don't see PRI

for outwards calls to work, add the following config -

!

call-manager-fallback

secondary-dialtone 0

!

dial-peer voice 2222 pots

destination-pattern 0T

port 0/0/0:15

!

To make calls to the PSTN , dial 0 then the rest of number . After 10 second timeout, the call should be sent out the PRI without the leading 0.

New Member

Re: SRST MGCP don't see PRI

call-manager-fallback

secondary-dialtone 0

!

dial-peer voice 2222 pots

destination-pattern 0T

port 0/0/0:15

!

This config also didn't help me.. :(

I wait for 10 seconds and receive busy signal

debug isdn q931 didn't show anything

New Member

Re: SRST MGCP don't see PRI

I think You are right :)

but by the words, internal and external numbers like this:

1004 422864

1005 422865

1006 422866

so voice translation-rule 111

rule 1 /^42286/ /100/

Am I right?

Cisco Employee

Re: SRST MGCP don't see PRI

this rule would only work for first 10 numbers 422860 - 422869, so you might to add other sub rules under voice translation-rule 111 , for example :

voice translation-rule 111

rule 1 /^42286/ /100/

rule 2 /^42287/ /101/

rule 3 /^42288/ /102/

rule 4 /^42289/ /103/

...

New Member

Re: SRST MGCP don't see PRI

Didn't help,

Feb 4 13:49:03.947: ISDN Se0/0/0:15 Q931: RX <- SETUP pd = 8 callref = 0x0061

Sending Complete

Bearer Capability i = 0x8090A3

Standard = CCITT

Transfer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA18381

Preferred, Channel 1

Progress Ind i = 0x8281 - Call not end-to-end ISDN, may have in-band info

Called Party Number i = 0x81, '422864'

Plan:ISDN, Type:Unknown

Feb 4 13:49:03.955: ISDN Se0/0/0:15 Q931: TX -> RELEASE_COMP pd = 8 callref = 0x8061

Cause i = 0x809B - Destination out of order

Feb 4 13:49:13.503: ISDN Se0/0/0:15 Q931: RX <- SETUP pd = 8 callref = 0x0062

Sending Complete

Bearer Capability i = 0x8090A3

Standard = CCITT

Transfer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA18381

Preferred, Channel 1

Progress Ind i = 0x8281 - Call not end-to-end ISDN, may have in-band info

Called Party Number i = 0x81, '422864'

Plan:ISDN, Type:Unknown

Feb 4 13:49:13.515: ISDN Se0/0/0:15 Q931: TX -> RELEASE_COMP pd = 8 callref = 0x8062

Cause i = 0x809B - Destination out of order

New Member

Re: SRST MGCP don't see PRI

You ALSO should know that outgoing calls don't see D channel

and look for this,

80 pots up up 0 down 0/0/0:15

3 pots up up 0[1234] 0 up 0/0/0:15

4 pots up up [234]..... 0 up 0/0/0:15

is it right, that this dial-peer is down?

command no shut didn't help

New Member

Re: SRST MGCP don't see PRI

is this a local number? if so why are you matching 6 digits instead of 7 I would say you need another . in you destination pattern, correct me if im wrong

New Member

Re: SRST MGCP don't see PRI

Maybe this help you:

3825#sh ccm-manager fallback-mgcp

Current active Call Manager: 10.10.0.1

MGCP Fallback mode: Enabled/OFF

Last MGCP Fallback start time: 17:56:05 UA Feb 4 2008

Last MGCP Fallback end time: 17:59:11 UA Feb 4 2008

I test SRST function with this

access-list 111 deny tcp 10.11.0.1 0.0.0.255 host 10.10.0.1 eq 2000

access-list 111 deny tcp 10.11.0.1 0.0.0.255 host 10.10.0.2 eq 2000

access-list 111 permit ip any any

int GigabitEthernet0/1.10

no ip access-group 111 in

Cisco Employee

Re: SRST MGCP don't see PRI

I know you suggested this particular access list in this earlier post to Netpro -

http://forums.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Unified%20Communications%20and%20Video&topic=IP%20Telephony&CommCmd=MB%3Fcmd%3Dpass_through%26location%3Doutline%40%5E1%40%40.2cbf5f35/7#selected_message

However, you have completely forgotten that MGCP uses a combination of traffic on UDP port 2427 (for registration and voice port control) and TCP 2428 for the TCP backhaul. The access list above will only block SCCP traffic from the phones, so the phones will go into SRST mode, but your gateway will still be registered to the call manager, which is why this is not working.

So you have two options.

1) Create an new access list to block outwards traffic on UDP port 2427 and TCP port 2428 and apply this on your WAN port in the outwards direction, alongside the other access list that you have applied in the inwards directions to block the SCCP responses.

2) or simply add these IP route statements so ALL traffic to the CCM is blocked and after a short period the CCM will not send any Keepalive repsonses -

ip route 10.10.0.1 255.255.255.255 null 0

ip route 10.10.0.2 255.255.255.255 null 0

New Member

Re: SRST MGCP don't see PRI

You are very helpful!Thanks!

But lets now suggest, what I should do.

(I don't to test SRST more +1 week)

I'm not strong in ACL

So, if I have network 10.111.70.1 that have phones which want to access CallManager ip address 10.10.10.1 so ?

access-list 111 deny tcp 10.111.70.0 0.0.0.255 host 10.10.10.1 eq 2000

access-list 111 deny tcp 10.111.70.0 0.0.0.255 host 10.10.10.1 eq 2428

access-list 111 deny udp 10.111.70.0 0.0.0.255 host 10.10.10.1 eq 2427

access-list 111 permit ip any any

and then

ip access-group 111 in

?

Cisco Employee

Re: SRST MGCP don't see PRI

Deny on the gateway towards the call manager. This blocks outgoing packets, including keepalive traffic, so the CCM stops responding to the devices and they will all drop into SRST and the MGCP will hand over to local call processing -

access-list 111 deny tcp 10.111.70.0 0.0.0.255 host 10.10.10.1 eq 2000

access-list 111 deny tcp 10.111.70.0 0.0.0.255 host 10.10.10.1 eq 2428

access-list 111 deny udp 10.111.70.0 0.0.0.255 host 10.10.10.1 eq 2427

access-list 111 permit ip any any

and then

interface gigabit 0/0

ip access-group 111 out

New Member

Re: SRST MGCP don't see PRI

command "ip access-group 111 out"

doesn't help

where have I to use this ACL?

I use it on Gateway 10.111.70.1

When I used ACL with "in" in the end

ip access-group 111 in

phones registers on the GATEWAY 10.111.70.1

As you understand, I should simulate local failure in the range of GATEWAY, whithout touching something like CCM etc.

Cisco Employee

Re: SRST MGCP don't see PRI

Can you draw us a simple text picture of how this system is connected ? Is your SRST router the WAN gateway router ? Or is there another router that is the main WAN connection ?

Paste the complete config of your routers here as well so we can understand exactly why this is not working. Without all the details it is too difficult to give you a solution.

New Member

Re: SRST MGCP don't see PRI

access-list 111 deny tcp 10.111.70.0 0.0.0.255 host 10.10.10.1 eq 2000

access-list 111 deny tcp 10.111.70.0 0.0.0.255 host 10.10.10.1 eq 2428

access-list 111 deny udp 10.111.70.0 0.0.0.255 host 10.10.10.1 eq 2427

access-list 111 permit ip any any

and then

interface gigabit 0/0

ip access-group 111 out/in

When I use ACL "ip access-group 111 in" phones register on Gateway 3825,but without FALLBACK MODE

New Member

Re: SRST MGCP don't see PRI

so,how can I simulate SRST with ACL only

without using any ip routes?

Help me Gurus

469
Views
12
Helpful
26
Replies
CreatePlease to create content