Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

SRST MGCP PRI

SRST is confirmed working, each phone seems to be registering fine. Inbound calls work fine as well, however, outbound when the first digit is dialed '9' it immediately gives a busy signal. Any advice on this is greatly appreciated. Thanks!

dial-peer voice 100 pots

incoming called-number .

direct-inward-dial

port 0/2/0:23

!

dial-peer voice 101 pots

description Emergency Services

destination-pattern 911

port 0/2/0:23

forward-digits 3

!

dial-peer voice 102 pots

description Emergency Services

destination-pattern 9911

port 0/2/0:23

forward-digits 3

!

dial-peer voice 103 pots

description Local Calls 10 Digit

destination-pattern 9[2-9]..[2-9]......

port 0/2/0:23

forward-digits 10

!

dial-peer voice 104 pots

description Long Distance

destination-pattern 91[2-9]..[2-9]......

port 0/2/0:23

forward-digits 11

!

dial-peer voice 105 pots

description International

destination-pattern 9011T

port 0/2/0:23

prefix 011

!

call-manager-fallback

secondary-dialtone 9

max-conferences 8 gain -6

transfer-system full-consult

timeouts ringing 30

ip source-address 172.16.96.1 port 2000

max-ephones 36

max-dn 72 dual-line

access-code pri 9 direct-inward-dial

voicemail 97064471399

no huntstop

call-forward busy 97064471399

call-forward noan 97064471399 timeout 20

moh Kenny-G-Track-1.wav

multicast moh 239.1.1.1 port 16384 route 172.16.96.1 10.1.1.1

time-zone 13

5 REPLIES
VIP Purple

Re: SRST MGCP PRI

Do you have one of the following depending on your version of IOS?

For Cisco IOS® Software Release 12.3(13)T or earlier:

R(config)#call application alternate default

For Cisco IOS® Software Release 12.3(14)T or later:

R(config)#application

R(config-app)#global

R(config-app-global)#service alternate Default

Hope this helps. If so, please rate the post.

Brandon

Community Member

Re: SRST MGCP PRI

Double check and found that it is in the config... Is there anything else?

Thanks!

VIP Purple

Re: SRST MGCP PRI

How about "ccm-manager fallback-mgcp"?

Brandon

Community Member

Re: SRST MGCP PRI

Here is most of the config, which does have the ccm-manager fallback-mgcp.

application

global

service alternate default

!

!

!

!

!

!

controller T1 0/2/0

framing esf

linecode b8zs

pri-group timeslots 1-24 service mgcp

!

!

!

!

!

!

interface Loopback0

description MoH for SRST

ip address 10.1.1.1 255.255.255.255

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.252

encapsulation dot1Q 252

ip address 172.16.239.5 255.255.255.0

ip pim sparse-dense-mode

!

interface FastEthernet0/1

description Connection to LAN

ip address 172.16.96.1 255.255.240.0

ip pim sparse-dense-mode

duplex full

speed auto

!

interface Serial0/2/0:23

no ip address

encapsulation hdlc

isdn switch-type primary-ni

isdn incoming-voice voice

isdn bind-l3 ccm-manager

no cdp enable

!

router eigrp 100

network 172.16.0.0

no auto-summary

!

ip route 0.0.0.0 0.0.0.0 172.16.239.1

!

!

no ip http server

no ip http secure-server

ip tacacs source-interface FastEthernet0/1

!

logging history size 500

logging trap critical

logging 172.16.16.48

snmp-server community backoff RO

snmp-server community anyone RW

snmp-server location Appling Main Data Closet

snmp-server contact Information Technology

snmp-server enable traps tty

snmp-server enable traps frame-relay multilink bundle-mismatch

!

!

!

!

!

tacacs-server host 172.16.16.47

tacacs-server directed-request

tacacs-server key xxx

!

control-plane

!

!

!

voice-port 0/2/0:23

echo-cancel coverage 32

!

voice-port 0/1/0

!

voice-port 0/1/1

!

ccm-manager fallback-mgcp

ccm-manager redundant-host 172.17.16.2

ccm-manager mgcp

no ccm-manager fax protocol cisco

ccm-manager music-on-hold

ccm-manager config server 172.17.16.3 172.17.16.2

ccm-manager config

!

mgcp

mgcp call-agent 172.17.16.3 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

no mgcp package-capability res-package

mgcp package-capability sst-package

no mgcp package-capability fxr-package

mgcp package-capability pre-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp validate call-agent source-ipaddr

no mgcp fax t38 ecm

mgcp fax t38 inhibit

mgcp rtp payload-type g726r16 static

mgcp bind control source-interface FastEthernet0/1

mgcp bind media source-interface FastEthernet0/1

!

mgcp profile default

!

sccp local FastEthernet0/1

sccp ccm 172.17.16.2 identifier 2 priority 2 version 4.1

sccp ccm 172.17.16.3 identifier 1 priority 1 version 4.1

sccp

!

sccp ccm group 100

associate ccm 1 priority 1

associate ccm 2 priority 2

associate profile 10 register CFB000ab82d4ba9

!

dspfarm profile 10 conference

description Remote_Site_Conferencing

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

codec g729r8

codec g729br8

shutdown

!

!

dial-peer voice 100 pots

service mgcpapp

destination-pattern 9T

incoming called-number .

direct-inward-dial

!

!

!

!

!

call-manager-fallback

secondary-dialtone 9

max-conferences 8 gain -6

transfer-system full-consult

timeouts ringing 30

ip source-address 172.16.96.1 port 2000

max-ephones 36

max-dn 72 dual-line

access-code pri 9 direct-inward-dial

voicemail 97064471399

no huntstop

call-forward busy 97064471399

call-forward noan 97064471399 timeout 20

moh Kenny-G-Track-1.wav

multicast moh 239.1.1.1 port 16384 route 172.16.96.1 10.1.1.1

time-zone 13

!

!

vm-integration

pattern direct 2 CGN *

pattern ext-to-ext no-answer 5 FDN * CGN *

pattern ext-to-ext busy 7 FDN * CGN *

pattern trunk-to-ext no-answer 4 FDN * CGN *

pattern trunk-to-ext busy 6 FDN * CGN *

!

!

Re: SRST MGCP PRI

As your pots dial-peers already have a trunk access code, the command 'access-code pri 9 direct-inward-dial' under call-manager-fallback is not necessary.

Please try removing the command and see if this helps.

Regards

Allan.

532
Views
3
Helpful
5
Replies
CreatePlease to create content