Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

SRST only allowing for digits to be dialed

I have a site with an H323 gateway that when phones are registered SRST,  will only allow the phones to dial 4 digits.  Incoming calls work and internal extension dialing work as well.

Here is the runing confige on the router

!

!

interface Loopback0

description Must use loopback for H323

ip address 10.1.117.1 255.255.255.255

h323-gateway voip interface

h323-gateway voip bind srcaddr 10.1.117.1

!

interface FastEthernet0/0

description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0$

no ip address

speed auto

full-duplex

no mop enabled

!

interface FastEthernet0/0.1

description DataVlan

encapsulation dot1Q 1 native

ip address 192.168.17.6 255.255.255.0

!

interface FastEthernet0/0.10

description VoiceVlan

encapsulation dot1Q 10

ip address 192.168.117.254 255.255.255.0

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

router rip

redistribute connected

network 192.168.17.0

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 192.168.17.252

!

!

ip http server

ip http access-class 23

ip http authentication local

no ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

logging trap debugging

logging facility local1

logging source-interface Loopback0

logging 192.168.117.1

logging 192.168.117.254

dialer-list 1 protocol ip permit

snmp-server community Kemper RW

snmp-server enable traps tty

!

!

!

control-plane

!

!

!

voice-port 0/0/0

supervisory disconnect dualtone mid-call

input gain 3

output attenuation 0

timeouts wait-release 2

timing min-ring 62

connection plar 1700

description Need Phone Number

caller-id enable

!

voice-port 0/0/1

supervisory disconnect dualtone mid-call

input gain 3

output attenuation 0

timeouts wait-release 2

timing min-ring 62

connection plar 1700

description Need Phone Number

caller-id enable

!

voice-port 0/0/2

supervisory disconnect dualtone mid-call

input gain 3

output attenuation 0

timeouts wait-release 2

timing min-ring 62

connection plar 1700

description Need Phone Number

caller-id enable

!

voice-port 0/0/3

supervisory disconnect dualtone mid-call

input gain 3

output attenuation 0

timeouts wait-release 2

timing min-ring 62

connection plar 1700

description Need Phone Number

caller-id enable

!

!

!

!

!

dial-peer voice 2 pots

incoming called-number .

!

dial-peer voice 7000 voip

destination-pattern 7...

voice-class codec 1

session target ipv4:192.168.151.10

dtmf-relay h245-alphanumeric

no vad

!

dial-peer voice 14 pots

destination-pattern 8T

port 0/0/0

!

dial-peer voice 15 pots

destination-pattern 8T

port 0/0/1

!

dial-peer voice 16 pots

preference 10

destination-pattern 8T

port 0/0/2

!

dial-peer voice 17 pots

preference 9

destination-pattern 8T

port 0/0/3

!

dial-peer voice 921 pots

preference 5

destination-pattern 911

prefix 911

!

dial-peer voice 911 pots

destination-pattern 911

port 0/0/0

prefix 911

!

dial-peer voice 912 pots

destination-pattern 911

port 0/0/1

prefix 911

!

dial-peer voice 913 pots

preference 10

destination-pattern 911

port 0/0/2

prefix 911

!

dial-peer voice 914 pots

preference 9

destination-pattern 911

port 0/0/3

prefix 911

!

dial-peer voice 1000 voip

destination-pattern 1...

voice-class codec 1

session target ipv4:192.168.151.10

dtmf-relay h245-alphanumeric

no vad

!

!

!

call-manager-fallback

max-conferences 4 gain -6

transfer-system full-consult

ip source-address 10.1.117.1 port 2000

max-ephones 30

max-dn 150

system message primary SRST Mode

system message secondary SRST Mode

default-destination 1710

alias 1 1700 to 1710

!

!

line con 0

line aux 0

line vty 0 4

exec-timeout 0 0

privilege level 15

password !Cs!^)@kcpag

transport input none

line vty 5 15

privilege level 15

password !Cs!&)@kcpag

transport input telnet ssh

!

scheduler allocate 20000 1000

ntp clock-period 17207731

ntp server 130.126.24.53

end

                  

!

!

interface Loopback0

description Must use loopback for H323

ip address 10.1.117.1 255.255.255.255

h323-gateway voip interface

h323-gateway voip bind srcaddr 10.1.117.1

!

interface FastEthernet0/0

description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0$

no ip address

speed auto

full-duplex

no mop enabled

!

interface FastEthernet0/0.1

description DataVlan

encapsulation dot1Q 1 native

ip address 192.168.17.6 255.255.255.0

!

interface FastEthernet0/0.10

description VoiceVlan

encapsulation dot1Q 10

ip address 192.168.117.254 255.255.255.0

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

router rip

redistribute connected

network 192.168.17.0

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 192.168.17.252

!

!

ip http server

ip http access-class 23

ip http authentication local

no ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

logging trap debugging

logging facility local1

logging source-interface Loopback0

logging 192.168.117.1

logging 192.168.117.254

dialer-list 1 protocol ip permit

snmp-server community Kemper RW

snmp-server enable traps tty

!

!

!

control-plane

!

!

!

voice-port 0/0/0

supervisory disconnect dualtone mid-call

input gain 3

output attenuation 0

timeouts wait-release 2

timing min-ring 62

connection plar 1700

description Need Phone Number

caller-id enable

!

voice-port 0/0/1

supervisory disconnect dualtone mid-call

input gain 3

output attenuation 0

timeouts wait-release 2

timing min-ring 62

connection plar 1700

description Need Phone Number

caller-id enable

!

voice-port 0/0/2

supervisory disconnect dualtone mid-call

input gain 3

output attenuation 0

timeouts wait-release 2

timing min-ring 62

connection plar 1700

description Need Phone Number

caller-id enable

!

voice-port 0/0/3

supervisory disconnect dualtone mid-call

input gain 3

output attenuation 0

timeouts wait-release 2

timing min-ring 62

connection plar 1700

description Need Phone Number

caller-id enable

!

!

!

!

!

dial-peer voice 2 pots

incoming called-number .

!

dial-peer voice 7000 voip

destination-pattern 7...

voice-class codec 1

session target ipv4:192.168.151.10

dtmf-relay h245-alphanumeric

no vad

!

dial-peer voice 14 pots

destination-pattern 8T

port 0/0/0

!

dial-peer voice 15 pots

destination-pattern 8T

port 0/0/1

!

dial-peer voice 16 pots

preference 10

destination-pattern 8T

port 0/0/2

!

dial-peer voice 17 pots

preference 9

destination-pattern 8T

port 0/0/3

!

dial-peer voice 921 pots

preference 5

destination-pattern 911

prefix 911

!

dial-peer voice 911 pots

destination-pattern 911

port 0/0/0

prefix 911

!

dial-peer voice 912 pots

destination-pattern 911

port 0/0/1

prefix 911

!

dial-peer voice 913 pots

preference 10

destination-pattern 911

port 0/0/2

prefix 911

!

dial-peer voice 914 pots

preference 9

destination-pattern 911

port 0/0/3

prefix 911

!

dial-peer voice 1000 voip

destination-pattern 1...

voice-class codec 1

session target ipv4:192.168.151.10

dtmf-relay h245-alphanumeric

no vad

!

!

!

call-manager-fallback

max-conferences 4 gain -6

transfer-system full-consult

ip source-address 10.1.117.1 port 2000

max-ephones 30

max-dn 150

system message primary SRST Mode

system message secondary SRST Mode

default-destination 1710

alias 1 1700 to 1710

!

!

line con 0

line aux 0

line vty 0 4

exec-timeout 0 0

privilege level 15

password !Cs!^)@kcpag

transport input none

line vty 5 15

privilege level 15

password !Cs!&)@kcpag

transport input telnet ssh

!

scheduler allocate 20000 1000

ntp clock-period 17207731

ntp server 130.126.24.53

end

1 REPLY
VIP Super Bronze

SRST only allowing for digits to be dialed

Are you saying you are unable to dial externally then?

Can you send us a debug voip ccapi inout and a debug vpm signal

Please rate all useful posts

"The essence of christianity is not the enthronement but the obliteration of self --William Barclay"

Please rate all useful posts "The essence of christianity is not the enthronement but the obliteration of self --William Barclay"
86
Views
0
Helpful
1
Replies
CreatePlease to create content