Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

SRST Unity Connection Configuration

Hi all:

I would much appreciate if some one walk me through the steps to have Unity Connection voice mail in SRST mode.

I am not able to make it work the unity connection in SRST, however I made partially to work with VM-Integartion command

Please if you have done it and have the steps, Please give me some knowledge

thanks

3 REPLIES
New Member

Re: SRST Unity Connection Configuration

Hi,

First of all, are you configuring your remote gateway/gateway as CME-as-SRST?

I guess this document could be helpful if you have not read through this before.

http://www.cisco.com/en/US/docs/voice_ip_comm/cucme/integration/unity_connect/configuration/guide/unityconn_cme-as-srst.pdf

Regards,

Nicholas

Re: SRST Unity Connection Configuration

Hi, forget about those vm-integration commads, follow the procedures below (if you are using call-manager-fallback SRST):

!

call-manager-fallback

voicemail 2342222 ! i guessed your original VM Pilot number is 2222 and 234 is the CUCM/Connection site access code, you got me?

call-forward noan 2342222 timeout 20

call-forward busy 2342222

!

You will need a seperate dial-peer for that:

!

dial-peer voice 2222 pots

destination-pattern 2342222

port x/y:0

forward-digit all

!

Now another important thing is don't forget to mark the 'Redirecting Number IE Delivery - Inbound' if there is MGCP gateway on main site, if it's H.323 then put the command 'isdn outgoing ie redirecting-number ' on voice serial interface.

Keep in mind your MWI won't work for SRST like your model.

If you are using CME SRST, configure like below:

!

Telephony-service

voicemail 2342222

!

ephone-dn-template 1

call-forward noan 2342222 timeout 20

call-forward busy 2342222

!

ephone-dn 1 octo-line

ephone-dn-template 1

!

You will need the dial-peer as well.

HTH.

New Member

Hi Md. Mijanur Rahman Client

Hi Md. Mijanur Rahman

 

Client have CUCM 10.5 and Unity connection 10.5 (attached screenshot) and Voice Gateway is configured as mgcp in HQ .

Issue is voicemail is not working in case on fallback. Please see the below configuration and let me know whats missing 

I

 

 


!
no aaa new-model
clock timezone GMT 4 0
network-clock-participate wic 0 
network-clock-select 1 E1 0/0/0
!
ip dhcp pool ipphones
 network 192.168.210.0 255.255.255.0
 default-router 192.168.210.1 
 option 150 ip 192.168.210.10 
 domain-name wr

!
ip domain name NLJcapital.kwi
ip cef
no ipv6 cef
multilink bundle-name authenticated
!
!
isdn switch-type primary-net5
!
cts logging verbose
!
voice-card 0
 dspfarm
 dsp services dspfarm
!
voice service voip
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 supplementary-service h450.12
 fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
 modem passthrough nse codec g711ulaw
 h323
 sip
  bind control source-interface GigabitEthernet0/0
  bind media source-interface GigabitEthernet0/0
  registrar server expires max 600 min 60
  no silent-discard untrusted
!
!
voice register global
 mode srst
 timeouts interdigit 7
 max-dn 10
 max-pool 40
!
!
voice translation-rule 7
 rule 1 /^2/ /043652/
!
voice translation-rule 9
 rule 1 /^1/ /91/
 rule 2 /^2/ /902/
 rule 3 /^3/ /903/
 rule 4 /^4/ /904/
 rule 5 /^5/ /905/
 rule 6 /^6/ /906/
 rule 7 /^7/ /907/
 rule 8 /^8/ /98/
 rule 9 /^9/ /9009/
 rule 10 /^0/ /90/
!
voice translation-rule 10
 rule 1 /^1/ /83041/
 rule 2 /^2/ /83042/
 rule 3 /^3/ /83043/
 rule 4 /^4/ /83044/
 rule 5 /^5/ /83045/
 rule 6 /^6/ /83046/
 rule 7 /^7/ /83047/
 rule 8 /^8/ /83048/
 rule 9 /^9/ /83049/
 rule 10 /^0/ /83040/
!
voice translation-rule 11
 rule 1 /^1/ /83651/
 rule 2 /^2/ /83652/
 rule 3 /^3/ /83653/
 rule 4 /^4/ /83654/
 rule 5 /^5/ /83655/
 rule 6 /^6/ /83656/
 rule 7 /^7/ /83657/
 rule 8 /^8/ /83658/
 rule 9 /^9/ /83659/
 rule 10 /^0/ /83650/
!
!
voice translation-profile Add9
 translate calling 9
!
voice translation-profile CALL-KWT
 translate calling 10
!
voice translation-profile CALL-NLJBranches
 translate calling 10
!
voice translation-profile change_calling
 translate calling 7
!
!
!
!
application
 global
  service alternate default
 !
!

hw-module pvdm 0/0
!
redundancy
!
!
controller E1 0/0/0
 framing NO-CRC4 
 pri-group timeslots 1-31 service mgcp
!
ip ssh authentication-retries 5
ip ssh version 2
!
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 ip address 192.168.210.11 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0/0:15
 no ip address
 encapsulation hdlc
 isdn switch-type primary-net5
 isdn incoming-voice voice
 isdn bind-l3 ccm-manager
 isdn outgoing display-ie
 isdn outgoing ie redirecting-number 
 no cdp enable
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 192.168.210.1

!
!
!
!
control-plane
!
!
voice-port 0/0/0:15
!
voice-port 0/1/0
!
voice-port 0/1/1
!
voice-port 0/1/2
!
voice-port 0/1/3
!
voice-port 0/2/0
!
voice-port 0/2/1
!
voice-port 0/2/2
!
voice-port 0/2/3
 !
 !
 !
 !
!
mgcp
mgcp call-agent 192.168.210.10 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode out-of-band
mgcp bind control source-interface GigabitEthernet0/0
mgcp bind media source-interface GigabitEthernet0/0
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
sccp local GigabitEthernet0/0
sccp ccm 192.168.210.10 identifier 1 priority 1 version 7.0 
sccp ccm 192.168.210.11 identifier 2 priority 2 version 7.0 
sccp
!
sccp ccm group 1
 associate ccm 1 priority 1
 associate ccm 2 priority 2
 associate profile 1 register HQ-CONF
 associate profile 2 register HQ-XCODE
!
ccm-manager music-on-hold
!
ccm-manager switchback immediate
ccm-manager fallback-mgcp 
ccm-manager mgcp
ccm-manager config
!
dspfarm profile 2 transcode universal  
 codec g729abr8
 codec g729ar8
 codec g711alaw
 codec g711ulaw
 codec g729br8
 codec g729r8
 codec ilbc
 codec pass-through
 maximum sessions 3
 associate application SCCP
!
dspfarm profile 1 conference  
 codec g729br8
 codec g729r8
 codec g729abr8
 codec g729ar8
 codec g711alaw
 codec g711ulaw
 codec ilbc
 maximum sessions 2
 associate application SCCP
!
dial-peer voice 1 pots
 translation-profile incoming Add9
 preference 7
 destination-pattern 9.T
 incoming called-number .
 direct-inward-dial
 port 0/0/0:15
 forward-digits all
!
dial-peer voice 101 pots
 translation-profile outgoing change_calling
 preference 3
 destination-pattern 9(050.......)
 progress_ind setup enable 3
 progress_ind alert enable 8
 progress_ind progress enable 8
 progress_ind connect enable 8
 translate-outgoing calling 7
 direct-inward-dial
 port 0/0/0:15
!
dial-peer voice 102 pots
 translation-profile outgoing change_calling
 preference 2
 destination-pattern 9([2,3,4,5]......)
 progress_ind setup enable 3
 progress_ind alert enable 8
 progress_ind progress enable 8
 progress_ind connect enable 8
 translate-outgoing calling 7
 direct-inward-dial
 port 0/0/0:15
!
dial-peer voice 103 pots
 translation-profile outgoing change_calling
 preference 1
 destination-pattern 9(0[2,3,6,7].......)
 progress_ind setup enable 3
 progress_ind alert enable 8
 progress_ind progress enable 8
 progress_ind connect enable 8
 translate-outgoing calling 7
 direct-inward-dial
 port 0/0/0:15
!
dial-peer voice 104 pots
 translation-profile outgoing change_calling
 destination-pattern 9T
 progress_ind setup enable 3
 progress_ind alert enable 8
 progress_ind progress enable 8
 progress_ind connect enable 8
 translate-outgoing calling 7
 direct-inward-dial
 port 0/0/0:15
!
dial-peer voice 165 pots
 translation-profile outgoing change_calling
 preference 3
 destination-pattern 9(055.......)
 progress_ind setup enable 3
 progress_ind alert enable 8
 progress_ind progress enable 8
 progress_ind connect enable 8
 translate-outgoing calling 7
 direct-inward-dial
 port 0/0/0:15

!
num-exp 2800 2824
!
!
gatekeeper
 shutdown
!
!
call-manager-fallback
 max-conferences 8 gain -6
 transfer-system full-consult
 ip source-address 192.168.210.11 port 2000
 max-ephones 75
 max-dn 152 dual-line
 keepalive 20
 voicemail 5000
 call-forward busy 5000
 call-forward noan 5000 timeout 20
!
!
!
line con 0
 login local
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line vty 0 4
 login local
 transport input all
!
scheduler allocate 20000 1000
ntp master 2
!
end

634
Views
0
Helpful
3
Replies