Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

SRST with FXO ports not working

I have implemented CCM 4.2 between my corporate office and my 11 branch offices. Each of the branch offices has a 2801 with at least 4 FXO ports (some have more). These will be used for inbound and outbound calls to that office. I have tried to configure SRST, but cannot get it to work correctly. Here is what I have done:

After bringing up the FXO ports with CCM in MGCP mode, I test inbound and outbound calls to verify they work correctly.

I put in my configurations for SRST (conn plar, dial-peers, etc). I then test calls again and everything works.

I then break the connection from the remote office to CCM. I see the phones register with the router. I can call between phones and place outbound calls on the FXO ports, however, all inbound calls ring once then go busy. I entered the "transfer-pattern" under call-manager-fallback and inbound calls started working correctly.

I restored the connection to CCM. I tested again and found that outbound calls and calls internally were working but the inbound calls on the FXO ports were ringing once, then going busy. I did a "debug voice dialpeer" and found that inbound calls were matching the first dial-peer. If I removed the "conn plar" statements from the voice ports, the calls would ring once then get dial tone. I had to remove all of the dial-peer statements for SRST in order to restore inbound calls. Not even a reboot on the router fixed it.

Please advise.

Thanks,

Jack

3 REPLIES
New Member

Re: SRST with FXO ports not working

Do you have the following in your configuration?

!

application

global

service alternate default

!

!

ccm-manager fallback-mgcp

!

H.323 should only be invoked in the event of an MGCP failure, the above commands will ensure that. Also, what version of IOS are you running?

New Member

Re: SRST with FXO ports not working

Jack,

FXO is not supported in SRST fallback.What i feel you can try is , configure FXO as H323.

This shuold solve your problem.

let me know the solution?

vishwesh

Hall of Fame Super Gold

Re: SRST with FXO ports not working

This is incorrect. From SRTS configuration guide at:

http://cisco.com/en/US/products/sw/voicesw/ps4625/products_configuration_guide_chapter09186a00807e13a7.html#wp1061320

Signal Support

Cisco SRST supports FXS, FXO, T1, E1, and E1 R2 signals

252
Views
1
Helpful
3
Replies
CreatePlease to create content