Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

SRST

I'm attempting to get SRST to work with a 7940 phone, 1751v router, and a 3500 switch.

I've got the call-manager-fallback configured according to the SRST 3.0 Admin Guide, however I don't think it's working properly.

The phone can successfully get an address from the router, but it just keeps trying to "Configuring CM List" or "opening IP Address" of an IP that's not even in this subnet.

I was expecting to see "CM Fallback Service Operating" on the screen, but can't get it.

I don't have a this router/gateways setup in our active Call Managers. Would this cause a problem? Does it need to be setup and then when the link is cut it THEN properly falls back to SRST?

Here's the running config from the router:

!

version 12.2

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot system flash c1700-sv8y-mz.122-15.ZJ2.bin

logging queue-limit 100

no logging console

enable password

!

memory-size iomem 15

clock timezone PST -7

ip subnet-zero

!

!

no ip domain lookup

no ip dhcp conflict logging

ip dhcp excluded-address 172.16.3.1

ip dhcp excluded-address 172.16.3.254

!

ip dhcp pool AZ

network 172.16.3.0 255.255.255.0

option 150 ip 172.16.3.1

!

ip cef

!

!

voice call send-alert

voice rtp send-recv

!

voice class codec 1

codec preference 1 g711ulaw

codec preference 2 g729br8

codec preference 3 g729r8

!

!

!

voice class h323 1

h225 timeout setup 3

!

!

!

!

no voice hpi capture buffer

no voice hpi capture destination

!

!

fax interface-type fax-mail

mta receive maximum-recipients 0

!

!

interface FastEthernet0/0

no ip address

speed auto

!

interface FastEthernet0/0.1

encapsulation dot1Q 1 native

ip address 10.10.3.1 255.255.255.0

ip helper-address 10.10.1.5

!

interface FastEthernet0/0.3

encapsulation dot1Q 3

ip address 172.16.3.1 255.255.255.0

!

interface Serial0/0

no ip address

encapsulation frame-relay

no ip mroute-cache

load-interval 30

shutdown

no fair-queue

frame-relay traffic-shaping

frame-relay ip rtp header-compression

h323-gateway voip interface

!

interface Serial0/0.16 point-to-point

description phoenix

ip address 172.1.1.9 255.255.255.252

no ip mroute-cache

frame-relay interface-dlci 16 CISCO

class qos-1536k

frame-relay ip tcp header-compression

frame-relay ip rtp header-compression

!

router bgp 19007

no synchronization

bgp log-neighbor-changes

no auto-summary

!

ip classless

no ip forward-protocol udp netbios-dgm

ip route 0.0.0.0 0.0.0.0 172.1.1.10

no ip http server

!

snmp-server community az RO

snmp-server enable traps tty

call rsvp-sync

!

voice-port 1/0

input gain -1

echo-cancel coverage 32

echo-cancel suppressor

no vad

no comfort-noise

timeouts interdigit 2

!

voice-port 1/1

input gain -1

echo-cancel coverage 32

echo-cancel suppressor

no vad

no comfort-noise

timeouts interdigit 2

!

!

mgcp profile default

!

dial-peer cor custom

!

!

!

dial-peer voice 91 pots

preference 1

destination-pattern 6T

!

call-manager-fallback

max-conferences 4

ip source-address 172.16.3.1 port 2000

max-ephones 24

max-dn 48

access-code fxo 9

Router#

1 REPLY
Gold

Re: SRST

On the CallManager, under Device Pool, you need this Router selected as SRST Reference.

The CallManager configuration would be:

1. Define SRST Reference

http://www.cisco.com/univercd/cc/td/doc/product/voice/c_callmg/4_1/sys_ad/4_1_3/ccmcfg/b02srst.htm

2. Assign this SRST Reference to the Device Pool

http://www.cisco.com/univercd/cc/td/doc/product/voice/c_callmg/4_1/sys_ad/4_1_3/ccmcfg/b02devpl.htm

Once this is done, you will have to reset the IP Phones and confirm that under the list of CallManagers mentioned in Network Settings (Settings|Network Settings) you see the SRST Router as the last available CallManager.

Hope this helps

352
Views
0
Helpful
1
Replies
CreatePlease to create content