Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Subscriber phone status error

hi

We have deployed CUCM 8 cluster with 1 publisher and 2 subscriber (A and B). Phones are all registered with subscriber A.  we are facing an issue since last few days that phone status of some phones on subscriber is showing following error:

"Unmapped Exception /usr/local/cm/db/xml/xml/Phone_3905_display_instance.xml (No such file or directory)"

because of this error phone can dial outside calls, but incoming calls receive busy tone.

While phone 3905 was running normally before.

I have checked dpreplication status between PUB and Subscriber and it is "2" good.

here is some show commands:

admin:utils dbreplication runtimestate

DB and Replication Services: ALL RUNNING

Cluster Replication State: Only available on the PUB

DB Version: ccm8_0_3_20000_2

Number of replicated tables: 519

Cluster Detailed View from SUB (3 Servers):

                                PING            REPLICATION     REPL.   DBver&  REPL.   REPLICATION SETUP

SERVER-NAME     IP ADDRESS      (msec)  RPC?    STATUS          QUEUE   TABLES  LOOP?   (RTMT)

-----------     ------------    ------  ----    -----------     -----   ------- -----   -----------------

Mbl-cucm-pub    172.30.10.10    1.59    Yes     Connected       0       match   N/A     (2)

Mbl-cucm-sub    172.30.10.11    0.022   Yes     Connected       0       match   N/A     (2)

Mbl-cucm-sub2   172.30.11.11    30.5    Yes     Connected       0       match   N/A     (2)

admin:

admin:utils dbreplication status

-------------------- utils dbreplication status --------------------

Replication status check is now running in background.

Use command 'utils dbreplication runtimestate' to check its progress

The final output will be in file cm/trace/dbl/sdi/ReplicationStatus.2013_08_13_14_24_32.out

Please use "file view activelog cm/trace/dbl/sdi/ReplicationStatus.2013_08_13_14_24_32.out " command to see the output 

admin:

admin:

admin:

admin:file view activelog cm/trace/dbl/sdi/ReplicationStatus.2013_08_13_14_24_32.out

SERVER                 ID STATE    STATUS     QUEUE  CONNECTION CHANGED

-----------------------------------------------------------------------

g_mbl_cucm_pub_ccm8_0_3_20000_2    2 Active   Connected       0 Aug 13 13:49:03

g_mbl_cucm_sub2_ccm8_0_3_20000_2    5 Active   Connected       0 Aug 13 13:49:09

g_mbl_cucm_sub_ccm8_0_3_20000_2    3 Active   Local           0               

end of the file reached

options: q=quit, n=next, p=prev, b=begin, e=end (lines 1 - 5 of 5) :

admin:


Also i have rebooted cluster (first publisher then subscriber) still no success.

Any solution/idea how to resolve this issue?

Thanks.

6 REPLIES
New Member

Subscriber phone status error

Issue resolves after stoping and reseting dbreplication on subscriber. Now incoming and outgoing calls are going through. but subscriber still shows "Unmapped Exception /usr/local/cm/db/xml/xml/Phone_3905_display_instance.xml (No such file or directory)" status message for all Cisco 3905 SIP phones.

Subscriber phone status error

Since it shows  No such file  for the 3905 phones on the subsriber . How about installing the 3905 phone cop file on the subscriber  again and restarting the tftp.

Regards,

Karthik  Sivaram

New Member

Subscriber phone status error

Hi Syed

I got similar error with CIsco 7841 SIP Phones on a BE6K v 9.1.2 ( one Publisher + one Subscriber) as you can see here:

"Unmapped Exception /usr/local/cm/db/xml/xml/Phone_7841_SIP_display_instance.xml (No such file or directory)"

On my Subscriber server ...The only thing we have is common is that we are using SIP Ip phones.

Have you found a solution ??

Thanks a lot for your help!!

Best Regards

Enrique Villasana

Subscriber phone status error

Hi Syed,


Install the device pack in addition to the COP file. Here is the latest device pack for 8.5.1 - http://software.cisco.com/download/release.html?mdfid=283423434&softwareid=282074299&relea
se=8.5%281.17115%29&relind=AVAILABLE&rellifecycle=&reltype=latest
Here is a link to the Device Pack Compatibility Matrix as well - http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/compat/devpack_comp_mtx.html

Rate the post accordinly.

Regards,
Kevin
New Member

Subscriber phone status error

Hi Kevin !!

I have similar problem on my new CUCM BE 6000 ver 9.1.2 implementation.

Although I already have installed recommended device pack (cmterm-devicepack9.1.2.11013-1.cop.sgn), and restarted both servers ( Pub & Sub), I still got this error on my Subscriber server.

I also run "utils dbreplication status" on both servers and got :

"No Errors or Mismatches found.

Replication status is good on all available servers"

....when I viewed generated file.

I also run "Unified CM Database status" report and got Replicate state= "2    Good " ob Subscriber server.

Do you have any idea about this kind of problem??

Thanks a lot for your help!!

New Member

Did you manage to get this

Did you manage to get this resolved?

 

I get same issue with Cisco 7921's when accessed the  from Publisher  it is fine but try to manage any of the 7921 Phones from any of the 2 subscribers you get the same error message:

 

"Unmapped Exception /usr/local/cm/db/xml/xml/Phone_7921_display_instance.xml (No such file or directory)"

 

 

The latest Device pack and cop files were installed and a clusterwide reboot but still not resolved the issue!

 

Any ideas to resolve issue

631
Views
0
Helpful
6
Replies
CreatePlease to create content