Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Switchboard in SRST mode (SIP)

Hello everyone,

I am trying to implement the Switchboard function that would work during SRST mode.

The configuration/requirement in moment (when CUCM is operating/reachable) :

External callers dial on the main number or main number + 0.

The Called Party Number is then translated to 111 (on the gateway), which is a Hunt Pilot in CUCM.

 

In SRST mode, the Hunt Pilot is not reachable and the main number or the main number + 0 or the 111 has to be translated to a DN which is configured on a Cisco 9971 Phone.

 

In our environment we have SCCP and SIP Phones. The forwarding is working with call-manager-fallback for the SCCP Phones (with alias). It is also working when using cme-srst (telephony service) for SCCP Phones, but we were never able to forward the call to the Switchboard phone (Cisco 9971). 

 

The Cisco 9971 registers on the gateway in SRST and it can be reached when we dial the full number (main number + DN of the 9971). We tried to do a translation from 111 to the DN with alias in the voice register pool, but that did not work.

 

In our test lab, we have both SCCP and SIP phones, but it should work in an environment with only SIP Phones.

 

Here is the configuration of the gateway :

router01.cucm.lab#sh run
Building configuration...


Current configuration : 7496 bytes
!
! Last configuration change at 11:04:32 UTC Thu Jun 5 2014
! NVRAM config last updated at 13:48:09 UTC Tue Jun 3 2014
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname router01.cucm.lab
!
boot-start-marker
boot-end-marker
!
!
logging buffered 10000
enable password cisco
!
aaa new-model
!
!
!         
!
!
!
!
aaa session-id common
network-clock-participate wic 0 
!
no ipv6 cef
ip source-route
ip cef
!
!
!
ip dhcp excluded-address 192.168.2.0 192.168.2.10
ip dhcp excluded-address 192.168.2.200 192.168.2.255
!
ip dhcp pool voip
!
!
no ip domain lookup
ip domain name cucm.lab
ip name-server 192.168.2.3
multilink bundle-name authenticated
!
!
!
!
isdn switch-type basic-net3
!
crypto pki token default removal timeout 0
!
crypto pki trustpoint TP-self-signed-432774010
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-432774010
 revocation-check none
!
!
voice-card 0
!
!
!
voice service voip
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 no supplementary-service h225-notify cid-update
 fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
 h323
 modem passthrough nse codec g711ulaw
 sip
  bind control source-interface GigabitEthernet0/0
  bind media source-interface GigabitEthernet0/0
  registrar server expires max 600 min 60
!
voice class codec 10
 codec preference 1 g711alaw
 codec preference 2 g711ulaw
 codec preference 3 g729r8
!
voice class h323 1
  h225 timeout tcp establish 3
!
!
voice register global
 max-dn 10
 max-pool 1
!
voice register pool  1
 translation-profile outgoing outgoingcallSRST
 id network 192.168.2.0 mask 255.255.255.0
 preference 1
 proxy 192.168.2.253 preference 1
 dtmf-relay sip-notify
 voice-class codec 10
!
!
!
voice translation-rule 10
 rule 1 /^$\(.*\)/ /111/
 rule 2 /^0/ /111/
!
voice translation-rule 41
 rule 1 /111/ /104/
!
!
voice translation-profile incomingcall
 translate called 10
!
voice translation-profile outgoingcallSRST
 translate called 41
!
!
license udi pid CISCO2911/K9 sn FCZ153820CM
license accept end user agreement
hw-module pvdm 0/0
!
!
!
archive
 log config
  hidekeys
username cisco privilege 15 secret 5 $1$qzcD$xhvbO9lcVgSW.CMSGdRwz0
username V62 password 0 12345
!
redundancy
!
!
ip ssh time-out 60
ip ssh authentication-retries 2
!
!
!
!
interface GigabitEthernet0/0
 ip address 192.168.2.253 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface GigabitEthernet0/1.2
 encapsulation dot1Q 2
 ip address 157.177.2.254 255.255.254.0
!
interface GigabitEthernet0/1.32
 description ### fuer ntp server ###
 encapsulation dot1Q 32
 ip address 157.177.32.20 255.255.254.0
!
interface GigabitEthernet0/1.202
 encapsulation dot1Q 202
 ip address 157.177.203.254 255.255.254.0
!
interface GigabitEthernet0/1.208
 description ### fuer ntp server ###
 encapsulation dot1Q 208
 ip address 157.177.208.20 255.255.254.0
!
interface GigabitEthernet0/2
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface BRI0/0/0
 no ip address
 isdn switch-type basic-net3
 isdn overlap-receiving T302 3000
 isdn point-to-point-setup
 isdn incoming-voice voice
 isdn send-alerting
 isdn sending-complete
 isdn static-tei 0
!
interface BRI0/0/1
 no ip address
 isdn switch-type basic-net3
 isdn point-to-point-setup
 isdn incoming-voice voice
!
ip forward-protocol nd
!
ip http server
ip http access-class 23
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
!
!
!
!
control-plane
!
!
voice-port 0/0/0
 translation-profile incoming incomingcall
 translation-profile outgoing outgoingcall
 no vad
 compand-type a-law
 cptone DE
 timeouts interdigit 5
 bearer-cap Speech
!
voice-port 0/0/1
!
!
mgcp fax t38 ecm
!
!
dial-peer voice 1 pots
 incoming called-number .
 direct-inward-dial
!
dial-peer voice 1100 voip
 description zum Callmanager-PUB
 preference 5
 destination-pattern [1-9]T
 session target ipv4:192.168.2.240
 voice-class codec 10  
 voice-class h323 1
 dtmf-relay h245-alphanumeric
 fax-relay ecm disable
!
dial-peer voice 2000 pots
 description *****Local Via BRI0/0/0*****
 preference 5
 destination-pattern 0T
 progress_ind alert enable 8
 progress_ind progress enable 8
 progress_ind connect enable 8
 fax rate disable
 direct-inward-dial
 port 0/0/0
!
!
!
!         
gatekeeper
 shutdown
!
!
telephony-service
 srst mode auto-provision all
 srst ephone template 5
 srst ephone description srst fallback auto-provision phone : Jul 07 2005 17:45:08 : Jun 05 2014 08:37:20
 srst dn line-mode dual
 max-ephones 5
 max-dn 10
 ip source-address 192.168.2.253 port 2000
 max-redirect 20
 system message "SRST Mode: Cisco Unified CME
 keepalive 10
 max-conferences 8 gain -6
 transfer-system full-consult
 create cnf-files version-stamp 7960 Jun 05 2014 08:37:38
!
!
ephone-dn  1  dual-line
 number 105
 label 105
 description +43732316262105
 name +43732316262105
!
!
ephone-dn  2  dual-line
 number 106
 description 106
 name 106
!
!
ephone-dn  3  dual-line
 number 101
 label 101
 description +43732316262101
 name +43732316262101
!
!
ephone  1
 description srst fallback auto-provision phone : Jul 07 2005 17:45:08 : Jun 05 2014 08:37:20
 mac-address 5897.1E29.955F
 ephone-template 5
 button  1:1 2:2
!
!
!
ephone  2
 description srst fallback auto-provision phone : Jul 07 2005 17:45:08 : Jun 05 2014 08:37:20
 mac-address A456.3040.3F2D
 ephone-template 5
 button  1:3
!
!
!
line con 0
 password cisco
 logging synchronous
line aux 0
line vty 0 4
 privilege level 15
 password cisco
 transport input all
line vty 5 15
 access-class 23 in
 privilege level 15
 password cisco
 transport input telnet ssh
!
scheduler allocate 20000 1000
ntp master 3
end

Thanks in advance for your help, it is really appreciated (been battling with this for few days).

Everyone's tags (1)
1 REPLY

There is a lot of changes to

There is a lot of changes to be made.

1 - To begin you need to review your voice translation-rules. For example, rule 40 is translating the call into a number you don't have and rule 10 is configured as a set that you're not using.

2 - You need to create a "voice hunt-group" for "111". Please see example below:

voice hunt-group

To create a hunt group for phones in a Cisco Unified Communications Manager Express (Cisco Unified CME) or Cisco Unified Session Initiation Protocol (SIP) Survivable Remote Site Telephony (SRST) system, use the voice hunt-group command in global configuration mode. To delete a hunt group, use the no form of this command.

voice hunt-group hunt-tag {longest-idle | parallel | peer | sequential}

no voice hunt-group hunt-tag

Syntax Description

 

hunt-tag

Unique sequence number that identifies the hunt group. Range is 1 to 100.

longest-idle

Allows an incoming call to go first to the number that has been idle the longest for the number of hops specified when the hunt group was defined. The longest-idle time is determined from the last time that a phone registered, reregistered, or went on-hook.

parallel

Allows an incoming call to simultaneously ring all the numbers in the hunt group member list.

peer

Allows a round-robin selection of the first extension to ring. Ringing proceeds in a circular manner from left to right. The round-robin selection starts with the number left of the number that answered when the hunt-group was last called.

sequential

Allows an incoming call to ring all the numbers in the left-to-right order in which they were listed when the hunt group was defined.
 

 

3 - You configured srst with an ephone-template that doesn't exist!

4 - dial-peer voice 2000 pots is not going to send the "0". Is "0" your site code or is the carrier expecting to see the "0"?

5 - Why does "dial-peer voice 1100 voip" and "dial-peer voice 2000" have the same preference?

6 - voice register pool  1 doesn't have a number assigned...

Regards,

Yosh

HTH Regards, Yosh
403
Views
0
Helpful
1
Replies