Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

T.38 fax over IP oubound problem (sip)

Hi everyone, I realize my graduation project on fax over IP. I am using t38modem + HylaFAX + + Cisco (12.4 / 2800 series).

Incoming calls work, but outgoing calls show not success due to sip error. If you there is a cisco voice expert, tell me what could be the cause of this problem ! pealse I need help caus' time is running out and I don't know what to do.

###############################Here is my configuration:

 

Router#sh run
Building configuration...

Current configuration : 2520 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$UpiM$n2bFrf.3tM/3HHfV45hDX.
!
no aaa new-model
ip cef
!
!
!
!
multilink bundle-name authenticated
!
!
!
trunk group PSTN
!
!
trunk group faxsend1
!
voice-card 0
!
!
!
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
no supplementary-service sip moved-temporarily
no supplementary-service sip refer
fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback cisco
sip
!
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g711alaw
codec preference 3 g729r8
!
!
!
!
!
!
!
!
!
!
!
voice translation-rule 1
rule 1 /.*/ //
!
!
voice translation-profile OUTGOING-PSTN
translate called 1
!
!
!
!
!
!
username cisco privilege 15 password 0 cisco
username fax privilege 15 password 0 fax123
!
!
!
!
!
interface FastEthernet0/0
ip address 172.25.53.53 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1/0
no ip address
shutdown
clock rate 2000000
!
interface Serial0/1/1
no ip address
shutdown
clock rate 2000000
!
interface ATM0/2/0
no ip address
shutdown
no atm ilmi-keepalive
dsl operating-mode auto
!
ip default-gateway 172.25.53.254
ip route 0.0.0.0 0.0.0.0 172.25.53.254
!
!
ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
voice-port 0/0/0
trunk-group PSTN
connection plar opx 71750143
caller-id enable
!
voice-port 0/0/1
!
voice-port 0/0/2
!
voice-port 0/0/3
!
!
!
!
!
dial-peer voice 1 pots
trunkgroup PSTN
translation-profile outgoing OUTGOING-PSTN
preference 2
destination-pattern .T
no digit-strip
forward-digits all
!
dial-peer voice 38 voip
preference 1
destination-pattern .T
session protocol sipv2
session target ipv4:172.25.53.27
session transport udp
dtmf-relay h245-signal
codec g711alaw
fax rate 14400
fax protocol t38 ls-redundancy 0 hs-redundancy 0 fallback pass-through g711alaw
no vad
!
!
sip-ua
retry options 0
registrar ipv4:172.25.53.27 expires 3600
!
!
telephony-service
max-ephones 10
max-dn 10
ip source-address 172.25.53.53 port 2000
auto assign 1 to 1
max-conferences 8 gain -6
transfer-system full-consult
!
!
line con 0
password 123456
login
line aux 0
line vty 0 4
password 123456
login
!
scheduler allocate 20000 1000
end

 

############received error from sip debug on router:


*May 23 14:57:39.843: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
SIP/2.0 405 Method Not Allowed
CSeq: 57 REGISTER
Via: SIP/2.0/UDP 172.25.53.53:5060;branch=z9hG4bK41940
From: <sip:.*@172.25.53.27>;tag=97C140-5D8
Call-ID: 52B263B1-E1AA11E3-8002DBCE-F88ED737
To: <sip:.*@172.25.53.27>
Contact: <sip:.*@172.25.53.27>
Allow: INVITE,ACK,OPTIONS,BYE,CANCEL,SUBSCRIBE,NOTIFY,REFER,MESSAGE,INFO,PING,PRACK
Content-Length: 0

Everyone's tags (1)
2 REPLIES
Cisco Employee

Hello Can you please paste

Hello

 

Can you please paste complete trace.


Br,
Nadeem

Br, Nadeem Please rate all useful post.
New Member

Thank you nadeem for your

Thank you nadeem for your reply! so kind of you!

well here is the last trace resulting from my last out call attempt:

 

 

*May 23 16:21:40.046: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
SIP/2.0 405 Method Not Allowed
CSeq: 85 REGISTER
Via: SIP/2.0/UDP 172.25.53.53:5060;branch=z9hG4bK5D14AA
From: <sip:.*@172.25.53.27>;tag=E4A990-200C
Call-ID: 52B263B1-E1AA11E3-8002DBCE-F88ED737
To: <sip:.*@172.25.53.27>
Contact: <sip:.*@172.25.53.27>
Allow: INVITE,ACK,OPTIONS,BYE,CANCEL,SUBSCRIBE,NOTIFY,REFER,MESSAGE,INFO,PING,PRACK
Content-Length: 0

 

*May 23 16:24:40.046: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
REGISTER sip:172.25.53.27:5060 SIP/2.0
Via: SIP/2.0/UDP 172.25.53.53:5060;branch=z9hG4bK5E169F
From: <sip:.*@172.25.53.27>;tag=E768B4-1106
To: <sip:.*@172.25.53.27>
Date: Fri, 23 May 2014 16:24:40 GMT
Call-ID: 52B263B1-E1AA11E3-8002DBCE-F88ED737
User-Agent: Cisco-SIPGateway/IOS-12.x
Max-Forwards: 70
Timestamp: 1400862280
CSeq: 86 REGISTER
Contact: <sip:.*@172.25.53.53:5060>
Expires:  3600
Content-Length: 0

 

*May 23 16:24:40.054: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
SIP/2.0 405 Method Not Allowed
CSeq: 86 REGISTER
Via: SIP/2.0/UDP 172.25.53.53:5060;branch=z9hG4bK5E169F
From: <sip:.*@172.25.53.27>;tag=E768B4-1106
Call-ID: 52B263B1-E1AA11E3-8002DBCE-F88ED737
To: <sip:.*@172.25.53.27>
Contact: <sip:.*@172.25.53.27>
Allow: INVITE,ACK,OPTIONS,BYE,CANCEL,SUBSCRIBE,NOTIFY,REFER,MESSAGE,INFO,PING,PRACK
Content-Length: 0

 

*May 23 16:27:40.054: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
REGISTER sip:172.25.53.27:5060 SIP/2.0
Via: SIP/2.0/UDP 172.25.53.53:5060;branch=z9hG4bK5FDFB
From: <sip:.*@172.25.53.27>;tag=EA27DC-ADE
To: <sip:.*@172.25.53.27>
Date: Fri, 23 May 2014 16:27:40 GMT
Call-ID: 52B263B1-E1AA11E3-8002DBCE-F88ED737
User-Agent: Cisco-SIPGateway/IOS-12.x
Max-Forwards: 70
Timestamp: 1400862460
CSeq: 87 REGISTER
Contact: <sip:.*@172.25.53.53:5060>
Expires:  3600
Content-Length: 0

 

*May 23 16:27:40.058: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
SIP/2.0 405 Method Not Allowed
CSeq: 87 REGISTER
Via: SIP/2.0/UDP 172.25.53.53:5060;branch=z9hG4bK5FDFB
From: <sip:.*@172.25.53.27>;tag=EA27DC-ADE
Call-ID: 52B263B1-E1AA11E3-8002DBCE-F88ED737
To: <sip:.*@172.25.53.27>
Contact: <sip:.*@172.25.53.27>
Allow: INVITE,ACK,OPTIONS,BYE,CANCEL,SUBSCRIBE,NOTIFY,REFER,MESSAGE,INFO,PING,PRACK
Content-Length: 0


As for my t38modem log file it is as follows:

2014/05/23 18:05:13.630     Housekeeper:0xafbffb40    OpalUDP    Setting interface to 172.25.53.27%eth0
2014/05/23 18:05:17.628     Housekeeper:0xafbffb40    SIP    INVITE transaction id=z9hG4bK44ea0005-0ae1-e311-9c37-a0b3cc744299 timeout, making retry 9, timeout 4.000, state 1
2014/05/23 18:05:17.629     Housekeeper:0xafbffb40    SIP    Sending PDU (1170 bytes) to: rem=udp$172.25.53.53:5060,local=udp$172.25.53.27:5060,if=172.25.53.27%eth0
INVITE sip:55204101@172.25.53.53 SIP/2.0
CSeq: 1 INVITE
Via: SIP/2.0/UDP 172.25.53.27:5060;branch=z9hG4bK44ea0005-0ae1-e311-9c37-a0b3cc744299;rport
User-Agent: T38Modem/2.0.0
From: "root" <sip:T38modem@172.25.53.27>;tag=706bfe04-0ae1-e311-9c37-a0b3cc744299
Call-ID: a888fe04-0ae1-e311-9c37-a0b3cc744299@hatem-HP-Pavilion-g6-Notebook-PC
Supported: 100rel,replaces
Organization: Vyacheslav Frolov
To: <sip:55204101@172.25.53.53>
Contact: "root" <sip:T38modem@172.25.53.27>
Allow: INVITE,ACK,OPTIONS,BYE,CANCEL,SUBSCRIBE,NOTIFY,REFER,MESSAGE,INFO,PING,PRACK
Content-Length: 532
Content-Type: application/sdp
Max-Forwards: 70

v=0
o=- 1400864690 1 IN IP4 172.25.53.27
s=T38Modem/2.0.0
c=IN IP4 172.25.53.27
t=0 0
m=audio 5004 RTP/AVP 123 3 118 119 120 121 0 8 106 102 116 101
a=sendrecv
a=rtpmap:123 AMR/8000/1
a=rtpmap:3 gsm/8000/1
a=rtpmap:118 G726-40/8000/1
a=rtpmap:119 G726-32/8000/1
a=rtpmap:120 G726-24/8000/1
a=rtpmap:121 G726-16/8000/1
a=rtpmap:0 PCMU/8000/1
a=rtpmap:8 PCMA/8000/1
a=rtpmap:106 lpc10/8000/1
a=rtpmap:102 SILK/8000/1
a=rtpmap:116 Speex/8000/1
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-16,32,36
a=maxptime:22

2014/05/23 18:05:17.630     Housekeeper:0xafbffb40    OpalUDP    Setting interface to 172.25.53.27%eth0
2014/05/23 18:05:21.630     Housekeeper:0xafbffb40    SIP    Set state Terminated_RetriesExceeded for INVITE transaction id=z9hG4bK44ea0005-0ae1-e311-9c37-a0b3cc744299
2014/05/23 18:05:21.631     Housekeeper:0xafbffb40    SIP    Transaction 1 INVITE sip:55204101@172.25.53.53 failed, unknown handler, ID: a888fe04-0ae1-e311-9c37-a0b3cc744299@hatem-HP-Pavilion-g6-Notebook-PC
2014/05/23 18:05:21.631     Housekeeper:0xafbffb40    SIP    OnTransactionFailed for transaction id=z9hG4bK44ea0005-0ae1-e311-9c37-a0b3cc744299
2014/05/23 18:05:21.631     Housekeeper:0xafbffb40    SIP    Checking for all forked INVITEs failing.
2014/05/23 18:05:21.631     Housekeeper:0xafbffb40    OpalCon    SetPhase from SetUpPhase to ReleasingPhase for Call[C1980ed4f4]-EP<sip>[706bfe04-0ae1-e311-9c37-a0b3cc744299]
2014/05/23 18:05:21.631     Housekeeper:0xafbffb40    OpalCon    Releasing asynchronously Call[C1980ed4f4]-EP<sip>[706bfe04-0ae1-e311-9c37-a0b3cc744299]
2014/05/23 18:05:21.632     Housekeeper:0xafbffb40    PTLib    Created thread 0xafd02518 OnRelease
2014/05/23 18:05:21.632     Housekeeper:0xafbffb40    SIP    Completed state for transaction id=z9hG4bK44ea0005-0ae1-e311-9c37-a0b3cc744299
2014/05/23 18:05:21.632       OnRelease:0xafb3cb40    PTLib    Started thread 0xafd02518 (14334) OnRelease:0xafb3cb40
2014/05/23 18:05:21.632       OnRelease:0xafb3cb40    OpalCon    Call end reason for Call[C1980ed4f4]-EP<sip>[706bfe04-0ae1-e311-9c37-a0b3cc744299] set to EndedByOffline
2014/05/23 18:05:21.632       OnRelease:0xafb3cb40    SIP    OnReleased: Call[C1980ed4f4]-EP<sip>[706bfe04-0ae1-e311-9c37-a0b3cc744299]
2014/05/23 18:05:21.632       OnRelease:0xafb3cb40    SIP    Cancelling 0 transactions.
2014/05/23 18:05:21.633       OnRelease:0xafb3cb40    OpalCon    OnReleased Call[C1980ed4f4]-EP<sip>[706bfe04-0ae1-e311-9c37-a0b3cc744299]
2014/05/23 18:05:21.633       OnRelease:0xafb3cb40    OpalCon    Media streams closed.
2014/05/23 18:05:21.633       OnRelease:0xafb3cb40    OpalEP    OnReleased Call[C1980ed4f4]-EP<sip>[706bfe04-0ae1-e311-9c37-a0b3cc744299]
2014/05/23 18:05:21.634       OnRelease:0xafb3cb40    OpalMan    OnReleased Call[C1980ed4f4]-EP<sip>[706bfe04-0ae1-e311-9c37-a0b3cc744299]
2014/05/23 18:05:21.634       OnRelease:0xafb3cb40    Call    OnReleased Call[C1980ed4f4]-EP<sip>[706bfe04-0ae1-e311-9c37-a0b3cc744299]
2014/05/23 18:05:21.634       OnRelease:0xafb3cb40    OpalCon    SetPhase from SetUpPhase to ReleasingPhase for Call[C1980ed4f4]-EP<modem>[modem:/C1980ed4f4/0]
2014/05/23 18:05:21.634       OnRelease:0xafb3cb40    OpalCon    Releasing Call[C1980ed4f4]-EP<modem>[modem:/C1980ed4f4/0]
2014/05/23 18:05:21.634       OnRelease:0xafb3cb40    OpalCon    Call end reason for Call[C1980ed4f4]-EP<modem>[modem:/C1980ed4f4/0] set to EndedByOffline
2014/05/23 18:05:21.634       OnRelease:0xafb3cb40    ModemConnection::OnReleased Call[C1980ed4f4]-EP<modem>[modem:/C1980ed4f4/0]
2014/05/23 18:05:21.635       OnRelease:0xafb3cb40    OpalCon    OnReleased Call[C1980ed4f4]-EP<modem>[modem:/C1980ed4f4/0]
2014/05/23 18:05:21.635       OnRelease:0xafb3cb40    OpalCon    Media streams closed.
2014/05/23 18:05:21.635       OnRelease:0xafb3cb40    OpalEP    OnReleased Call[C1980ed4f4]-EP<modem>[modem:/C1980ed4f4/0]
2014/05/23 18:05:21.635       OnRelease:0xafb3cb40    OpalMan    OnReleased Call[C1980ed4f4]-EP<modem>[modem:/C1980ed4f4/0]
2014/05/23 18:05:21.635       OnRelease:0xafb3cb40    Call    OnReleased Call[C1980ed4f4]-EP<modem>[modem:/C1980ed4f4/0]
2014/05/23 18:05:21.636       OnRelease:0xafb3cb40    Call[C1980ed4f4] cleared (EndedByOffline)
2014/05/23 18:05:21.636       OnRelease:0xafb3cb40    OpalMan    OnClearedCall Call[C1980ed4f4] from "modem:" to "sip:55204101@172.25.53.53"
2014/05/23 18:05:21.636       OnRelease:0xafb3cb40    OpalCon    SetPhase from ReleasingPhase to ReleasedPhase for Call[C1980ed4f4]-EP<modem>[modem:/C1980ed4f4/0]
2014/05/23 18:05:21.636       OnRelease:0xafb3cb40    OpalCon    Connection Call[C1980ed4f4]-EP<modem>[modem:/C1980ed4f4/0] released
        Initial Time: Fri, 23 May 2014 18:04:50 +01:00
          SetUpPhase: 0.000
     ProceedingPhase: N/A
       AlertingPhase: N/A
      ConnectedPhase: N/A
    EstablishedPhase: N/A
     ForwardingPhase: N/A
      ReleasingPhase: 31.541
       ReleasedPhase: 31.543
     Call end reason: EndedByOffline

2014/05/23 18:05:21.636       OnRelease:0xafb3cb40    OpalCon    SetPhase from ReleasingPhase to ReleasedPhase for Call[C1980ed4f4]-EP<sip>[706bfe04-0ae1-e311-9c37-a0b3cc744299]
2014/05/23 18:05:21.637       OnRelease:0xafb3cb40    OpalCon    Connection Call[C1980ed4f4]-EP<sip>[706bfe04-0ae1-e311-9c37-a0b3cc744299] released
        Initial Time: Fri, 23 May 2014 18:04:50 +01:00
          SetUpPhase: 0.021
     ProceedingPhase: N/A
       AlertingPhase: N/A
      ConnectedPhase: N/A
    EstablishedPhase: N/A
     ForwardingPhase: N/A
      ReleasingPhase: 31.536
       ReleasedPhase: 31.541
     Call end reason: EndedByOffline

2014/05/23 18:05:21.637       OnRelease:0xafb3cb40    OpalCon    OnRelease thread completed for Call[C1980ed4f4]-EP<sip>[706bfe04-0ae1-e311-9c37-a0b3cc744299]
2014/05/23 18:05:21.637       OnRelease:0xafb3cb40    PTLib    Thread ended: name="OnRelease:0xafb3cb40", real=0.005, kernel=0.000 (0%), user=0.000 (0%), both=0.000 (0%)
2014/05/23 18:05:21.637       OnRelease:0xafb3cb40    PTLib    Destroyed thread 0xafd02518 OnRelease:0xafb3cb40(id = afb3cb40)
2014/05/23 18:05:22.193    Opal Garbage:0xb03f9b40    ModemConnection::~ModemConnection Call[C1980ed4f4]-EP<modem>[modem:/C1980ed4f4/0] EndedByOffline
2014/05/23 18:05:22.193    Opal Garbage:0xb03f9b40    PseudoModemQ::Enqueue ttyT38
2014/05/23 18:05:22.193    Opal Garbage:0xb03f9b40    ModemEngineBody::Request: stConnectWait request={
calltoken=modem:/C1980ed4f4/0
command=clearcall
}
2014/05/23 18:05:22.193    Opal Garbage:0xb03f9b40    ModemEngineBody::SetCallState: off-hook cstReleasing.0 stConnectWait
2014/05/23 18:05:22.194    Opal Garbage:0xb03f9b40    ModemEngineBody::OnTimerCallback stConnectWait Timeout 1
2014/05/23 18:05:22.194    Opal Garbage:0xb03f9b40    ttyT38 AudioEngine AudioEngine
2014/05/23 18:05:22.194    Opal Garbage:0xb03f9b40    ttyT38 AudioEngine Attach
2014/05/23 18:05:22.194    Opal Garbage:0xb03f9b40    ttyT38 AudioEngine OnAttach Attached
2014/05/23 18:05:22.194    Opal Garbage:0xb03f9b40    ttyT38 AudioEngine OnResetModemState
2014/05/23 18:05:22.194    Opal Garbage:0xb03f9b40    ttyT38 AudioEngine ChangeModemClass to mcFax
2014/05/23 18:05:22.194    Opal Garbage:0xb03f9b40    ttyT38 AudioEngine OnChangeModemClass to mcFax
2014/05/23 18:05:22.194    Opal Garbage:0xb03f9b40    ttyT38 AudioEngine SendOnIdle dtNone
2014/05/23 18:05:22.194    Opal Garbage:0xb03f9b40    ModemEngineBody::_AttachEngine Attached mceAudio
2014/05/23 18:05:22.194    Opal Garbage:0xb03f9b40    ttyT38 AudioEngine RecvOnIdle dtBusy
2014/05/23 18:05:22.195    ttyT38(e):...0xaffffb40    ModemEngineBody::SetCallSubState: off-hook cstReleasing.1 stConnectWait
2014/05/23 18:05:22.195    Opal Garbage:0xb03f9b40    OpalCon    Connection Call[C1980ed4f4]-EP<modem>[modem:/C1980ed4f4/0] destroyed.
2014/05/23 18:05:22.195    ttyT38(e):...0xaffffb40    ttyT38 AudioEngine Detach
2014/05/23 18:05:22.195    ttyT38(e):...0xaffffb40    ttyT38 AudioEngine OnChangeModemClass to mcUndefined
2014/05/23 18:05:22.195    ttyT38(e):...0xaffffb40    ttyT38 AudioEngine OnDetach Detached
2014/05/23 18:05:22.195    ttyT38(e):...0xaffffb40    ttyT38 AudioEngine OnResetModemState
2014/05/23 18:05:22.195    ttyT38(e):...0xaffffb40    ttyT38 AudioEngine ~AudioEngine
2014/05/23 18:05:22.196    ttyT38(e):...0xaffffb40    ModemEngineBody::_DetachEngine Detached mceAudio
2014/05/23 18:05:22.196    ttyT38(e):...0xaffffb40    ModemEngineBody::OnHook: on-hook cstReleasing.1 stCommand
2014/05/23 18:05:22.196    ttyT38(e):...0xaffffb40    ModemEngineBody::SetCallState: on-hook cstCleared stCommand
2014/05/23 18:05:22.196    ttyT38(e):...0xaffffb40    <--  {
  0d 0a 42 55 53 59 0d 0a                            ..BUSY.. }
2014/05/23 18:05:22.197    Opal Garbage:0xb03f9b40    RTP    Deleting session 1
2014/05/23 18:05:22.197    Opal Garbage:0xb03f9b40    RTPEp    Session 1, forgetting local RTP port 5004 on connection Call[C1980ed4f4]-EP<sip>[706bfe04-0ae1-e311-9c37-a0b3cc744299]
2014/05/23 18:05:22.197    Opal Garbage:0xb03f9b40    RTP_UDP    Session 1, Shutting down read.
2014/05/23 18:05:22.197    Opal Garbage:0xb03f9b40    RTP_UDP    Session 1, shutting down write.
2014/05/23 18:05:22.198    Opal Garbage:0xb03f9b40    SIP    Transaction id=z9hG4bK44ea0005-0ae1-e311-9c37-a0b3cc744299 destroyed.
2014/05/23 18:05:22.198    Opal Garbage:0xb03f9b40    SIP    Deleting connection.
2014/05/23 18:05:22.198    Opal Garbage:0xb03f9b40    SIP    Setting new transport for destination ""
2014/05/23 18:05:22.198    Opal Garbage:0xb03f9b40    Opal    Transport clean up on termination
2014/05/23 18:05:22.199    Opal Garbage:0xb03f9b40    Opal    Transport Close
2014/05/23 18:05:22.199    Opal Garbage:0xb03f9b40    Opal    Transport clean up on termination
2014/05/23 18:05:22.199    Opal Garbage:0xb03f9b40    Opal    Transport Close
2014/05/23 18:05:22.199    Opal Garbage:0xb03f9b40    Opal    Deleted transport udp$172.25.53.53:5060<if=udp$172.25.53.27:5060>
2014/05/23 18:05:22.200    Opal Garbage:0xb03f9b40    OpalCon    Connection Call[C1980ed4f4]-EP<sip>[706bfe04-0ae1-e311-9c37-a0b3cc744299] destroyed.
2014/05/23 18:05:23.201    Opal Garbage:0xb03f9b40    Call    Destroyed Call[C1980ed4f4]


Any help would be appreciated! I am runnig out of Time :/

303
Views
0
Helpful
2
Replies