Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

T1 to FXS Configuration Question: Dial-peer's okay?

I have  an issue, I'm getting a fast-busy when I call from 555-6002 to 555-5028.  Where am I going wrong with this?

  • Calls work from 555-6002 to 555-5000 
  • Calls work from 555-5028 to 555-6002
  • Calls Fail from 555-6002 to 555-5028

ephone-dn  1  dual-line
 number 5000 secondary 5555000
 name Sara Driscoll

 


dial-peer voice 1 pots
 destination-pattern 5555028
 port 0/3/1
!

dial-peer voice 3 pots
 incoming called-number 5555...
 direct-inward-dial
 port 0/2/0:23
!
dial-peer voice 2 pots
 destination-pattern 555[4,5,6]...
 port 0/2/0:23
 forward-digits all

 

 

 

 

FULL CONFIG

 

! Last configuration change at 15:12:39 UTC Tue Sep 30 2014
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname RouterVOIP1
!
boot-start-marker
boot-end-marker
!
!
card type t1 0 2
!
no aaa new-model
!
memory-size iomem 5
network-clock-participate wic 2
!
dot11 syslog
ip source-route
!
!
ip cef
!
ip dhcp excluded-address 10.15.0.1 10.15.0.10
!
ip dhcp pool Voice
 network 10.15.0.0 255.255.255.0
 default-router 10.15.0.1
 option 150 ip 10.15.0.1
!
!
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
isdn switch-type primary-ni
!
!
!
!
!
!
!
voice-card 0
!
crypto pki token default removal timeout 0
!
!
!
!
license udi pid CISCO2811 sn FTX1151A3PR
username class privilege 15 password 0 cisco
!
redundancy
!
!
controller T1 0/2/0
 cablelength long 0db
 pri-group timeslots 1-8,24
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.1
 encapsulation dot1Q 1
 ip address 10.1.0.1 255.255.255.0
!
interface FastEthernet0/0.10
 encapsulation dot1Q 10 native
 ip address 10.10.0.1 255.255.255.0
!
interface FastEthernet0/0.15
 encapsulation dot1Q 15
 ip address 10.15.0.1 255.255.255.0
!
interface Service-Engine0/0
 no ip address
 shutdown
!
interface FastEthernet0/1
 ip address 172.20.0.1 255.255.255.0
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0/0
 no ip address
 shutdown
 no fair-queue
 clock rate 2000000
!
interface Serial0/0/1
 no ip address
 shutdown
 clock rate 2000000
!
interface Serial0/2/0:23
 no ip address
 encapsulation hdlc
 isdn switch-type primary-ni
 isdn incoming-voice voice
 no cdp enable
!
!
router eigrp 100
 network 10.0.0.0
!
ip forward-protocol nd
ip http server
ip http authentication local
no ip http secure-server
!
!
!
!
!
!
!
!
tftp-server flash:CME_8.6/cmterm-7940-7960-sccp.8-1-2/P00308010200.bin alias P00308010200.bin
tftp-server flash:CME_8.6/cmterm-7940-7960-sccp.8-1-2/P00308010200.loads alias P00308010200.loads
tftp-server flash:CME_8.6/cmterm-7940-7960-sccp.8-1-2/P00308010200.sb2 alias P00308010200.sb2
tftp-server flash:CME_8.6/cmterm-7940-7960-sccp.8-1-2/P00308010200.sbn alias P00308010200.sbn
tftp-server flash:CME_8.6/ringtones/DistinctiveRingList.xml alias DistinctiveRingList.xml
tftp-server flash:CME_8.6/ringtones/RingList.xml alias RingList.xml
tftp-server flash:CME_8.6/ringtones/Jamaica.raw alias Jamaica.raw
tftp-server flash:CME_8.6/music-on-hold.au alias music-on-hold.au
tftp-server flash:CME_8.6/ringtones/Classic1.raw alias Classic1.raw
tftp-server flash:CME_8.6/ringtones/Drums1.raw alias Drums1.raw
tftp-server flash:CME_8.6/ringtones/Piano1.raw alias Piano1.raw
tftp-server flash:CME_8.6/ringtones/KotoEffect.raw alias KotoEffect.raw
tftp-server flash:CME_8.6/ringtones/AreYouThere.raw alias AreYouThere.raw
!
control-plane
!
!
voice-port 0/2/0:23
!
voice-port 0/1/0
 ring number 2
!
voice-port 0/1/1
!
voice-port 0/3/0
!
voice-port 0/3/1
!
voice-port 0/3/2
!
voice-port 0/3/3
!
!
!
mgcp profile default
!
!
dial-peer voice 1 pots
 destination-pattern 5555028
 port 0/3/1
!
dial-peer voice 3 pots
 incoming called-number 5555...
 direct-inward-dial
 port 0/2/0:23
!
dial-peer voice 2 pots
 destination-pattern 555[4,5,6]...
 port 0/2/0:23
 forward-digits all
!
!
!
!
telephony-service
 max-ephones 10
 max-dn 40
 ip source-address 10.15.0.1 port 2000
 load 7960-7940 P00308010200
 keepalive 10
 max-conferences 8 gain -6
 transfer-system full-consult
 create cnf-files version-stamp Jan 01 2002 00:00:00
!
!
ephone-dn  1  dual-line
 number 5000 secondary 5555000
 name Sara Driscoll
!
!
ephone-dn  2  dual-line
 number 5001
 name Jenny Parker
!
!
ephone  1
 device-security-mode none
 mac-address 001F.6C7F.973B
 button  1:1
!
!
!
ephone  2
 device-security-mode none
 mac-address 001F.6C80.FDE9
 button  1:2
!
!
!
!
line con 0
 logging synchronous
line aux 0
line 194
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
line vty 0 4
 login
 transport input all
!
scheduler allocate 20000 1000
end

 

  • IP Telephony
1 ACCEPTED SOLUTION

Accepted Solutions

Hi.Please activate a debug

Hi.

Please activate a debug voice ccapi inout, test the failing call and post the output

Thanks

 

 

Regards

 

Carlo

Please rate all helpful posts "The more you help the more you learn"
6 REPLIES
Green

Hi,Can you try mod in your

Hi,

Can you try mod in your existing DP 3 pots
EXISTS
!
dial-peer voice 3 pots
 incoming called-number 5555...
 direct-inward-dial
 port 0/2/0:23
!

MODIFY

!
dial-peer voice 3 pots
desc *** MATCH INCOMING CALLS ***
no incoming called-number 5555...
 incoming called-number 555....
 direct-inward-dial
 port 0/2/0:23
!

Regards
Alex

Regards, Alex. Please rate useful posts.
New Member

Thank you for the reply and

Thank you for the reply and trying to help me out, I really appreciate it.  I"m still racking my brain.

 

Based on the commands below it seems the dial-peers are okay.  I wonder if its the T-1, but that appears okay too.

 

 

lobal ISDN Switchtype = primary-ni
ISDN Serial0/2/0:23 interface
        dsl 0, interface ISDN Switchtype = primary-ni
    Layer 1 Status:
        ACTIVE
    Layer 2 Status:
        TEI = 0, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
    Layer 3 Status:
        0 Active Layer 3 Call(s)
    Active dsl 0 CCBs = 0
    The Free Channel Mask:  0x800000FF
    Number of L2 Discards = 0, L2 Session ID = 3
    Total Allocated ISDN CCBs = 0

 

Hi.Please activate a debug

Hi.

Please activate a debug voice ccapi inout, test the failing call and post the output

Thanks

 

 

Regards

 

Carlo

Please rate all helpful posts "The more you help the more you learn"
Green

Hi,The dial peer in the

Hi,

The dial peer in the config for 5555028 shows as :-

!
dial-peer voice 1 pots
 destination-pattern 5555028
 port 0/3/1 <------------------------------------------------ VP 0/3/1 ???
!


But look at the "show dial peer voice summary" ouput

1 pots up up 5555028 0 up 0/3/0 <----------------------------- VP 0/3/0 ???

Can you recheck the config which port is correct ???

Regards
Alex

Regards, Alex. Please rate useful posts.
New Member

Thanks for the reply, I had a

Hi Alex, 

Thank for your the reply, I had a different FXS card that I swapped out with the output.  FXS 0/3/0 is the correct port, I'll reflect that change in the drawing. 

New Member

Carlo, thank you for your

Carlo, thank you for your reply.   That helped me out a great deal.   When debugging "debug voice ccapi inout"  it yielded no results which had me thinking...that isn't right.  

Through further investigation I found that the PBX was to blame "Bad Adtan PBX!" 

 

I'll raise the issue with Adtran.

 

54
Views
0
Helpful
6
Replies