Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Telephony Question - Call Manager & SRST Router

I am currently in the process of designing a setup that has me a little stumped. 

Company A: - My current employer

Company B: - Another company to reside in our bldg

SCENARIO: 

My company will be leasing a desk to another company within one of our buildings.  This company (Company B) will require a phone that will reside on our Cisco Call Manager (4 digit dialing), but will require dedicated analog line for all outbound calls to show Caller ID as Company B.

I currently have an SRST router at this site with a 2 port FXO module in place where if 911 is dialed, it automatically goes out the SRST Router at that facility. 

I plan on purchasing another 2 port FXO module for all calls from Company B to dial out of this SRST Router. 

I am a little stumped on Call Manager Configurations as well as SRST router configuration.

I have configured the following on the Call Manager:

CompanyB_PT - Partition                  

CompanyB_CSS - Calling Search Space (Selected Partitions:  CompanyB_PT)

CompanyB_RG - Route Group (I have the SRST router at CompanyA as selected device)

CompanyB_RL - Route List (CompanyB_RG as selected route group)

6.1[2-9]XX[2-9]XXXXXX - Route Pattern LD (Partition:  CompanyB_PT & Associated Dece:  CompanyB_RL) - dial 6 for outside line

6.[2-9]XXXXXX - Route Pattern Local (Partition:  CompanyB_PT & Associated Device:  CompanyB_RL) - dial 6 for outside line

I have a phone setup on the voice lan at that facility and member of CompanyB_CSS.  I'm just wanting to see any "outside line" routed to the SRST router.  but I get the attendant "your call cannot be completed" message.  I am not very diversed on the voice side.  Any help is appreciated.

NetworkLayout.jpg


Thanks

5 REPLIES
Hall of Fame Super Silver

Telephony Question - Call Manager & SRST Router

Are you using MGCP or H323/SIP to control the GW?

Have you looked at Dialed Number analyzer?

Chris

New Member

Telephony Question - Call Manager & SRST Router

I am honestly not sure on MGCP or H323 as I didn’t setup the SRST router and it is solely for 911 purposes right now.  Is there a quick CLI command that can output the MGCP or H323 configuration as I do not see either in the config.

Hall of Fame Super Silver

Telephony Question - Call Manager & SRST Router

Provide "sh run" from it.

Use DNA to determine if this is a CUCM issue.

Chris

New Member

Telephony Question - Call Manager & SRST Router

Here is the Running Config on the SRST Router from the topology.

Current configuration : 5648 bytes

version 15.0
service timestamps debug datetime msec
service timestamps log datetime
service password-encryption
!
hostname CompanyA_SRST
!
boot-start-marker
boot-end-marker
!
enable secret 5 <......>
!
aaa new-model
!
!
aaa authentication login default group tacacs+ local
aaa authentication login localport line
aaa authentication enable default group tacacs+ enable
aaa authorization exec localport none
aaa accounting exec default
action-type start-stop
group tacacs+
!
aaa accounting commands 15 default
action-type stop-only
group tacacs+
!
!
!
!
!
!
aaa session-id common
!
!
!
clock timezone EST -5
clock summer-time EDT recurring
!
no ipv6 cef
ip source-route
ip cef
!
!
ip dhcp excluded-address 10.20.8.1 10.20.8.99
!
ip dhcp pool CompanyA_Voice
   network 10.20.8.0 255.255.255.0
   default-router 10.20.8.1
   dns-server 172.20.1.6 172.20.1.40
   domain-name CompanyA.com
   option 150 ip 10.20.1.10 10.20.9.10
!
!
ip domain name raocala.com
!
multilink bundle-name authenticated
!
!
!
!
!
!
trunk group FXO
!
!
!
voice-card 0
!
!
voice call send-alert
voice rtp send-recv
!
voice class codec 9999
codec preference 1 g711ulaw
codec preference 2 g729r8
codec preference 3 g729br8
!
voice class h323 8888
  h225 timeout tcp establish 3
!
!
!
!
license udi pid CISCO2911/K9 sn FTX1520AL78
hw-module pvdm 0/0
!
!
!
username privilege 15 password 7 <......>
username privilege 15 password 7 <......>
!
redundancy
!
!
ip ssh version 2
!
!
!
!
!
!
!
interface GigabitEthernet0/0
description CompanyA Voice VLAN
ip address 10.20.8.2 255.255.255.0
duplex auto
speed auto
!
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
!
interface GigabitEthernet0/2
no ip address
shutdown
duplex auto
speed auto
!
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 10.20.8.1
!
logging facility local6
logging 172.20.1.79
!
!
!
!
!
snmp-server community raoread RO
snmp-server location CompanyA
snmp-server contact CompanyA
snmp-server enable traps snmp linkdown linkup coldstart warmstart
snmp-server enable traps vrrp
snmp-server enable traps ds1
snmp-server enable traps eigrp
snmp-server enable traps ospf state-change
snmp-server enable traps ospf errors
snmp-server enable traps ospf retransmit
snmp-server enable traps ospf lsa
snmp-server enable traps ospf cisco-specific state-change nssa-trans-change
snmp-server enable traps ospf cisco-specific state-change shamlink interface-old
snmp-server enable traps ospf cisco-specific state-change shamlink neighbor
snmp-server enable traps ospf cisco-specific errors
snmp-server enable traps ospf cisco-specific retransmit
snmp-server enable traps ospf cisco-specific lsa
snmp-server enable traps envmon
snmp-server enable traps flash insertion removal
snmp-server enable traps ds3
snmp-server enable traps icsudsu
snmp-server enable traps isdn layer2
snmp-server enable traps isdn ietf
snmp-server enable traps ds0-busyout
snmp-server enable traps ds1-loopback
snmp-server enable traps atm subif
snmp-server enable traps cnpd
snmp-server enable traps entity
snmp-server enable traps event-manager
snmp-server enable traps frame-relay multilink bundle-mismatch
snmp-server enable traps frame-relay
snmp-server enable traps frame-relay subif
snmp-server enable traps hsrp
snmp-server enable traps ipmulticast
snmp-server enable traps msdp
snmp-server enable traps mvpn
snmp-server enable traps pim neighbor-change rp-mapping-change invalid-pim-message
snmp-server enable traps pppoe
snmp-server enable traps cpu threshold
snmp-server enable traps rsvp
snmp-server enable traps l2tun session
snmp-server enable traps vtp
snmp-server enable traps ipsla
snmp-server enable traps isakmp policy add
snmp-server enable traps isakmp policy delete
snmp-server enable traps isakmp tunnel start
snmp-server enable traps isakmp tunnel stop
snmp-server enable traps ipsec cryptomap add
snmp-server enable traps ipsec cryptomap delete
snmp-server enable traps ipsec cryptomap attach
snmp-server enable traps ipsec cryptomap detach
snmp-server enable traps ipsec tunnel start
snmp-server enable traps ipsec tunnel stop
snmp-server enable traps ipsec too-many-sas
tacacs-server host 172.20.0.15
tacacs-server host 172.20.0.16
tacacs-server directed-request
tacacs-server key 7 <.........>
!
control-plane
!
!
!
voice-port 0/0/0
trunk-group FXO
bearer-cap Speech
!
voice-port 0/0/1
trunk-group FXO
bearer-cap Speech
!
!
!
!
dial-peer voice 1 pots
incoming called-number .
direct-inward-dial
port 0/0/1
!
dial-peer voice 2 pots
incoming called-number .
direct-inward-dial
port 0/0/0
!
dial-peer voice 3 pots
trunkgroup FXO
destination-pattern 911
incoming called-number .
forward-digits 3
!
dial-peer voice 4 pots
trunkgroup FXO
destination-pattern 911
incoming called-number .
forward-digits 3
!
!
!
!
gatekeeper
shutdown
!
!
call-manager-fallback
max-conferences 8 gain -6
transfer-system full-consult
ip source-address 10.20.8.2 port 2000
max-ephones 15
max-dn 30 dual-line
time-zone 12
!
banner motd ^C ... ^C
!
line con 0
line aux 0
line vty 0 4
transport input ssh
!
scheduler allocate 20000 1000
ntp server 172.20.1.1 prefer
end

Hall of Fame Super Silver

Telephony Question - Call Manager & SRST Router

The GW is not configured with any protocol, it is only SRST GW. You need to add h323 configuration to the GW as well as add H323 to CUCM and point the Route Group to it.

You also only have 911 dial peers, so you will need to add other dial peers that allow other routing.

If you have never performe such a configuration I strongly suggest you hire a professional to assist you.

HTH, please rate all useful posts!

Chris

1059
Views
4
Helpful
5
Replies