Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Time on phone


I'm having problems with the time on the display on my phone's

I'm using CCME 4.3 with 7941 and 7961 phones.

Time on 2851 is synced via NTP and system time and time zone result in the correct time

I also set the timezone on the telephony service but whatever I do my time on the phone's stay's 2 hours off

Phones are running on version 8-3-2-27.

What am I missing ?

And is there a way to check the "telephony service" time ?


New Member

Re: Time on phone

After making all these changes, have you reset the phone itself?

New Member

Re: Time on phone


created manualy the CNF files and powered phone off and on again.

Didn't do the trick

Hall of Fame Super Gold

Re: Time on phone

This can due to bugs in phone FW.

I run latest 8.2 on 79x1 in multiple sites without issues.

New Member

Re: Time on phone

So you would suggest a downgrade of the phone's Firmware to 8.2(2)SR4 ?

Hall of Fame Super Gold

Re: Time on phone

That is what works for me.

New Member

Re: Time on phone

I'm getting realy nervous over here, my original phone does not want to downgrade.

But when I used a new phone which was still in the box it perfectly went to the 8.2 firmware.

Time problem consists .. I am so missing something over here.

Normal behaviour would be that even the phones with the newer firmware should load (downgrade) to the version I pressent on my tftp server right ?

Strange that a new out of the box phone does load the files of the tftp server but the phone which is allready configured does not.

Hall of Fame Super Gold

Re: Time on phone

I suppose you're saying the 8.2 FW does NOT show the right time ?

For the 8.3 phones do a factory reset and they will downgrade.

New Member

Re: Time on phone

8.2 does not show the right time, and 8.3 lates version neither.

I'm totaly confused, I'm hoping on a fresh idea tomorow morning, calling it a day now.

Thanks for your help.

New Member

Re: Time on phone

Check NTP setting in your Switch's as well

New Member

Re: Time on phone

Good point :-)

But all network devices are configured on the same NTP server and have the same correct timezone settings and summertime settings.

But to make the problem even more strange

I am currently in my headoffice, and have manually set a 7941 to my "problem" CCME at the remote site

and the phone updated, so is running nou the same firmware, and is on the correct time !!

So that excludes a firmware issue.

But phones on the site are still 2 hours early.

Switches are all the same type and software (3560's ).

All devices are showing correct time, Call Manager (system,Callender and NTP ) Switches (Core and Access)

So I'm completely lost here.

Hall of Fame Super Gold

Re: Time on phone


with patience, compare all the possible discrepancies. For example, possibly the phones are using a dhcp pool that gives use a NTP server, etc.

New Member

Re: Time on phone

Guess so,

Too bad I can't find any documentation how a 7941 gets its time.

A bit more in depth info would be helpfull, so I'm trying to get some help from Cisco.

Cisco Employee

Re: Time on phone

The 79X1 series phones are java based devices. They take the time off the CME router, but run a time service that maintains the time locally in the handset.

The CME sends the UTC time to the phone with no locally applied offset. The phones have their own calendar and clock and will internally apply a time-zone offset based upon a formally named time-zone/DST combination that is passed to the phone via the phone's configuration file.

Here are some basic troubleshooting steps -

1. Be sure to check and see if the problem occurs on all IP Phones or just the 79X1 IP phones. If problem occurs on all IP Phones, then the problem is most likely with router sending incorrect time.

2. Make sure that you have configured the “time-zone” command with the appropriate selection under telephony-service to configure the correct off-set in minutes from UTC.

3. After you configure the time-zone command, perform “create-cnf” in telephony-service and reset the phone

4. To display the contents of the config file use cli command “more” to view the xml file for the phone type that you are troubleshooting to view the contents .

CME-Router#more system:/its/XMLDefault7961.cnf.xml



Central Standard/Daylight Time

5. load the phone config file on you PC via the tftp CLI and and confirm the timezone is correct for the specific config files for each phone (based on MAC address)

C:\Documents and Settings>tftp get SEP111222333.cnf.xml

Once the file has been transfered you can load it into Notepad to confirm.

6. You can also capture a wireshark trace while the phone boots up and registers to CME. In this sniffer trace, you will be looking to see if the CME sends the correct time offset/timezone to the phone. In particular, look for a SCCP packet labeled “DefineTimeDate”. Be sure that the information sent in this packet from CME to the IP Phone has the correct date and time.

There has been a few bugs with timezones and daylight savings for the 79X1 phones. The DST adjustment for the particular regions may not occur at the right time/date, or due to local government alterations of the DST changeover dates the phones may not apply the correct time.

You might want to try setting the timezone to another region that is still using the same offset , then doing a 'create cnf' and resetting the handsets to see if this helps. In the meantime let us know what your current timezone is set to in case there is a known bug.

New Member

Re: Time on phone


I had no CNF files for specific phones and the default.cnf didn't had the DateTimeSetting part in the file.

I created the CNF files with

#cnf-file perphonetype

But still no change, even not when I added the line :

tftp-server flash:its/XMLDefault7941.cnf.xml

I'm not sure if I need to do this.

Anyhow .. tomorow I go back on site and will check this with wireshark.

I do appriciate your explaination .. makes things more clear !


New Member

Re: Time on phone

Finaly found the problem,

I forgot the type command in the Ephone part of my configuration.

After putting

type 7941

in my config

create cnf files in telephony service

and a restart of my phone all works well.