Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Traffic shaping and QoS on ppp Dialers

Hi

I've go a Cisco CISCO2901/K9 running c2900-universalk9-mz.SPA.152-4.M4.bin connected to my ISP and SIP provider using two different dialers attached to the same physical interface Gi0/1. My provider gives 4Mbps link split into 3Mbps  for Data and 1Mpbs for Voice. Dialer 1 is for data and Dialer2 is for voice.I tried first to apply traffic shaping on Dialer1 for limitting it going above 3Mbps and so leaving the remaining 1Meg but that didnt work. Even though I was seding more that 3Megs via data network, traffic shapping applied to Dialer1 didn't seem to work. See "policy dialer.png"

So finally I decided to apply QoS on the physical interface shaping to 4Mbps (maximum capacity of the service) and prioritizing voice using config below.

interface Dialer1
 description *** WAN 3M Public Internet ***
 bandwidth 3000
 bandwidth inherit
 ip address negotiated
 ip access-group Outside-ACL in
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip flow ingress
 ip flow egress
 ip nat outside
 ip inspect Firewall out
 ip virtual-reassembly in
 encapsulation ppp
 load-interval 30
 dialer pool 1
 dialer-group 1
 ppp authentication chap callin
 ppp chap hostname [REMOVED]
 ppp chap password [REMOVED]
 no cdp enable
 crypto map siteconnect
!
interface Dialer2
 description *** SIP 1M LINK ***
 bandwidth inherit
 ip address negotiated
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 encapsulation ppp
 load-interval 30
 dialer pool 2
 dialer-group 2
 ppp authentication chap callin
 ppp chap hostname [REMOVED]
 ppp chap password [REMOVED]
!
interface GigabitEthernet0/1
 description *** WAN 4M LINK TO PROVIDER ***
 no ip address
 load-interval 30
 duplex full
 speed 100
 pppoe enable group global
 pppoe-client dial-pool-number 2
 pppoe-client dial-pool-number 1
 no cdp enable
 service-policy output QOS_OUT
!
class-map match-any VOIP
 match dscp ef 
 match precedence 5 
class-map match-any VOIP-SIGNALLING
 match dscp af31 
 match dscp cs3 
!
policy-map CHILD
 class VOIP
  priority percent 33
 class VOIP-SIGNALLING
  bandwidth percent 5 
 class class-default
  fair-queue
policy-map QOS_OUT
 description ** SHAPPING TO 4M AND QoS FOR VOICE **
 class class-default
  shape average 4000000
   service-policy CHILD

However, above config doesn't stop data traffic from going above the 3Meg limit as there's no way in the
config that prevents that from happening. Anyhow, my questions are these two:

1./ Even though I've got QoS applied on the Physical interface, my customer is complaining that sometimes
the quality of the voice is not good. I don't understand it cos it seems QoS is working from below pic. Based on
the above config, that's the way to apply QoS, right? See "Qos.png" file



2./ Is there a smart way of completely limiting the amount of data used by Dialer1 (ie no more than 3Megs) so
I don't need to deal with QoS as Dialer 2 would have 1Meg for its own?

Thanks in advance

Everyone's tags (1)
1 REPLY
Green

Traffic shaping and QoS on ppp Dialers

Hi,

You could also apply QOS to your dialer interfaces

see this link:-

http://www.cisco.com/c/en/us/support/docs/quality-of-service-qos/qos-congestion-management-queueing/10102-cbwfqdialer.html

Regards,
Alex.
Please rate useful posts.

Regards, Alex. Please rate useful posts.
466
Views
0
Helpful
1
Replies
CreatePlease to create content