Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Transcoding between two SIP trunks on 2811

Hello all,

I have 2811 with 2xPVDM2-16. There are two SIP trunks, one should be g729 and the other g711. When I make a call from another side to the other with both trunks having g711 everything is fine, call goes through, you can talk etc. However when the codecs are different (transcoding should take place) I can hear the phone ringing but when B side picks up the phone, 2811 sends BYE to the B side. Sdspfarm is registered everything looks fine regarding the transcoders, still seems that transcoding cannot be done. I am using c2800nm-adventerprisek9-mz.124-15.T3.bin.

This seems to be trivial problem but I have already spent quite some time on it.

Here are some parts of running config:

voice-card 0

dspfarm

dsp services dspfarm

!

!

!

voice service voip

allow-connections sip to sip

!

!

voice class codec 1

codec preference 1 g711alaw

codec preference 2 g729r8

!

voice class codec 2

codec preference 1 g729r8

codec preference 2 g711alaw

interface Loopback1

ip address 10.18.64.37 255.255.255.255

!

interface FastEthernet0/0

no ip address

ip virtual-reassembly

duplex auto

speed auto

!

interface FastEthernet0/0.337

encapsulation dot1Q 337

ip address a.a.a.a 255.255.255.252

ip nat outside

ip virtual-reassembly

service-policy input police-1M-in

service-policy output police-1M-out

!

interface FastEthernet0/0.338

encapsulation dot1Q 338

ip address 10.18.0.210 255.255.255.252

service-policy output voice

sccp local FastEthernet0/0.337

sccp ccm 10.18.0.210 identifier 1

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

associate profile 1 register transkodiranje

!

dspfarm profile 1 transcode

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

codec g729r8

maximum sessions 12

associate application SCCP

!

!

dial-peer voice 2000 voip

description outbound voip

destination-pattern .T

modem passthrough nse codec g711alaw redundancy

session protocol sipv2

session target ipv4:x.x.x.x

dtmf-relay h245-alphanumeric h245-signal

codec g711alaw

fax rate disable

fax protocol pass-through g711alaw

no vad

!

dial-peer voice 4000 voip

description inbound voip

no modem passthrough

session protocol sipv2

incoming called-number 3851777595.

dtmf-relay h245-alphanumeric

codec g711alaw

fax rate disable

fax protocol pass-through g711alaw

no vad

!

dial-peer voice 3000 voip

description outbound pots

destination-pattern 3851777595.

modem passthrough nse codec g711alaw redundancy

session protocol sipv2

session target ipv4:y.y.y.y

dtmf-relay h245-alphanumeric h245-signal

fax rate disable

fax protocol pass-through g711alaw

!

dial-peer voice 5000 voip

description inbound voip

no modem passthrough

session protocol sipv2

incoming called-number .T

dtmf-relay h245-alphanumeric

fax rate disable

fax protocol pass-through g711alaw

no vad

!

telephony-service

sdspfarm units 1

sdspfarm transcode sessions 12

sdspfarm tag 1 transkodiranje

load 7960-7940 P00308000400

max-ephones 2

max-dn 2

ip source-address 10.18.0.210 port 2000

timeouts interdigit 5

time-format 24

date-format dd-mm-yy

max-conferences 8 gain -6

call-forward pattern .T

dn-webedit

time-webedit

transfer-system full-consult

best regards,

Goran Pilat

6 REPLIES

Re: Transcoding between two SIP trunks on 2811

Hi Goran,

Try changing this:

sccp ccm 10.18.0.210 identifier 1

to

sccp ccm 10.18.0.210 id 1 version 4.1

You'll need to disable sccp and remove the association first.

hth,

nick

New Member

Re: Transcoding between two SIP trunks on 2811

Hi Nick,

thanks for the reply. Unfortunately this didn't solve the issue. I have an IOS which should support universal transcoding. So the phone rings but immediatelly as the B side answers, BYE is sent by the router. If the transcoder is not registered (no sccp), the phone doesn't ring at all. So it seems that transcoder is not ignored in the call setup.

Any other advice?

best regards,

Goran Pilat

New Member

Re: Transcoding between two SIP trunks on 2811

Another thing, I noticed now that transcoding is done with no problems g711alaw -> g711ulaw (call goes through, I also see used channels with sh dspfarm all), but with g729 still doesn't work. Could it be that the codec from Cisco and Audio Codec modem are not compatible?

regards,

goran pilat

Re: Transcoding between two SIP trunks on 2811

You can check the codecs on your dspfarm profile, make sure you have the desired codecs there.

Additionally - check the SIP messaging and see who/why the call is disconnecting. It could be related to the annex of g729 they're attempting to use.

hth,

nick

New Member

Re: Transcoding between two SIP trunks on 2811

Hi Nick,

I just wanted to let you know that it is solved. When we put Asterisk instead of AudioCodes it worked right away (above config is fine). However I still find confusing the following. AudioCodes could only use g729A codec (off all the g729 variants) but Asterisk can use "pure" g729. But on dial-peer I can only put g729r8 and g729br8. To get things more confusing, on the transcoder you CAN set g729ar8, g729abr8 and g729r8. So I think with AudioCodes was something like this:

-I called the number

-the right dial-peer was hit

-codec on dial-peer matched the one supported on transcoding, the call establishment went on

-phone rings

-phone answers, sends that the codec it supports is not actually g729 but g729a (which can't be set on dial-peer)

-call is released

This is only my opinion,

Anyway thanks again, cheers

Goran Pilat

Re: Transcoding between two SIP trunks on 2811

Hi Goran,

Glad to see you figured this out. There are some hidden commands that change the way we handle some of the g729 annexes, so you may have been able to do some changes on the gateway.

-nick

411
Views
0
Helpful
6
Replies
CreatePlease to create content