Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Transcoding Sessions unregistered with CUCM from standby gateway of CUBE with HA usingHSRP

I have 2 C2921 routers working fine untill I enbale CUBE with HA. After configureing HSRP on ethernet interface, the transcoding and conferencing resources were unregistered on HSRP standby router even though I bind the sccp ccm group to physical interface.

 

Raised Cisco TAC, but they also could not solve yet. Cisco TAC recommanded to have loopback or another interface.

 

I configure gi02/ without HSRP configuration, but still the transcoding and conferencing resources are not getting registered. Cisco TAC is still analysing the logs.

 

I am hoping I get resolution here. Configuration of standby router is below.

Building configuration...


Current configuration : 13985 bytes
!
! Last configuration change at 15:07:25 BST Fri Aug 1 2014
! NVRAM config last updated at 15:07:25 BST Fri Aug 1 2014
!
version 15.4
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
service password-encryption
service internal
service sequence-numbers
!
hostname CHN-RT-VG01
!
boot-start-marker
boot system flash:c2900-universalk9_npe-mz.SPA.154-3.M.bin
boot system flash:c2900-universalk9_npe-mz.SPA.154-2.T1.bin
boot-end-marker
!
!
! card type command needed for slot/vwic-slot 0/0
card type e1 0 1
card type e1 0 2
logging queue-limit 10000
logging buffered 10000000
logging rate-limit 10000
no logging console
enable secret 4 XkK1t85uKpzHay4O0x8hP0rt1uO7UwNlcWBLwLAsn3Y
!
!
ipc zone default
 association 1
  no shutdown
  protocol sctp
   local-port 5000
    local-ip 10.215.8.148
   remote-port 5000
    remote-ip 10.215.8.149
!
 --More--         no aaa new-model
clock timezone BST 0 0
clock summer-time BST date Mar 28 1993 0:00 Oct 27 2035 23:59
network-clock-participate wic 1
network-clock-participate wic 2
network-clock-select 1 E1 0/1/0
network-clock-select 2 E1 0/1/1
network-clock-select 3 E1 0/2/0
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
no ip domain lookup
ip domain name DILFLPROD.CO.UK
 --More--         ip cef
ipv6 multicast rpf use-bgp
no ipv6 cef
multilink bundle-name authenticated
!
!
!
!
!
isdn switch-type primary-4ess
!
cts logging verbose
!
crypto pki trustpoint TP-self-signed-3464013556
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3464013556
 revocation-check none
 rsakeypair TP-self-signed-3464013556
!
!
crypto pki certificate chain TP-self-signed-3464013556
 certificate self-signed 01
  3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 33343634 30313335 3536301E 170D3132 31313232 30353530
  30345A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 34363430
  31333535 3630819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100FD06 30324087 5D131745 446B6933 963E32DB 4B3F78D3 C2627F7B A68792EA
  0686B7C1 93B66C1A 2287DD72 26AC10BE F6B5DE89 CEF9C800 836DAD25 4A32FC52
  99A65E45 FAD97919 4BD2CFC8 136EB9AC F7F21045 0A930247 0E72CE1B 1C00D1BD
  59B83BED 73639AA5 C78A657B EC55F15B 5287703C 3ED94E47 492DFAD0 89934B27
  5CD10203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603
  551D2304 18301680 146F6961 3C46FDE7 C105ADBF 5C07A675 7F7B5828 E1301D06
  03551D0E 04160414 6F69613C 46FDE7C1 05ADBF5C 07A6757F 7B5828E1 300D0609
  2A864886 F70D0101 05050003 8181005E 509EACC9 67205643 133DD745 5A6E7C82
  7AAE0766 C68C215B 6222A86F A08AC77D 1030664E F77F6CFB CF021C94 BC5FB190
  FEA96EE9 5A502DC6 D4407467 9662683E CFDC1779 4016A9A0 32EF415D 6E21DF53
  D710D173 7BFC300A FDEE54D8 36BBED28 05A6A752 652F2550 E6BC5896 D4EC222A
  C82C1B2A 4FEF6ED3 44DE109E DD796E
 --More--            quit
voice-card 0
 dspfarm
 dsp services dspfarm
!
!
voice call send-alert
!
voice service voip
 mode border-element
 allow-connections sip to sip
 redundancy
 fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback none
 sip
  early-offer forced
  midcall-signaling passthru
  g729 annexb-all
!
!
!
!
!
!
!
voice translation-rule 100
 rule 1 /^44845..\(.....\)/ /\1/
 rule 3 /^4411...\(....\)/ /2\1/
!
!
voice translation-profile LiveOpsInbound
 translate called 100
!
voice translation-profile OutboundtoKolDDI
 translate called 1
!
!
!
 --More--         !
application
 global
  service alternate Default
 !
!
license udi pid CISCO2921/K9 sn FCZ164760NP
hw-module pvdm 0/0
!
hw-module pvdm 0/1
!
!
!
username controller privilege 15 password 7 050F0F03284B4B070D04
username voiceadmin privilege 15 password 7 1514190501242F37243A3327
username shaums privilege 15 password 7 151602000D2D2E2A3C32
username 745162 privilege 15 password 7 08254542001E0019060A
username 256108 privilege 15 password 7 0124030858040B0A70
!
redundancy inter-device
 scheme standby SB
!
!
redundancy
 no keepalive-enable
 notification-timer 60000
!
!
controller E1 0/1/0
 pri-group timeslots 1-31 service mgcp
!
controller E1 0/1/1
 pri-group timeslots 1-31 service mgcp
 !
controller E1 0/2/0
 pri-group timeslots 1-31 service mgcp
 !
controller E1 0/2/1
 pri-group timeslots 1-31 service mgcp
 !
track 1 interface GigabitEthernet0/0 line-protocol
!
track 2 interface GigabitEthernet0/1 line-protocol
!
!
!
!
!
interface Embedded-Service-Engine0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/0
 description **Inside***
 ip address 10.215.8.132 255.255.255.240
 standby delay minimum 30 reload 60
 standby version 2
 standby 1 ip 10.215.8.135
 standby 1 priority 50
 standby 1 preempt
 standby 1 name SB
 standby 1 track 2 decrement 10
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 description **Outside***
 ip address 10.215.8.148 255.255.255.240
 standby delay minimum 30 reload 60
 standby version 2
 standby 2 ip 10.215.8.150
 standby 2 priority 50
 standby 2 preempt
 standby 2 track 1 decrement 10
 duplex auto
 speed auto
 media-type rj45
 --More--         !
interface GigabitEthernet0/2
 ip address 10.215.8.164 255.255.255.240
 duplex full
 speed 1000
!
interface Serial0/1/0:15
 no ip address
 encapsulation hdlc
 isdn switch-type primary-net5
 isdn incoming-voice voice
 isdn bind-l3 ccm-manager
 no cdp enable
!
interface Serial0/1/1:15
 no ip address
 encapsulation hdlc
 isdn switch-type primary-net5
 isdn incoming-voice voice
 isdn bind-l3 ccm-manager
 no cdp enable
!
interface Serial0/2/0:15
 no ip address
 encapsulation hdlc
 isdn switch-type primary-net5
 isdn incoming-voice voice
 isdn bind-l3 ccm-manager
 no cdp enable
!
interface Serial0/2/1:15
 no ip address
 encapsulation hdlc
 isdn switch-type primary-net5
 isdn incoming-voice voice
 isdn bind-l3 ccm-manager
 no cdp enable
!
ip forward-protocol nd
!
 --More--         ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip rtcp report interval 3000
ip route 0.0.0.0 0.0.0.0 10.215.8.129
!
ip sla auto discovery
ip sla 40001
 udp-jitter 10.215.191.3 17000 source-ip 10.215.8.132 codec g729a codec-numpackets 100
 tos 184
 owner SW.IpSla.CHVISM0210.SolarWindsOrion
 frequency 300
 timeout 180000
 threshold 1000
ip sla schedule 40001 life forever start-time now
ip sla 40003
 udp-jitter 10.215.221.131 17000 source-ip 10.215.8.132 codec g729a codec-numpackets 100
 tos 184
 owner SW.IpSla.CHVISM0210.SolarWindsOrion
 frequency 300
 timeout 180000
 threshold 1000
ip sla schedule 40003 life forever start-time now
no logging trap
!
!
snmp-server community m&9C4rd4L%mw RO 10
snmp-server community m&9C4rd4L%m RW 10
snmp-server enable traps isdn call-information
snmp-server enable traps isdn layer2
snmp-server enable traps isdn chan-not-avail
snmp-server enable traps isdn ietf
snmp-server host 10.215.10.10 version 2c m&9C4rd4L%mw
snmp-server host 10.215.232.202 version 2c m&9C4rd4L%mw
tftp-server flash0:SCCP42.9-1-1SR1S.loads
tftp-server flash0:apps42.9-1-1TH1-16.sbn
tftp-server flash0:cnu42.9-1-1TH1-16.sbn
 --More--         tftp-server flash0:cvm42sccp.9-1-1TH1-16.sbn
tftp-server flash0:dsp42.9-1-1TH1-16.sbn
tftp-server flash0:jar42sccp.9-1-1TH1-16.sbn
tftp-server flash0:term42.default.loads
tftp-server flash0:term62.default.loads
tftp-server flash0:/c2600-ipvoicek9-mz.124-25d.bin
access-list 23 permit 10.10.10.0 0.0.0.7
!
control-plane
!
!
voice-port 0/1/0:15
!
voice-port 0/2/0:15
!
voice-port 0/1/1:15
!
voice-port 0/2/1:15
 !
 !
 !
 !
!
mgcp
mgcp call-agent 10.215.8.7 2427 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode out-of-band
mgcp rtp unreachable timeout 1000 action notify
mgcp modem passthrough voip mode nse
mgcp package-capability rtp-package
mgcp package-capability sst-package
mgcp package-capability pre-package
no mgcp package-capability res-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp fax t38 inhibit
mgcp bind control source-interface GigabitEthernet0/0
mgcp bind media source-interface GigabitEthernet0/0
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
 --More--         mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
sccp local GigabitEthernet0/2
sccp ccm 10.215.8.7 identifier 1 priority 1 version 7.0
sccp ccm 10.215.8.6 identifier 2 priority 2 version 7.0
!
sccp ccm group 1
 bind interface GigabitEthernet0/2
 associate ccm 1 priority 1
 associate ccm 2 priority 2
 associate profile 2 register CFBCHEVG1
 associate profile 1 register XCODERCHEVG1
!
ccm-manager music-on-hold
!
ccm-manager fallback-mgcp
ccm-manager redundant-host 10.215.8.6
ccm-manager mgcp
no ccm-manager fax protocol cisco
ccm-manager config server 10.215.8.6 
ccm-manager config
!
dspfarm profile 1 transcode 
 codec g729r8
 codec ilbc
 codec pass-through
 codec g722-64
 codec g711ulaw
 codec g711alaw
 codec g729ar8
 codec g729abr8
 maximum sessions 70
 associate application SCCP
!
dspfarm profile 2 conference 
 codec g729br8
 codec g729r8
 codec g729abr8
 --More--         codec g729ar8
 codec g711alaw
 codec g711ulaw
 codec g722-64
 codec ilbc
 maximum sessions 10
 associate application SCCP
!
dial-peer voice 1 pots
 description **Incoming Dial Peer**
 incoming called-number .
 direct-inward-dial
!
dial-peer voice 2 pots
 description **Outbound Dialpeer**
 translation-profile outgoing OutboundtoKolDDI
 destination-pattern 02083917600
 incoming called-number .
 port 0/1/1:15
!
dial-peer voice 3 pots
 description **Outbound Dialpeer**
 translation-profile outgoing OutboundtoKolDDI
 destination-pattern 02083917600
 incoming called-number .
 port 0/2/0:15
!
dial-peer voice 4 pots
 description **Outbound Dialpeer**
 translation-profile outgoing OutboundtoKolDDI
 destination-pattern 02083917600
 incoming called-number .
 port 0/2/1:15
!
dial-peer voice 100 voip
 description to-DorkingCUCM
 translation-profile outgoing LiveOpsInbound
 destination-pattern 44..........
 session protocol sipv2
 session target ipv4:10.156.125.2
 --More--         incoming called-number .
 voice-class sip bind control source-interface GigabitEthernet0/0
 voice-class sip bind media source-interface GigabitEthernet0/0
 dtmf-relay rtp-nte
 codec g711ulaw
 no vad
!
dial-peer voice 200 voip
 description to-LiveOpsCCC
 preference 1
 destination-pattern .T
 session protocol sipv2
 session target ipv4:x.x.x.x
 incoming called-number 44..........
 voice-class sip bind control source-interface GigabitEthernet0/1
 voice-class sip bind media source-interface GigabitEthernet0/1
 dtmf-relay rtp-nte
 codec g711ulaw
 no vad
!
dial-peer voice 300 voip
 description to-LiveOpsCCC
 preference 2
 destination-pattern .T
 session protocol sipv2
 session target ipv4:x.x.x.x
 incoming called-number 44..........
 voice-class sip bind control source-interface GigabitEthernet0/1
 voice-class sip bind media source-interface GigabitEthernet0/1
 dtmf-relay rtp-nte
 codec g711ulaw
 no vad
!
dial-peer voice 101 voip
 description to-ChessingtonCUCM
 translation-profile outgoing LiveOpsInbound
 preference 1
 destination-pattern 44..........
 session protocol sipv2
 session target ipv4:10.215.8.7
 --More--         incoming called-number 40008
 voice-class sip bind control source-interface GigabitEthernet0/0
 voice-class sip bind media source-interface GigabitEthernet0/0
 dtmf-relay rtp-nte
 codec g711ulaw
 no vad
!
dial-peer voice 102 voip
 description to-ChessingtonCUCM
 translation-profile outgoing LiveOpsInbound
 preference 2
 destination-pattern 44..........
 session protocol sipv2
 session target ipv4:10.215.8.6
 incoming called-number 40008
 voice-class sip bind control source-interface GigabitEthernet0/0
 voice-class sip bind media source-interface GigabitEthernet0/0
 dtmf-relay rtp-nte
 codec g711ulaw
 no vad
!
dial-peer voice 103 voip
 description to-DorkingCUCM
 preference 1
 shutdown
 destination-pattern 25544
 session protocol sipv2
 session target ipv4:10.156.125.2
 incoming called-number .
 voice-class sip bind control source-interface GigabitEthernet0/0
 voice-class sip bind media source-interface GigabitEthernet0/0
 dtmf-relay rtp-nte
 codec g711ulaw
 no vad
!
dial-peer voice 104 voip
 description to-ChessingtonCUCM
 translation-profile outgoing LiveOpsInbound
 preference 1
 shutdown
 --More--         destination-pattern 40008
 session protocol sipv2
 session target ipv4:10.215.8.7
 incoming called-number .
 voice-class sip bind control source-interface GigabitEthernet0/1
 voice-class sip bind media source-interface GigabitEthernet0/1
 dtmf-relay rtp-nte
 codec g711ulaw
 no vad
!
!
gateway
 media-inactivity-criteria all
 timer receive-rtcp 5
 timer receive-rtp 1200
!
!
!
gatekeeper
 shutdown
!
!
banner login ^CC
"This system and components thereof is the sole and exclusive property of Diligenta and is intended solely for the usage of its authorized administrators. Unauthorized access or use will attract appropriate legal action.
Access would be bound by Diligenta policies and could be monitored. Do not use this system, if the terms are not acceptable."
^C
!
line con 0
 login local
line aux 0
line 2
 no activation-character
 no exec
 transport preferred none
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
 stopbits 1
line vty 0 4
 privilege level 15
 login local
 --More--         transport input ssh
line vty 5 15
 privilege level 15
 login local
 transport input ssh
!
scheduler allocate 20000 1000
!
end

7 REPLIES
Cisco Employee

FYI, if you're using those

FYI, if you're using those DSPs for CUBE HA call flows, it's not supported.

HTH

java

if this helps, please rate

www.cisco.com/go/pdi
New Member

Hi Jaime,I have the same

Hi Jaime,

I have the same scenario and I do need to use conference resources, transcending for DTMF, and MTP resources for CUBE HA call flows. In this case what would be a possible solution to provide those resources to CUBE HA call flows?

Bronze

I don't have an answer for

I don't have an answer for you but would like to add a note.  I was initially configuring and troubleshooting some things on a HA cube pair recently.  I was using external DNS for some dial-peer session target lookup and noticed the non-active CUBE could not lookup DNS.  When the non-active CUBE became active it could all of a sudden resolve DNS.  So I am speculating that something to do with the HA configuration is disallowing communication or bindings preventing routing to the rest of the network from the non-active CUBE.  I ended up putting local host records on the router to make me feel better.  I am guessing whatever is causing that might be related to the reason your SCCP is loosing registration on the non-active CUBE. 

Jaime says what you are trying to do is not supported anyway.  I would like a a little clarification on that but what I believe to be supported is if you need transcoding or mtp resources for this CUBE only (Not registered to UCM) then LTI is a good option.

http://www.cisco.com/c/en/us/support/docs/voice-unified-communications/unified-border-element/115018-configure-cube-lti.html

Hope any of this helps.  I am really commenting so I can track any updates to this thread. :)

New Member

Anybody find a solution to

Anybody find a solution to this?

 

Thanks

Cisco Employee

I believe only the latest

I believe only the latest releases of CUBE now support having dspfarms on both CUBEs and they should work, older releases would not let you register anything of the standby CUBE.

HTH

java

if this helps, please rate

www.cisco.com/go/pdi
New Member

It does not register for me,

It does not register for me, running 3945 15.4m3

New Member

Hi,

Hi,

Did you find the solution?

I have the same scenario.

Thanks in advanced.

Regards,

670
Views
0
Helpful
7
Replies
CreatePlease to create content