Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Transcoding without NM-HDV or AIM (only PVDM's on board)

Dear all,

I have a 2811 router that works as IPIPGW from h.323 to SIP. It has PVDM2's installed on the board of the router (so no NM-HDV or AIM installed).

I cannot figure out how to configure this router to perform transcoding of voice channels. Is it possible with PVDM2's only on the motherboard?

Now with g.711 on complete network it works fine, but it would be excellent if I could implement any other codec.

Any help on this would be highly appreciated!

All the best!

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: Transcoding without NM-HDV or AIM (only PVDM's on board)

I just did some research, and found that the error message 'Please configure the maximum sessions for this profile and retry' means you do not have enough DSP resources to handle the mixture of analogue and digital voice ports as well as the transcoding profile.

Paste the SH RUN and SH VOICE DSP DETAIL here so I can confirm this, otherwise as a test, power down the router and remove the E1 card, then power up the router and see if you can configure the maximum sessions under the transcoder profile.

10 REPLIES
Cisco Employee

Re: Transcoding without NM-HDV or AIM (only PVDM's on board)

try

voice-card 0

dspfarm

dsp services dspfarm

then you can follow this doc

Configuring Enhanced Conferencing and Transcoding for Voice Gateway Routers

http://www.cisco.com/en/US/products/ps6441/products_configuration_guide_chapter09186a0080541bf3.html

HTH

HTH

java

if this helps, please rate

www.cisco.com/go/pdi
Community Member

Re: Transcoding without NM-HDV or AIM (only PVDM's on board)

Thanks for help!

However, it did not work for some reason. I followed the instructions and here is what happens:

voice-gateway(config)#voice-card 0

voice-gateway(config-voicecard)#dspfarm

voice-gateway(config-voicecard)#dsp services dsp

voice-gateway(config-voicecard)#exit

voice-gateway(config)#dspfarm profile 10 transcode

voice-gateway(config-dspfarm-profile)#codec g729abr

voice-gateway(config-dspfarm-profile)#maximum sessions ?

<0-0> Number of sessions assigned to this profile

voice-gateway(config-dspfarm-profile)#maximum sessions 0

voice-gateway(config-dspfarm-profile)#no shu

Please configure the maximum sessions for this profile and retry

voice-gateway(config-dspfarm-profile)#

I cannot configure any larger number for max.sessions but 0, and then it does not allow me to turn profile ON. Without this the rest of configuration for transcoding doesnot work.

Do you have any idea what could be wrong?

Thanks in advance!

Cisco Employee

Re: Transcoding without NM-HDV or AIM (only PVDM's on board)

do a sh voice dsp in order to look at the resources, there is the possibility that something is already using them

that will show up if the DSPs are already in use

HTH

HTH

java

if this helps, please rate

www.cisco.com/go/pdi
Cisco Employee

Re: Transcoding without NM-HDV or AIM (only PVDM's on board)

You can use the telephony service and register the transcoding/conferencing on the local router as a CME resource. It willthen transcode the media for the inwards and outward VOIP calls.

Here is a sample config that shows the concept:

!

voice-card 0

dspfarm

dsp services dspfarm

!

!

!

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

sip

bind control source-interface GigabitEthernet0/0

bind media source-interface GigabitEthernet0/0

!

!

voice class media 1

media flow-through

!

!

voice class codec 1

codec preference 1 g729r8

codec preference 2 g711ulaw

!

!

sccp local GigabitEthernet0/0

sccp ccm identifier 1

sccp

!

sccp ccm group 1

bind interface GigabitEthernet0/0

associate ccm 1 priority 1

associate profile 1 register TranscodeCalls

keepalive retries 5

switchover method immediate

switchback method immediate

switchback interval 5

!

dspfarm profile 1 transcode

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

codec gsmfr

codec g729br8

maximum sessions 24

associate application SCCP

no shutdown

!

!

dial-peer voice 9700 voip

description - G729/H323 calls to CME

destination-pattern 67824497[12].

voice-class media 1

voice-class codec 1

session target ipv4:10.1.1.1

dtmf-relay rtp-nte h245-alphanumeric

!

dial-peer voice 1000 voip

description - G711/SIP calls to SIP provider

destination-pattern ..........

progress_ind setup enable 3

voice-class media 1

voice-class codec 1

session protocol sipv2

session target ipv4:172.16.1.1

dtmf-relay sip-notify rtp-nte h245-alphanumeric

!

!

telephony-service

sdspfarm units 5

sdspfarm transcode sessions 30

sdspfarm tag 1 TranscodeCalls

!

Community Member

Re: Transcoding without NM-HDV or AIM (only PVDM's on board)

Thanxs for help!

I am having problem in turning DSP profile in "ON" state.

Please find attached reply from the router on "show voice dsp".

The router has one 4xFXO voice card and one 2-port E1-MFT (only one E1 is used). PVDM2-64 is installed on the motherboard.

Any ideas what could be wrong?

Thanks in advance!

Cisco Employee

Re: Transcoding without NM-HDV or AIM (only PVDM's on board)

I'm having trouble opening the attachment - can you re-post the file again , or just paste the text straight into the window here.

Community Member

Re: Transcoding without NM-HDV or AIM (only PVDM's on board)

Appologies for the inconvenience!

Hope this works fine. Thank you!

DSP DSP DSPWARE CURR BOOT PAK TX/RX

TYPE NUM CH CODEC VERSION STATE STATE RST AI VOICEPORT TS ABORT PACK COUNT

==== === == ======== ======= ===== ======= === == ========= == ===== ===========

=

----------------------------FLEX VOICE CARD 0 ------------------------------

*DSP VOICE CHANNELS*

DSP DSP DSPWARE CURR BOOT PAK TX/RX

TYPE NUM CH CODEC VERSION STATE STATE RST AI VOICEPORT TS ABRT PACK COUNT

===== === == ======== ======= ===== ======= === == ========= == ==== ===========

=

C5510 001 01 g711ulaw 4.4.21 busy idle 0 0 0/0/0:15 31 0 816/87

6

C5510 001 02 g711ulaw 4.4.21 busy idle 0 0 0/0/0:15 01 0 6960/711

9

C5510 001 04 g711ulaw 4.4.21 busy idle 0 0 0/0/0:15 18 0 4228/434

5

*DSP SIGNALING CHANNELS*

DSP DSP DSPWARE CURR BOOT PAK TX/RX

TYPE NUM CH CODEC VERSION STATE STATE RST AI VOICEPORT TS ABRT PACK COUNT

===== === == ======== ======= ===== ======= === == ========= == ==== ===========

=

C5510 001 01 {flex} 4.4.21 alloc idle 0 0 0/1/0 02 0 853/

0

C5510 001 02 {flex} 4.4.21 alloc idle 0 0 0/1/1 06 0 850/

0

C5510 001 03 {flex} 4.4.21 alloc idle 0 0 0/1/2 10 0 1393/

0

C5510 001 04 {flex} 4.4.21 alloc idle 0 0 0/1/3 14 0 1404/

0

------------------------END OF FLEX VOICE CARD 0 ----------------------------

Cisco Employee

Re: Transcoding without NM-HDV or AIM (only PVDM's on board)

I just did some research, and found that the error message 'Please configure the maximum sessions for this profile and retry' means you do not have enough DSP resources to handle the mixture of analogue and digital voice ports as well as the transcoding profile.

Paste the SH RUN and SH VOICE DSP DETAIL here so I can confirm this, otherwise as a test, power down the router and remove the E1 card, then power up the router and see if you can configure the maximum sessions under the transcoder profile.

Community Member

Re: Transcoding without NM-HDV or AIM (only PVDM's on board)

Thanks for help!

I have 2 ISDN E1 interfaces and 4FXO interfaces on this router, with 64PVDM2.

Show run:::

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname voice-gateway

!

boot-start-marker

boot-end-marker

!

aaa new-model

!

!

!

aaa session-id common

network-clock-participate wic 0

!

isdn switch-type primary-net5

!

voice-card 0

dspfarm

dsp services dspfarm

!

!

!

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

redirect ip2ip

!

!

controller E1 0/0/0

pri-group timeslots 1-31

!

controller E1 0/0/1

pri-group timeslots 1-31

!

!

!

!

interface FastEthernet0/0

ip address 192.168.1.208 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice voice

no cdp enable

!

interface Serial0/0/1:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice voice

no cdp enable

!

ip route 0.0.0.0 0.0.0.0 192.168.1.111

!

!

ip http server

ip http access-class 23

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

!

!

!

control-plane

!

!

!

voice-port 0/0/0:15

!

voice-port 0/1/0

echo-cancel coverage 32

cptone SI

timing hookflash-out 50

connection plar 303

impedance complex2

!

voice-port 0/1/1

echo-cancel coverage 32

cptone SI

timing hookflash-out 50

connection plar 303

impedance complex2

!

voice-port 0/1/2

echo-cancel coverage 32

cptone SI

timing hookflash-out 50

connection plar 303

impedance complex2

!

voice-port 0/1/3

echo-cancel coverage 32

cptone SI

timing hookflash-out 50

connection plar 303

impedance complex2

!

voice-port 0/0/1:15

!

!

!

sccp local FastEthernet0/0

sccp ccm 192.168.1.200 priority 1 version 4.1

sccp ip precedence 3

sccp

!

sccp ccm group 1

associate profile 1 register MTP00000000000

!

dspfarm profile 1 transcode

description DSPprofile-transcode

codec g711ulaw

codec g711alaw

codec g729ar8

codec g729abr8

codec g729br8

associate application SCCP

shutdown

!

dial-peer voice 100 voip

destination-pattern 5..

modem passthrough nse codec g711ulaw

session target ipv4:192.168.1.200

dtmf-relay h245-alphanumeric

codec g711ulaw

no vad

!

dial-peer voice 9000 pots

port 0/1/0

!

dial-peer voice 9001 pots

port 0/1/1

!

dial-peer voice 9002 pots

port 0/1/2

!

dial-peer voice 9003 pots

port 0/1/3

!

dial-peer voice 200 pots

destination-pattern .T

direct-inward-dial

port 0/0/0:15

!

dial-peer voice 150 pots

destination-pattern 8..

direct-inward-dial

port 0/0/1:15

!

dial-peer voice 151 pots

destination-pattern 9T

direct-inward-dial

port 0/0/1:15

!

dial-peer voice 1 pots

service onramp-sffax

incoming called-number 577

direct-inward-dial

!

dial-peer voice 2 pots

service onramp-sffax

incoming called-number 578

direct-inward-dial

!

!

dial-peer voice 102 voip

translation-profile outgoing profile1

destination-pattern 99T

session protocol sipv2

session target ipv4:x.y.x.y

dtmf-relay rtp-nte

codec g711ulaw

!

sip-ua

authentication abc password abc realm x.y.x.y

retry register 10

registrar ipv4:x.y.x.y expires 3600

!

!

!

!

line con 0

line aux 0

line vty 0 4

access-class 23 in

privilege level 15

transport input telnet ssh

line vty 5 15

access-class 23 in

privilege level 15

transport input telnet ssh

!

scheduler allocate 20000 1000

!

end

Show voice dsp detail:::

If this confirms your assumption, would removing fxo card or turning one ISDN E1 interface to shutdown help on this issue?

Thanks in advance!

Community Member

Re: Transcoding without NM-HDV or AIM (only PVDM's on board)

Dear friends,

thank you for your patience in waiting for final resolution on this. This gateway was in production, so I had to wait for the right time to shutdown it.

Removing E1 card finally resulted in releasing enough DSP resources to turn dspfarm 'on', and configure transcoding properly. However, since our customer needs this 1E1 interface (but not both) shutting down the second E1 interface on MFT card and removing all configuration related to it also resulted in release of enough DSP resources to have transcoding work.

Thank you all for your help!

436
Views
5
Helpful
10
Replies
CreatePlease to create content