Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Translation on PRI circuit...

Hello everyone! ... and thanks for reading!

We have a CISCO 2921 router (see attached config)

We need to plug our current PRI into it, however the numbers going in (or direct numbers) are for example 6016250123, and it's corresponding extension HAS to be 6123. As you can see we need to make that 0 a 6.

We've created a translation rule (in this config is 5) to do so. One of the other rules was for testing and the other to bring in all the digits but change the 0 to a 6...

The router is part of CCM version 7.

When you dial in it hits the router and sees the number, translates it but goes nowhere... you end up getting a busy signal.

Also from inside, trying to dial out, we get a busy signal. Call does not go out.

This is my first config on this type of setup. I want to make sure I am on the right track when I say that I am missing a piece of config, a dial peer or I am not considering something between the call coming in/going out and the corresponding peers.

I setup the tranlslation as the call comes into the router with

voice-port 0/0/1:23

translation-profile incoming PRIInbound

bearer-cap Speech

and bringing in only the last 4 digits with the 0 already swapped for a 6

... any ideas on what else I need to do or what I DON'T need to be doing?

Thank you for your help!

Best Regards,

Mario Manzano

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions

Re: Translation on PRI circuit...

Mario can you test few more changes..
1. Shutdown the inbound dial-peer from gw towards 120.12 cucm (dp-2102) and add sip trunk on 120.11 then test a inbound call.
2. Uncheck run on all active nodes in sip trunk then again do a inbound test call.

Do collect debug ccsip message on both these cases.

The device pool assigned to sip trunk contains these two cucm servers in ccm group ? If yes then in which sequence.


Sent from Cisco Technical Support App

26 REPLIES
Silver

Translation on PRI circuit...

Hi Mario,

The first thing I would do would be to test your translation rule on the router.  You can do this by entering

routername#test voice translation-rule 5 6016250123

If everything is setup corectly on the router then the output should show what you are looking for. 

The one thing I am having trouble finding in you config is the incoming dial peer.  You will need to make sure that the translation profile is added to the incoming dial peer. 

Thanks,
Tony

Please rate helpful posts!

Please rate helpful posts
Thanks,
Tony
New Member

Translation on PRI circuit...

Thank you Tony for your response... I tried that "test voice" command before and I could have sworn it was working...

I tried it today and it gave me the wrong result... mybe my eyes are just playing tricks on me...

the incoming dial peers should be 2101 % 2102 on voip and go to CCM

the one for pots is 100

I'll retrace my steps and pile some logs to check...

I believe my downfall is the translation of the number as soon as it hits the router before anything else happens... I will remove that and try the translation within the peer aproach...

Thank you for your post and pointing me in the right direction...

Have a great day!

Silver

Translation on PRI circuit...

No worries Mario -

What is your output from running the test command?

You should not have to remove anything you have so far.  I was just commenting that along with everything you have thus far, you may need to double check you incoming dial peer to make sure the correct translation profile has been added.

For example you should only need the follow setup -

voice translation-rule 5

rule 3 /0\(...\)/ /6\1/

rule 4 /\(.*\)7432/ /\26245/

rule 5 /^16016250\(...\)/ /6\1/

rule 6 /^6016250\(...\)/ /6\1/

voice translation-profile PRIInbound

translate called 5

**You then want to make sure that your incoming POTS dial peer has the following line associated with it**

translation-profile incoming PRIInbound

Thanks,
Tony

Please rate helpful posts!

Please rate helpful posts
Thanks,
Tony
New Member

Translation on PRI circuit...

Yes... you are right... I have this output on rule 5

SPMS-2921#test voice translation-rule 5 6016250246
Matched with rule 6
Original number: 6016250246     Translated number: 6246
Original number type: none      Translated number type: none
Original number plan: none      Translated number plan: none

SPMS-2921#test voice translation-rule 6 6016250246

I am also testing output on rule 6 and this is the output (even though I am not using it)


Matched with rule 6
Original number: 6016250246     Translated number: 6016256246
Original number type: none      Translated number type: none
Original number plan: none      Translated number plan: none

... rule 3 within the trasnlation-rule 5 was wrong it gave me as result 6616250246 ...

then I show

voice translation-profile PRIInbound

translate called 5

And I have dial peer 100 like this:

dial-peer voice 100 pots

trunkgroup pstn

corlist incoming PSTN-CSS

description ** Incoming PSTN DialPeer **

translation-profile incoming PRIInbound

incoming called-number .

... I will check all the config again and swing that PRI fist chance to re-test with a live call...

Again, many thanks for your help!!

Re: Translation on PRI circuit...

Hi Mario,

You can collect debugs when you do a test call that will help finding the exact matching dial -peer and translated number .

Debug voice ccapi inout
Debug ccsip message
Debug voice translation


Sent from Cisco Technical Support iPhone App

New Member

Re: Translation on PRI circuit...

Thank you Manish!

I will have better and more info when I get that cable plugged and thanks to your input and Tony's too!!

Your help is much appreciated!!

New Member

Re: Translation on PRI circuit...

Ok... I got the PRI on it... I got debugs I am jusst finishing the first read...

It seems to be matching incoming peer 100 ... translation IS happening (can see it on the debug voice translation) after that matches outgoing peers 2101 & 2102 (to CUCM 1 & 2 respectively)

... still, busy signal... and I also get a busy dialing out even though it matches dial-peer 66 as it should...

I might be looking at the router when I should be looking at CCM... ???

I am a little lost here...

Thank you for the continued support!!

Silver

Re: Translation on PRI circuit...

Are you sure that you have a DN within Call Manager that matches what is being sent from the router?

Thanks,
Tony

Please rate helpful posts!

Please rate helpful posts
Thanks,
Tony
New Member

Re: Translation on PRI circuit...

Yes, we have the phones registered in CCM with extensions 62xx ...

Router seems to be picking up the incoming number i.e. 6016250246 ... matching incoming peer... gets translated to 6016256246 then chops off all except last 4 and that what works with...

I am looking in CCM now... making sure all seems right...

What puzzles me is the fact that also trying to dial out does not work...

Thanks for your help!

Re: Translation on PRI circuit...

Send across debug ccsip message and debug isdn q931 for an outgoing call.

Sent from Cisco Technical Support iPhone App

New Member

Re: Translation on PRI circuit...

thanks Manish! ... It will take me a bit... I get NO LOGS for outbound calls...

New Member

Re: Translation on PRI circuit...

Ok... this is an extract from outside into the router... anything that tried to go out does not give me a log (which is something missing in CCM and I am looking for it)

.Feb 27 20:17:27.905: //-1/xxxxxxxxxxxx/RXRULE/regxrule_profile_match_internal: Matched with rule 3 in ruleset 6

.Feb 27 20:17:27.905: //-1/xxxxxxxxxxxx/RXRULE/sed_subst: Successful substitution; pattern=0259 matchPattern=(.*)0(...) replacePattern=6\2 replaced pattern=6259

.Feb 27 20:17:27.905: //-1/xxxxxxxxxxxx/RXRULE/regxrule_subst_num_type: Match Type = none, Replace Type = none Input Type = unknown

.Feb 27 20:17:27.905: //-1/xxxxxxxxxxxx/RXRULE/regxrule_subst_num_plan: Match Plan = none, Replace Plan = none Input Plan = unknown

.Feb 27 20:17:27.905: //-1/xxxxxxxxxxxx/RXRULE/regxrule_get_RegXrule: Invalid translation ruleset tag=0

.Feb 27 20:17:27.905: //-1/xxxxxxxxxxxx/RXRULE/regxrule_profile_subst_internal: Error: ruleset for redirect-called number not found

... any ideas are helpful... I am in a mental loop here... THANKS!

Silver

Re: Translation on PRI circuit...

From the logs, my next question would be if you have a voip dial peer that targets the call manager that uses a destination pattern utilizing the number pattern of your DN's.

Thanks,
Tony

Please rate helpful posts!

Please rate helpful posts
Thanks,
Tony
New Member

Re: Translation on PRI circuit...

Yessir! .... here are the dial-peers... Thank YOU!

dial-peer voice 2101 voip

corlist outgoing CCM-PT

description Outbound to UCM01 from PSTN

preference 2

destination-pattern [0-8]...

session protocol sipv2

session target ipv4:10.10.120.11

session transport tcp

voice-class codec 1

dtmf-relay rtp-nte

no vad

!

dial-peer voice 2102 voip

corlist outgoing CCM-PT

description Outbound to UCM02 from PSTN

preference 1

destination-pattern [0-8]...

session protocol sipv2

session target ipv4:10.10.120.12

session transport tcp

voice-class codec 1

dtmf-relay rtp-nte

no vad

!

Silver

Re: Translation on PRI circuit...

Thanks!  Could you try to remove the session protocol sipv2 and make a test call while pulling the same logs that Manish asked for.

Thanks,
Tony

Please rate helpful posts!

Please rate helpful posts
Thanks,
Tony

Translation on PRI circuit...

Hi Mario.

Can you attach your gateway config here so we can analyze it and fix it?

Thanks

Regards

Carlo

Please rate all helpful posts

"The more you help the more you learn"

Please rate all helpful posts "The more you help the more you learn"
New Member

Re: Translation on PRI circuit...

Thank YOU!!


Building configuration...


Current configuration : 19053 bytes
!
! Last configuration change at 14:28:50 CST Thu Feb 27 2014 by teklinks
! NVRAM config last updated at 14:14:56 CST Thu Feb 27 2014 by teklinks
! NVRAM config last updated at 14:14:56 CST Thu Feb 27 2014 by teklinks
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname SPMS-2921
!
boot-start-marker
boot-end-marker
!
!
vrf definition outside
!
address-family ipv4
exit-address-family
!
card type t1 0 0
logging buffered 500000

!
no aaa new-model
clock timezone CST -6 0
clock summer-time CST recurring
network-clock-participate wic 0
!
ip cef
!
!
!
ip dhcp excluded-address 10.71.100.1 10.71.100.5
ip dhcp excluded-address 10.71.100.250 10.71.100.254
ip dhcp excluded-address 192.168.29.1 192.168.29.100
ip dhcp excluded-address 10.71.10.1 10.71.10.100
ip dhcp excluded-address 10.71.99.1 10.71.99.29
ip dhcp excluded-address 10.71.99.31 10.71.99.254
!
ip dhcp pool VoicePhones
network 10.71.100.0 255.255.255.0
default-router 10.71.100.1
dns-server 192.168.17.18 192.168.7.5
option 150 ip 10.10.120.11 10.10.120.12
domain-name peco.local
!
ip dhcp pool DataNetwork
network 10.71.10.0 255.255.255.0
default-router 10.71.10.1
dns-server 192.168.17.18 192.168.7.5
domain-name peco.local
!
ip dhcp pool Management
network 10.71.99.0 255.255.255.0
default-router 10.71.99.1
dns-server 192.168.17.18 192.168.7.5
domain-name peco.local
!
!
!
ip domain name peco.local
ip name-server 192.168.17.18
ip inspect name firewall tcp
ip inspect name firewall udp
ip inspect name firewall icmp
no ipv6 cef
!
multilink bundle-name authenticated
!
!
stcapp ccm-group 1
stcapp
!
stcapp feature access-code
!
!
!
stcapp call-control mode feature
!
isdn switch-type primary-ni
!
!
trunk group pstn
!
!
crypto pki trustpoint TP-self-signed-933658104
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-933658104
revocation-check none
rsakeypair TP-self-signed-933658104
!
!
crypto pki certificate chain TP-self-signed-933658104
certificate self-signed 01
  30820229 30820192 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
  30312E30 2C060355 04031325 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 39333336 35383130 34301E17 0D313330 38303131 32343330
  395A170D 32303031 30313030 30303030 5A303031 2E302C06 03550403 1325494F
  532D5365 6C662D53 69676E65 642D4365 72746966 69636174 652D3933 33363538
  31303430 819F300D 06092A86 4886F70D 01010105 0003818D 00308189 02818100
  AB2F414E F8912ED2 D45EA237 2561494D 4A131A49 0FA1A5BC 6AE4DC13 E40989F1
  AE6636CA BDB74FB7 3A55E289 3EE7BBE9 1752526D 40466474 946D8E8D FFDD6F2D
  4C24357F 31DE25BC 8436AC57 AB37BAA9 D07D9FEC 168B9E9E B28B8048 CDA41AB3
  CB7251D6 AFC19E00 79BBA20F B9D488DE 49B084D4 FD55005F 96DD6C86 9055E2C9
  02030100 01A35330 51300F06 03551D13 0101FF04 05300301 01FF301F 0603551D
  23041830 168014F4 F5940AD5 EAC8A45F F12411BC E9CF99AE A2A22A30 1D060355
  1D0E0416 0414F4F5 940AD5EA C8A45FF1 2411BCE9 CF99AEA2 A22A300D 06092A86
  4886F70D 01010505 00038181 008267C1 D0B8EB29 7BE8E732 7A4E78B5 F2C1C53E
  876C574A 60FB1EA2 93A2CF94 8FF4A9A6 C836E459 6154F431 911D0FE6 DFEE146B
  E1074D6D 788D8B47 B5C561E3 31BEC7A1 872D7F85 1AB39155 68EB88DB 8589927D
  AD2B8171 951FD717 DD484A2C 6976FEB5 3734699D 9F46D8B7 EC43777B F64553A5
  90F9A952 8892DE2C 6DFFECE3 72
        quit
voice-card 0
dsp services dspfarm
!
!
!
voice service voip
ip address trusted list
  ipv4 69.176.112.12
  ipv4 69.176.112.13
  ipv4 10.0.0.0 255.0.0.0
callmonitor
clid network-provided
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
no supplementary-service sip moved-temporarily
fax protocol t38 nse force version 0 ls-redundancy 1 hs-redundancy 0 fallback pass-through g711ulaw
fax-relay ans-disable
h323
  emptycapability
  h225 timeout setup 2
  h225 display-ie ccm-compatible
  call preserve
modem relay nse codec g711ulaw redundancy maximum-sessions 6 gw-controlled
sip
  bind control source-interface GigabitEthernet0/0.100
  bind media source-interface GigabitEthernet0/0.100
  rel1xx disable
  asserted-id pai
  early-offer forced
  midcall-signaling passthru
  g729 annexb-all
  sip-profiles 2
  no call service stop
!
voice class codec 1
codec preference 1 g729r8
codec preference 2 g711ulaw
!
voice class codec 2
codec preference 1 g711ulaw
!
voice class h323 1
  h225 timeout tcp establish 3
!
voice class sip-profiles 2
request ANY sdp-header Audio-Attribute modify "inactive" "active"
!
!
!
!
voice translation-rule 5
rule 4 /\(.*\)7432/ /\26245/
rule 5 /^16016250\(...\)/ /6\1/
rule 6 /^6016250\(...\)/ /6\1/
!
voice translation-rule 6
rule 3 /\(.*\)0\(...\)/ /6\2/
rule 4 /0259/ /6259/
rule 5 /\(.*\)7432/ /\26245/
!
voice translation-rule 8
rule 2 /\(.*\)7432/ /\26245/
rule 3 /\(^......\)0\(...\)/ /6\2/
rule 5 /\^\0\(...\)/ /6\1/
!
voice translation-rule 1111
!
voice translation-rule 1112
rule 1 /^9/ //
!
!
voice translation-profile INCOMING_TRANSLATION_PROFILE
translate called 1111
!
voice translation-profile OUTGOING_TRANSLATION_PROFILE
translate called 1112
!
voice translation-profile PRIInbound
translate called 6
!
!
!
license udi pid CISCO2921/K9 sn FTX1731AL82
license accept end user agreement
license boot module c2900 technology-package securityk9
hw-module pvdm 0/0
!
hw-module sm 1
!
!
!
!
redundancy
!
!
!
!
!
controller T1 0/0/0
cablelength long 0db
channel-group 0 timeslots 1-24
!
controller T1 0/0/1
cablelength long 0db
pri-group timeslots 1-24
!
!
class-map match-any call_signaling
match ip dscp af31
class-map match-any voice_media
match ip dscp ef
!
policy-map voip
class voice_media
  priority percent 50
class call_signaling
  bandwidth remaining percent 5
class class-default
  fair-queue
!
!
crypto keyring dmvpn vrf outside
  pre-shared-key address 0.0.0.0 0.0.0.0 key tek1links
!
crypto isakmp policy 10
encr aes
authentication pre-share
group 2
!
!
crypto ipsec transform-set DMVPNSET esp-aes esp-sha-hmac
mode tunnel
!
crypto ipsec profile DMVPN_Profile
set transform-set DMVPNSET
!
!
!
!
!
!
!
interface Tunnel0
bandwidth 1000
ip address 10.155.1.27 255.255.255.0
no ip redirects
ip mtu 1400
no ip next-hop-self eigrp 1
no ip split-horizon eigrp 1
ip nat outside
ip nhrp authentication cisco123
ip nhrp map multicast 12.236.119.130
ip nhrp map 10.155.1.5 12.236.119.130
ip nhrp map 10.155.1.1 64.234.50.103
ip nhrp map multicast 64.234.50.103
ip nhrp network-id 5
ip nhrp nhs 10.155.1.5
ip nhrp nhs 10.155.1.1 priority 10
ip nhrp shortcut
ip virtual-reassembly in
ip tcp adjust-mss 1360
load-interval 30
tunnel source Dialer1
tunnel mode gre multipoint
tunnel key 6
tunnel vrf outside
tunnel protection ipsec profile DMVPN_Profile
!
interface Embedded-Service-Engine0/0
no ip address
!
interface GigabitEthernet0/0
description Internal
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/0.1
encapsulation dot1Q 1 native
ip address 192.168.29.1 255.255.255.0 secondary
ip address 10.71.10.1 255.255.255.0
ip helper-address 192.168.7.5
ip nat inside
ip virtual-reassembly in
!
interface GigabitEthernet0/0.99
description Management
encapsulation dot1Q 99
ip address 10.71.99.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface GigabitEthernet0/0.100
description VoicePhones
encapsulation dot1Q 100
ip address 10.71.100.1 255.255.255.0
!
interface GigabitEthernet0/0.200
description CFS
encapsulation dot1Q 200
ip address 10.71.200.1 255.255.255.0
!
interface GigabitEthernet0/0.204
description Marel
encapsulation dot1Q 204
ip address 10.71.204.1 255.255.255.0
!
interface GigabitEthernet0/0.206
description ControlSystems(WasteWater)
encapsulation dot1Q 206
ip address 10.71.206.1 255.255.255.0
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
no cdp enable
!
interface GigabitEthernet0/2
ip address 192.168.0.1 255.255.255.0
shutdown
duplex auto
speed auto
!
interface Serial0/0/0:0
description Circuit IF : .DHEC.418874..ATI..
bandwidth 1500
ip address 12.112.149.198 255.255.255.252
encapsulation ppp
load-interval 30
service-policy output voip
!
interface Serial0/0/1:23
no ip address
encapsulation hdlc
isdn switch-type primary-ni
isdn incoming-voice voice
isdn supp-service name calling
trunk-group pstn
no cdp enable
!
interface Dialer1
mtu 1492
vrf forwarding outside
ip address negotiated
encapsulation ppp
ip tcp adjust-mss 1400
dialer pool 1
dialer-group 1
ppp authentication chap callin
ppp chap hostname
ppp chap password
ppp pap sent-username
!
!
router eigrp 1
network 10.71.0.0 0.0.255.255
network 10.155.0.0 0.0.255.255
eigrp router-id 10.155.1.27
!
router bgp 65001
bgp log-neighbor-changes
network 10.71.10.0 mask 255.255.255.0
network 10.71.99.0 mask 255.255.255.0
network 10.71.100.0 mask 255.255.255.0
network 10.71.200.0 mask 255.255.255.0
network 10.71.204.0 mask 255.255.255.0
network 10.71.206.0 mask 255.255.255.0
neighbor 12.112.149.197 remote-as 7018
neighbor 12.112.149.197 soft-reconfiguration inbound
!
ip forward-protocol nd
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip nat inside source list InternetNat interface Tunnel0 overload
ip route 0.0.0.0 0.0.0.0 10.155.1.5 10
ip route 10.10.99.0 255.255.255.0 10.155.1.1
ip route 10.20.99.0 255.255.255.0 10.155.1.1
ip route vrf outside 0.0.0.0 0.0.0.0 Dialer1
!
ip access-list extended InternetNat
deny   ip any 10.0.0.0 0.255.255.255
deny   ip any 172.16.0.0 0.15.255.255
deny   ip any 192.168.0.0 0.0.255.255
permit ip any any
ip access-list extended outside_access_in
remark CCP_ACL Category=17
remark Auto generated by CCP for NTP (123) 192.5.41.40
permit udp host 192.5.41.40 eq ntp any eq ntp
remark Auto generated by CCP for NTP (123) 192.5.41.41
permit udp host 192.5.41.41 eq ntp any eq ntp
permit tcp any any
permit udp any any eq isakmp
permit esp any any
permit icmp any any
!
!
route-map InternetATT permit 20
match ip address 102
set interface Dialer1
set default interface Dialer1
!
route-map InternetATT permit 100
match ip address 101
set interface Dialer1
!
!
!
control-plane
!
!
voice-port 0/1/0
!
voice-port 0/1/1
!
voice-port 0/0/1:23
translation-profile incoming PRIInbound
bearer-cap Speech
!
voice-port 1/0/0
!
voice-port 1/0/1
!
voice-port 1/0/2
!
voice-port 1/0/3
!
voice-port 1/0/4
!
voice-port 1/0/5
!
voice-port 1/0/6
!
voice-port 1/0/7
!
voice-port 1/0/8
!
voice-port 1/0/9
!
voice-port 1/0/10
!
voice-port 1/0/11
!
voice-port 1/0/12
!
voice-port 1/0/13
!
voice-port 1/0/14
!
voice-port 1/0/15
!
!
!
!
!
!
mgcp profile default
!
sccp local GigabitEthernet0/0.100
sccp ccm 10.10.120.11 identifier 1 version 7.0
sccp ccm 10.10.120.12 identifier 2 version 7.0
sccp ip precedence 2
sccp
!
sccp ccm group 1
associate ccm 2 priority 1
associate ccm 1 priority 2
associate profile 2 register CFBSEMP
associate profile 1 register XCDSEMP
!
dspfarm profile 1 transcode
codec g729abr8
codec g729ar8
codec g711alaw
codec g711ulaw
maximum sessions 12
associate application SCCP
shutdown
!
dspfarm profile 2 conference
codec g729br8
codec g729r8
codec g729abr8
codec g729ar8
codec g711alaw
codec g711ulaw
maximum sessions 2
associate application SCCP
shutdown
!
dial-peer cor custom
name CCM-PT
name PSTN-PT
name FAX-PT
!
!
dial-peer cor list CCM-CSS
member PSTN-PT
member FAX-PT
!
dial-peer cor list PSTN-CSS
member CCM-PT
member FAX-PT
!
dial-peer cor list FAX-CSS
member CCM-PT
member PSTN-PT
member FAX-PT
!
dial-peer cor list CCM-PT
member CCM-PT
!
dial-peer cor list PSTN-PT
member PSTN-PT
!
dial-peer cor list FAX-PT
member FAX-PT
!
!
dial-peer voice 58 pots
trunkgroup pstn
corlist outgoing PSTN-PT
description **CCA*North American-7-Digit*Emergency**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 3
destination-pattern 9911
forward-digits all
!
dial-peer voice 60 pots
trunkgroup pstn
corlist outgoing PSTN-PT
description **CCA*North American-7-Digit*Emergency**
preference 3
destination-pattern 911
forward-digits all
!
dial-peer voice 63 pots
trunkgroup pstn
corlist outgoing PSTN-PT
description **CCA*North American-7-Digit*10-Digit Local**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 3
destination-pattern 9[2-9]..[2-9]......
forward-digits all
!
dial-peer voice 64 pots
trunkgroup pstn
corlist outgoing PSTN-PT
description **CCA*North American-7-Digit*Service Numbers**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 3
destination-pattern 9[2-9]11
forward-digits all
!
dial-peer voice 68 pots
trunkgroup pstn
corlist outgoing PSTN-PT
description **CCA*North American-7-Digit*International**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 3
destination-pattern 9011T
forward-digits all
!
dial-peer voice 70 pots
trunkgroup pstn
corlist outgoing PSTN-PT
description **CCA*North American-7-Digit*Toll-Free**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 3
destination-pattern 91800.......
forward-digits all
!
dial-peer voice 72 pots
trunkgroup pstn
corlist outgoing PSTN-PT
description **CCA*North American-7-Digit*Toll-Free**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 3
destination-pattern 91888.......
forward-digits all
!
dial-peer voice 74 pots
trunkgroup pstn
corlist outgoing PSTN-PT
description **CCA*North American-7-Digit*Toll-Free**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 3
destination-pattern 91877.......
forward-digits all
!
dial-peer voice 76 pots
trunkgroup pstn
corlist outgoing PSTN-PT
description **CCA*North American-7-Digit*Toll-Free**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 3
destination-pattern 91866.......
forward-digits all
!
dial-peer voice 78 pots
trunkgroup pstn
corlist outgoing PSTN-PT
description **CCA*North American-7-Digit*Toll-Free**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 3
destination-pattern 91855.......
forward-digits all
!
dial-peer voice 1001 voip
corlist incoming CCM-CSS
description UCM01 Inbound DIALPEER
session protocol sipv2
session target ipv4:10.10.120.11
session transport tcp
incoming called-number .
voice-class codec 1
dtmf-relay rtp-nte
no vad
!
dial-peer voice 1002 voip
corlist incoming CCM-CSS
description UCM02 Inbound DIALPEER
session protocol sipv2
session target ipv4:10.10.120.12
session transport tcp
incoming called-number .
voice-class codec 1
dtmf-relay rtp-nte
no vad
!
dial-peer voice 2101 voip
corlist outgoing CCM-PT
description Outbound to UCM01 from PSTN
preference 2
destination-pattern [0-8]...
session protocol sipv2
session target ipv4:10.10.120.11
session transport tcp
voice-class codec 1
dtmf-relay rtp-nte
no vad
!
dial-peer voice 2102 voip
corlist outgoing CCM-PT
description Outbound to UCM02 from PSTN
preference 1
destination-pattern [0-8]...
session protocol sipv2
session target ipv4:10.10.120.12
session transport tcp
voice-class codec 1
dtmf-relay rtp-nte
no vad
!
dial-peer voice 2103 voip
corlist outgoing CCM-PT
description Outbound to UCM01 from PSTN (PLACEHOLDER)
preference 2
destination-pattern 93...
session protocol sipv2
session target ipv4:10.10.120.11
session transport tcp
voice-class codec 1
dtmf-relay rtp-nte
no vad
!
dial-peer voice 2104 voip
corlist outgoing CCM-PT
description Outbound to UCM02 from PSTN (PLACEHOLDER)
preference 1
destination-pattern 93..
session protocol sipv2
session target ipv4:10.10.120.12
session transport tcp
voice-class codec 1
dtmf-relay rtp-nte
no vad
!
dial-peer voice 1100 pots
corlist incoming FAX-CSS
corlist outgoing FAX-PT
destination-pattern 6226
incoming called-number .
port 1/0/0
!
dial-peer voice 1101 pots
corlist incoming FAX-CSS
corlist outgoing FAX-PT
destination-pattern 6228
incoming called-number .
port 1/0/1
!
dial-peer voice 1102 pots
corlist incoming FAX-CSS
corlist outgoing FAX-PT
destination-pattern 6230
incoming called-number .
port 1/0/2
!
dial-peer voice 1103 pots
corlist incoming FAX-CSS
corlist outgoing FAX-PT
destination-pattern 6231
incoming called-number .
port 1/0/3
!
dial-peer voice 1104 pots
corlist incoming FAX-CSS
corlist outgoing FAX-PT
destination-pattern 6257
incoming called-number .
port 1/0/4
!
dial-peer voice 1105 pots
corlist incoming FAX-CSS
corlist outgoing FAX-PT
destination-pattern 6258
incoming called-number .
port 1/0/5
!
dial-peer voice 1106 pots
corlist incoming FAX-CSS
corlist outgoing FAX-PT
destination-pattern 6262
incoming called-number .
port 1/0/6
!
dial-peer voice 1107 pots
corlist incoming FAX-CSS
corlist outgoing FAX-PT
destination-pattern 6262
incoming called-number .
port 1/0/7
!
dial-peer voice 1108 pots
corlist incoming FAX-CSS
corlist outgoing FAX-PT
destination-pattern 6269
incoming called-number .
port 1/0/8
!
dial-peer voice 1109 pots
corlist incoming FAX-CSS
corlist outgoing FAX-PT
destination-pattern 6276
incoming called-number .
port 1/0/9
!
dial-peer voice 1110 pots
corlist incoming FAX-CSS
corlist outgoing FAX-PT
destination-pattern 6281
incoming called-number .
port 1/0/10
!
dial-peer voice 1111 pots
corlist incoming FAX-CSS
corlist outgoing FAX-PT
destination-pattern 6275
incoming called-number .
port 1/0/11
!
dial-peer voice 66 pots
trunkgroup pstn
corlist outgoing PSTN-PT
description **CCA*NorthAmerican-7-digit*LongDistance**
translation-profile outgoing OUTGOING_TRANSLATION_PROFILE
preference 3
destination-pattern 91[2-9]..[2-9]......
forward-digits all
!
dial-peer voice 100 pots
trunkgroup pstn
corlist incoming PSTN-CSS
description ** Incoming PSTN DialPeer **
translation-profile incoming PRIInbound
incoming called-number .
!
!
!
!
gatekeeper
shutdown
!
!
call-manager-fallback
secondary-dialtone 9
max-conferences 8 gain -6
transfer-system full-consult
limit-dn 7945 2
limit-dn 7965 4
ip source-address 10.71.100.1 port 2000
max-ephones 24
max-dn 50 dual-line preference 1
keepalive 10
cor incoming CCM-CSS default
cor outgoing CCM-PT default
!
!
banner motd ^CThis equipment is for Peco use only!^C
!
line con 0
login local
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
privilege level 15
login local
transport input telnet ssh
line vty 5 15
privilege level 15
login local
transport input telnet ssh
!
scheduler allocate 20000 1000
ntp server 192.5.41.40
ntp server 192.5.41.41
!
end

New Member

Re: Translation on PRI circuit...

Thanks Tony!!

I had a bunch of calls trying to come in while doing it... but here is a section on an incoming to the main number


Feb 27 21:37:35.884: //-1/34E5F2DE8106/RXRULE/regxrule_stack_push_RegXruleNumInfo_internal: stack=0x24719668; count=1
Feb 27 21:37:35.884: //-1/34E5F2DE8106/RXRULE/regxrule_stack_pop_RegXruleNumInfo: stack=0x24719668; count=1
Feb 27 21:37:35.884: //-1/34E5F2DE8106/RXRULE/regxrule_stack_pop_callinfo_internal: numinfo=0x247BB8E4
Feb 27 21:37:35.884: //-1/34E5F2DE8106/RXRULE/regxrule_stack_push_RegXruleNumInfo_internal: stack=0x24719668; count=1
Feb 27 21:37:36.664: //781/34E5F2DE8106/CCAPI/cc_api_call_disconnected:
   Cause Value=38, Interface=0x3D19A488, Call Id=781
Feb 27 21:37:36.664: //781/34E5F2DE8106/CCAPI/cc_api_call_disconnected:
   Call Entry(Responsed=TRUE, Cause Value=38, Retry Count=0)
Feb 27 21:37:36.668: //779/34E5F2DE8106/CCAPI/ccCallReleaseResources:
   release reserved xcoding resource.
Feb 27 21:37:36.668: //781/34E5F2DE8106/CCAPI/ccCallSetAAA_Accounting:
   Accounting=0, Call Id=781
Feb 27 21:37:36.668: //781/34E5F2DE8106/CCAPI/ccCallDisconnect:
   Cause Value=38, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=38)
Feb 27 21:37:36.668: //781/34E5F2DE8106/CCAPI/ccCallDisconnect:
   Cause Value=38, Call Entry(Responsed=TRUE, Cause Value=38)
Feb 27 21:37:36.668: //781/34E5F2DE8106/CCAPI/cc_api_get_transfer_info:
   Transfer Number=NULL
Feb 27 21:37:36.672: //781/34E5F2DE8106/CCAPI/cc_api_call_disconnect_done:
   Disposition=0, Interface=0x3D19A488, Tag=0x0, Call Id=781,
   Call Entry(Disconnect Cause=38, Voice Class Cause Code=0, Retry Count=0)
Feb 27 21:37:36.672: //-1/34E5F2DE8106/RXRULE/regxrule_stack_pop_callinfo_internal: numinfo=0x0
Feb 27 21:37:36.672: //781/34E5F2DE8106/CCAPI/cc_api_call_disconnect_done:
   Call Disconnect Event Sent
Feb 27 21:37:36.672: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:

Feb 27 21:37:36.672: :cc_free_feature_vsa freeing 3C38FAC0
Feb 27 21:37:36.672: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:

Feb 27 21:37:36.672:  vsacount in free is 1
Feb 27 21:37:36.672: //779/34E5F2DE8106/CCAPI/cc_api_call_facility:
   Interface=0x3EF125F4, Call Id=779
Feb 27 21:37:36.672: //779/34E5F2DE8106/CCAPI/ccCallDisconnect:
   Cause Value=38, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=0)
Feb 27 21:37:36.676: //779/34E5F2DE8106/CCAPI/ccCallDisconnect:
   Cause Value=38, Call Entry(Responsed=TRUE, Cause Value=38)
Feb 27 21:37:36.676: //779/34E5F2DE8106/CCAPI/cc_api_get_transfer_info:
   Transfer Number=NULL
Feb 27 21:37:37.512: //779/34E5F2DE8106/CCAPI/cc_api_call_disconnect_done:
   Disposition=0, Interface=0x3EF125F4, Tag=0x0, Call Id=779,
   Call Entry(Disconnect Cause=38, Voice Class Cause Code=0, Retry Count=0)
Feb 27 21:37:37.512: //-1/34E5F2DE8106/RXRULE/regxrule_stack_pop_RegXruleNumInfo: stack=0x24719668; count=1
Feb 27 21:37:37.512: //-1/34E5F2DE8106/RXRULE/regxrule_stack_pop_callinfo_internal: numinfo=0x247BB8E4
Feb 27 21:37:37.512: //779/34E5F2DE8106/CCAPI/cc_api_call_disconnect_done:
   Call Disconnect Event Sent
Feb 27 21:37:37.512: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:

Feb 27 21:37:37.512: :cc_free_feature_vsa freeing 3C38FF20
Feb 27 21:37:37.512: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:

Feb 27 21:37:37.512:  vsacount in free is 0
Feb 27 21:37:41.688: //-1/xxxxxxxxxxxx/RXRULE/regxrule_get_profile_from_voiceport_internal: Found profile PRIInbound defined on voice-port
Feb 27 21:37:41.688: //-1/xxxxxxxxxxxx/RXRULE/regxrule_get_RegXrule: Invalid translation ruleset tag=0
Feb 27 21:37:41.688: //-1/xxxxxxxxxxxx/RXRULE/regxrule_profile_subst_internal: Error: ruleset for calling number not found
Feb 27 21:37:41.688: //-1/xxxxxxxxxxxx/RXRULE/regxrule_match: more digits needed; number=7432 rule precedence=3
Feb 27 21:37:41.688: //-1/xxxxxxxxxxxx/RXRULE/regxrule_match: No match; number=7432 rule precedence=4
Feb 27 21:37:41.688: //-1/xxxxxxxxxxxx/RXRULE/regxrule_profile_match_internal: Matched with rule 5 in ruleset 6
Feb 27 21:37:41.688: //-1/xxxxxxxxxxxx/RXRULE/regxrule_match: more digits needed; number=7432 rule precedence=3
Feb 27 21:37:41.688: //-1/xxxxxxxxxxxx/RXRULE/regxrule_match: No match; number=7432 rule precedence=4
Feb 27 21:37:41.688: //-1/xxxxxxxxxxxx/RXRULE/sed_subst: Successful substitution; pattern=7432 matchPattern=(.*)7432 replacePattern=\26245 replaced pattern=6245
Feb 27 21:37:41.688: //-1/xxxxxxxxxxxx/RXRULE/regxrule_subst_num_type: Match Type = none, Replace Type = none Input Type = unknown
Feb 27 21:37:41.688: //-1/xxxxxxxxxxxx/RXRULE/regxrule_subst_num_plan: Match Plan = none, Replace Plan = none Input Plan = unknown
Feb 27 21:37:41.692: //-1/xxxxxxxxxxxx/RXRULE/regxrule_get_profile_from_voiceport_internal: Found profile PRIInbound defined on voice-port
Feb 27 21:37:41.692: //-1/xxxxxxxxxxxx/RXRULE/regxrule_get_RegXrule: Invalid translation ruleset tag=0
Feb 27 21:37:41.692: //-1/xxxxxxxxxxxx/RXRULE/regxrule_profile_subst_internal: Error: ruleset for calling number not found
Feb 27 21:37:41.692: //-1/xxxxxxxxxxxx/RXRULE/regxrule_match: more digits needed; number=7432 rule precedence=3
Feb 27 21:37:41.692: //-1/xxxxxxxxxxxx/RXRULE/regxrule_match: No match; number=7432 rule precedence=4
Feb 27 21:37:41.692: //-1/xxxxxxxxxxxx/RXRULE/regxrule_profile_match_internal: Matched with rule 5 in ruleset 6
Feb 27 21:37:41.692: //-1/xxxxxxxxxxxx/RXRULE/regxrule_match: more digits needed; number=7432 rule precedence=3
Feb 27 21:37:41.692: //-1/xxxxxxxxxxxx/RXRULE/regxrule_match: No match; number=7432 rule precedence=4
Feb 27 21:37:41.692: //-1/xxxxxxxxxxxx/RXRULE/sed_subst: Successful substitution; pattern=7432 matchPattern=(.*)7432 replacePattern=\26245 replaced pattern=6245
Feb 27 21:37:41.692: //-1/xxxxxxxxxxxx/RXRULE/regxrule_subst_num_type: Match Type = none, Replace Type = none Input Type = unknown
Feb 27 21:37:41.692: //-1/xxxxxxxxxxxx/RXRULE/regxrule_subst_num_plan: Match Plan = none, Replace Plan = none Input Plan = unknown
Feb 27 21:37:41.692: //-1/xxxxxxxxxxxx/RXRULE/regxrule_get_RegXrule: Invalid translation ruleset tag=0
Feb 27 21:37:41.692: //-1/xxxxxxxxxxxx/RXRULE/regxrule_profile_subst_internal: Error: ruleset for redirect-called number not found
Feb 27 21:37:41.692: //-1/388646C38107/CCAPI/cc_api_display_ie_subfields:
   cc_api_call_setup_ind_common:
   cisco-username=
   ----- ccCallInfo IE subfields -----
   cisco-ani=6019518202
   cisco-anitype=2
   cisco-aniplan=1
   cisco-anipi=0
   cisco-anisi=3
   dest=6245
   cisco-desttype=0
   cisco-destplan=0
   cisco-rdie=FFFFFFFF
   cisco-rdn=
   cisco-rdntype=-1
   cisco-rdnplan=-1
   cisco-rdnpi=-1
   cisco-rdnsi=-1
   cisco-redirectreason=-1   fwd_final_type =0
   final_redirectNumber =
   hunt_group_timeout =0

Feb 27 21:37:41.692: //-1/388646C38107/CCAPI/cc_api_call_setup_ind_common:
   Interface=0x3EF125F4, Call Info(
   Calling Number=6019518202,(Calling Name=)(TON=National, NPI=ISDN, Screening=Network, Presentation=Allowed),
   Called Number=6245(TON=Unknown, NPI=Unknown),
   Calling Translated=FALSE, Subscriber Type Str=RegularLine, FinalDestinationFlag=TRUE,
   Incoming Dial-peer=1100, Progress Indication=NULL(0), Calling IE Present=TRUE,
   Source Trkgrp Route Label=pstn, Target Trkgrp Route Label=, CLID Transparent=FALSE), Call Id=-1
Feb 27 21:37:41.692: //-1/388646C38107/CCAPI/ccCheckClipClir:
   In: Calling Number=6019518202(TON=National, NPI=ISDN, Screening=Network, Presentation=Allowed)
Feb 27 21:37:41.692: //-1/388646C38107/CCAPI/ccCheckClipClir:
   Out: Calling Number=6019518202(TON=National, NPI=ISDN, Screening=Network, Presentation=Allowed)
Feb 27 21:37:41.692: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

Feb 27 21:37:41.692: :cc_get_feature_vsa malloc success
Feb 27 21:37:41.692: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

Feb 27 21:37:41.692:  cc_get_feature_vsa count is 1
Feb 27 21:37:41.692: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

Feb 27 21:37:41.692: :FEATURE_VSA attributes are: feature_name:0,feature_time:1010368296,feature_id:782
Feb 27 21:37:41.692: //782/388646C38107/CCAPI/cc_api_call_setup_ind_common:
   Set Up Event Sent;
   Call Info(Calling Number=6019518202(TON=National, NPI=ISDN, Screening=Network, Presentation=Allowed),
   Called Number=6245(TON=Unknown, NPI=Unknown))
Feb 27 21:37:41.692: //-1/388646C38107/RXRULE/regxrule_stack_pop_RegXruleNumInfo: stack=0x2471CC08; count=1
Feb 27 21:37:41.692: //-1/388646C38107/RXRULE/regxrule_stack_pop_callinfo_internal: numinfo=0x247BB8E4
Feb 27 21:37:41.692: //782/388646C38107/CCAPI/cc_process_call_setup_ind:
   Event=0x3D7305F8
Feb 27 21:37:41.692: //-1/xxxxxxxxxxxx/CCAPI/cc_setupind_match_search:
   Try with the demoted called number 6245
Feb 27 21:37:41.692: //782/388646C38107/CCAPI/ccCallSetContext:
   Context=0x24C58664
Feb 27 21:37:41.692: //782/388646C38107/CCAPI/cc_process_call_setup_ind:
   >>>>CCAPI handed cid 782 with tag 1100 to app "_ManagedAppProcess_Default"
Feb 27 21:37:41.692: //-1/388646C38107/RXRULE/regxrule_stack_push_RegXruleNumInfo_internal: stack=0x2471CC08; count=1
Feb 27 21:37:41.696: //782/388646C38107/CCAPI/ccCallProceeding:
   Progress Indication=NULL(0)
Feb 27 21:37:41.696: //782/388646C38107/CCAPI/ccCallSetupRequest:
   Destination=, Calling IE Present=TRUE, Mode=0,
   Outgoing Dial-peer=2102, Params=0x24C60154, Progress Indication=NULL(0)
Feb 27 21:37:41.696: //782/388646C38107/CCAPI/ccCheckClipClir:
   In: Calling Number=6019518202(TON=National, NPI=ISDN, Screening=Network, Presentation=Allowed)
Feb 27 21:37:41.696: //782/388646C38107/CCAPI/ccCheckClipClir:
   Out: Calling Number=6019518202(TON=National, NPI=ISDN, Screening=Network, Presentation=Allowed)
Feb 27 21:37:41.696: //782/388646C38107/CCAPI/ccCallSetupRequest:
   Destination Pattern=[0-8]..., Called Number=6245, Digit Strip=FALSE
Feb 27 21:37:41.696: //782/388646C38107/CCAPI/ccCallSetupRequest:
   Calling Number=6019518202(TON=National, NPI=ISDN, Screening=Network, Presentation=Allowed),
   Called Number=6245(TON=Unknown, NPI=Unknown),
   Redirect Number=, Display Info=
   Account Number=, Final Destination Flag=TRUE,
   Guid=388646C3-9F2E-11E3-8107-4C00827D8B40, Outgoing Dial-peer=2102
Feb 27 21:37:41.696: //782/388646C38107/CCAPI/cc_api_display_ie_subfields:
   ccCallSetupRequest:
   cisco-username=
   ----- ccCallInfo IE subfields -----
   cisco-ani=6019518202
   cisco-anitype=2
   cisco-aniplan=1
   cisco-anipi=0
   cisco-anisi=3
   dest=6245
   cisco-desttype=0
   cisco-destplan=0
   cisco-rdie=FFFFFFFF
   cisco-rdn=
   cisco-rdntype=-1
   cisco-rdnplan=-1
   cisco-rdnpi=-1
   cisco-rdnsi=-1
   cisco-redirectreason=-1   fwd_final_type =0
   final_redirectNumber =
   hunt_group_timeout =0

Feb 27 21:37:41.696: //782/388646C38107/CCAPI/ccIFCallSetupRequestPrivate:
   Interface=0x3D19A488, Interface Type=1, Destination=, Mode=0x0,
   Call Params(Calling Number=6019518202,(Calling Name=)(TON=National, NPI=ISDN, Screening=Network, Presentation=Allowed),
   Called Number=6245(TON=Unknown, NPI=Unknown), Calling Translated=FALSE,
   Subscriber Type Str=RegularLine, FinalDestinationFlag=TRUE, Outgoing Dial-peer=2102, Call Count On=FALSE,
   Source Trkgrp Route Label=pstn, Target Trkgrp Route Label=, tg_label_flag=1, Application Call Id=)
Feb 27 21:37:41.696: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

Feb 27 21:37:41.696: :cc_get_feature_vsa malloc success
Feb 27 21:37:41.696: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

Feb 27 21:37:41.696:  cc_get_feature_vsa count is 2
Feb 27 21:37:41.696: //-1/xxxxxxxxxxxx/CCAPI/cc_get_feature_vsa:

Feb 27 21:37:41.696: :FEATURE_VSA attributes are: feature_name:0,feature_time:1010367176,feature_id:783
Feb 27 21:37:41.696: //783/388646C38107/CCAPI/ccIFCallSetupRequestPrivate:
   SPI Call Setup Request Is Success; Interface Type=1, FlowMode=1
Feb 27 21:37:41.696: //783/388646C38107/CCAPI/ccCallSetContext:
   Context=0x24C60104
Feb 27 21:37:41.696: //782/388646C38107/CCAPI/ccSaveDialpeerTag:
   Outgoing Dial-peer=2102
Feb 27 21:37:41.696: //783/388646C38107/CCAPI/ccGetMediaClassTag:
   media class tag 0
Feb 27 21:37:41.696: //783/388646C38107/CCAPI/ccSetMediaclassIp2ipTags:
   media class tags set: NR 0, ASP 0
Feb 27 21:37:41.696: //782/388646C38107/CCAPI/ccSetMediaclassIp2ipTags:
   media class tags set: NR 0, ASP 0
Feb 27 21:37:41.696: //783/388646C38107/CCAPI/ccGet_xc_nr_asp_info:
   media class tags: NR 0, ASP 0
Feb 27 21:37:41.696: //782/388646C38107/CCAPI/ccGet_xc_nr_asp_info:
   media class tags: NR 0, ASP 0
Feb 27 21:37:41.696: //-1/388646C38107/RXRULE/regxrule_stack_pop_RegXruleNumInfo: stack=0x2471CC08; count=1
Feb 27 21:37:41.696: //-1/388646C38107/RXRULE/regxrule_stack_pop_callinfo_internal: numinfo=0x247BB8E4
Feb 27 21:37:41.696: //-1/388646C38107/RXRULE/regxrule_stack_push_RegXruleNumInfo_internal: stack=0x2471CC08; count=1
Feb 27 21:37:41.700: //-1/388646C38107/RXRULE/regxrule_stack_pop_RegXruleNumInfo: stack=0x2471CC08; count=1
Feb 27 21:37:41.700: //-1/388646C38107/RXRULE/regxrule_stack_pop_callinfo_internal: numinfo=0x247BB8E4
Feb 27 21:37:41.700: //-1/388646C38107/RXRULE/regxrule_stack_push_RegXruleNumInfo_internal: stack=0x2471CC08; count=1
Feb 27 21:37:41.892: //783/388646C38107/CCAPI/cc_api_call_disconnected:
   Cause Value=38, Interface=0x3D19A488, Call Id=783
Feb 27 21:37:41.892: //783/388646C38107/CCAPI/cc_api_call_disconnected:
   Call Entry(Responsed=TRUE, Cause Value=38, Retry Count=0)
Feb 27 21:37:41.896: //782/388646C38107/CCAPI/ccCallReleaseResources:
   release reserved xcoding resource.
Feb 27 21:37:41.896: //783/388646C38107/CCAPI/ccCallSetAAA_Accounting:
   Accounting=1, Call Id=783
Feb 27 21:37:41.896: //783/388646C38107/CCAPI/ccCallDisconnect:
   Cause Value=38, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=38)
Feb 27 21:37:41.896: //783/388646C38107/CCAPI/ccCallDisconnect:
   Cause Value=38, Call Entry(Responsed=TRUE, Cause Value=38)
Feb 27 21:37:41.896: //783/388646C38107/CCAPI/cc_api_get_transfer_info:
   Transfer Number=NULL
Feb 27 21:37:41.900: //783/388646C38107/CCAPI/cc_api_call_disconnect_done:
   Disposition=0, Interface=0x3D19A488, Tag=0x0, Call Id=783,
   Call Entry(Disconnect Cause=38, Voice Class Cause Code=0, Retry Count=0)
Feb 27 21:37:41.900: //-1/388646C38107/RXRULE/regxrule_stack_pop_callinfo_internal: numinfo=0x0
Feb 27 21:37:41.900: //783/388646C38107/CCAPI/cc_api_call_disconnect_done:
   Call Disconnect Event Sent
Feb 27 21:37:41.900: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:

Feb 27 21:37:41.900: :cc_free_feature_vsa freeing 3C38FAC0
Feb 27 21:37:41.900: //-1/xxxxxxxxxxxx/CCAPI/cc_free_feature_vsa:

Re: Translation on PRI circuit...

Hi Mario,

For Incoming call

Incoming configuration is good and working. Its look like there is a  problem with SIP trunk that you configured on CUCM. Attach SIP trunk snap shots , we need to look at its configuration.

For Outbound call

We first need to fix sip trunk as there is no logs for outbound call on VG and few changes need to done on VGW.

Modify DP 1001 and 1002 like this.

dial-peer voice1001 voip

corlist incoming CCM-CSS

description UCM0[1-2] Inbound DIALPEER

session protocol sipv2

session transport tcp

incoming called-number [0-8]...

voice-class codec 1

dtmf-relay rtp-nte

no vad

dial-peer voice 1002 voip

corlist incoming CCM-CSS

description Inbound to UCM0[1-2] from PSTN (PLACEHOLDER)

session protocol sipv2

session transport tcp

incoming called-number 93...

voice-class codec 1

dtmf-relay rtp-nte

no vad

And add trunk group to T1 controller.

controller T1 0/0/0

cablelength long 0db

channel-group 0 timeslots 1-24

trunk-group pstn timeslots 1-24 preference 1

!

controller T1 0/0/1

cablelength long 0db

pri-group timeslots 1-24

trunk-group pstn timeslots 1-24 preference 2

Rate useful post.

Thanks

Manish

New Member

Translation on PRI circuit...

Thank you for the post!! I've attached a power point with snapshots... I can attach JPEG pics if the presentation proves to be a problem for you...

I tried the trunk-group command and came back with "unrecognized command" ... I'll research why...

Again, thanks for your time!

Re: Translation on PRI circuit...

Can you also send debug ccsip message for an inbound call.

Sent from Cisco Technical Support iPhone App

New Member

Translation on PRI circuit...

Here is one from yesterday Manish! .... THANKS!

Feb 27 21:54:32.313: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
INVITE sip:7432@10.10.120.12:5060 SIP/2.0
Via: SIP/2.0/TCP 10.71.100.1:5060;x-route-tag="tgrp:pstn";branch=z9hG4bK1A8186A
User-Agent: Cisco-SIPGateway/IOS-15.2.4.M3
o=CiscoSystemsSIP-GW-UserAgent 8962 2536 IN IP4 10.71.100.1
s=SIP Call
Feb 27 21:54:32.337: //827/9262747F8116/SIP/Msg/ccsipDisplayMsg:
SIP/2.0 100 Trying
Via: SIP/2.0/TCP 10.71.100.1:5060;x-route-tag="tgrp:pstn";branch=z9hG4bK1A8186A
Feb 27 21:54:32.337: //827/9262747F8116/SIP/Msg/ccsipDisplayMsg:
SIP/2.0 503 Service Unavailable
Via: SIP/2.0/TCP 10.71.100.1:5060;x-route-tag="tgrp:pstn";branch=z9hG4bK1A8186A
Feb 27 21:54:32.349: //827/9262747F8116/SIP/Msg/ccsipDisplayMsg:
ACK sip:7432@10.10.120.12:5060 SIP/2.0
Via: SIP/2.0/TCP 10.71.100.1:5060;x-route-tag="tgrp:pstn";branch=z9hG4bK1A8186A
SPMS-2921#sh log | beg Feb 27 21:54:32.313: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Feb 27 21:54:32.313: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
INVITE sip:7432@10.10.120.12:5060 SIP/2.0
Via: SIP/2.0/TCP 10.71.100.1:5060;x-route-tag="tgrp:pstn";branch=z9hG4bK1A8186A
From: <9163997992>;tag=B37AA7C-250E
To: <7432>
Date: Thu, 27 Feb 2014 21:54:31 GMT
Call-ID: 9266BA2F-9F3011E3-8825989D-EE43631F@10.71.100.1
Supported: timer,resource-priority,replaces,sdp-anat
Min-SE:  1800
Cisco-Guid: 2455925887-2670727651-2165722112-2189265728
User-Agent: Cisco-SIPGateway/IOS-15.2.4.M3
Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY, INFO, REGISTER
CSeq: 101 INVITE
Max-Forwards: 70
Timestamp: 1393538071
Contact: <9163997992>
Expires: 180
Allow-Events: telephone-event
P-Asserted-Identity: "pending" <9163997992>
Content-Type: application/sdp
Content-Disposition: session;handling=required
Content-Length: 478

v=0
o=CiscoSystemsSIP-GW-UserAgent 8962 2536 IN IP4 10.71.100.1
s=SIP Call
c=IN IP4 10.71.100.1
t=0 0
m=audio 17480 RTP/AVP 18 0 100 101
c=IN IP4 10.71.100.1
a=rtpmap:18 G729/8000
a=fmtp:18 annexb=no
a=rtpmap:0 PCMU/8000
a=rtpmap:100 X-NSE/8000

a=fmtp:100 192-194,200-202

a=rtpmap:101 telephone-event/8000

a=fmtp:101 0-16

a=X-sqn:0

a=X-cap: 1 audio RTP/AVP 100

a=X-cpar: a=rtpmap:100 X-NSE/8000

a=X-cpar: a=fmtp:100 192-194,200-202

a=X-cap: 2 image udptl t38


Feb 27 21:54:32.321: //-1/xxxxxxxxxxxx/RXRULE/regxrule_get_profile_from_voiceport_internal: Found profile PRIInbound defined on voice-port

Re: Translation on PRI circuit...

SIP request sent to 10.10.120.12. Did you added sip trunk on this cucm ? Are you able to reach gw binded gig ip from 120.12? The css assigned in sip trunk inbound direction contains partition assigned to phone ?

Sent from Cisco Technical Support iPhone App

New Member

Translation on PRI circuit...

Yes SIP is added... Able to reach it; we can make internal calls extension to extension (GW to GW) with no problems...

We have about 12 SIP trunks using the same CSS and phones are assigned the same partition...

Thank you sir!!

Re: Translation on PRI circuit...

Mario can you test few more changes..
1. Shutdown the inbound dial-peer from gw towards 120.12 cucm (dp-2102) and add sip trunk on 120.11 then test a inbound call.
2. Uncheck run on all active nodes in sip trunk then again do a inbound test call.

Do collect debug ccsip message on both these cases.

The device pool assigned to sip trunk contains these two cucm servers in ccm group ? If yes then in which sequence.


Sent from Cisco Technical Support App

New Member

Translation on PRI circuit...

Well... after all the problem lied in Call Manager...

As it turns out, the SIP needed a RESTART ... Apparently something went out of whack in the background and/or within UCM's database and even though the SIP was there and properly configured it was like it didn't exist...

Thank you all for your invaluable help and guidance!

Kudos to all involved!!

Enjoy your weekend!

932
Views
10
Helpful
26
Replies
CreatePlease to create content