Cisco Support Community
Showing results for 
Search instead for 
Did you mean: 

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

Translation Pattern Error


I'm having a problem with translation patterns. I have only 1 translation pattern on my inbound isdn and that is:-

rule 1 /^329/ /9/

Which I'm using to translate 329xxx to 9xxx I then have a dial-peer for 9... going to call manager.

**Please see the attached file**

On a debug of q931 and translations, I see the call come in aiming at 329444 and it translates it to 9444, as per the rule.

For some reason, it then translates it to 444, which I've not got a dial-peer for and didn't tell it to do.

When a call comes in for 329752, it gets translated to 9752 and gets routed.

Out of the 400 number in the ddi range, about 200 work no problems and about 200 get stripped back to 3 digits.

I was running the software: c2800nm-spservicesk9-mz.124-3g.bin

Which I have upgraded to: c2800nm-spservicesk9-mz.124-13a.bin

The issue is still there.

I have worked around this by sending the 6 digits from the isdn to call manager and translating there.

However, there is also a link to a second provider on the same gateway and that still has the issue and I can't translate that on call manager, as it is mobile short dial and they call the real internal extentions.

Any ideas welcomed.


PS - I also have a a translation on incoming calling to put 90 on the front of the number.


Re: Translation Pattern Error

Hi Leigh,

I think your problem here is that you are using 9 for an outside line and using 9xxx for your extensions and as such they are conflicting, as a quick test change the outside line access dial-peer to another number ie from 9 to 8 and see if this solves your issue




Re: Translation Pattern Error

Can you post you dial-peers looks like the two calls are hitting two different dial-peers.

Re: Translation Pattern Error


The problem was that I had dial peers pointing to 9xxx and 9.T

I resolved this my sending all 6 digits to call manager and doing the translations there.

Thinking about it, I probably could have solved this with a "huntstop" command.

Many thanks for all your help,


Re: Translation Pattern Error

Take a debug voice ccapi inout of both calls and see the difference between the dial peers and what is going on on the call. Post both and also the sh run